
Otasuke GP-EX!

　 Intro - 0

Introduction Summary

Introduction
Summary

Introduction

　Summary ……………………………………………… Intro-1

Development Environment …………………………… Intro-4

Procedures of Creating New Screen ……………… Intro-5

Main Window …………………………………………… Intro-6

Tips for man-hours reduction ~Full use of Work Space~
…………………………………………………… Intro-10

Simulation ……………………………………………… Intro-17

Transferring Screen Data …………………………… Intro-19

Display Unit Settings ………………………………… Intro-21

Manuals ………………………………………………… Intro-26



Otasuke GP-EX!

　 Intro - 1

Introduction Summary

Summary

This textbook is for GP-EX Basic Course, GP-EX Advanced Course, GP-EX 
Logic Feature Course, and GP-EX Computer Linking Feature Course. 

In GP-EX Basic Course and GP-EX Advanced Course, create screens by use 
assuming an operation panel of general sort lines. 

Sort line image

Operation Panel

ＧＰ LineA LineB LineC

LineD
（Defect）

Connect the GP to the PLC controlling the lines for data 
display and operation.

PLC

Equipments that are used in practice of GP-EX Basic Course and GP-EX 
Advanced Course are as follows:

• Windows Personal Computer 
• Screen Creation Software GP-Pro EX
• GP3000 Series (resolution: 640 × 480 pixels or more)
• MELSEC AnN Series by Mitsubishi Electric Corporation

CPU A1SJ
　　　 Link Unit A1SJ71UC24-R2

• Screen Transfer Cable or Ethernet Cable

Use attached data for practice on creating screen. 
Please refer to the readme.txt file for details. 

One Point 
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Screens of  GP-EX Basic Course GP-EX Advanced Course

GP-EX Basic Course: Create basic screens that can be substitutes of the control panel 
in Chapter 1 through 5. 

Chapter 1
Menu Screen

Chapter 3
Device Monitor Screen

Chapter 2
Run State Screen

Chapter 4
Operation / Guide Screen

Chapter 5
Set Value Input Screen

for Displays for Operations

GP-EX Advanced Course: Create screens using the settings of the memory features 
and the movie features, which are particular features of the 
programmable display units, in Chapter 6 through 8. 

Chapter 6
Alarm History Screen

Chapter 7
Data Sampling Screen

Chapter 8
Recipe Input Screen

We recommend you practice basic screens before 
advanced screens. 

One Point
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Create preventive maintenance screen and ecology air conditioning system screens 
using the logic program. 　

In GP-EX Computer Interaction Feature Course, let’s practice the “Remote PC Access”
feature with which you can operate a computer screen from a GP unit, the “GP-Viewer 
EX” feature with which you can operate data in a GP from a computer, and “WinGP”
which enables the GP functions on our panel computer screens by interacting with a 
computer. 

Screens of GP-EX Logic Feature Course

Screens of GP-EX Computer Interaction Feature Course

Ethernet

PDFPDF

ManualManual

GP

PC

PDFPDF
ManualManual

RPA (Remote PC Access)
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To develop GP screens, please prepare the followings:

Screen Creation Software
GP-Pro EX
(CD-ROM)

Transfer Cable
CA3-USBCB-01, 

Ethernet Cable, CF Card, 
or USB Memory

Windows
PC

(1) Requirements for Development

GP3000
Series

Development Environment

By installing the screen creation software on your computer and transferring the created 
project file ( * .prx ) to the GP unit, the GP can communicate with a device/PLC and displays/ 
operates data. 

(2) Operating Environment

Operation Environment for GP-Pro EX

Required Specification Remark

PC/AT compatible machine on which Windows 
operates normally.

Pentium4 1.3GHz or faster is 
recommended. PC

SVGA 800×600 or above is recommended
Display with 256 or more colors is required.Resolution 

Hard Disk 
Space 720 MB or more Free space required for installation 

Memory 512 MB or more 1 GB or more is recommended.

The Remote Printer Server, Movie 
Converter, Remote PC Access, 
and Pass-Through features are not 
available if your operating systems 
is Windows Vista.

Windows2000(Service Pack3 or later),
Windows XP (Home Edition or Professional), 
Windows Vista (*)

OS

Internet Explorer Ver.6.0 or later
.NET Framework Ver.2.0 or later
Acrobat Reader Ver.6.02 or later

To install GP-Pro EX, .NET 
Framework Ver.2.0 or later is 
required to be installed in the PC. 

Other

Required Specification Remark

PC PC/AT compatible machine on which Windows 
operates normally.

PentiumⅡ 266MHz or faster is 
recommended. 

Hard Disk Space 135 MB or more

Memory 128 MB or more 512 MB or more is recommended. 

OS

Windows98 Second Edition  or higher, Windows 
ME, Windows 2000 Service Pack3  or higher, 
Windows XP Home Edition or Professional Edition, 
Windows Vista *

Supports Japanese and English

Operation Environment for Transfer Tool

* An environment recommended for Windows Vista is required.
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Procedures of Creating New Screen

(1) Start up Screen Creation Software

Double-click the shortcut icon on the desktop. 
Or click Window’s [Start] menu, select [All Programs] → [Pro-face] → [GP-Pro EX 2.51] →
[GP-Pro EX] to start up the screen creation software. 

Double-click the 
shortcut icon. 

The logo mark appears.

　

(2) Create New Project File

Click the [New] icon 
on the main window. 

Select GP Series, Model, 
and Orientation. Click 
[Next]. 

Configure Device/PLC. 

To start creating a screen, click 
[New Screen]. 

　

The main window opens. 

Select if you want to run the “Online 
Update Service” or not and click [OK]. →
Select [New].

　 　

Device/PLCGP3000 Series

Create and transfer screen data

Transferring a project file which has been created on a computer to a GP unit, the GP communicates 
with a device/PLC, displays and operates data in the device/PLC.

* A project file is created using screen creation software. When the project file created with screen 
creation software is saved in a computer, the extension, “.prx” is allocated to the file. 

Project file = a pack of data to transfer to a GP unit. 　

　　　One Point
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Main Window 

This section introduces the major features on the main window.

Icons line up in order of development, [System Settings] → [Edit] → [Preview] →
[Simulation] → [Transfer Project] → [Monitor]. 

System Settings: Displays a System Settings window such as the Display Unit settings and the 
Device/PLC settings in the editing area. 

Edit: Displays a screen editor to edit or create a screen.
Preview: Displays a preview screen to check the display state. 
Simulation: Allows you to check the performance without connecting a device/PLC. 
Transfer Project: Launches the Transfer Tool and transfers screens. 
Monitor: Allows you to check the states of the transferred logic program on a computer 

by connecting to a GP unit. . 

(1) Operation State Bar

Icons of frequently used features and objects are 
assorted. You can select bars to be displayed with the 
[View] → [Tool Bar] menu. 

Default Tool Bar

Select from the menu.

Work Space

Operation
State Bar

Tool Bar

Editing Area

* The Operation State Bar can be reduced its size, but cannot be hidden. 

(2) Tool Bar
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Using the Work Space windows enables efficient editing. Each Work Space is movable to the 
left, right, top, and bottom of the editing area. 

To show each Work Space, select the View 
menu -> Work Space and then check a desired 
Work Space. (See the right figure.)

To move a Work Space, drag its tab or title bar. 
If you point the cursor on an icon on the cross 
switch displayed on the middle of the screen 
while dragging, the Work Space will be fixed 
into each position and placed. (See the below 
figure.)

For the details of each Work Space window, 
see “Tips for man-hours reduction.”

(3) Work Space

Title Bar

Tab
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　　　One Point

Use the screen editing area wider (Auto-hide feature and Full Screen feature)

Auto-hide feature
Clicking the push pin icon right above in the Work Space, the whole Work Space will be 
iconized on the left and you keep the editing area wide. If you click the icon, the work space 
will be displayed. 

Click to hide.

Point your mouse on 
here, and the Work 
Space will appear. Click to fix the space.

Full Screen feature
To expand the editing area as widely as possible, press the F11 key. The editing area will 
be expanded and if you press the F11 key again, the editor will show normally. 

F11

Normal　　　　　　　　　　　　　　　　　　　　　Full Screen
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　　　One Point

1)Dual editor startups
You can start up 2 project files 
of the same version and copy 
and paste date from/to each 
other. 

2) Copy from another project file
By selecting Project menu
-> Utility
-> Copy from Another Project, 
you can copy various information 
including base screens to the 
currently opened project file. 

3) Share parts in the Package
By registering your original parts 
to the Package of the Work 
Space, you can use them in 
other project files. Also, you can 
share the registered Package 
with other PCs by exporting. 

Editor 1

You can select screens 
to copy from the 
thumbnailed list of 
screens in another 
project. 

Editor 2

Utility of an existing project file

4) Project Converter

The Project Converter is a tool to convert a project file created in GP-PRO/PB3 into the 
file format (*.prx) for GP-Pro EX. To use this tool, a separate installation is required. 
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Tips for man-hours reduction ~Full use of Work Space~

(1) Selecting/Creating a Screen ~Screen List Window~
Default Position

The Screen List window allows you not only to select a created 
screen intuitively from the thumbnailed list, but also to recognize at 
glance which window calls another screen or window screen, or 
has a header/ footer set on it. You can narrow down your search 
with the following procedures: 

New Screen
Creates a new screen.

Copy
Copies a selected screen.

Paste
Pastes a copied screen.

Delete
Deletes a selected screen.

Change Attributes
Changes the attribute of a 
selected screen. 

Change Display Mode
Changes the display mode 
between the list and the thumb 
nail display.

Nesting
Displays screens hierarchically.

Select the type: Base Screens, Window 
Screens, etc. 
Search a screen by the title or screen 
number. 

You can change screens, which are open 
already, using their tabs. 
By right-clicking a tab, you can tile windows 
vertically or horizontally. 

1

2

3

4

Select a screen and double-click it to 
open.

Display Example
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(2) Selecting/Placing a Part ~Parts Toolbox~

The Parts Toolbox allows you to intuitively select a shape of a part 
and place it on a screen by a drag and drop operation. 
You can narrow down your search with the following procedures: 

Default Position

1

2

3

4

5

Select a Part type. 

Select an image.

Select the Part color and specify the 
ON/OFF state.

Select a shape from the list and drag and 
drop it on the screen. 

If you click “Extended,” you 
can also select the Colors 
and the Part Picture ID.

Select the number of colors from All, 
65535 colors, 64 colors, etc. 
The ID of the selected part shows here. 

You can also place a part from the Menu bar and with an icon on the Tool Bar. 

Example: Place a Switch Lamp

Designate the size of the 
switch by dragging. 
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Place objects neatly
The Grid and Guideline features are helpful to place objects neatly on a screen. 

Grid
The Grid feature automatically arranges the top left coordinate of an object on a dot (grid) showing 
on a screen when you adjust the size of the object or the interval with other objects. 
Selecting “Open Screen Option” from the right-click menu on the base screen allows you to change 
the settings for the screen edit style such as the intervals and the color of the grid. 

　　　One Point

Guideline
The Guideline feature automatically arranges the coordinates of an object aligning with other objects 
when you place the object or move it. 

Example

View Tool Bar　　　　　　　　　　　　　Right-click shortcut menu

Example
Right-click shortcut menu

The guiding line  will be displayed on 
the checked location.

If you move an object with pressing the Alt key on the PC keyboard, you can place it on 
the grid. Also, arrow keys can move an object by 1 dot. 

Grid size Show Grid Snap to 
Grid
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(3) Changing a Part’s Attribute ~Properties Window~

2

The displayed items vary depending on the 
selected object. 
(The left figure is an example for a Switch.)

The Properties window allows you to change the attribute of an 
object seeing it. 

Expand All
Expands and displays all categories.

Collapse All
Reduces and hides all categories.

Expand to 1st Level
Expands and displays only top level 
categories.

Display shape information
Displays a selected part’s shape 
information. 

　
Display text information

Displays a selected part’s text 
information.

１

Good points of the Properties window
• You can check changes after each 

operation seeing the object. 
• You can change attributes of the same type 

of objects at once.

Default Position

You can also edit the attribute of an object in the dialog box by double-clicking the 
object.

Example: Edit a Switch

Double-click

Good points of the dialog box

• You can select each object intuitively. 

• Items are categorized on each tab.

• It uses user-friendly interfaces including buttons, check boxes, radio buttons, etc. 
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(4) Setting Common Information ~Common Settings Window~

The Common Settings window allows you to create or edit information in 
common to the whole project. The selected setting item shows in the 
editing area. 

Alarm Settings (Chapter 6)

Sampling Settings
(Chapter 7)

Security Settings
(Chapter 8)

Default Position

(5) Checking/Setting Addresses ~Address Window~

The Address window allows you to check whether addresses are used 
or not and where they are used. Also, you can allocate an address by 
dragging and dropping it from the Address window onto a part on a 
screen. 

1) Cells of currently used addresses are displayed in red.
2) Click an address, and objects that use the address are displayed below the address map. 
3) Select a cell of an address and drag and drop it into a part to allocate the address.

Example

Default Position

1

2

3
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(6) Reuse of Original Parts ~Package Window~

The Package window allows you to register your originally-created 
parts with a drag and drop operation and use them in other project 
files or share with other PCs. 

Default Position

Example

①

1) Select a part to be registered and 
drag and drop to the Package 
window. 

2) To use the part on the screen, drag 
and drop it to the screen. 

If you point the mouse 
cursor, the full-size part 
image will be displayed.

The Package List, which you can open 
from the View menu -> Package, allows 
you to export/import a created Package. 

(7) Searching Information ~Search Window~

The Search window allows you not only to search a text, address, or 
variable used in the project file quickly but also to replace. 
Go to the View menu -> Work Space and check “Search,” and then 
the Search window will show on the left of the editor. 

Default Position

Not Displayed

Example

1

2

1) Enter a search target.
2) Search results appears in the list. You can replace one or all.
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(8) Checking/Changing Order of Placement ~Screen Data List Window~ 

The Screen Data List window lists parts, drawings, and other objects 
placed on the screen. It allows you to select an object which is hard 
to select on the screen or to change the order of placement. 
Go to the View menu -> Work Space and check “Screen Data list,”
and then the Screen Data List window will show on the right of the 
editor.

Default Position

Not Displayed

Display Navigator

Objects are listed in 
order of placement. 

The Display Navigator allows you to remove overlapping 
parts one by one and edit the desired object. 

Blue pin (tilted) when not fixed
The object can be edited and 
moved.

Red pin (vertical) when fixed
A lock shows next to the object 
and it cannot be edited or 
moved.  

Fixing Pin

The Fixing Pin fixes the object that you don’t want to move on the screen and locks 
the object’s coordinates and attributes not to be changed. 
When you select an object, a blue pin shows on the left top corner, and if you click the 
blue pin, it will turn red and the object will be fixed. When you double-click the fixed 
object, the red pin shows, and if you click the red pin, it will be released. 

　　　One Point
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Simulation

(1) What is Simulation? 

Simulation is a feature that allows you to check performance of GP screens on a 
computer. 
It is unnecessary to use a GP unit or a device/PLC. You can check simulated 
operation or display easily at anytime, even during creating screens. 

Transfer

Create screens 
on your PC….

Before

Transfer screen 
data….

Connect with a 
device/PLC and 
check the 
performance….

After

Check the screen operations 
while editing screens on your PC!

Performance Example in Simulation

Click the data display (Allow Input checked) 
and enter a value with the keypad. If you 
enter a value out of the range, an alarm 
beeps. 
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(2) Simulation Settings

Clicking the icon on the state bar, the Simulation window will appear.

　

You can enter the 
Simulation mode 
with the F12 key on 
the keyboard. 

F12

One Point 

Sample operation of the Simulation feature

Open the “Set Value Input” screen and 
click the data display of a “Target 
Setting”, and a numeric keypad will pop 
up. Enter a value with the mouse cursor. 
If the value is out or the range, it alerts 
you by beeping. 

Click the Close button on the top right of 
the window or click the Exit icon to close 
the window. 

View of Simulation

The Address View allows you 
to check data, turn on/off a bit, 
and enter a value. 

It is also allows you to check 
the performance in the logic 
program. 

To display/hide each View 
window, use the icon on the 
Tool Bar. 

　　One Point

You can capture screen images with 
the Save Screen feature and use 
them on documents. 
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Transferring Screen Data

(1) Transfer Method

For transferring screen data, an Ethernet cable is available as well as a USB transfer cable. 

USB Transfer Cable (1m) Ethernet Cable CF Card USB Memory

Commercial 
Product

* Some types of USB   
memories may be 
unavailable for 
screen data transfer. 

Type: CA3-USBCB-01

(2) Starting Transfer Tool

2) The Transfer Tool opens. 
Click [Transfer Settings]. 

1) Click the “Transfer Project” icon 
on the state bar and start the 
Transfer Tool. 
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(3) Transfer Settings

1

2

3

1) Select either a transfer cable (USB) or 
an Ethernet cable (LAN).

2) Select either transferring the changed 
screens automatically or transferring all 
screens. 

3) Select either transferring the system 
automatically or forcing to transfer the 
system. 

4) Click [OK] to close the Transfer Settings 
window. 
Clicking “Send Project” starts 
transferring the project to the GP unit. 

4

55) Click [Send Project], and transfer to the 
GP will start.

One Point

USB Front Mount Cable
CA5-USBEXT-01
(Sold Separately) 

USB Memory Transfer

Using a USB memory allows you to transfer a project file between a GP and a computer. Also 
you can copy a project file from a GP to another GP by using a USB memory. 
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Display Unit Settings

Display Unit settings are for operating environment of the GP unit. 
Make following settings with the System Settings icon on the state 
bar or the System Settings window in the work space. 

(1) Display Unit Settings

State Bar

System Settings Window

Display: Screen Settings Initial Screen Number, Standby Mode, etc. 

Display Settings Color, Faded Color Blink, etc.

Menu and Error Settings System Language, Show Error Online, etc.

Operation: System Password, Touch Buzzer Sound, etc. 

Mode: Window Settings Global Window Operation

Backup Internal Device Backup, Backup Area Size, etc. 

Screen Capture Settings Capture Action, Control Word Address, etc. 

Memory Card Settings Control Word Address, Free Space Storage Address, etc. 

System Area: System Area Start Address, System Data Area Items, etc. 

One Point
Offline Mode of the GP unit also allows you to change the system settings. 

Please see GP3000 Maintenance/Troubleshooting Manual for details of Offline Mode. 

Offline ResetError

1) Touch the two corners 
which are diagonal (the 
upper left and bottom right, 
or the upper right and 
bottom left) of the screen 
alternately.

Operation Screen

<< How to Enter Offline Screen >>

2) Touch [Offline] when the 
gray bar appears. 

CF 
Starting

Touch 

Touch

1

2
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(2) System Data Area

A GP has an internal memory area of 9000 words, which is called LS Area. The area of the 
first 20 words in LS Area is called System Data Area. 
System Data Area is an area to deal operating environment of a GP and each address in it 
has own function. By allocating this area to the data register in a device/PLC, a GP can be 
controlled by the PLC. System Data Area lets the GP read data in the PLC and performs, for 
example, Auto-screen change, Backlight On/Off, Clock calibration, etc. directly.  

LS8
|

LS19

LS Area
System 

Data Area

9000
Words

＋0
|
＋7

＋8
|
＋19

Write Area

Data Register

Read Area

LS0
|

LS7

One Point
GP Internal Device

GP has an internal device called USR Area as well as LS Area.
For details of these internal devices, refer to Appendix 1-2 Communicating 
with a Device/PLC Using the Direct Access Method A-4 in Reference Manual.
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(3) System Data Area Settings 

On the System Settings window, select “Display Unit” and then the “System Area” tab. 

3

2

1

1) System Area Device
Select which device to allocate the 
System Area to when connecting 
multiple devices. 

2) System Area Start Address
Set the System Area Start Address 
to allocate to the device/PLC. 

3) System Area Address Items
Select items of System Data Area to 
allocate to the device/PLC. 

NOTE

When you create a new project, 
you cannot use the System 
Area because it’s disabled at 
default.

When you use the System 
Area for a project, please 
check the check box of [Use 
System Area] on the 
Device/PLC Settings or the 
System Settings as shown on 
the right.

When connecting multiple 
devices/PLC to a GP unit, you 
can allocate the System Area 
to one of them.
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(3) Actions of Each Address in System Data Area

<Write-only Area> 
Area that a GP informs status of GP itself to a device/PLC. 

GP Internal 
Address

Word 
Address Description Bit Detail

LS0000 ＋0 Current Screen 
Number - 1 to 9999（BIN）

1 to 7999（BCD）

0 to 2 Unused

3 Screen Memory Checksum 

4 SIO Flaming

5 SIO Parity

6 SIO Overrun

7 to 9 Unused

10 Backup Battery Low Voltage

11 PLC Communication Error

12 to 15 Unused

LS0002 ＋2 Current Value of
“Year” in Clock - Last 2 digits of year (2 BCD digits)

LS0003 ＋3 Current Value of
“Month” in Clock - 01 to 12 (2 BCD digits) 

LS0004 ＋4 Current Value of
“Day” in Clock - 01 to 31 (2 BCD digits)

LS0005 ＋5 Current Value of
“Time” in Clock -

Hour: 00 to 23,
Minute: 00 to 59
(4 BCD digits)

0 to 1 Reserved

2 Printing

3 Data Display Part
Write Setting Value

4 to 7 Reserved

8 Data Display Part Input Error

9 Display On/Off
0: On, 1: Off

10 Backlight Burnout Detection

11 to 15 Reserved

LS0007 ＋7 Reserved - Reserved

LS0006 ＋6 Status

LS0001 ＋1 Error Status

Write-only Area
GP → PLC

See GP-Pro EX Reference Manual “Appendix 1.4 LS Area (Direct Access Method)” for details 
of each address. You can open the manual with the [Help] menu -> [Reference Manual] -> 
[Preface] -> [Basic Operation/Settings] -> [Communicating with Connection Device/PLCs] . 
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< Read-only Area>
Area that a GP reads data in a device/PLC and performs actions.

GP Internal 
Address

Word 
Address Description Bit Detail

LS0008 +8 Change-to Screen -

<When reflecting the 
change-screen number 

to the device/PLC> 
1 to 9999（BIN）
1 to 7999（BCD）

LS0009 +9 Screen Display 
On/Off - Not Display Screen with FFFFh 

Display Screen with 0h

LS0010 +10 Set Value of
“Year” in Clock - Last 2 digit of year (2 BCD digits)

(Bit 15 is a click data rewrite flag)

LS0011 +11 Set Value of
“Month” in Clock - 01 to 12 (2 BCD digits)

LS0012 +12 Set Value of
“Day” in Clock - 01 to 31 (2 BCD digits)

LS0013 +13 Set Value of
“Time” in Clock -

Hour: 00 to 23,
Minute:  00 to 59

(4 BCD digits)

0 Backlight Off

1 Buzzer On

2 Print Started

3 Reserved

4 Buzzer

0 Window Display
0: Off, 1: On

1 Window Overlap Order Change
0: Permitted, 1: Not Permitted

2 to 15 Reserved

LS0016 +16 Window Control

LS0014 +14 Control

5 AUX Output

6 to 10 Reserved

11 Print Canceled

12 to 15 Reserved

LS0015 +15 Reserved - Reserved

LS0017 +17 Window Screens -
Global Window Registration 
Number selected indirectly:

1 to 2000 (BIN/BCD)

LS0018 +18
Window Display 

Position 
(X Coordinate)

-
Top left of  Global  Window

(BIN/BCD)

Read-only Area
GP ← PLC

LS0019 +19
Window Display 

Position 
(Y Coordinate)

-

B100
Error 

Occurred!

An error occurred.
(Writes 100 in the 

address +8)  

LS8 example
When an error occurs in a device/PLC, a GP screen will be changed automatically. 
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Manuals

(1) Manual

The Help menu allows you to open manuals. 

Reference Manual: for operating GP-Pro EX, each feature and function
Device/PLC Manual: for system structure and communication settings of each 

device
Hardware Manual: for names, functions, features and specifications of each 

display unit 
Maintenance/Troubleshooting: for countermeasures toward errors and troubles that occur 

during using GP-Pro EX
Parts List: a list of part shapes that are available for switches and lamps

(2) Help in Dialog Box 

Click the [Help] button in each dialog box, and the corresponding page of GP-Pro EX 
Reference Manual will open. 

The F1 key also opens manuals. 
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MEMO
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