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Introduction
This manual describes how to connect the Display and the External Device (target PLC).
In this manual, the connection procedure is described in the sections indentified below.

KV-700/1000/3000/5000 CPU Direct

1

System Configuration
This section lists the types of External
Devices and SIO that you can connect.

& System Configuration” (page 3)

<

External Device Selection
Select the model (series) of the External
Device and its connection method.

&~ "2 External Device Selection" (page 8)

<=

Communication Settings
This section describes setting examples
for communicating between the Display
and the External Device.

&~ "3 Communication Settings" (page 9)

<

Setup ltems

This section describes communication
setup items on the Display.

Set the Display’s communication settings
in GP-Pro EX or in offline mode.

Fy Setup Items" (page 43)

Cable Diagrams

This section describes cables and
adapters used to connect the Display and
the External Device.

&~ "5 Ccable Diagrams" (page 48)

Operation
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KV-700/1000/3000/5000 CPU Direct

1 System Configuration

The following table lists system configurations for connecting KEYENCE Corporation External Devices and the

Display.
i ) Setting Cable
Series CPU Link I/F SIO Type .
Example Diagram
Setting Cable
CPU Direct’™? RS-232C Example 1 | Diagram 1
(page 9) (page 48)
Setting Cable
(FTDSo-ri:?LZ((::onnection) Example 2 | Diagram 2
(page 11) (page 50)
Setting Cable
KV-L20 EIQDSo-r%:;Z((:iJnnection) Example 4 | Diagram 3
(page 15) (page 52)
RS-422/485 (4wire) Eimgle . g?:;am .
(Port 2 connection) (page 19) (page 54)
Setting Cable
RS-232C . Example 3 | Diagram 2
(Port 1 connection)
KV-700 |\ 200 (page 13) (page 50)
Series RS.230C Setting Cable
KV-L20R (Port 2 connection) Example 5 Diagram 3
(page 17) (page 52)
RS-422/485 (4wire) Eimgle , g?:;am .
(Port 2 connection) (page 21) (page 54)
Setting Cable
(Ffiiﬁizannection) Example 8 | Diagram 2
(page 23) (page 50)
Setting Cable
KV-L20V"2 EIQDSo-r%:;Z((:iJnnection) Example 9 | Diagram 3
(page 25) (page 52)
Rs-422/485 (awir) | Sl 1 | Dt
(Port 2 connection) (page 27) (page 54)
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) ) Setting Cable
Series CPU Link I/F SIO Type .
Example Diagram
Setting Cable
CPU Direct’? RS-232C Example 1 | Diagram 1
(page 9) (page 48)
RS-232C Setting Cable

Example 3 Diagram 2

(Port 1 connection) (page 13) (page 50)

Setting Cable
KV-L20R (RPSo_riazzc(::onnection) Example5 | Diagram 3
(page 17) (page 52)
. Setting Cable
KV-1000 -
. KV-1000 ;i:zzzéiiie(gm:;) Example 7 Diagram 4
Series (page 21) (page 54)
RS-232C Setting Cable

Example 8 Diagram 2
(page 23) (page 50)

Setting Cable

(Port 1 connection)

KV-L20V"2 RS-232C . Example 9 | Diagram 3
(Port 2 connection) (page 25) (page 52)
. Setting Cable
RS-422/485 (4wire) Example 10 | Diagram 4
(Port 2 connection) (age 27) (page 54)
Setting Cable
CPU Direct’™? RS-232C Example 11 | Diagram 1
(page 29) (page 48)
Setting Cable
RS-232C . Example 12 | Diagram 2
KV-3000 (Port 1 connection) (page 30) (page 50)
B KV-3000
Series RS-232C Setting Cable
KV-L20V "2 . Example 13 | Diagram 3
(Port 2 connection) (age 32) (page 52)
. Setting Cable
RS-422/485 (4wire) Example 14 | Diagram 4
(Port 2 connection) (page 34) (page 54)
Setting Cable
RS-232C . Example 12 | Diagram 2
(Port 1 connection) (page 30) (page 50)
Setting Cable
KV-5000 KV-5000 KV-L20V"? RS-232C . Example 13 | Diagram 3
Series (Port 2 connection)

(page 32) (page 52)

Setting Cable
Example 14 | Diagram 4

(page 34) (page 54)

RS-422/485 (4wire)
(Port 2 connection)
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) ) Setting Cable
Series CPU Link I/F SIO Type .
Example Diagram
RS-232C Setting Cable

Example 15 | Diagram 2
(page 36) (page 50)

Setting Cable

(Port 1 connection)

KV-5500 KV-5500 KV-L20V"3 RS-232C . Example 16 | Diagram 3
Series (Port 2 connection) (page 38) (page 52)
. Setting Cable
RS-422/485 (4wire) Example 17 | Diagram 4
(Port 2 connection) (page 40) (page 54)
KV-N14 .
. Setting Cable
KV-Nano KV-N24 Serial port on -
Series KV-N40 CPU Unit RS-232C (E’;arza'ze)ls (D';‘gﬁg)l
KV-N60 Pag bag

*1  Using modular connector on CPU.
*2  For communication settings, KV STUDIO Ver. 4 or later ladder software is required.

*3  For communication settings, KV STUDIO Ver. 6 or later ladder software is required.
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B |[PC COM Port

When connecting IPC with an External Device, the COM port used depends on the series and SIO type. Please

refer to the IPC manual for details.

KV-700/1000/3000/5000 CPU Direct

Usable port
) Usable Port
Series
RS-232C RS-422/485(4 wire) | RS-422/485(2 wire)
com1™, comz,
PS-2000B Com3*L coma - .
PS-3450A, PS-3451A, % * qxo
PS3000-BA, PS3001-BD COMIL, COM2 com2 com2
PS-3650A (T41 model), 1 ] ]
PS-3651A (T41 model) coMl
PS-3650A (T42 model), % % 2
PS-3651A (T42 model) com1™t*2 com2 COM1 CcCoM1
PS-3700A (Pentium®4-M) | COM1™, com2™, 2 o
PS-3710A COM3™2, coM4 com3 CoM3
PS-3711A comM1™ com2™ CoM2™2 COM2*?
PS4000™3 COM1, COM2 - -
com1™2 com2™, 1% %
PL3000 COM3, COM4 coM1 CcCoM1

*1  The RI/5V can be switched. Use the IPC’s switch to change if necessary.

*2  Set up the SIO type with the DIP Switch. Please set up as follows according to SIO type to be used.

*3  When making communication between an External Device and COM port on the Expansion slot,
only RS-232C is supported. However, ER (DTR/CTS) control cannot be executed because of the
specification of COM port.

For connection with External Device, use user-created cables and disable Pin Nos. 1, 4, 6 and 9.
Please refer to the IPC manual for details of pin layout.

DIP Switch setting: RS-232C

DIP Switch Setting Description
1 OFF™1 Reserved (always OFF)
2 OFF
SIO type: RS-232C
3 OFF
4 OFF Output mode of SD (TXD) data: Always output
5 OFF Terminal resistance (220Q2) insertion to SD (TXD): None
6 OFF Terminal resistance (220€2) insertion to RD (RXD): None
7 OFF Short-circuit of SDA (TXA) and RDA (RXA): Not available
8 OFF Short-circuit of SDB (TXB) and RDB (RXB): Not available
9 OFF
RS (RTS) Auto control mode: Disabled
10 OFF

*1  When using PS-3450A, PS-3451A, PS3000-BA and PS3001-BD, turn ON the set value.
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DIP Switch setting: RS-422/485 (4 wire)

DIP Switch Setting Description
1 OFF Reserved (always OFF)
2 ON
SIO type: RS-422/485
3 ON
4 OFF Output mode of SD (TXD) data: Always output
5 OFF Terminal resistance (220€2) insertion to SD (TXD): None
6 OFF Terminal resistance (220Q2) insertion to RD (RXD): None
7 OFF Short-circuit of SDA (TXA) and RDA (RXA): Not available
8 OFF Short-circuit of SDB (TXB) and RDB (RXB): Not available
9 OFF
RS (RTS) Auto control mode: Disabled
10 OFF

DIP Switch setting: RS-422/485 (2 wire)

DIP Switch Setting Description
1 OFF Reserved (always OFF)
2 ON
SIO type: RS-422/485
3 ON
4 OFF Output mode of SD (TXD) data: Always output
5 OFF Terminal resistance (220Q2) insertion to SD (TXD): None
6 OFF Terminal resistance (220Q2) insertion to RD (RXD): None
7 ON Short-circuit of SDA (TXA) and RDA (RXA): Available
8 ON Short-circuit of SDB (TXB) and RDB (RXB): Available
9 ON
RS (RTS) Auto control mode: Enabled
10 ON

GP-Pro EX Device/PLC Connection Manual 7
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2 External Device Selection

Select the External Device to connect to the Display.

,g'f: Welcome to GP-Pro EX [=]

4 —Devica/PLE
GP-Prole |
Humber of Devices/PLCs I 1 33

Device/PLC 1

Manufacturer | KEYEMCE Corporation |L
Series K/-700,1000,/3000,/5000 CPU Direct E
For COM1 =

Reter to the manual of thiz Device/PLC
Eecent Device/PLC
4 3

{—\ I Use System Area Dievice Information
.~

QT

Back [B) Communication Settings | Mew Screen I Cancel

Setup Items Setup Description

Number of Devices/

PLCs Enter an integer from 1 to 4 to define the number of Devices/PLCs to connect to the display.

Manufacturer Select the manufacturer of the External Device to connect. Select "KEYENCE Corporation".

Select the External Device model (series) and the connection method. Select "KV-700/1000/
3000/5000 CPU Direct".

Series In System configuration, make sure the External Device you are connecting is supported by
"KV-700/1000/3000/5000 CPU Direct".

& System Configuration” (page 3)

Port Select the Display port to connect to the External Device.

Check this option to synchronize the system data area of the Display and the device (memory)
of the External Device. When synchronized, you can use the External Device’s ladder program
to switch the display or display the window on the Display.

Cf. GP-Pro EX Reference Manual "LS Area (Direct Access Method Area)"
This feature can also be set in GP-Pro EX or in the Display's offline mode.

Cf. GP-Pro EX Reference Manual "System Settings [Display Unit] - [System Area]

Settings Guide"
Cf. Maintenance/Troubleshooting Guide "Main Unit - System Area Settings"

Use System Area

GP-Pro EX Device/PLC Connection Manual 8
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|

3 Communication Settings

This section provides examples of communication settings recommended by Pro-face for the Display and the
External Device.

3.1 Setting Example 1
B GP-Pro EX Settings

4 Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

" ODD

NOTE * You can set the speed to 9600-57600bps for KV-700 Series, and 9600-115200 bps for KV-
1000 Series.

GP-Pro EX Device/PLC Connection Manual 9
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@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the external device and click [Settings] B

Series Ky-700/1000 |

Fleaze reconfirm all of address zettings that
yau are wzing if yau have changed the senes.

[refauilt |
okE | Cancel |

B External Device Settings

There are no settings on the External Device. The speed automatically switches according to the Display settings.

GP-Pro EX Device/PLC Connection Manual 10
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|

3.2 Setting Example 2
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

C OpD

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the external device and click [Settings] ﬁ .

#* Individual Deyice Settings Ed

k-70041000 Ed

GP-Pro EX Device/PLC Connection Manual 11
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B External Device Settings

Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 4 or later) to configure communication
settings for the External Device.

Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].
(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L20" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit placement
area.

(6) Double-click "KV-L20" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

Setup Items Setup Description
Operation Mode KV BUILDER mode
Interface RS-232C
Baud Rate Auto
Data Bit Length 8 bits
Port 1 Start Bit 1 bit
Stop Bit 1 bit
Parity Even
Check Sum None
RS/CS Flow Control Disabled

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.
(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.

GP-Pro EX Device/PLC Connection Manual 12
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3.3 Setting Example 3
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

£ o

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the external device and click [Settings] ﬁ .

¢* Individual Device Settings E3

K-700/1000 -
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B External Device Settings
Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 4 or later) to configure communication
settings for the External Device.
Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].
(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L20R" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit

placement area.
(6) Double-click "KV-L20R" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-232C
Baud Rate Auto
Data Bit Length 8 bits
Port 1 Start Bit 1 bit
Stop Bit 1 bit
Parity Even
Check Sum None
RS/CS Flow Control Disabled
Station No. Station No. 0
g::tz?:gs Transfer Timeout (sec.) | 3

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.

GP-Pro EX Device/PLC Connection Manual
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|

3.4 Setting Example 4
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

- opD

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the external device and click [Settings] ﬁ .

* Individual Device Settings E3

k37001 000 R
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B External Device Settings

Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 4 or later) to configure communication
settings for the External Device.

Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].
(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L20" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit placement
area.

(6) Double-click "KV-L20" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

Setup Items Setup Description
Operation Mode KV BUILDER mode
Interface RS-232C
Station No. 0
Baud Rate Auto
Port 2 Data Bit Length 8 bits
Start Bit 1 bit
Stop Bit 1 bit
Parity Even
Check Sum None

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.
(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.

GP-Pro EX Device/PLC Connection Manual 16
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|

3.5 Setting Example 5
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

O

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the external device and click [Settings] ﬁ .

#* Individual Deyice Settings Ed

k-70041000 Ed

GP-Pro EX Device/PLC Connection Manual 17
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B External Device Settings
Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 4 or later) to configure communication
settings for the External Device.
Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].
(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L20R" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit

placement area.
(6) Double-click "KV-L20R" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-232C
Baud Rate Auto
Data Bit Length 8 bits
Port 2
Start Bit 1 bit
Stop Bit 1 bit
Parity Even
Check Sum None
Station No. Station No. 0
gs:filri:gs Transfer Timeout (sec.) | 3

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.

GP-Pro EX Device/PLC Connection Manual
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|

3.6 Setting Example 6
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Jn i

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the external device and click [Settings] ﬁ .

* Individual Device Settings E3

KA-700,/41000 ka
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B External Device Settings

Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 4 or later) to configure communication
settings for the External Device.

Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].
(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L20" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit placement
area.

(6) Double-click "KV-L20" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

Setup Items Setup Description
Operation Mode KV BUILDER mode
Interface RS-422A
Station No. 0
Baud Rate Auto
Port 2 Data Bit Length 8 bits
Start Bit 1 bit
Stop Bit 1 bit
Parity Even
Check Sum None

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.
(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.

GP-Pro EX Device/PLC Connection Manual 20
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|

3.7 Setting Example 7
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Jn i

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the external device and click [Settings] ﬁ .

¢* Individual Device Settings E3

K-700/1000 -
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B External Device Settings
Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 4 or later) to configure communication
settings for the External Device.
Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].
(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L20R" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit

placement area.
(6) Double-click "KV-L20R" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-422A/485 (4wire)
Baud Rate Auto
Data Bit Length 8 bits
Port 2
Start Bit 1 bit
Stop Bit 1 bit
Parity Even
Check Sum None
Station No. Station No. 0
gs:filri:gs Transfer Timeout (sec.) | 3

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.
(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.

GP-Pro EX Device/PLC Connection Manual 22
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|

3.8 Setting Example 8
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

£ moo

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the external device and click [Settings] ﬁ .

#* Individual Device Settings Ed

kx-700/1000 R
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B External Device Settings
Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 4 or later) to configure communication
settings for the External Device.
Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].
(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L20V" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit

placement area.
(6) Double-click "KV-L20V" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-232C
Baud Rate Auto
Data Bit Length 8 bits
Port 1 Start Bit 1 bit
Stop Bit 1 bit
Parity Even
Check Sum None
RS/CS Flow Control Disabled
Station No. Station No. 0
g::tz?:gs Transfer Timeout (sec.) | 3

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.

GP-Pro EX Device/PLC Connection Manual
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3.9 Setting Example 9
B SGP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

£ o

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the external device and click [Settings] ﬁ .

* Individual Device Settings E3

KA-700,/41000 ka
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B External Device Settings
Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 4 or later) to configure communication
settings for the External Device.
Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].
(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L20V" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit

placement area.
(6) Double-click "KV-L20V" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-232C
Baud Rate Auto
Data Bit Length 8 bits
Port 2
Start Bit 1 bit
Stop Bit 1 bit
Parity Even
Check Sum None
Station No. Station No. 0
gs:filri:gs Transfer Timeout (sec.) | 3

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.
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3.10 Setting Example 10
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Jn i

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the external device and click [Settings] ﬁ .

* Individual Device Settings E3

KA-700,/41000 ka
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B External Device Settings
Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 4 or later) to configure communication
settings for the External Device.
Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].
(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L20V" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit

placement area.
(6) Double-click "KV-L20V" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-422A/485 (4wire)
Baud Rate Auto
Data Bit Length 8 bits
Port 2
Start Bit 1 bit
Stop Bit 1 bit
Parity Even
Check Sum None
Station No. Station No. 0
gs:filri:gs Transfer Timeout (sec.) | 3

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.
(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.
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3.11 Setting Example 11
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

(" ODoy

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the external device and click [Settings] ﬁ .

* Individual Device Settings E3

K-3000/5000 ka

B External Device Settings

There are no settings on the External Device. The speed automatically switches according to the Display setting.

GP-Pro EX Device/PLC Connection Manual 29



KV-700/1000/3000/5000 CPU Direct
|

3.12 Setting Example 12
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

{ ODD

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the external device and click [Settings] ﬁ .

#* Individual Deyice Settings Ed

K-3000/5000 Ed
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B External Device Settings
Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 4 or later) to configure communication
settings for the External Device.
Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].
(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L20V" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit

placement area.
(6) Double-click "KV-L20V" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-232C
Baud Rate Auto
Data Bit Length 8 bits
Port 1 Start Bit 1 bit
Stop Bit 1 bit
Parity Even
Check Sum None
RS/CS Flow Control Disabled
Station No. Station No. 0
g::tz?:gs Transfer Timeout (sec.) | 3

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.
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3.13 Setting Example 13
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

L mpm

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the external device and click [Settings] ﬁ .

#* Individual Deyice Settings Ed

K-3000/5000 Ed
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B External Device Settings
Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 4 or later) to configure communication
settings for the External Device.
Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].
(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L20V" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit

placement area.
(6) Double-click "KV-L20V" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-232C
Baud Rate Auto
Data Bit Length 8 bits
Port 2
Start Bit 1 bit
Stop Bit 1 bit
Parity Even
Check Sum None
Station No. Station No. 0
gs:filri:gs Transfer Timeout (sec.) | 3

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.
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3.14 Setting Example 14
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Sn]

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the external device and click [Settings] ﬁ .

#* Individual Deyice Settings Ed

K-3000/5000 Ed
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B External Device Settings
Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 4 or later) to configure communication
settings for the External Device.
Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].
(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L20V" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit

placement area.
(6) Double-click "KV-L20V" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-422A/485 (4wire)
Baud Rate Auto
Data Bit Length 8 bits
Port 2
Start Bit 1 bit
Stop Bit 1 bit
Parity Even
Check Sum None
Station No. Station No. 0
gs:filri:gs Transfer Timeout (sec.) | 3

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.
(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.
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3.15 Setting Example 15
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

L mpm

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the external device and click [Settings] ﬁ .

#* Individual Device Settings Ed

k430005000 R

@ Note
» Ifyou are using a KV-5500 series device, select [KV-3000/5000] from the [Series] list.
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Use ladder software KV STUDIO Ver. 6 or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) Inthe [Project name] field enter the project name, in the [PLC model] property select the External Device, and

click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.

(5) On the [Select unit (1)] tab, from the displayed list of units select "KV-L20V", then drag & drop to the unit

placement area.

(6) In the unit placement area click "KV-L20V" and then select the [Setup unit (2)] tab.

(7) Configure the setup items as follows.

Setup ltems

Setup Description

Operation Mode

KV BUILDER/KV STUDIO mode

Interface RS-232C (Fixed)
Baud Rate Auto (Fixed)
Data Bit Length 8 bits (Fixed)

Port 1 Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
RS/CS Flow Control Disabled

Base Node No. 0

gs:te;:gs g:g:;er timeout time 3 (Fixed)

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(12)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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3.16 Setting Example 16
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

£ moon

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the external device and click [Settings] ﬁ .

#* Individual Devyice Settings Ed

k430005000 R

€ Note
« If you are using a KV-5500 series device, select [KV-3000/5000] from the [Series] list.
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Use ladder software KV STUDIO Ver. 6 or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) Inthe [Project name] field enter the project name, in the [PLC model] property select the External Device, and

click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.

(5) On the [Select unit (1)] tab, from the displayed list of units select "KV-L20V", then drag & drop to the unit

placement area.

(6) In the unit placement area click "KV-L20V" and then select the [Setup unit (2)] tab.

(7) Configure the setup items as follows.

Setup ltems

Setup Description

Operation Mode

KV BUILDER/KV STUDIO mode

Interface RS-232C
Baud Rate Auto (Fixed)
Data Bit Length 8 bits (Fixed)
Port 2
Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
Base Node No. 0
gg:tei\rl:gs g:g:;er timeout time 3 (Fixed)

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(12)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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3.17 Setting Example 17
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

O

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the external device and click [Settings] ﬁ .

#* Individual Device Settings Ed

k430005000 R

@ Note
e Ifyou are using a KV-5500 series device, select [KV-3000/5000] from the [Series] list.
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Use ladder software KV STUDIO Ver. 6 or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) Inthe [Project name] field enter the project name, in the [PLC model] property select the External Device, and

click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.

(5) On the [Select unit (1)] tab, from the displayed list of units select "KV-L20V", then drag & drop to the unit

placement area.

(6) In the unit placement area click "KV-L20V" and then select the [Setup unit (2)] tab.

(7) Configure the setup items as follows.

Setup ltems

Setup Description

Operation Mode

KV BUILDER/KV STUDIO mode

Interface RS-422A/485 (4wire)
Baud Rate Auto (Fixed)
Data Bit Length 8 bits (Fixed)
Port 2
Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
Base Node No. 0
gg:tei\rl:gs g:g:;er timeout time 3 (Fixed)

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(12)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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3.18 Setting Example 18
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

(" ODoy

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the external device and click [Settings] ﬁ .

* Individual Device Settings E3

K-3000/5000 ka

@ Note
If you are using a KV-Nano series device, select [KV-3000/5000] from the [Series] list.

B External Device Settings

There are no settings on the External Device. The speed automatically switches according to the Display setting.
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4 Setup Items

Set up the Display’s communication settings in GP-Pro EX or in the Display’s offline mode.
The setting of each parameter must match that of the External Device.
&~ "3 Communication Settings" (page 9)

4.1 Setup Items in GP-Pro EX

B Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Surnmary Change DevicePLC
M anufacturer IKEYENCE Corporation Series K-700/1000/3000/5000 CPU Direct Port |COM1
Text Data Made IT LChange

Communication Settings

510 Type ' R5232C € BE422/ 485 e " R5422/4854wire]
Speed lm

Data Length () 7 [l

Farity £ HOKE & EVEN v}

Stop Bit =1 2

Flows Cantral & HOKE £ ER[DTR/CTS] L P o

Timeout 3 = [sec)

Fietry m

‘Wit To Send m (ms)

Rl #¥CC &~ Al  YCC

In the case of RS232C, vou can select the Sth pin to Rl [Input]
or YCC [ Power Supply). If you uge the Digital's RS232C
Izalation Unit, please select it to VLT, Default

Device-5 pecific Settings

Allowable Humber Add Device
of Devices/PLCs 1

&dd Indirect
Mo, Device Mame Settings Device
[&] 1 JFci ] [Series=Fv-700/1000
Setup Items Setup Description
SIO Type Select the SIO type for communicating with the External Device.
Speed Select the communication speed between the External Device and the Display.
Data Length Select a data length.
Parity Select how to check parity.
Stop Bit Select a stop bit length.
Select the communication control method to prevent overflow of transmission and reception
Flow Control
data.
) Enter the time (s) for which the Display waits for the response from the External Device, from
Timeout " "
1to 127",
In case of no response from the External Device, enter how many times the Display retransmits
Retry " "
the command, from "0 to 255",
Wait To Send Enter the standby time (ms) from when the Display receives packets until it transmits the next

command, from "0 to 255",
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Setup Items Setup Description

You can switch between RI/VCC for the 9th pin when you select RS-232C for SIO type.
RI/VCC To connect to the IPC, switch between RI/5V using the IPC selector switch. Refer to your IPC
manual for details.

NOTE * Refer to the GP-Pro EX Reference Manual for Indirect Device.

Cf.  GP-Pro EX Reference Manual "Changing the Device/PLC at Runtime (Indirect
Device)"

B Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the external device and click [Settings] B

,g‘rf: Individual Device Settings

PLC1

Series Ky-700/1000 |

Fleaze reconfirm all of address zettings that
you are uzing if you have changed the senes.

Diefault |
oko) | Cancel |

Setup ltems Setup Description

Series Select the series of the External Device.
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4.2 Setup Items in Offline Mode
NOTE « Refer to the Maintenance/Troubleshooting guide for information on how to enter offline mode

or about the operation.
Cf.  Maintenance/Troubleshooting Guide "Offline Mode"

« The number of the setup items to be displayed for 1 page in the offline mode depends on the
Display in use. Please refer to the Reference manual for details.

B Communication Settings

To display the setting screen, touch [Device/PLC Settings] from [Peripheral Settings] in offline mode. Touch the
External Device you want to set from the displayed list.

Comm, Device Option

KV-TABS 1080/ 3000,/5000 GFU Direct [com1] Page 1/1
SI0 Type RS232C hd
Speed 19200 -
Data Length 8
Parity EVEN
Stop Bit 1
Flow Gontrol MONE
Timeout{s) | 3 w | Al

Retry | P w | A

Wait to Send(ms) | 0w | al

: 2008/01/0
R il 16:10:14

Setup Items Setup Description

Select the SIO type for communicating with the External Device.

In the communication settings, set [SIO Type] correctly according to the serial interface

SIO Type specifications of the Display.
If you select an S10O type that the serial interface does not support, proper operation cannot
be guaranteed.
Refer to your Display manual for details on the serial interface specifications.

Speed Select the communication speed between the External Device and the Display.

Data Length Data length is displayed.
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Setup ltems Setup Description
Parity The parity check method is displayed.
Stop Bit Stop bit length is displayed.
The communication control method to prevent overflow of transmission and reception
Flow Control
data.
) Enter the time (s) for which the Display waits for the response from the External Device,
Timeout " "
from "1 to 127".
Retr In case of no response from the External Device, enter how many times the Display
y retransmits the command, from "0 to 255".
Wait To Send Enter the standby time (ms) from when the Display receives packets until it transmits the

next command, from "0 to 255".

W Device Setting

To display the setting screen, touch [Device/PLC Settings] from [Peripheral Settings]. Touch the External Device

you want to set from the list that appears, and touch [Device].

Comm, Device Option
K\-780/1008/3080/5080 GPU Direct [comM1] Page 1/1
Device/PLG Name [PLCL > |
Series Kv-T80/ 10aa
Setup ltems Setup Description

Device/PLC Name

Select the External Device to set. Device/PLC Name is the title of the External Device set
with GP-Pro EX. (Initial value [PLCL1])

Series

Displays the series of the External Device.
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H Option
To display the setting screen, touch [Device/PLC Settings] from [Peripheral Settings]. Touch the External Device

you want to set from the list that appears, and touch [Option].

Comm, Device Dptian
Kv-T00/1000,3000/50088 GPU Direct [comM1] Fage 1/1
RI / VGG + RI VGG
In the case of ES2320, wou can select
the 9th pin to RI(Input) or WOGIAY
Power Supplyy, If wou use the Digital’s
RS232C Tsolation Unit, please select
it to VGO,
: ZHRB/01/08
el = 19:19:33
Setup ltems Setup Description
You can switch between RI/VCC for the 9th pin when you select RS-232C for SIO type.
RI/VCC To connect to the IPC, you need to switch between RI/5V using the IPC selector switch.
Refer to your IPC manual for details.

NOTE * GP-4100 series, GP-4*01TM, LT-4*01TM and LT-Rear Module do not have the [Option]
setting in the offline mode.
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The cable diagrams shown below may be different from the cable diagrams recommended by KEYENCE

Corporation. Please be assured there is no operational problem in applying the cable diagrams shown in this

manual.

e The FG pin on the External Device must be D-class grounded. Refer to your External Device manual for

details.

e The SG and FG are connected inside the Display. If you connect the External Device to the SG, do not form
any short-circuit loop in the system design.

* |f the communication is not stable because of noise or other factors, connect an isolation unit.

Cable Diagram 1

Displ
ISp. = Cable Remarks
(Connection Port)
GP3000 (COML1)
GP4000™! (COM1) D-sub 9Pin by KEYENCE Corporation
SP5000 (COM1/2) OP-26486
ST (COM1) 1A +
LT3000 (COM1) Modular cable by KEYENCE Corporation
IPC™2 OP-26487 (2.5m)
PC/AT
User-created cable
+
D-sub 9Pin by KEYENCE Corporation
GP-4105 (COM1) 1B OP-26486
+

Modular cable by KEYENCE Corporation
OP-26487 (2.5m)

*1  All GP4000 models except GP-4100 Series and GP-4203T

*2  Available only with COM ports that support RS-232C.
B [PC COM Port (page 6)

1A)

Display

OP-26486

OP-26487
L o

External Device

NS

|

Modular connector 6 pin (plug)

D-sub 9 pin (socket)
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1B)
Display side External Device side
Terminal block Shield D-sub 9 pin (plug)
Signal i kY ; Signal
Display name H Pin name
RD(RXD) + — 2 |RD(RXD) OP-26486 External Device
SD(TXD) — 3 |SD(TXD) @ - OP-26487 - ﬂiﬁi
ER(DTR) — 4 |ER(DTR)
SG L 5 SG /
RS(RTS) - ‘ 7 RS(RTS) Modular connector 6 pin (plug)
' . D-sub 9 pi ket
CS(CTS) . 8 [Cs(CTs)| DP9 P (socked

| ||—4|

User-created cable
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Cable Diagram 2

Displa
p. i Cable Remarks

(Connection Port)
GP3000 (COM1)
GP4000*1 (COML1)
SP5000 (COM1/2)
ST (COM1) 2A User-created cable I?:aegsable length must be 15m
LT3000 (COM1) '
IPC"2
PCIAT
GP-4105 (COM1) 2B User-created cable The cable length must be 15m

or less.

_A*

g—éeﬂﬂv'\lﬂo éﬁ.ng) RJ45 RS-232C Cable (5m) by Pro-face The cable lendth must be 5 or
2C PFXZLMCBRJR21 g

(Comi) less.

*1  All GP4000 models except GP-4100 Series and GP-4203T

*2  Available only with COM ports that support RS-232C.
5" m |PC COM Port (page 6)

2A)

Display side External Device side
Dsub 9 pin (socket) Shield Dsub 9 pin (socket)
Pin Signal name :,’" ',"r“‘.'l Pin Signal name
Display 2 RD(RXD) :::><: 2 RD(RXD)
3 SD(TXD) . . : 3 SD(TXD)
4 ER(DTR) f— | — 5 SG
5 se L 7 |Rrs®TS)
8 |cscTs) e} '. ,' 8 | cs(cTs)
shel | FG |—% \f
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2B)
Display side External Device side
Terminal block Shield Dsub 9 pin (socket)
Signal name :'" ',"“",' Pin  |Signal name
Display RD(RXD) 4—:><-:—:—> 2 RD(RXD)
SD(TXD) 3 SD(TXD)
ER(DTR) 5 SG
SG _l ' o 7 RS(RTS)
CS(CTS) <J I—_> 8 | cs(cTs)
| L
\_------------.-T_
2C)
External Device side
Dsub 9 pin (socket)
. Pin Signal name
Display TXD 5 RD(RXD)
RXD 3 | sD(Txp)
(1) Ghb 5 SG
7 RS(RTS)
I—_> 8 CS(CTS)
Legend Name Note
RJ45 RS-232C Cable (5m) by Pro-face
Q) PFXZLMCBRJR21
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Cable Diagram 3

KV-700/1000/3000/5000 CPU Direct

Display
(Connection Port)

Cable

Remarks

GP3000 (COM1)
GP4000*1 (COML1)

SP5000 (COM1/2)
ST (COM1) 3A User-created cable I?:aegsable length must be 15m
LT3000 (COM1) '
IPC"2
PC/AT
GP-4105 (COM1) 3B User-created cable The cable length must be 15m
or less.
A%
g_‘éegﬂv'\l"o éﬁ.ng) RJ45 RS-232C Cable (5m) by Pro-face The cable lendth must be 5 or
3C PFXZLMCBRIR21 less g

(COM1)

*1  All GP4000 models except GP-4100 Series and GP-4203T

*2  Available only with COM ports that support RS-232C.
5" m |PC COM Port (page 6)

« Set the PORT2 toggle switch on the External Device to "232C".

3A)

Display

Display side
Dsub 9 pin (socket)

Shield

External Device side
Terminal block

Pin Signal name

RD(RXD)

ER(DTR)

2

3 SD(TXD)
4

5

SG

1

]
1

]
]
]
i
[]

Pin Signal name
1 SG
3 SD(TXD)
5 RD(RXD)

8 CS(CTS)
Shell FG |—=
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3B)
Display side External Device side
Terminal block Shield Terminal block
s T\
Signal name H "' \ Pin Signal name
! P
RD(RXD) i 1 SG
Display SD(TXD) 3 [sD(TxD)
ER(DTR) 5 RD(RXD)
SG
CS(CTS)
3C)
External Device side
Terminal block
Pin Signal name
Display GND
1 SG
RXD
3 SD(TXD)
1 TXD
(1) 5 RD(RXD)
Legend Name Note
RJ45 RS-232C Cable (5m) by Pro-face
Q) PFXZLMCBRJR21
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Cable Diagram 4
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Displa:
p. 4 Cable Remarks
(Connection Port)
COM port conversion adapter by Pro-face
AGP-3302B (COM2) _ o
i 4A |  Connector terminal block conversion adapter by Pro-face | The cable length
GP-4*01TM (COM) must be 500m or
ST2 (COM2) CA3-ADPTRM-01 m
LT3000 (COM1) + :
*3 User-created cable
IPC
4B User-created cable
Online adapter by Pro-face
CA4-ADPONL-01
+
AC Connector terminal block conversion adapter by Pro-face
CA3-ADPTRM-01
+ The cable length
GP3000"}(COM2) User-created cable must be 500m or
less.
Online adapter by Pro-face
CA4-ADPONL-01
4D .\
User-created cable
The cable length
GP-4106 (COM1) 4E User-created cable must be 500m or
less.
RS-422 Terminal Block Conversion Adapter by Pro-face
* *5
GP4000™ (COM2) 4F PFXZCBADTM1 The cable length
GP-4201T (COM1) + must be 500m or
SP5000 (COM1/2) User-created cable less.
4B User-created cable

*1  All GP3000 models except AGP-3302B
*2  All ST models except AST-3211A and AST-3302B

*3  Available only with COM ports that support RS-422/485 (4wire).
" m |PC COM Port (page 6)

*4  All GP4000 models except GP-4100 Series, GP-4*01TM, GP-4201T and GP-4*03T

*5  When using a Terminal Block Conversion Adapter (CA3-ADPTRM-01) instead of the RS-422 Terminal Block
Conversion Adapter, refer to Cable Diagram 4A.

» Set the PORT2 toggle switch on the External Device to "422A 485(4)". Also, turn ON the
switch of the terminator.
« Pay attention that pole A and pole B are reversely named for the Display and the External

Device.
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4A)

Termination _Display side

External Device side

resistance Ierminal block __.Shield____ Terminal block
2200 1/4W Signal name ‘," ," |‘, Pin Signal name
[}
Display ~ CA3-ADPCOM-01 RDA  |le—t /\\ {1 5 SDB(+)
1 (] 1
] ) )
(= RDB <—v—/ T 3 SDA(-)
, =3 /\ !
{ SDA / \ > 4 RDB(+)
CA3-ADPTRM-01 SDB > 2 RDA(-)
Termination SG H Vot ! SG
resistance FG S Vo
220Q 1/4W i Vi
TERMRX [ \/
D User-created cable "
4B)
o Display side External Device side
Termination gy 9 pin (socket) Shield Terminal block
resistance ; o
220Q 1/4W Pin Signal name / | |'| Pin Signal name
] | )
{ 1 RDA fe—i /\\ i 5 SDB(+)
Displ = P
by 2 RDB |e -, 3 SDA(-)
]
{ 3 SDA /\\ —— 4 RDB(+)
]
7 SDB > 2 RDA()
5 SG 1 SG
Termination
resistance 4 ERA :I
220Q 1/4W
8 CSA '
]
9 ERB :I ‘. .
1 H
6 CSB '-, L
Shell FG |—= \
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4C)

R Display side External Device side
Treer;'l‘s'?:;fg Terminal block Shield Terminal block
[ A}
220Q 1/4W [ Signal name / i Pin  [Signal name
! [N
Display ~ CA4-ADPONL-01 \ { RDA e :" /\\ Ll 5 SDB(+)
1 ]
' [
ﬂj] [ = RDB  [——/ 3 SDA(-)
, =3 ! /\
{ SDA : / \ > 4 RDB(+)
CA3-ADPTRM-} SDB ; > 5 RDA()
)
[
Termination SG \ Vo ! SG
resistance FG Y ] .:
220Q 1/4W \ [
TERMRX \ \ ,,'
< P>
User-created cable
4D)
Termination Display side Externa] Device side
resistance  D-Sub 9 pin (plug) Shield Terminal block
2200 /4w Pin Signal name '," ,,‘“‘.I Pin Signal name
) [}
i 2 RDA |« ANEI
Display  a4-aDPONL-01 { / \ ' 5 SDB(+)
7 RDB |« : 3 SDA(+)
{ 3 SDA /\\ > 4 RDB(+)
/ 8 SDB : - < RDA(-)
Termination 5 SG '-| '.' ,' 1 SG
resistance \ ! H
2200 14w | Shell FG - Y

User-created cable
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4E)

Display side External Device side
Termination Terminal block Shield Terminal block
resistance! [ g/ ame ‘;' i Pin Signal name
i A
{ RDA  Je——A—i 5 SDB(+)
Displ i P
i RDB |e—— \——— 3 SDA(-)
1 |
{ SDA A » 4 RDB(+)
/ SDB —iJ > 2 RDA(-)
[l ]
SG ; — 1 SG
Termination H E E
resistance*1 ERA i ! E
CSA E bl
1 Vol
ERB :l b
: b
\ Vi

al

*1  The resistance in the Display is used as the termination resistance. Set the value of the DIP Switch on the
rear of the Display as shown in the table below.

DIP Switch No. Set Value
1 OFF
2 ON
3 OFF
4 ON
4F)
Termination Display side External Device side
resistance 1erminal block ____S_rliglq___’ Terminal block
2200 oW Signal name ." .'I “. Pin Signal name
i i A I
Display { RDA [« \ — 5 SDB(+)
] ] h
| = RDB (e 3 SDA(-)
, =3 ! A
{ SDA y / \ > 4 RDB(+)
PFXZCBADTM1 SDB ; > > RDAQ)
H :
Termination SG ] Pl 1 SG
resistance FG Y I
220Q 1/4W :‘ I'| :'
TERMRX L \/

User-created cable
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6 Supported Device

The range of supported device addresses is shown in the table below. Please note that the actual supported range
for devices varies depending on the external device that is used. Please check the actual range in the external

device manual.

6.1 KV-700 Series
[E=== : This address can be specified as system data area.
Device Bit Address Word Address 32 bits Remarks
Input Relay
Output Relay 00000 - 59915 000 - 599 rLIH)
Internal Auxiliary Relay
Control Relay CRO0000 - CR3915 CROO0 - CR39
Timer (Contact) TOOO-T511 | -
Counter (Contact) cooo-Ccs11 | e i
High-speed Counter *]
Comparator (Contact) CTC0-CTC3
Timer (Setting Value) | - TS000 - TS511 *2
Counter (Setting Value) | - CS000 - CS511 "2
Timer (Current Value) | - TCO000 - TC511 2
Counter (Current Value) | - CC000 - CC511 2
Data Memory | e DMO00000 - DM39999 c19)
Temporary Data Memory | - TMO000 - TM511 [LIH) e 19]
Control Memory | - CMO0000 - CM3999 9]
Digital Trimmer | - TRMO - TRM7 "2
High-speed Counter | ) *0
(Current Value) CTHO - CTHL
High-speed Counter | ) *0
Comparator (Setting Value) CTCo-CTC3

*1  Write disable
*2  32-bit device

« When connecting KV-700 Series, use settings within the device address ranges above.

« If you try to access device addresses supported only by the KV-1000 Series devices, the following
error messages display: "Error has been responded for device read command (Error
Code(02)[(0x02)]" or "Error has been responded for device write command (Error
Code(02)[(0x02)]".
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NOTE | ¢ Refer to the GP-Pro EX Reference Manual for system data area.
Cf.  GP-Pro EXReference Manual "LS Area (Direct Access Method Area)"

¢ Refer to the precautions on manual notation for icons in the table.

&~ "Manual Symbols and Terminology"
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6.2 KV-1000 Series
[E=== : This address can be specified as system data area.
Device Bit Address Word Address 32 bits Remarks
Input Relay 1
Output Relay 00000 - 59915 000 - 599 1
Internal Auxiliary Relay LIH) 1
Internal Auxiliary Relay MRO00000 - MR99915 MRO000 - MR999
Latch Relay LR0O0000 - LR99915 LROO0O - LR999
Control Relay CRO0000 - CR3915 CROO - CR39
Timer (Contact) TO000-T3999 | -
Counter (Contact) C0000-C3999 | - i
sttt | camcres | -
Timer (Setting Value) | - TS0000 - TS3999 3
Counter (Setting Value) | - CS0000 - CS3999 *3
Timer (Current Value) | - TC0000 - TC3999 "3
Counter (Current Value) | - CC0000 - CC3999 "3
Data Memory | e DMO00000 - DM65534 o |
Extension Data Memory EM |  ----- EMO00000 - EM65534 = b
Extension Data Memory FM |  —---- FMO00000 - FM32766 LIH) =15
Temporary Data Memory |  ------ TMO00 - TM511 e 1)
Control Memory | e CMO00000 - CM11998 =15
Index Register | e Z01-Z712 15"
Digital Trimmer | e TRMO - TRM7 "3
o N - :
High-speed Counter | CTCO - CTC3 *3

Comparator (Setting Value)

*1  ROO0O to R599 (R00000 to R59915) are shown in KV-1000, but 000 to 599 (00000 to 59915) in GP-Pro EX.

*2  Write disable
*3  32-bit device

*4 Do not write to the addresses Z11 and Z12. They are used in the system of the External Device.
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NOTE | ¢ Refer to the GP-Pro EX Reference Manual for system data area.
Cf.  GP-Pro EX Reference Manual "LS Area (Direct Access Method Area)"

¢ Refer to the precautions on manual notation for icons in the table.

&~ "Manual Symbols and Terminology"
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6.3 KV-3000/5000/5500 Series
[E=== : This address can be specified as system data area.
Device Bit Address Word Address 32 bits | Remarks
Input Relay
Output Relay R00000 - R99915 R0O00 - R999

Internal Auxiliary Relay

Link Relay B0000 - B3FFF B0O0O - B3FF rLIH]
Internal Auxiliary Relay MRO00000 - MR99915 MRO000 - MR999
Latch Relay LRO0000 - LR99915 LRO0O - LR999
Control Relay CRO0000 - CR3915 CRO00 - CR39
Work Relay VB0000 - VB3FFF VBO000 - VB3FF
Timer (Contact) TO000-T3999 | -
Counter (Contact) C0000-C3999 | - i
et o coo-ctes | .
Timer (Setting Value) | - TS0000 - TS3999 2
Counter (Setting Value) | - CS0000 - CS3999 2
Timer (Current Value) | - TC0000 - TC3999 "2
Counter (Current Value) | - CC0000 - CC3999 2
Data Memory | - DMO00000 - DM65534 m
Extension Data Memory | = -eee- EMO00000 - EM65534 =15
o CurrentBank | - FMO00000 - FM32767 =15
ile
Register | Serial Number | ZF000000 - ZF131071 15
System
[L/H
Temporary Data Memory | - TMO00 - TM511 03]
Control Memory | - CMO00000 - CM05999 @
Link Register | - W0000 - W3FFF [eicF]
Work Memory | e VMO00000 - VM59999 =15
Index Register | - Z01-2712 23
Digital Trimmer | e TRMO - TRM7 2
C;?:;peed Counter (Current | CTHO - CTH1 *9
High-speed Counter | CTCO-CTC3 *)

Comparator (Setting Value)

*1  Write disable
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*2  32-bit device

*3 Do not write to the addresses Z11 and Z12. They are used in the system of the External Device.

NOTE | * Refer to the GP-Pro EX Reference Manual for system data area.
Cf.  GP-Pro EX Reference Manual "LS Area (Direct Access Method Area)"

« Refer to the precautions on manual notation for icons in the table.

&~ "Manual Symbols and Terminology"
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6.4 KV-Nano Series
[E=== : This address can be specified as system data area.
Device Bit Address Word Address 32 bits | Remarks
Input Relay
Output Relay R0O0000 - R59915 R000 - R599
Internal Auxiliary Relay
Link Relay B0000 - B1FFF BOOO - B1FF rLIH]
Internal Auxiliary Relay MRO00000 - MR59915 MRO000 - MR599
Latch Relay LRO0000 - LR19915 LRO0O - LR199
Control Relay CRO0000 - CR3915 CRO00 - CR39
Work Relay VB0000 - VB1FFF VBO000 - VB1FF
Timer (Contact) TOO0O-TO511 | -
Counter (Contact) C0000-C0255 | e i
Comparator (Gontach crw-ctes | — b
Timer (Setting Value) | - TS0000 - TS0511 2
Counter (Setting Value) | - CS0000 - CS0255 2
Timer (Current Value) | - TCO0000 - TCO511 "2
Counter (Current Value) | - CC0000 - CC0255 "2
Data Memory | - DMO00000 - DM32767 | m
Temporary Data Memory | = - TMOO00 - TM511 =15
Control Memory | e CMO00000 - CM05999 LiH et 15
Link Register | - WO0000 - W3FFF [EicF]
Work Memory | - \VVMO00000 - VM09999 =15
Index Register | e Z01- 712 273
\I—/I;?Lkllspeed Counter (Current | CTHO - CTH1 *9
High-speed Counter | CTCO - CTC3 *9

Comparator (Setting Value)

*1  Write disable
*2  32-bit device

*3 Do not write to the addresses Z11 and Z12. They are used in the system of the External Device.
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NOTE | ¢ Refer to the GP-Pro EX Reference Manual for system data area.
Cf.  GP-Pro EX Reference Manual "LS Area (Direct Access Method Area)"

¢ Refer to the precautions on manual notation for icons in the table.

&~ "Manual Symbols and Terminology"
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7 Device Code and Address Code

Use device code and address code if you select "Device Type & Address" for the address type in Data displays.

KV-700/1000/3000/5000 CPU Direct

7.1 KV-700 Series
Device Device Name Device Code Address Code
(HEX)
Input Relay
OutputRelay | e 0080 Word Address
Internal Auxiliary Relay
Control Relay CR 008A Word Address
Timer (Setting Value) TS 0062 Double Word Address
Counter (Setting Value) CS 0063 Double Word Address
Timer (Current Value) TC 0060 Double Word Address
Counter (Current Value) cC 0061 Double Word Address
Data Memory DM 0000 Word Address
Temporary Data Memory ™ 0001 Word Address
Control Memory CM 0002 Word Address
Digital Trimmer TRM 0064 Double Word Address
High-speed Counter (Current Value) CTH 0065 Double Word Address
?;g;;rs{ge\?;ui?unter Comparator CTC 0066 Double Word Address
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7.2 KV-1000 Series
Device Device Name Device Code Address Code
(HEX)

Input Relay
OutputRelay | e 0080 Word Address
Internal Auxiliary Relay
Internal Auxiliary Relay MR 0082 Word Address
Latch Relay LR 0084 Word Address
Control Relay CR 008A Word Address
Timer (Setting Value) TS 0062 Double Word Address
Counter (Setting Value) CS 0063 Double Word Address
Timer (Current Value) TC 0060 Double Word Address
Counter (Current Value) cC 0061 Double Word Address
Data Memory DM 0000 Word Address
Extension Data Memory EM 0010 Word Address
Extension Data Memory FM 0011 Word Address
Temporary Data Memory ™ 0001 Word Address
Control Memory CM 0002 Word Address
Index Register Z 0003 Word Address
Digital Trimmer TRM 0064 Double Word Address
High-speed Counter (Current Value) CTH 0065 Double Word Address
ggt‘tﬁge\f;uce‘)’”mer Comparator cTC 0066 Double Word Address
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7.3 KV-3000/5000/5500 Series
Device Device Name Device Code Address Code
(HEX)
Input Relay
Output Relay R 0080 Word Address
Internal Auxiliary Relay
Link Relay B 008B Word Address
Internal Auxiliary Relay MR 0082 Word Address
Latch Relay LR 0084 Word Address
Control Relay CR 008A Word Address
Work Relay VB 008C Word Address
Timer (Setting Value) TS 0062 Double Word Address
Counter (Setting Value) CS 0063 Double Word Address
Timer (Current Value) TC 0060 Double Word Address
Counter (Current Value) CcC 0061 Double Word Address
Data Memory DM 0000 Word Address
Extension Data Memory EM 0010 Word Address
Current Bank FM 0011 Word Address
File Register 252;' nl:lumber ZF 0012 Word Address
Temporary Data Memory ™ 0001 Word Address
Control Memory CM 0002 Word Address
Link Register W 0013 Word Address
Work Memory VM 0014 Word Address
Index Register z 0067 Double Word Address
Digital Trimmer TRM 0064 Double Word Address
High-speed Counter (Current Value) CTH 0065 Double Word Address
I(—tggezgige\f/s;ui())unter Comparator CTC 0066 Double Word Address
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7.4 KV-Nano Series
Device Device Name Device Code Address Code
(HEX)

Input Relay
Output Relay R 0080 Word Address
Internal Auxiliary Relay
Link Relay B 008B Word Address
Internal Auxiliary Relay MR 0082 Word Address
Latch Relay LR 0084 Word Address
Control Relay CR 008A Word Address
Work Relay VB 008C Word Address
Timer (Setting Value) TS 0062 Double Word Address
Counter (Setting Value) CS 0063 Double Word Address
Timer (Current Value) TC 0060 Double Word Address
Counter (Current Value) CcC 0061 Double Word Address
Data Memory DM 0000 Word Address
Temporary Data Memory ™ 0001 Word Address
Control Memory CM 0002 Word Address
Link Register W 0013 Word Address
Work Memory VM 0014 Word Address
Index Register z 0067 Double Word Address
High-speed Counter (Current Value) CTH 0065 Double Word Address
ggzgﬁg‘?;uceg’“”ter Comparator cTC 0066 Double Word Address
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8 Error Messages

Error messages are displayed on the Display screen as follows: "No.: Device Name: Error Message (Error

Occurrence Area)". Each description is shown below.

Item

Description

No.

Error No.

Device Name

Name of the External Device where an error has occurred. Device name is a title of the
External Device set with GP-Pro EX. (Initial value [PLCL1])

Error Message

Displays messages related to an error that has occurred.

Error Occurrence Area

Displays the IP address or device address of the External Device where an error has
occurred, or error codes received from the External Device.

 |P address is displayed as "IP address (Decimal): MAC address (Hex)".
 Device address is displayed as "Address: Device address".
» Received error codes are displayed as "Decimal [Hex]".

Display Examples of Error Messages
"RHAAOQ35: PLC1: Error has been responded for device write command (Error Code: 1 [01H])"

NOTE * Refer to your External Device manual for details on received error codes.
« Refer to "Display-related errors” in "Maintenance/Troubleshooting Manual” for details on the

error messages common to the driver.

@ Error Codes Specific to the External Device

Error Code o
Error Description
(HEX)
Executed illegal access.
02 o Wrote in the write disable device.
o Accessed the nonexistent device or address.
04 Tried to communicate in the communication baud rate not supported by the External
Device.
31 Accessed the device not defined as device in the External Device.™
0B Performed monitor read with the monitor unregistered.

*1  When you write to Timer (Contact/Current Value/Setting Value), Counter (Contact/Current
Value/Setting Value), High-speed Counter, and High-speed Counter Comparator (Setting
Value), the changed settings must be made in the in the ladder program in advance.
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