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Introduction

Personal Computer Link Ethernet Driver

This manual describes how to connect the Display and the External Device (target PLC).

In this manual, the connection procedure will be described by following the below sections:

This section describes communication
setup items on the Display.

Set communication settings of the Display
with GP-Pro Ex or in offline mode.

1 System Configuration & ) o
This section shows the types of External 1 System Configuration” (page 3)
Device which can be connected and SIO
type.

2 Selection of External Device &= ) .

Select a model (series) of the External 2 Selection of External Device" (page 8)
Device to be connected and connection
method.

3 Example of Communication Settings & o o
This section shows setting examples for SaEza;ple of Communication Setting
communicating between the Display and (page 9)
the External Device.

4 Setup ltems

Fny Setup Items" (page 57)

4

Operation
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Personal Computer Link Ethernet Driver

1 System Configuration
The system configuration in the case when the External Device of Yokogawa Electric Corporation and the
Display are connected is shown.
. . Data Code .
Series CPU Link I/F Port No. SIO Type Settings Setting Example
. * Setting Example 1
Binary ™2
Ethernet (page 9)
(UDP) ASCII™® Setting Example 2
. (page 11)
F3LE01-5T ™ 12289
. * Setting Example 5
Binary ™2
Ethernet (page 17)
(TCP) ASCII™3 Setting Example 6
(page 19)
. * Setting Example 1
Binary ™2
F3SP25-2N Einernet (o2
- UDP ;
F3SP28-3N “ep ASCII"3 f’e“‘”fl)Examp'e 2
- page
FA-M3 F3SP35-5N 12289
F3SP38-6N . * Setting Example 5
F3SP53-4H Binary ™ (page 17)
F3SP58-6H Ethernet pag
(TCP) ASCII™3 Setting Example 6
. (page 19)
F3LE11-0T ™
. * Setting Example 3
Binary™
Ethernet (age 13)
(UDP) ASCII™2 Setting Example 4
(page 15)
12291
. * Setting Example 7
Binary™
Ethernet (age 21)
(TCP) ASCII™2 Setting Example 8
(page 23)
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Personal Computer Link Ethernet Driver

_ ) Data Code .
Series CPU Link I/F Port No. SIO Type . Setting Example
Settings
. * Setting Example 1
Binary 2
Ethernet (page 9)
(UDP) ASCIT™ Setting Example 2
) (page 11)
F3LE0L1-5T "1 | 12289
. * Setting Example 5
Binary ™2
Ethernet i (page 17)
(TCP) ASCIT™ Setting Example 6
(page 19)
— Setting Example 1
Binary 2
F3SP21-0N e e
- (UDP) i
F35P28.35 ASCII™3 Setting Example 2
F3SP38-6S 12289 (page 1)
Egggggg: Binary ™ Setting Example 5
F3SP59-75 Ethernet e ™1
I (TCP) ASCIT™ SettinngxampIe 6
F3LE11-0T 1 (pag.e )
F3LE12-0T *1 Binary™3 Setting Example 3
Ethernet (page 13)
(UDP) ASCIT™2 Setting Example 4
(page 15)
FA-M3 12291
— Setting Example 7
Binary ™
Ethernet i (page 21)
(TCP) ASCIT™ Setting Example 8
(page 23)
— Setting Example 1
Binary 2
Ethernet (page 9)
(UDP) ASCIT™ Setting Example 2
(page 11)
12289
— Setting Example 5
Binary ™2
Ethernet i (page 17)
oo (TCP) ASCIT™ Setting Example 6
0T (page 19)
F3sP22-0S | F3LE11-0T * _
F3LE12-0T *1 Binary™3 Setting Example 3
Ethernet (page 13)
(UDP) ASCIT™2 Setting Example 4
(page 15)
12291
— Setting Example 7
Binary ™
Ethernet i (page 21)
(TCP) ASCIT™ Setting Example 8
(page 23)
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Personal Computer Link Ethernet Driver

. . Data Code .
Series CPU Link I/F Port No. SIO Type . Setting Example
Settings
. Setting Example 9
Binary
Ethernet (page 25)
(UDP) ASCII Setting Example
10 (page 27)
12289
. Setting Example
Binary
Ethernet 11 (page 29)
(TCP) Setting Example
ASCII 12 31
Ethernet I/F on (page 31)
CPU Unit _ Setting Example
Binary 13 33
Ethernet (page 33)
(UDP) ASCII Setting Example
14 (page 35)
12291
. Setting Example
Binary
Ethernet 15 (page 37)
(TCP) Setting Example
ASCII 16 39
F3SP66-4S (page 39)
FAMS | Easpe7.65
- Binary 2 Setting Example 1
Ethernet (page 9)
(UDP) *3 Setting Example 2
ASCII
(page 11)
12289
— Setting Example 5
Binary 2
Ethernet (page 17)

. (TCP) ASCIT™ Setting Example 6
F3LE01-0T ! (page 19)
F3LE11-0T ™

*1 * i
F3LE12-0T Binary 3 Settlnngxample 3

Ethernet (page 13)
(UDP) * Setting Example 4
ASCII
(page 15)
12291
— Setting Example 7
Binary 3
Ethernet (page 21)
(TCP) » Setting Example 8
ASCII
(page 23)
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Personal Computer Link Ethernet Driver

. . Data Code .
Series CPU Link I/F Port No. SIO Type . Setting Example
Settings
. Setting Example
Binary
Ethernet 17 (page 41)
(UDP) ASCII Setting Example
18 (page 43)
12289
. Setting Example
Binary
Ethernet 19 (page 45)
(TCP) Setting Example
ASCII 20 47
Ethernet I/F on (page 47)
CPU Unit . Setting Example
Binary 21 (page 49)
Ethernet (pag
(UDP) ASCII Setting Example
22 (page 51)
12291
. Setting Example
Binary
Ethernet 23 (page 53)
TCP ;
F3SP71-4N ( ) ASCII Setting Example
) 24 (page 55)
F3SP76-7N
FAMS | Easp71.4s
F3SP76-75 Binary 2 Setting Example 1
Ethernet (page 9)
(UDP) *3 Setting Example 2
ASCII
(page 11)
12289
— Setting Example 5
Binary™?
Ethernet (page 17)
. (TCP) ASCII3 Setting Example 6
F3LE01-0T ! (page 19)
F3LE11-0T ™
*1 - H
F3LE12-0T Binary 3 Settlnngxample 3
Ethernet (page 13)
(UDP) *0 Setting Example 4
ASCII
(page 15)
12291
— Setting Example 7
Binary™®
Ethernet (page 21)
(TCP) *0 Setting Example 8
ASCII
(page 23)

*1  In TCP connection, you can connect max 8 units of the External Device to 1 display unit.
*2  Set the data code setting to ON.
*3  Set the data code setting to OFF.
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Personal Computer Link Ethernet Driver
|

B Connection Configuration

1:1 Connection

Display
HUB Extell'nal
Device
1:n Connection
Display
HUB
External External External
Device Device Device
n:1 Connection
Display Display Display
HUB External
Device
n:m Connection
Display Display Display
HUB
External External External
Device Device Device
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Personal Computer Link Ethernet Driver

2 Selection of External Device

Select the External Device to be connected to the Display.

B Welcome to GP-Pro EX E

— Device/PLC
Mumber of Devices/PLCs Iﬁ.
Device/PLC 1
Manufacturer | YOKOGAWA Electic Corporation |L
Series Perzonal Computer Link Ethernet E
Fart Ethemet (UDF} [+
Eefer to the manual of this Device/PLC
Eecent Device/PLC
4 L
I Use Spstem Area Drevice Information

Back [B] | Communication Settings | Mew Logic | Mew Screen I Cancel

Setup Items Setup Description

Number of Devices/

PLCs Use an integer from 1 to 4 to enter the number of Devices/PLCs to connect to the display.

Select the manufacturer of the External Device to be connected. Select "YOKOGAWA

Manufacturer Electric Corporation™.

Select a model (series) of the External Device to be connected and connection method.
Select "Personal Computer Link Ethernet".

Series Check the External Device which can be connected in "Personal Computer Link Ethernet"
in system configuration.

& System Configuration" (page 3)

Port Select the Display port to be connected to the External Device.

Check this option to synchronize the system data area of the Display and the device
(memory) of the External Device. When synchronized, you can use the External Device’s
ladder program to switch the display or display the window on the Display.

Cf. GP-Pro EX Reference Manual "LS Area (Direct Access Method Area)"
This feature can also be set in GP-Pro EX or in the Display's offline mode.

Cf. GP-Pro EX Reference Manual "System Settings [Display Unit] - [System

Area] Settings Guide"
Cf. Maintenance/Troubleshooting Guide "Main Unit - System Area Settings"

Use System Area

GP-Pro EX Device/PLC Connection Manual 8




Personal Computer Link Ethernet Driver

3 Example of Communication Setting

Examples of communication settings of the Display and the External Device, recommended by Pro-face, are

shown.
When you use the FA-M3 Series, use GP-Pro EX and the ladder software to set as below.

3.1 Setting Example 1
W Settings of GP-Pro EX

4 Communication Settings
To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Summary Change Device/PLC
M anufacturer |YDKDGAW'A Electric: Corporation ~ Series Perzonal Computer Link Ethernet Port |Ethemet [UDPF)
Text Data Mode ’T LChange
Communication Settings
Part N, ’m
Timeout m [zec)
Fietry m

wiatt To Send 0 3: [ms] Diefault

Device-Specific Settings

Alloweable Mumber Add Device
of Devices/PLCs 32
Add Indirect
Mo, Device Mame Seftings Device
1 |F'LEI‘I E |Data Code=Binary.|P Addresz=000.000.000.000,Part b 8

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the External Device and click [Settings] B .
To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add

Device] to add another External Device.

,f_‘: Individual Device Settings

PLCA
IP Address ] ] ] ]
Part Ma. 12289 3:
Data Code of

" Asci

Drefault
oK@ | Cancel |

@ Notes
e Check with a network administrator about IP address. Do not set the duplicate IP address.
e Set IP address on the External Device for IP address in Device-specific settings.
* You need to set IP address on the Display in the offline mode of the Display.

GP-Pro EX Device/PLC Connection Manual 9



Personal Computer Link Ethernet Driver

W Setting of External Device

Use the switches on the side of Ethernet module for setting the External Device.

@ |P Address Setting Switch

Use 8 Hex rotary switches for setting.

Setup Items Setup Description
IP Address Setting Rotary Switch Option
@ Port No.
Setup ltems Setup Description
Port No. 12289

@ Condition Setting Switch

DIP Switch Settings Setup Description

SW1 ON Binary

Sw2 OFF Not protect

SW3 (Reserved)

SW4 --- (Reserved)

SW5 --- (Reserved)

SW6 --- (Reserved)

swr't OFF Close
SW8 OFF Normal

*1  SWT7 is available to set in F3LEO1-5T only.

@ Notes

e Check with a network administrator about IP address. Do not set the duplicate IP address.
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3.2 Setting Example 2
W Settings of GP-Pro EX

4 Communication Settings
To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Change Device/FLC

Summary
M anufacturer |YDKDGAW'A Electric: Corporation ~ Series Perzonal Computer Link Ethernet Port |Ethemet [UDPF)
Text Data Mode ’T LChange
Communication Settings
Part N, ’m
Timeout m [zec)
Fietry m

wiatt To Send 0 3: [ms] Diefault

Device-Specific Settings

Alloweable Mumber Add Device
of Devices/PLCs 32
Add Indirect
Mo. Device Mame Settings Device
1 [PLcT [it] [P ata Code=fiscillP Address=000.000.000.000 Part N

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the External Device and click [Settings] B .
To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add

Device] to add another External Device.

,f_‘: Individual Device Settings

IP &ddress 1] ] 0 0
Part Ma. 12289 3:
Data Code " Binary

Drefault
oK@ | Cancel |

@ Notes
e Check with a network administrator about IP address. Do not set the duplicate IP address.
« Set IP address on the External Device for IP address in Device-specific settings.
* You need to set IP address on the Display in the offline mode of the Display.

GP-Pro EX Device/PLC Connection Manual 11



Personal Computer Link Ethernet Driver

W Setting of External Device

Use the switches on the side of Ethernet module for setting the External Device.

@ |P Address Setting Switch

Use 8 Hex rotary switches for setting.

Setup Items Setup Description
IP Address Setting Rotary Switch Option
@ Port No.
Setup ltems Setup Description
Port No. 12289

@ Condition Setting Switch

DIP Switch Settings Setup Description

SW1 OFF ASCII
Sw2 OFF Not protect
SW3 (Reserved)
SW4 --- (Reserved)
SW5 --- (Reserved)
SW6 --- (Reserved)

swr't OFF Close
SW8 OFF Normal

*1  SWT7 is available to set in F3LEO1-5T only.

@ Notes

e Check with a network administrator about IP address. Do not set the duplicate IP address.
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3.3 Setting Example 3
W Settings of GP-Pro EX

4 Communication Settings
To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Summary Change Device/PLC
M anufacturer |YDKDGAW'A Electric: Corporation ~ Series Perzonal Computer Link Ethernet Port |Ethemet [UDPF)
Text Data Mode ’T LChange
Communication Settings
Part N, ’m

Timeout 3 + [sec)
Retry 2 3:
wiatt To Send 0 3: [ms] Diefault

Device-Specific Settings

Alloweable Mumber Add Device
of Devices/PLCs 32
Add Indirect
Mo. Device Mame Settings Device
1 |F'LEI‘I E |Data Code=Binary.|P Address=000.000.000.000,Part +

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the External Device and click [Settings] B .
To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add

Device] to add another External Device.

,f_‘: Individual Device Settings

PLC1
IP &ddress 1] ] 0 0
Part Ma. 12291 3:
Data Code {+ Binary

" Asci

Drefault
oK@ | Cancel |

@ Notes
e Check with a network administrator about IP address. Do not set the duplicate IP address.
« Set IP address on the External Device for IP address in Device-specific settings.
* You need to set IP address on the Display in the offline mode of the Display.
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W Setting of External Device

Use the switches on the side of Ethernet module for setting the External Device.

@ |P Address Setting Switch

Use 8 Hex rotary switches for setting.

Setup Items Setup Description
IP Address Setting Rotary Switch Option
@ Port No.
Setup ltems Setup Description
Port No. 12291

@ Condition Setting Switch

DIP Switch Settings Setup Description

SW1 OFF Binary

Sw2 OFF Not protect

SW3 (Reserved)

SW4 --- (Reserved)

SW5 --- (Reserved)

SW6 --- (Reserved)

SW7 OFF Close

SW8 OFF Normal

@ Notes

e Check with a network administrator about IP address. Do not set the duplicate IP address.
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3.4 Setting Example 4
W Settings of GP-Pro EX

4 Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Summary Change Device/PLC
M anufacturer |YDKDGAW'A Electric: Corporation ~ Series Perzonal Computer Link Ethernet Port |Ethemet [UDPF)
Text Data Mode ’T LChange

Communication Settings

Port No. 1024 3:
Timeout 3 3: [sec]
Retry 2 3:

wiatt To Send 0 3: [ms] Diefault

Device-Specific Settings

Alloweable Mumber Add Device
of Devices/PLCs 32

Add Indirect
Mo. Device Mame Settings Device
1 |F'LEI‘I E |Data Code=Ascil |P Addresz=000.000.000.000 Part Ne 8

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the External Device and click [Settings] B .
To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add
Device] to add another External Device.

,f_‘: Individual Device Settings

PLCA
IP Address ] ] ] ]
Part Ma. 12291 3:

Data Code " Binary

9
Drefault
oK@ | Cancel |

@ Notes
e Check with a network administrator about IP address. Do not set the duplicate IP address.
» Set IP address on the External Device for IP address in Device-specific settings.
* You need to set IP address on the Display in the offline mode of the Display.
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W Setting of External Device

Use the switches on the side of Ethernet module for setting the External Device.

@ |P Address Setting Switch

Use 8 Hex rotary switches for setting.

Setup Items Setup Description
IP Address Setting Rotary Switch Option
@ Port No.
Setup ltems Setup Description
Port No. 12291

@ Condition Setting Switch

DIP Switch Settings Setup Description

SW1 ON ASCII

Sw2 OFF Not protect

SW3 (Reserved)

SW4 --- (Reserved)

SW5 --- (Reserved)

SW6 --- (Reserved)

SW7 OFF Close

SW8 OFF Normal

@ Notes

e Check with a network administrator about IP address. Do not set the duplicate IP address.
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3.5 Setting Example 5
W Settings of GP-Pro EX

4 Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Summary Change Device/PLC
M anufacturer |YDKDGAW'A Electric: Corporation ~ Series Perzonal Computer Link Ethernet Port |Ethemet [TCP)
Text Data Mode ’T LChange

Communication Settings

Port No. 1024 3: [ Auto
Timeout 3 3: [sec]
Retry 0 3‘

wiatt To Send 0 3: [ms] Diefault

Device-Specific Settings

Alloweable Mumber Add Device
of Devices/PLCs 16

Add Indirect
Mo, Device Mame Seftings Device
1 |F'LEI‘I E |Data Code=Binary.|P Address=000.000.000.000,Part +

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the External Device and click [Settings] B .
To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add
Device] to add another External Device.

,f_‘: Individual Device Settings

PLC1
IP Address ] ] ] ]
Part Ma. 12289 3:
Data Code {+ Binary

" Asci

Drefault
oK@ | Cancel |

@ Notes
e Check with a network administrator about IP address. Do not set the duplicate IP address.
e Set IP address on the External Device for IP address in Device-specific settings.
* You need to set IP address on the Display in the offline mode of the Display.
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W Setting of External Device

Use the switches on the side of Ethernet module for setting the External Device.

@ |P Address Setting Switch

Use 8 Hex rotary switches for setting.

Setup Items Setup Description
IP Address Setting Rotary Switch Option
@ Port No.
Setup ltems Setup Description
Port No. 12289

@ Condition Setting Switch

DIP Switch Settings Setup Description

SW1 ON Binary

Sw2 OFF Not protect

SW3 (Reserved)

SW4 --- (Reserved)

SW5 --- (Reserved)

SW6 --- (Reserved)

swr't OFF Close
SW8 OFF Normal

*1  SWT7 is available to set in F3LEO1-5T only.

@ Notes

e Check with a network administrator about IP address. Do not set the duplicate IP address.
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3.6 Setting Example 6
W Settings of GP-Pro EX

4 Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Summary Change Device/PLC
M anufacturer IYDKDGAWA Electric: Corporation ~ Series Perzonal Computer Link Ethernet Port IEthemet [TCP)
Text Data Mode I‘I_ LChange

Communication Settings

Port Mo, lm [~ Auta

Timeout m [zec)

Retry m

Wait To Send o = ims Defautt_ |

Device-Specific Settings

Alloweable Mumber Add Device
of Devices/PLCs 16

Add Indirect
Mo, Device Name Settings Device
[&] 1 JrLct [it] [P ata Code=fiscillP Address=000.000.000.000 Part N

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the External Device and click [Settings] B .
To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add

Device] to add another External Device.

,;g"'_‘: Individual Device Settings

PLC1
IP &ddress o o o 0
Fort Mo, I‘I 2289 3:
Data Code " Binary
% Ascii
Default |
0K (@) Cancel |

@ Notes
e Check with a network administrator about IP address. Do not set the duplicate IP address.
« Set IP address on the External Device for IP address in Device-specific settings.
* You need to set IP address on the Display in the offline mode of the Display.
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W Setting of External Device

Use the switches on the side of Ethernet module for setting the External Device.

@ |P Address Setting Switch

Use 8 Hex rotary switches for setting.

Setup Items Setup Description
IP Address Setting Rotary Switch Option
@ Port No.
Setup ltems Setup Description
Port No. 12289

@ Condition Setting Switch

DIP Switch Settings Setup Description

SW1 OFF ASCII
Sw2 OFF Not protect
SW3 (Reserved)
SW4 --- (Reserved)
SW5 --- (Reserved)
SW6 --- (Reserved)

swr't OFF Close
SW8 OFF Normal

*1  SWT7 is available to set in F3LEO1-5T only.

@ Notes

e Check with a network administrator about IP address. Do not set the duplicate IP address.
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3.7 Setting Example 7

W Settings of GP-Pro EX

4 Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |

Change Device/PLC
Port |Ethemnet [TCF]

Summary

M anufacturer |YDKDGAW'A Electric: Corporation ~ Series

Perzonal Computer Link Ethernet

Text Data Mode ’T Change

Communication Settings

Port No. 1024 3: [ Auto

Timeout 3 3: [sec]

Retry 0 3:

wiatt To Send 0 3: [ms] Diefault
Device-Specific Settings

Alloweable Mumber Add Device
of Devices/PLCs 16
Add Indirect

Mo, Device Mame Seftings Device

1 |F'LEI‘I E |Data Code=Binary.|P Address=000.000.000.000,Part +

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the External Device and click [Settings] B .
To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add
Device] to add another External Device.

,f_‘: Individual Device Settings

¢ Notes

IP Address ] ] ]
Part Ma. m
Data Code {+ Binary

" Asci

Default

oK () |

Cancel

e Check with a network administrator about IP address. Do not set the duplicate IP address.

e Set IP address on the External Device for IP address in Device-specific settings.

* You need to set IP address on the Display in the offline mode of the Display.

GP-Pro EX Device/PLC Connection Manual
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W Setting of External Device

Use the switches on the side of Ethernet module for setting the External Device.

@ |P Address Setting Switch

Use 8 Hex rotary switches for setting.

Setup Items Setup Description
IP Address Setting Rotary Switch Option
@ Port No.
Setup ltems Setup Description
Port No. 12291

@ Condition Setting Switch

DIP Switch Settings Setup Description

SW1 OFF Binary

Sw2 OFF Not protect

SW3 (Reserved)

SW4 --- (Reserved)

SW5 --- (Reserved)

SW6 --- (Reserved)

SW7 OFF Close

SW8 OFF Normal

@ Notes

e Check with a network administrator about IP address. Do not set the duplicate IP address.
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3.8 Setting Example 8
W Settings of GP-Pro EX

4 Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Summary Change Device/PLC
M anufacturer |YDKDGAW'A Electric: Corporation ~ Series Perzonal Computer Link Ethernet Port |Ethemet [TCP)
Text Data Mode ’T LChange

Communication Settings

Port No. 1024 3: [ Auto
Timeout 3 3: [sec]
Retry 0 3‘

wiatt To Send 0 =i [ms] Diefault

Device-Specific Settings

Alloweable Mumber Add Device
of Devices/PLCs 16

Add Indirect
Mo, Device Name Settings Device
1 [PLcT [it] [P ata Code=fiscillP Address=000.000.000.000 Part N

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the External Device and click [Settings] B .
To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add
Device] to add another External Device.

,f_‘: Individual Device Settings

PLC1
IP Address ] ] ] ]
Part Ma. I 2291 3:
Data Code " Binary

(+ Asci

Drefault
oK@ | Cancel |

€ Notes
e Check with a network administrator about IP address. Do not set the duplicate IP address.
« Set IP address on the External Device for IP address in Device-specific settings.
* You need to set IP address on the Display in the offline mode of the Display.
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W Setting of External Device

Use the switches on the side of Ethernet module for setting the External Device.

@ |P Address Setting Switch

Use 8 Hex rotary switches for setting.

Setup Items Setup Description
IP Address Setting Rotary Switch Option
@ Port No.
Setup ltems Setup Description
Port No. 12291

@ Condition Setting Switch

DIP Switch Settings Setup Description

SW1 ON ASCII

Sw2 OFF Not protect

SW3 (Reserved)

SW4 --- (Reserved)

SW5 --- (Reserved)

SW6 --- (Reserved)

SW7 OFF Close

SW8 OFF Normal

@ Notes

e Check with a network administrator about IP address. Do not set the duplicate IP address.
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3.9 Setting Example 9
W Settings of GP-Pro EX
4 Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Change Device/PLC
Port |Ethernet [UDF]

Summary
M anufacturer |YDKDGAW'A Electric: Corporation ~ Series Perzonal Computer Link Ethernet

Text Data Mode ’T Change
Communication Settings
Port No. 1024 3:
Timeout 3 3: [sec]
Retry 2 3‘

wiatt To Send 0 =i [ms] Diefault

Device-Specific Settings

Alloweable Mumber Add Device
of Devices/PLCs 32
Add Indirect
Mo, Device Mame Seftings Device
1 |F'LEI‘I E |Data Code=Binary.|P Address=000.000.000.000,Part +

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the External Device and click [Settings] B .
To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add

Device] to add another External Device.

,f_‘: Individual Device Settings

PLC1

IP &ddress 1] ] 0 0
Part Ma.
Data Code

Drefault
oK@ | Cancel |

€ Notes
e Check with a network administrator about IP address. Do not set the duplicate IP address.
« Set IP address on the External Device for IP address in Device-specific settings.
* You need to set IP address on the Display in the offline mode of the Display.
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W Setting of External Device
Make communication settings of the External Device with the ladder soft (Wide Field2).
Please refer to the manual of the External Device for more details.

@ Procedure
1 start the ladder soft.
2 Create a new project. Select the External Device to be used when creating the project.
3 Select [Open]-[CPU Properties] from the [File] menu and open the CPU property file for settings.
4 In the [LOAD] settings, select the settings to be loaded. Set 0 (not loaded) for the others except the following
settings.
* [LOAD] Settings

Setup Items Setup Description
NETWORK 1
ETHERNET 1
HIGHER-LEVEL LINK SERVICE 1

5 Make communication settings with the [Setting] tree’s [NETWORK][ETHERNET][HIGHER-LEVEL LINK

SERVICE].
¢ [NETWORK] Settings

Setup Items Setup Description

NETWORK_SELECT 1

* [ETHERNET] Settings

Setup Items Setup Description

IP Address of the External Device

ETHER_MY_IPADDRESS Ex: 192.168.0.3

Subnet Mask of the External Device

ETHER_SUBNET_MASK Ex: 255,255 255 0

* [HIGHER-LEVEL LINK SERVICE] Settings

Setup ltems Setup Description
HILINK_PROTOCOL_A 1
HILINK_DATA_FORMAT_A 1

6 Select [Save as] from the [File] menu and save the CPU property file.
7 Select [Download]-[CPU Properties] from the [ONLINE] menu and download the set CPU property file to the

External Device.
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3.10 Setting Example 10
W Settings of GP-Pro EX

4 Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Summary Change Device/PLC
M anufacturer |YDKDGAW'A Electric: Corporation ~ Series Perzonal Computer Link Ethernet Port |Ethemet [UDPF)
Text Data Mode ’T LChange
Communication Settings
Part N, ’m
Timeout m [zec)
Fietry m

wiatt To Send 0 =i [ms] Diefault

Device-Specific Settings

Alloweable Mumber Add Device
of Devices/PLCs 32
Add Indirect
Mo, Device Mame Seftings Device
1 [PLcT [it] [P ata Code=fiscillP Address=000.000.000.000 Part N

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the External Device and click [Settings] B .
To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add

Device] to add another External Device.

,f_‘: Individual Device Settings

PLCA
IP Address ] ] ] ]
Part Ma. 12289 3:

Data Code " Binary

Drefault
oK@ | Cancel |

€ Notes
e Check with a network administrator about IP address. Do not set the duplicate IP address.
« Set IP address on the External Device for IP address in Device-specific settings.
* You need to set IP address on the Display in the offline mode of the Display.
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W Setting of External Device
Make communication settings of the External Device with the ladder soft (Wide Field2).
Please refer to the manual of the External Device for more details.

@ Procedure
1 start the ladder soft.
2 Create a new project. Select the External Device to be used when creating the project.
3 Select [Open]-[CPU Properties] from the [File] menu and open the CPU property file for settings.
4 In the [LOAD] settings, select the settings to be loaded. Set 0 (not loaded) for the others except the following
settings.
* [LOAD] Settings

Setup Items Setup Description
NETWORK 1
ETHERNET 1
HIGHER-LEVEL LINK SERVICE 1

5 Make communication settings with the [Setting] tree’s [NETWORK][ETHERNET][HIGHER-LEVEL LINK

SERVICE].
¢ [NETWORK] Settings

Setup Items Setup Description

NETWORK_SELECT 1

* [ETHERNET] Settings

Setup Items Setup Description

IP Address of the External Device

ETHER_MY_IPADDRESS Ex: 192.168.0.3

Subnet Mask of the External Device

ETHER_SUBNET_MASK Ex: 255,255 255 0

* [HIGHER-LEVEL LINK SERVICE] Settings

Setup ltems Setup Description
HILINK_PROTOCOL_A 1
HILINK_DATA_FORMAT_A 0

6 Select [Save as] from the [File] menu and save the CPU property file.
7 Select [Download]-[CPU Properties] from the [ONLINE] menu and download the set CPU property file to the

External Device.
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3.11 Setting Example 11
W Settings of GP-Pro EX

4 Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Summary Change Device/PLC
M anufacturer |YDKDGAW'A Electric: Corporation ~ Series Perzonal Computer Link Ethernet Port |Ethemet [TCP)
Text Data Mode ’T LChange

Communication Settings

Port No. 1024 3: [ Auto
Timeout 3 3: [sec]
Retry 0 3‘

wiatt To Send 0 =i [ms] Diefault

Device-Specific Settings

Alloweable Mumber Add Device
of Devices/PLCs 16

Add Indirect
Mo, Device Mame Seftings Device
1 |F'LEI‘I E |Data Code=Binary.|P Address=000.000.000.000,Part +

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the External Device and click [Settings] B .
To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add
Device] to add another External Device.

,f_‘: Individual Device Settings

PLC1
IP Address ] ] ] ]
Part Ma. 12289 3:
Data Code {+ Binary

" Asci

Drefault
oK@ | Cancel |

€ Notes
e Check with a network administrator about IP address. Do not set the duplicate IP address.
« Set IP address on the External Device for IP address in Device-specific settings.
* You need to set IP address on the Display in the offline mode of the Display.
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W Setting of External Device
Make communication settings of the External Device with the ladder soft (Wide Field2).
Please refer to the manual of the External Device for more details.

@ Procedure
1 start the ladder soft.
2 Create a new project. Select the External Device to be used when creating the project.
3 Select [Open]-[CPU Properties] from the [File] menu and open the CPU property file for settings.
4 In the [LOAD] settings, select the settings to be loaded. Set 0 (not loaded) for the others except the following
settings.
* [LOAD] Settings

Setup Items Setup Description
NETWORK 1
ETHERNET 1
HIGHER-LEVEL LINK SERVICE 1

5 Make communication settings with the [Setting] tree’s [NETWORK][ETHERNET][HIGHER-LEVEL LINK

SERVICE].
¢ [NETWORK] Settings

Setup Items Setup Description

NETWORK_SELECT 1

* [ETHERNET] Settings

Setup Items Setup Description

IP Address of the External Device

ETHER_MY_IPADDRESS Ex: 192.168.0.3

Subnet Mask of the External Device

ETHER_SUBNET_MASK Ex: 255,255 255 0

* [HIGHER-LEVEL LINK SERVICE] Settings

Setup ltems Setup Description
HILINK_PROTOCOL_A 0
HILINK_DATA_FORMAT_A 1

6 Select [Save as] from the [File] menu and save the CPU property file.
7 Select [Download]-[CPU Properties] from the [ONLINE] menu and download the set CPU property file to the

External Device.
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3.12 Setting Example 12
W Settings of GP-Pro EX

4 Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Summary Change Device/PLC
M anufacturer |YDKDGAW'A Electric: Corporation ~ Series Perzonal Computer Link Ethernet Port |Ethemet [TCP)
Text Data Mode ’T LChange

Communication Settings

Port No. 1024 3: [ Auto
Timeout 3 3: [sec]
Retry 0 3‘

wiatt To Send 0 =i [ms] Diefault

Device-Specific Settings

Alloweable Mumber Add Device
of Devices/PLCs 16

Add Indirect
Mo, Device Name Settings Device
1 [PLcT [it] [P ata Code=fiscillP Address=000.000.000.000 Part N

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the External Device and click [Settings] B .
To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add
Device] to add another External Device.

,f_‘: Individual Device Settings

PLC1
IP Address ] ] ] ]
Part Ma. 12289 3:
Data Code " Binary

(+ Asci

Drefault
oK@ | Cancel |

€ Notes
e Check with a network administrator about IP address. Do not set the duplicate IP address.
« Set IP address on the External Device for IP address in Device-specific settings.
* You need to set IP address on the Display in the offline mode of the Display.
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W Setting of External Device
Make communication settings of the External Device with the ladder soft (Wide Field2).
Please refer to the manual of the External Device for more details.

@ Procedure

1 start the ladder soft.

2 Create a new project. Select the External Device to be used when creating the project.

3 Select [Open]-[CPU Properties] from the [File] menu and open the CPU property file for settings.

4 In the [LOAD] settings, select the settings to be loaded. Set 0 (not loaded) for the others except the following

settings.
* [LOAD] Settings
Setup Items Setup Description
NETWORK 1
ETHERNET 1
HIGHER-LEVEL LINK SERVICE 1

5 Make communication settings with the [Setting] tree’s [NETWORK][ETHERNET][HIGHER-LEVEL LINK

SERVICE].
¢ [NETWORK] Settings

Setup Items Setup Description

NETWORK_SELECT 1

* [ETHERNET] Settings

Setup Items Setup Description

IP Address of the External Device

ETHER_MY_IPADDRESS Ex: 192.168.0.3

Subnet Mask of the External Device

ETHER_SUBNET_MASK Ex: 255,255 255 0

* [HIGHER-LEVEL LINK SERVICE] Settings

Setup ltems Setup Description
HILINK_PROTOCOL_A 0
HILINK_DATA_FORMAT_A 0

6 Select [Save as] from the [File] menu and save the CPU property file.
7 Select [Download]-[CPU Properties] from the [ONLINE] menu and download the set CPU property file to the

External Device.
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3.13 Setting Example 13
W Settings of GP-Pro EX

4 Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Summary Change Device/PLC
M anufacturer |YDKDGAW'A Electric: Corporation ~ Series Perzonal Computer Link Ethernet Port |Ethemet [UDPF)
Text Data Mode ’T LChange
Communication Settings
Part N, ’m
Timeout m [zec)
Fietry m

wiatt To Send 0 =i [ms] Diefault

Device-Specific Settings

Alloweable Mumber Add Device
of Devices/PLCs 32
Add Indirect
Mo, Device Mame Seftings Device
1 |F'LEI‘I E |Data Code=Binary.|P Address=000.000.000.000,Part +

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the External Device and click [Settings] B .
To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add

Device] to add another External Device.

,f_‘: Individual Device Settings

PLC1
IP &ddress 1] ] 0 0
Part Ma. 12291 3:
Data Code {+ Binary

" Asci

Drefault
oK@ | Cancel |

€ Notes
e Check with a network administrator about IP address. Do not set the duplicate IP address.
« Set IP address on the External Device for IP address in Device-specific settings.
* You need to set IP address on the Display in the offline mode of the Display.
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W Setting of External Device
Make communication settings of the External Device with the ladder soft (Wide Field2).
Please refer to the manual of the External Device for more details.

@ Procedure
1 start the ladder soft.
2 Create a new project. Select the External Device to be used when creating the project.
3 Select [Open]-[CPU Properties] from the [File] menu and open the CPU property file for settings.
4 In the [LOAD] settings, select the settings to be loaded. Set 0 (not loaded) for the others except the following
settings.
* [LOAD] Settings

Setup Items Setup Description
NETWORK 1
ETHERNET 1
HIGHER-LEVEL LINK SERVICE 1

5 Make communication settings with the [Setting] tree’s [NETWORK][ETHERNET][HIGHER-LEVEL LINK

SERVICE].
¢ [NETWORK] Settings

Setup Items Setup Description

NETWORK_SELECT 1

* [ETHERNET] Settings

Setup Items Setup Description

IP Address of the External Device

ETHER_MY_IPADDRESS Ex: 192.168.0.3

Subnet Mask of the External Device

ETHER_SUBNET_MASK Ex: 255,255 255 0

* [HIGHER-LEVEL LINK SERVICE] Settings

Setup ltems Setup Description
HILINK_PROTOCOL_B 1
HILINK_DATA_FORMAT_B 1

6 Select [Save as] from the [File] menu and save the CPU property file.
7 Select [Download]-[CPU Properties] from the [ONLINE] menu and download the set CPU property file to the

External Device.

GP-Pro EX Device/PLC Connection Manual 34



Personal Computer Link Ethernet Driver

3.14 Setting Example 14
W Settings of GP-Pro EX

4 Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Summary Change Device/PLC
M anufacturer |YDKDGAW'A Electric: Corporation ~ Series Perzonal Computer Link Ethernet Port |Ethemet [UDPF)
Text Data Mode ’T LChange
Communication Settings
Part N, ’m
Timeout m [zec)
Fietry m

wiatt To Send 0 =i [ms] Diefault

Device-Specific Settings

Alloweable Mumber Add Device
of Devices/PLCs 32
Add Indirect
Mo, Device Mame Seftings Device
1 [PLcT [it] [P ata Code=fiscillP Address=000.000.000.000 Part N

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the External Device and click [Settings] B .
To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add

Device] to add another External Device.

,f_‘: Individual Device Settings

PLCA
IP &ddress 1] ] 0 0
Part Ma. 12291 3:

Data Code " Binary

Drefault
oK@ | Cancel |

€ Notes
e Check with a network administrator about IP address. Do not set the duplicate IP address.
« Set IP address on the External Device for IP address in Device-specific settings.
* You need to set IP address on the Display in the offline mode of the Display.
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W Setting of External Device
Make communication settings of the External Device with the ladder soft (Wide Field2).
Please refer to the manual of the External Device for more details.

@ Procedure
1 start the ladder soft.
2 Create a new project. Select the External Device to be used when creating the project.
3 Select [Open]-[CPU Properties] from the [File] menu and open the CPU property file for settings.
4 In the [LOAD] settings, select the settings to be loaded. Set 0 (not loaded) for the others except the following
settings.
* [LOAD] Settings

Setup Items Setup Description
NETWORK 1
ETHERNET 1
HIGHER-LEVEL LINK SERVICE 1

5 Make communication settings with the [Setting] tree’s [NETWORK][ETHERNET][HIGHER-LEVEL LINK

SERVICE].
¢ [NETWORK] Settings

Setup Items Setup Description

NETWORK_SELECT 1

* [ETHERNET] Settings

Setup Items Setup Description

IP Address of the External Device

ETHER_MY_IPADDRESS Ex: 192.168.0.3

Subnet Mask of the External Device

ETHER_SUBNET_MASK Ex: 255,255 255 0

* [HIGHER-LEVEL LINK SERVICE] Settings

Setup ltems Setup Description
HILINK_PROTOCOL_B 1
HILINK_DATA_FORMAT_B 0

6 Select [Save as] from the [File] menu and save the CPU property file.
7 Select [Download]-[CPU Properties] from the [ONLINE] menu and download the set CPU property file to the

External Device.
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3.15 Setting Example 15
W Settings of GP-Pro EX

4 Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Summary Change Device/PLC
M anufacturer |YDKDGAW'A Electric: Corporation ~ Series Perzonal Computer Link Ethernet Port |Ethemet [TCP)
Text Data Mode ’T LChange

Communication Settings

Port No. 1024 3: [ Auto
Timeout 3 3: [sec]
Retry 0 3‘

wiatt To Send 0 =i [ms] Diefault

Device-Specific Settings

Alloweable Mumber Add Device
of Devices/PLCs 16

Add Indirect
Mo, Device Mame Seftings Device
1 |F'LEI‘I E |Data Code=Binary.|P Address=000.000.000.000,Part +

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the External Device and click [Settings] B .
To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add
Device] to add another External Device.

,f_‘: Individual Device Settings

PLC1
IP &ddress 1] ] 0 0
Part Ma. 12291 3:
Data Code {+ Binary

" Asci

Drefault
oK@ | Cancel |

€ Notes
e Check with a network administrator about IP address. Do not set the duplicate IP address.
« Set IP address on the External Device for IP address in Device-specific settings.
* You need to set IP address on the Display in the offline mode of the Display.
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W Setting of External Device
Make communication settings of the External Device with the ladder soft (Wide Field2).
Please refer to the manual of the External Device for more details.

@ Procedure
1 start the ladder soft.
2 Create a new project. Select the External Device to be used when creating the project.
3 Select [Open]-[CPU Properties] from the [File] menu and open the CPU property file for settings.
4 In the [LOAD] settings, select the settings to be loaded. Set 0 (not loaded) for the others except the following
settings.
* [LOAD] Settings

Setup Items Setup Description
NETWORK 1
ETHERNET 1
HIGHER-LEVEL LINK SERVICE 1

5 Make communication settings with the [Setting] tree’s [NETWORK][ETHERNET][HIGHER-LEVEL LINK

SERVICE].
¢ [NETWORK] Settings

Setup Items Setup Description

NETWORK_SELECT 1

* [ETHERNET] Settings

Setup Items Setup Description

IP Address of the External Device

ETHER_MY_IPADDRESS Ex: 192.168.0.3

Subnet Mask of the External Device

ETHER_SUBNET_MASK Ex: 255,255 255 0

* [HIGHER-LEVEL LINK SERVICE] Settings

Setup ltems Setup Description
HILINK_PROTOCOL_B 0
HILINK_DATA_FORMAT_B 1

6 Select [Save as] from the [File] menu and save the CPU property file.
7 Select [Download]-[CPU Properties] from the [ONLINE] menu and download the set CPU property file to the

External Device.
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3.16 Setting Example 16
W Settings of GP-Pro EX

4 Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Summary Change Device/PLC
M anufacturer |YDKDGAW'A Electric: Corporation ~ Series Perzonal Computer Link Ethernet Port |Ethemet [TCP)
Text Data Mode ’T LChange

Communication Settings

Port No. 1024 3: [ Auto
Timeout 3 3: [sec]
Retry 0 3‘

wiatt To Send 0 =i [ms] Diefault

Device-Specific Settings

Alloweable Mumber Add Device
of Devices/PLCs 16

Add Indirect
Mo, Device Name Settings Device
1 [PLcT [it] [P ata Code=fiscillP Address=000.000.000.000 Part N

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the External Device and click [Settings] B .
To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add

Device] to add another External Device.

,f_‘: Individual Device Settings

PLC1
IP &ddress 1] ] 0 0
Part Ma. 12291 3:
Data Code " Binary

Drefault
oK@ | Cancel |

€ Notes
e Check with a network administrator about IP address. Do not set the duplicate IP address.
« Set IP address on the External Device for IP address in Device-specific settings.
* You need to set IP address on the Display in the offline mode of the Display.
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W Setting of External Device
Make communication settings of the External Device with the ladder soft (Wide Field2).
Please refer to the manual of the External Device for more details.

@ Procedure

1 start the ladder soft.

2 Create a new project. Select the External Device to be used when creating the project.

3 Select [Open]-[CPU Properties] from the [File] menu and open the CPU property file for settings.

4 In the [LOAD] settings, select the settings to be loaded. Set 0 (not loaded) for the others except the following

settings.
* [LOAD] Settings
Setup Items Setup Description
NETWORK 1
ETHERNET 1
HIGHER-LEVEL LINK SERVICE 1

5 Make communication settings with the [Setting] tree’s [NETWORK][ETHERNET][HIGHER-LEVEL LINK

SERVICE].
¢ [NETWORK] Settings

Setup Items Setup Description

NETWORK_SELECT 1

* [ETHERNET] Settings

Setup Items Setup Description

IP Address of the External Device

ETHER_MY_IPADDRESS Ex: 192.168.0.3

Subnet Mask of the External Device

ETHER_SUBNET_MASK Ex: 255,255 255 0

* [HIGHER-LEVEL LINK SERVICE] Settings

Setup ltems Setup Description
HILINK_PROTOCOL_B 0
HILINK_DATA_FORMAT_B 0

6 Select [Save as] from the [File] menu and save the CPU property file.
7 Select [Download]-[CPU Properties] from the [ONLINE] menu and download the set CPU property file to the

External Device.
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3.17 Setting Example 17
W Settings of GP-Pro EX

4 Communication Settings
To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Change Device/PLC
Port |Ethernet [UDF]

Summary
M anufacturer |YDKDGAW'A Electric: Corporation ~ Series Perzonal Computer Link Ethernet

Text Data Mode ’T Change
Communication Settings
Port No. 1024 3:
Timeout 3 + [sec)
Retry 2 3‘

wiatt To Send 0 3: [ms] Diefault

Device-Specific Settings

Alloweable Mumber Add Device
of Devices/PLCs 32
Add Indirect
Mo, Device Mame Seftings Device
1 |F'LEI‘I E |Data Code=Binary.|P Address=1592.168.000.001 Part +

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the External Device and click [Settings] B .
To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add

Device] to add another External Device.

,f_‘: Individual Device Settines

PLC1
IP &ddress 192 188 1] 1
Port No. 12289 3:
Data Code {+ Binary

" Asci

Drefault
oK@ | Cancel |

€ Notes
e Check with a network administrator about IP address. Do not set the duplicate IP address.
« Set IP address on the External Device for IP address in Device-specific settings.
* You need to set IP address on the Display in the offline mode of the Display.

GP-Pro EX Device/PLC Connection Manual 41



Personal Computer Link Ethernet Driver

W Setting of External Device
The ladder software (WideField3) configures the External Device’s communication settings.

Refer to your External Device manual for communication setting details.

@ Procedure

1 start up the ladder software.

2 Create a new project. Select the External Device to be used when creating the project.

3 Select [Open]-[CPU Properties] from the [File] menu and open the CPU property file for settings.

4 Select [CPU properties] from [Project Settings].

5 Make communication settings with the [SETUP] tree’s [ETHERNET], [HIGHER-LEVEL LINK SERVICE].

* [ETHERNET] Settings

Setup Items Setup Description
ETHER_MY_IPADDRESS 192.168.0.1
ETHER_SUBNET_MASK 255.255.255.0

¢ [HIGHER-LEVEL LINK SERVICE] Settings

Setup Items Setup Description
HILINK_PROTOCOL_A 1
HILINK_DATA_FORMAT_A 1
HLINK_PROTECT 0

6 Download the setting CPU property file and the project file to the External Device.
7 Reboot the External Device.
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3.18 Setting Example 18
W Settings of GP-Pro EX

4 Communication Settings
To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Change Device/PLC
Port |Ethernet [UDF]

Summary
M anufacturer |YDKDGAW'A Electric: Corporation ~ Series Perzonal Computer Link Ethernet

Text Data Mode ’T Change
Communication Settings
Port No. 1024 3:
Timeout 3 + [sec)
Retry 2 3‘

wiatt To Send 0 3: [ms] Diefault

Device-Specific Settings

Alloweable Mumber Add Device
of Devices/PLCs 32
Add Indirect
Mo, Device Mame Seftings Device
1 [PLcT [it] [P ata Code=fiscillP Address=192.168.000.001 Part N

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the External Device and click [Settings] B .
To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add

Device] to add another External Device.

,f_‘: Individual Device Settines

PLC1
IP &ddress 192 188 1] 1
Port No. 12289 3:
Data Code " Binary

(+ Asci

Drefault
oK@ | Cancel |

€ Notes
e Check with a network administrator about IP address. Do not set the duplicate IP address.
« Set IP address on the External Device for IP address in Device-specific settings.
* You need to set IP address on the Display in the offline mode of the Display.
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W Setting of External Device
The ladder software (WideField3) configures the External Device’s communication settings.

Refer to your External Device manual for communication setting details.

@ Procedure

1 start up the ladder software.

2 Create a new project. Select the External Device to be used when creating the project.

3 Select [Open]-[CPU Properties] from the [File] menu and open the CPU property file for settings.

4 Select [CPU properties] from [Project Settings].

5 Make communication settings with the [SETUP] tree’s [ETHERNET], [HIGHER-LEVEL LINK SERVICE].

* [ETHERNET] Settings

Setup Items Setup Description
ETHER_MY_IPADDRESS 192.168.0.1
ETHER_SUBNET_MASK 255.255.255.0

¢ [HIGHER-LEVEL LINK SERVICE] Settings

Setup Items Setup Description
HILINK_PROTOCOL_A 1
HILINK_DATA_FORMAT_A 0
HLINK_PROTECT 0

6 Download the setting CPU property file and the project file to the External Device.
7 Reboot the External Device.

GP-Pro EX Device/PLC Connection Manual 44



Personal Computer Link Ethernet Driver

3.19 Setting Example 19
W Settings of GP-Pro EX

4 Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Summary Change Device/PLC
M anufacturer |YDKDGAW'A Electric: Corporation ~ Series Perzonal Computer Link Ethernet Port |Ethemet [TCP)
Text Data Mode ’T LChange

Communication Settings

Port No. 1024 3: [ Auto
Timeout 3 3: [sec]
Retry 0 3:

wiatt To Send 0 3: [ms] Diefault

Device-Specific Settings

Alloweable Mumber Add Device
of Devices/PLCs 16

Add Indirect
Mo. Device Mame Settings Device
1 |F'LEI‘I E |Data Code=Binary.|P Address=1592.168.000.001 Part +

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the External Device and click [Settings] B .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add
Device] to add another External Device.

,f_‘: Individual Device Settines

PLC1

IP &ddress 192 188 1] 1
Port No. 12289 3:

Data Code {+ Binary

" Asci

Drefault
oK@ | Cancel |

 Notes

e Check with a network administrator about IP address. Do not set the duplicate IP address.
« Set IP address on the External Device for IP address in Device-specific settings.
* You need to set IP address on the Display in the offline mode of the Display.
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W Setting of External Device
The ladder software (WideField3) configures the External Device’s communication settings.

Refer to your External Device manual for communication setting details.

@ Procedure

1 start up the ladder software.
2 Create a new project. Select the External Device to be used when creating the project.
3 Select [Open]-[CPU Properties] from the [File] menu and open the CPU property file for settings.

4 Select [CPU properties] from [Project Settings].
5 Make communication settings with the [SETUP] tree’s [ETHERNET], [HIGHER-LEVEL LINK SERVICE].

* [ETHERNET] Settings

Setup Items Setup Description
ETHER_MY_IPADDRESS 192.168.0.1
ETHER_SUBNET_MASK 255.255.255.0

¢ [HIGHER-LEVEL LINK SERVICE] Settings

Setup Items Setup Description
HILINK_PROTOCOL_A 0
HILINK_DATA_FORMAT_A 1
HLINK_PROTECT 0

6 Download the setting CPU property file and the project file to the External Device.
7 Reboot the External Device.
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3.20 Setting Example 20
W Settings of GP-Pro EX

4 Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Summary Change Device/PLC
M anufacturer |YDKDGAW'A Electric: Corporation ~ Series Perzonal Computer Link Ethernet Port |Ethemet [TCP)
Text Data Mode ’T LChange

Communication Settings

Port No. 1024 3: [ Auto
Timeout 3 3: [sec]
Retry 0 3:

wiatt To Send 0 3: [ms] Diefault

Device-Specific Settings

Alloweable Mumber Add Device
of Devices/PLCs 16

Add Indirect
Mo, Device Name Settings Device
1 [PLcT [it] [P ata Code=fiscillP Address=192.168.000.001 Part N

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the External Device and click [Settings] B .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add
Device] to add another External Device.

,f_‘: Individual Device Settines

PLC1

IP &ddress 192 188 1] 1
Port No. 12289 3:

Data Code " Binary

(+ Asci

Drefault
oK@ | Cancel |

 Notes

e Check with a network administrator about IP address. Do not set the duplicate IP address.
« Set IP address on the External Device for IP address in Device-specific settings.
* You need to set IP address on the Display in the offline mode of the Display.
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W Setting of External Device
The ladder software (WideField3) configures the External Device’s communication settings.

Refer to your External Device manual for communication setting details.

@ Procedure

1 start up the ladder software.

2 Create a new project. Select the External Device to be used when creating the project.

3 Select [Open]-[CPU Properties] from the [File] menu and open the CPU property file for settings.

4 Select [CPU properties] from [Project Settings].

5 Make communication settings with the [SETUP] tree’s [ETHERNET], [HIGHER-LEVEL LINK SERVICE].

* [ETHERNET] Settings

Setup Items Setup Description
ETHER_MY_IPADDRESS 192.168.0.1
ETHER_SUBNET_MASK 255.255.255.0

¢ [HIGHER-LEVEL LINK SERVICE] Settings

Setup Items Setup Description
HILINK_PROTOCOL_A 0
HILINK_DATA_FORMAT_A 0
HLINK_PROTECT 0

6 Download the setting CPU property file and the project file to the External Device.
7 Reboot the External Device.
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3.21 Setting Example 21
W Settings of GP-Pro EX

4 Communication Settings
To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Change Device/PLC
Port |Ethernet [UDF]

Summary
M anufacturer |YDKDGAW'A Electric: Corporation ~ Series Perzonal Computer Link Ethernet

Text Data Mode ’T Change
Communication Settings
Port No. 1024 3:
Timeout 3 + [sec)
Retry 2 3‘

wiatt To Send 0 3: [ms] Diefault

Device-Specific Settings

Alloweable Mumber Add Device
of Devices/PLCs 32
Add Indirect
Mo, Device Mame Seftings Device
1 |F'LEI‘I E |Data Code=Binary.|P Address=1592.168.000.001 Part +

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the External Device and click [Settings] B .
To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add

Device] to add another External Device.

,f_‘: Individual Device Settines

PLC1
IP &ddress 192 188 1] 1
Port No. 12291 3:
Data Code {+ Binary

" Asci

Drefault
oK@ | Cancel |

€ Notes
e Check with a network administrator about IP address. Do not set the duplicate IP address.
« Set IP address on the External Device for IP address in Device-specific settings.
* You need to set IP address on the Display in the offline mode of the Display.
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W Setting of External Device
The ladder software (WideField3) configures the External Device’s communication settings.

Refer to your External Device manual for communication setting details.

@ Procedure

1 start up the ladder software.

2 Create a new project. Select the External Device to be used when creating the project.

3 Select [Open]-[CPU Properties] from the [File] menu and open the CPU property file for settings.

4 Select [CPU properties] from [Project Settings].

5 Make communication settings with the [SETUP] tree’s [ETHERNET], [HIGHER-LEVEL LINK SERVICE].

* [ETHERNET] Settings

Setup Items Setup Description
ETHER_MY_IPADDRESS 192.168.0.1
ETHER_SUBNET_MASK 255.255.255.0

¢ [HIGHER-LEVEL LINK SERVICE] Settings

Setup Items Setup Description
HILINK_PROTOCOL_B 1
HILINK_DATA_FORMAT_B 1
HLINK_PROTECT 0

6 Download the setting CPU property file and the project file to the External Device.
7 Reboot the External Device.
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3.22 Setting Example 22
W Settings of GP-Pro EX

4 Communication Settings
To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Change Device/PLC
Port |Ethernet [UDF]

Summary
M anufacturer |YDKDGAW'A Electric: Corporation ~ Series Perzonal Computer Link Ethernet

Text Data Mode ’T Change
Communication Settings
Port No. 1024 3:
Timeout 3 + [sec)
Retry 2 3‘

wiatt To Send 0 3: [ms] Diefault

Device-Specific Settings

Alloweable Mumber Add Device
of Devices/PLCs 32
Add Indirect
Mo, Device Mame Seftings Device
1 [PLcT [it] [P ata Code=fiscillP Address=192.168.000.001 Part N

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the External Device and click [Settings] B .
To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add

Device] to add another External Device.

,f_‘: Individual Device Settines

PLC1
IP &ddress 192 188 1] 1
Port No. 12291 3:
Data Code " Binary

(+ Asci

Drefault
oK@ | Cancel |

€ Notes
e Check with a network administrator about IP address. Do not set the duplicate IP address.
« Set IP address on the External Device for IP address in Device-specific settings.
* You need to set IP address on the Display in the offline mode of the Display.
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W Setting of External Device
The ladder software (WideField3) configures the External Device’s communication settings.

Refer to your External Device manual for communication setting details.

@ Procedure

1 start up the ladder software.

2 Create a new project. Select the External Device to be used when creating the project.

3 Select [Open]-[CPU Properties] from the [File] menu and open the CPU property file for settings.

4 Select [CPU properties] from [Project Settings].

5 Make communication settings with the [SETUP] tree’s [ETHERNET], [HIGHER-LEVEL LINK SERVICE].

* [ETHERNET] Settings

Setup Items Setup Description
ETHER_MY_IPADDRESS 192.168.0.1
ETHER_SUBNET_MASK 255.255.255.0

¢ [HIGHER-LEVEL LINK SERVICE] Settings

Setup Items Setup Description
HILINK_PROTOCOL_B 1
HILINK_DATA_FORMAT_B 0
HLINK_PROTECT 0

6 Download the setting CPU property file and the project file to the External Device.
7 Reboot the External Device.
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3.23 Setting Example 23
W Settings of GP-Pro EX

4 Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Summary Change Device/PLC
M anufacturer |YDKDGAW'A Electric: Corporation ~ Series Perzonal Computer Link Ethernet Port |Ethemet [TCP)
Text Data Mode ’T LChange

Communication Settings

Port No. 1024 3: [ Auto
Timeout 3 3: [sec]
Retry 0 3:

wiatt To Send 0 3: [ms] Diefault

Device-Specific Settings

Alloweable Mumber Add Device
of Devices/PLCs 16

Add Indirect
Mo. Device Mame Settings Device
1 |F'LEI‘I E |Data Code=Binary.|P Address=1592.168.000.001 Part +

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the External Device and click [Settings] B .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add
Device] to add another External Device.

,f_‘: Individual Device Settines

PLC1
IP &ddress 192 188 1] 1
Port No. 12291 3:
Data Code {+ Binary

" Asci

Drefault
oK@ | Cancel |

 Notes

e Check with a network administrator about IP address. Do not set the duplicate IP address.
« Set IP address on the External Device for IP address in Device-specific settings.
* You need to set IP address on the Display in the offline mode of the Display.
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W Setting of External Device
The ladder software (WideField3) configures the External Device’s communication settings.

Refer to your External Device manual for communication setting details.

@ Procedure

1 start up the ladder software.
2 Create a new project. Select the External Device to be used when creating the project.
3 Select [Open]-[CPU Properties] from the [File] menu and open the CPU property file for settings.

4 Select [CPU properties] from [Project Settings].
5 Make communication settings with the [SETUP] tree’s [ETHERNET], [HIGHER-LEVEL LINK SERVICE].

* [ETHERNET] Settings

Setup Items Setup Description
ETHER_MY_IPADDRESS 192.168.0.1
ETHER_SUBNET_MASK 255.255.255.0

¢ [HIGHER-LEVEL LINK SERVICE] Settings

Setup Items Setup Description
HILINK_PROTOCOL_B 0
HILINK_DATA_FORMAT_B 1
HLINK_PROTECT 0

6 Download the setting CPU property file and the project file to the External Device.
7 Reboot the External Device.
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3.24 Setting Example 24
W Settings of GP-Pro EX

4 Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Summary Change Device/PLC
M anufacturer |YDKDGAW'A Electric: Corporation ~ Series Perzonal Computer Link Ethernet Port |Ethemet [TCP)
Text Data Mode ’T LChange

Communication Settings

Port No. 1024 3: [ Auto
Timeout 3 3: [sec]
Retry 0 3:

wiatt To Send 0 3: [ms] Diefault

Device-Specific Settings

Alloweable Mumber Add Device
of Devices/PLCs 16

Add Indirect
Mo, Device Name Settings Device
1 [PLcT [it] [P ata Code=fiscillP Address=192.168.000.001 Part N

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the External Device and click [Settings] B .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add
Device] to add another External Device.

,f_‘: Individual Device Settines

PLC1
IP &ddress 192 188 1] 1
Port No. 12291 3:
Data Code " Binary

(+ Asci

Drefault
oK@ | Cancel |

 Notes

e Check with a network administrator about IP address. Do not set the duplicate IP address.
« Set IP address on the External Device for IP address in Device-specific settings.
* You need to set IP address on the Display in the offline mode of the Display.
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W Setting of External Device
The ladder software (WideField3) configures the External Device’s communication settings.

Refer to your External Device manual for communication setting details.

@ Procedure

1 start up the ladder software.

2 Create a new project. Select the External Device to be used when creating the project.

3 Select [Open]-[CPU Properties] from the [File] menu and open the CPU property file for settings.

4 Select [CPU properties] from [Project Settings].

5 Make communication settings with the [SETUP] tree’s [ETHERNET], [HIGHER-LEVEL LINK SERVICE].

* [ETHERNET] Settings

Setup Items Setup Description
ETHER_MY_IPADDRESS 192.168.0.1
ETHER_SUBNET_MASK 255.255.255.0

¢ [HIGHER-LEVEL LINK SERVICE] Settings

Setup Items Setup Description
HILINK_PROTOCOL_B 0
HILINK_DATA_FORMAT_B 0
HLINK_PROTECT 0

6 Download the setting CPU property file and the project file to the External Device.
7 Reboot the External Device.

GP-Pro EX Device/PLC Connection Manual 56



Personal Computer Link Ethernet Driver

4 Setup Items

Set communication settings of the Display with GP-Pro EX or in offline mode of the Display.

The setting of each parameter must be identical to that of External Device.

F 3 Example of Communication Setting" (page 9)

NOTE | * Set the Display’s IP address in offline mode.

Cf.  Maintenance/Troubleshooting Guide "Ethernet Settings"

4.1 Setup Items in GP-Pro EX

B Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC]..

Device/PLE T |
Summary Change Device/FLE
b arwifacturer |YD KOGAWS Electric Corporation Series |F'ersnna| Computer Link Ethernet Piort |Ethemet [TCF)
Text Data Mode ,T LChange

Communication Settings

Fort Mo, m [ Auto

Tirneaut m (sec]

Retry m

Wiait To Send [0 = msl Defaul

Device-5pecific Settings

Alloweable Mumber Add Device
of Devices/PLCs 16
Add Indirect
Mo, Device Mame Settings Device

1 |F'LE1 ﬁl |Data Code=Binarny |P &ddress=000 000 000.000,Part *

Setup ltems Setup Description

Use an integer from 1024 to 65535 to enter the port No. of the Display. When you check
the option of [Auto Assign], the port No. will be automatically set.

Port No. NOTE

» [Auto Assign] option is available to set only when you select "Ethernet (TCP)" in
[Connecting Method].

Use an integer from 1 to 127 to enter the time (s) for which the Display waits for the

Timeout response from the External Device.

In case of no response from the External Device, use an integer from 0 to 255 to enter how
Retry . : :

many times the Display retransmits the command.
Wait To Send Use an integer from 0 to 255 to enter standby time (ms) for the Display from receiving

packets to transmitting next commands.

NOTE | * Refer to the GP-Pro EX Reference Manual for Indirect Device.
Cf. GP-Pro EX Reference Manual "Changing the Device/PLC at Runtime (Indirect
Device)"
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B Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the External Device and click [Settings] B .
To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add

Device] to add another External Device.

.;g'v‘j: Individual Device Settings

IP Address | 00 o0 0 0
Fort Ma. |1 2283 3:
Data Code ' Binary

" Ascii

Default |

Ok (3] |

Setup Items Setup Description

Set IP address of the External Device.

IP Address

» Check with a network administrator about IP address. Do not set the duplicate IP

address.
Port No. Use an integer 12289 or 12291 to enter the port No. of the External Device.
Data Code Select the data format to communicate with the External Device from "Binary" or "ASCII".
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4.2 Setup Items in Offline Mode

NOTE | ¢ Refer to the Maintenance/Troubleshooting guide for information on how to enter offline mode or
about the operation.

Cf.  Maintenance/Troubleshooting Guide "Offline Mode"

B Communication Settings

To display the setting screen, touch [Device/PLC Settings] from [Peripheral Settings] in offline mode. Touch the
External Device you want to set from the displayed list.

| Cornm, Device

Personal Computer Link Ethernet [UDP] Page 1/1
Port No. e Fixed futo
| 1024 » | a|
Timeout(s) 3w | A
Retry 7w | a
Wait To Sendims) 0w a

. 2085/29/01
Exit Back 19:39:44

Setup ltems Setup Description

Set the Port No. of the Display. In UDP connection, entered port No. will be assigned
regardless of whether you select [Fixed] or [Auto]. In TCP connection, select either of
Port No. [Fixed] or [Auto]. When you select [Fixed], use an integer from 1024 to 65535 to enter the
port No. of the Display. When you select [Auto], the port No. will be automatically
assigned regardless of the entered value.

Use an integer from 1 to 127 to enter the time (s) for which the Display waits for the

Timeout response from the External Device.

In case of no response from the External Device, use an integer from 0 to 255 to enter how
Retry . - .

many times the Display retransmits the command.
Wait To Send Use an integer from 0 to 255 to enter standby time (ms) for the Display from receiving

packets to transmitting next commands.
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To display the setting screen, touch [Device/PLC Settings] from [Peripheral Settings]. Touch the External Device

you want to set from the displayed list, and touch [Device].

Cornm, Device
Personal Computer Link Ethernet [UDP] Page 1/1
Device/PLC Name  [PLCI ==

IP fddress [ ]

Port No. 17789 » | a |

Data Code [Binary ==

; 20n5/09/01

Exit Back 19:39:47

Setup Items

Setup Description

Device/PLC Name

Select the External Device for device setting. Device name is a title of External Device set
with GP-Pro EX.(Initial value [PLC1])

Set IP address of the External Device.

IP Address
» Check with a network administrator about IP address. Do not set the duplicate IP
address.
Port No. Use an integer 12289 or 12291 to enter the port No. of the External Device.
Data Code Select the data format to communicate with the External Device from "Binary" or "ASCII".
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5 Supported Device

Range of supported device address is shown in the table below. Please note that the actually supported range of
the devices varies depending on the External Device to be used. Please check the actual range in the manual of
your External Device.

(=== This address can be specified as system data area.

Device Bit Address Word Address tjtzs Notes
Input Relay X00201 to X71664 X00201 to X71649 =
Output Relay Y00201 to Y71664 Y00201 to Y71649 “oe | 1
Internal Relay 100001 to 165535 10001 to 165521 @
Common Relay E0001 to E4096 EO0001 to E4081 @
Special Relay MO0001 to M9984 MO0001 to M9969 e |
Link Relay L00001 to L78192 L00001 to L78177 1]
Time-up Relay TUO0001 to TU3072
Count-up Relay CUO000 to CU3072 -
Timer present value --- TPOO001 to TP3072
(T!Q:;rtﬁjrs)sem value TI0001 to TI3072
Timer preset value TS0001 to TS3072 *2
Counter present value CP0001 to CP3072

[L/H

Counter present value
(count-up)

C10001 to CI13072

Counter preset value

CS001 to CS3072

Data Register

D00001.00 to
D65535.15

D00001 to D65535

Common Register

B000001.00 to
B262144.15

B000001 to B262144

F000001.00 to

*2

*4

Cache Register F524288.15 F000001 to F524288
. R0001.00 to
General Register RA096.15 R0001 to R4096
Special Register Z0001.00 to 21024.15 Z0001 to 21024
. . WO00001.00 to *3

Link Register W78192 15 WO00001 to W78192

Special Module SW0010000 to SW7169999 *2*5
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32
Device Bit Address Word Address bits Notes
INF100 to INF101 *2*6
INF200 to INF214 *2*8
. INF30010 to INF37163 *2"6
Information
INF4100.00 to g
INF4215.15 INF4100 to INF4215
[L ] H]
INF500 *6
Program Information PRI00000 to PRI99913 A
User Log Read ULR000000 to ULR 064128 *2*8
Error History Read ERH000000 to ERH 128000 *2%9

*1  Address for input relay and output relay can be specified when data position number (bit) 01 to 49 for lower
2 digits is the value of (multiples of 16) + 1 only.

Example: X00201

X 0 02 01
L Data Position No.
Module slot No.
Module unit No.

*2  Write disable

*3  Inlink relay (L) and link register (W), the upper 1st digit on address input area shows the link number, and
lower 4th digit shows the address. Specify the word address for link relay (L) and link register (W) with the
value of (multiples of 16) + 1.

Example: When specifying L71024 of link relay

L 7 1

o

24

Address(Link Relay:0001 to 8192 Link device:0001 to 4096
Link No.(0 to 7)

B

Device Name(Link Relay:L Link device:W)

*4  Only the F3SP71-4N, F3SP76-7N, F3SP71-4S and F3SP76-7S can be used.
*5  Information of Special Module Read/Write

SW0 01 0003
Data Position No. (0000 to 9999)

Module Slot No. (01 to 16)
Module Unit No. (0 to 7)

I

GP-Pro EX Device/PLC Connection Manual 62



*6

Personal Computer Link Ethernet Driver

Information Read
1. Read the status of CPU module and program

INF 1 00

0: CPU status (1 word)
1:Program status (1 word)

Parameter No. (1)
2. Read the information of system ID, CPU type and area size
INF 2 00
—ASCII mode:
13,14: Program area size (2 words)
12: CPU type (1 word)

08 to 11: Revisiov (4 words)
00 to 07: System ID (8 words)

Binary mode:
13: Program area size (1 word)
12: CPU type (1 word)
08 to 11: Revisiov (4 words)
00 to 07: System ID (8 words)

Parameter No. (2)

3. Read the mounting module name
INF3 0010

3: Input/Output relay point (1 word)
2: Input/Output (1 word)
0,1: Module name (2 words)

Slot No. (1 to 16)

Unit No. (0 to 7)

Parameter No. (3)

4. Read the ERR LED of CPU module or the ALM LED lighting factor
INF4 1 01

LO to 15: Factor (16 words)

Factor designated flag (1:ERR factor, 2:ALM factor)
Parameter No. (4)

5. Delete the current alarm information of CPU module (write only)
INF5 00

Parameter No. (5)
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*7  Program Information Read

When 000 is written in Read information
PRI 000 00

ASCII mode:
Creation date: 7 to 13 (7 words)
Size step No.: 4 to 6 (3 words)
Program name: 0 to 3 (4 words)

Binary mode:
Creation date: 6 to 10 (5 words)
Size step No.: 4 to 5 (2 words)
Program name: 0 to 3 (4 words)

Read information (000: Program name, Creation date)

When one of the numbers from 001 to 999 is written in Read information
PRI 000 00
ASCII mode:

Size step No.: 4 to 6 (3 words)
Program name: 0 to 3 (4 words)

Binary mode:
Size step No.: 4 to 5 (2 words)
Program name: 0 to 3 (4 words)

Read information (001 to 999: Reading such as the block names of No.n)

*8  User Log Read
ULR 000 000

User log: 0 to 128 (word)

User log reading point
000: Latest user log
001 to 064: No.n user log from new data

*9  Error History Read
ERH 000 000

——ASCII mode:
0: Error information
(00: System error, 01: BASIC error, 02: Sequence error, 03: 1/O error)

1, 2: Error code (Charactor string)
3 to 6: Date (YY/MM/DD) charactor string

7 to 10: Time (HH:MM:SS) charactor string
11 to 22: Added information (Charactor string)

—Binary mode:
0: Error information
(0000: System error, 0001: BASIC error, 0002: Sequence error, 0003: I/O error)
1: Error code
2 to 4: Date (YYYY/MMMM/DDDD)
5to 7: Time (HHHH:MMMM:SSSS)
8 to 18: Added information

Error history reading point
000: Latest user log
001 to 128: No.n user log from new data
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NOTE | * Please refer to the GP-Pro EX Reference Manual for system data area.
Cf. GP-Pro EX Reference Manual "LS Area (Direct Access Method Area)"
 Please refer to the precautions on manual notation for icons in the table.

&~ "Manual Symbols and Terminology"
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Use device code and address code when you select "Device Type & Address" for the address type in data displays.

Device Code

Device Device Name Address Code
(HEX)
1X 0080
2X 0180 (Module unit No. x 0x40) + ((Module
Input Relay slot No. - 1) x 0x4) + ((Terminal No. -
3X 0280 1) divided by 16)™
4X 0380
1Y 0081
2y 0181 (Module unit No. x 0x40) + ((Module
Output Relay slot No. - 1) x 0x4) + ((Terminal No. -
3Y 0281 1) divided by 16)™1
4Y 0381
11 0082
21 0182 i
Internal Relay \1/glue of (word address - 1) divided by
3l 0282
41 0382
1E 0084
2E 0184 ) i
Common Relay \llglue of (word address - 1) divided by
3E 0284
4E 0384
M 0083
2M 0183 ) L
Special Relay \1/glue of (word address - 1) divided by
3M 0283
4M 0383
1L 0088
. 2L 0188 (Link No. x 0x10000) + ((word address
Link Relay 1) divided by 16)*2
3L 0288 - 1) divided by 16)
4L 0388
1TP 0060
. 2TP 0160 Value of word address from which 1 is
Timer present value deducted
3TP 0260 educte
4TP 0360
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Device Code

Device Device Name (HEX) Address Code
1TI 006D
Timer present value 2Tl 016D Value of word address from which 1 is
(count-up) 3TI 026D deducted
4TI 036D
1TS 0063
Timer oreset value 2TS 0163 Value of word address from which 1 is
P 3TS 0263 deducted
4TS 0363
1CP 0061
Counter present value 2CP 0161 Value of word address from which 1 is
P 3CP 0261 deducted
4CP 0361
1CI 006E
Counter present value 2Cl 016E Value of word address from which 1 is
(count-up) 3l 026E deducted
4ClI 036E
1CS 0064
Counter preset value 2CS 0164 Value of word address from which 1 is
P 3CS 0264 deducted
ACS 0364
1D 0000
Data Register 2D 0100 Value of word address from which 1 is
g 3D 0200 deducted
4D 0300
1B 0004
Common Redister 2B 0104 Value of word address from which 1 is
9 3B 0204 deducted
4B 0304
1F 0006
Cache Redister™ 2F 0106 Value of word address from which 1 is
g 3F 0206 deducted
4F 0306
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Device Code

Device Device Name Address Code
(HEX)
1R 0003
. 2R 0103 Value of word address from which 1 is
General Register deducted
3R 0203 educte
4R 0303
1z 0001
. . 2Z 0101 Value of word address from which 1 is
Special Register deducted
3z 0201 educte
47 0301
1w 0002
. . 2W 0102 (Link No. x 0x10000) + ((word address
Link Register 1) divided by 16)*2
3w 0202 - 1) divided by 16)
4W 0302
1SwW 0065
2SW 0165
Special Module Word address
3SW 0265
4SW 0365
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: . Device Code
Device Device Name (HEX) Address Code
1INF1 0066
2INFL 0166 Word address
3INF1 0266 (Read only)
4INF1 0366
1INF2 006a
2INF2 016a Word address
3INF2 026a (Read only)
4INF2 036a
1INF3 006b
i 2INF3 016b Word address
Information
3INF3 0260 (Read only)
4INF3 036b
1INF4 0005
2INF4 0105 Word address
3INF4 0205 (Read only)
4INF4 0305
1INF5 006¢c
2INFS 016c Word address
3INF5 026¢ (Write only)
4INF5 036¢
1PRI 0067
i 2PRI 0167 Word address
Program Information
3PRI 0267 (Read only)
4PRI 0367
1ULR 0068
2ULR 0168
User Log Read Word address
3ULR 0268 (Read only)
4ULR 0368
1ERH 0069
2ERH 0169
Error History Read Word address
3ERH 0269 (Read only)
4ERH 0369
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|
*1  Please refer to "5 Supported Device *1" for each name.

*2  Please refer to "5 Supported Device *3" for each name.
*3  Only the F3SP71-4N, F3SP76-7N, F3SP71-4S and F3SP76-7S can be used.
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7 Error Messages
Error messages are displayed on the screen of Display as follows: "No. : Device Name: Error Message (Error
Occurrence Area)". Each description is shown below.
Item Description
No. Error No.

Device Name

Name of External Device where error occurs. Device name is a title of External Device set
with GP-Pro EX.(Initial value [PLC1])

Error Message

Displays messages related to the error which occurs.

Error Occurrence Area

Displays IP address or device address of External Device where error occurs, or error codes
received from External Device.

« IP address is displayed such as "IP address (Decimal): MAC address (Hex)".
« Device address is displayed such as "Address: Device address".
» Received error codes are displayed such as "Decimal [Hex]".

Display Examples of Error Messages
"RHAAOQ35: PLC1: Error has been responded for device write command (Error Code: 2 [02H])"

NOTE | * Refer to your External Device manual for details on received error codes.
« Refer to "Display-related errors™ in "Maintenance/Troubleshooting Guide" for details on the error

messages common to the driver.
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