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XGT/XGB Series FEnet Driver

Introduction
This manual describes how to connect the Display and the External Device (target PLC).
In this manual, the connection procedure will be described by following the below sections:

1 || System Configuration
This section shows the types of External
Devices which can be connected and SIO

type.

&g System Configuration" (page 3)

2 Selection of External Device

Select a model (series) of the External
Device to be connected and connection
method.

"2 Selection of External Device" (page 5)

3 Example of Communication Settings
This section shows setting examples for
communicating between the Display and
the External Device.

&3 Example of Communication Setting"

(page 6)

4 Setup ltems

This section describes communication
setup items on the Display.

Set communication settings of the Display
with GP-Pro EX or in offline mode.

Fny Setup Items" (page 16)

Operation
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1 System Configuration

The system configuration in the case when the External Device of LS Industrial Systems Co., Ltd. and the Display
are connected is shown.

Series CPU Link I/F Interface Setting Example
XGK-CPUU
XGK-CPUE
XGK-CPUS Ethernet Setting Example 1
XGK-CPUA XGL-EFMT (UDP, TCP) (page 6)
XGK-CPUH
XGT XGI-CPUU/D
XGI-CPUU .
XGI-CPUH XGL-EFMT E(ﬂ‘gge;cp) (Sittfeng) Example 2
XGI-CPUS ! bag
XGI-CPUE
Ethernet Setting Example 3
XGR-CPUH/T XGL-EFMT (UDP, TCP) (page 10)
Ethernet Setting Example 4
_D**x* -
XBM-D***S XBL-EMTA (UDP, TCP) (age 12)
Ethernet Setting Example 4
_D*** -
XGB XBC-D***H XBL-EMTA (UDP, TCP) (page 12)
Ethernet Setting Example 5
_D*** -
XEC-D***H XBL-EMTA (UDP, TCP) (page 14)

NOTE | ¢ Check the combination of the CPU version and the link I/F version with the external device
manufacturer. When the versions which are not supported are used, some features may not work
properly. Check the versions with the label of each unit or manufacturer's software.

B Connection Configuration

¢ 1:1 Connection
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¢ 1:n Connection

Maximum number of connections: n*1

*1  The maximum 32 units connection by UDP connection, the maximum 16 units connection by TCP
connection.

¢ n:1 Connection

Maximum number of connections: 16 units
"
\

¢ n:m Connection

Maximum number of connections: 16 units
A

-~
Maximum number of connections: n

*2  The maximum 32 units connection by UDP connection, the maximum 16 units connection by TCP
connection.
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Selection of External Device

Select the External Device to be connected to the Display.

% Welcome to GP-Pro EX E

— Device/PLC
Mumber of Devices/PLCs Iﬁ’
Device/PLC 1
Manufacturer | LS Industrial Systems Co., Ltd, |L
Series GT/XGE Series FEnet [~
Fart Ethemet (UDF} [~
Eefer to the manual of this Device/PLC
Eecent Device/PLC
4 4
[~ Use System Area Drevice Information

Back [B] | Communication Settings Hew Logic | Mew Screen I Cancel

Setup Items

Setup Description

Number of Devices/
PLCs

Enter an integer from 1 to 4 to define the number of Devices/PLCs to connect to the display.

Select the manufacturer of the External Device to connect. Select "LS Industrial Systems Co.,

Manufacturer Ltd"
Select the External Device model (series) and the connection method. Select "XGT/XGB
Series FEnet".
Series In System configuration, make sure the External Device you are connecting is supported by
"XGT/XGB Series FEnet".
& System Configuration” (page 3)
Port Select the Display port to connect to the External Device.

Use System Area

Check this option to synchronize the system data area of the Display and the device (memory)
of the External Device. When synchronized, you can use the External Device’s ladder program
to switch the display or display the window on the Display.

Cf. GP-Pro EX Reference Manual "LS Area (Direct Access Method Area)"
This feature can also be set in GP-Pro EX or in the Display's offline mode.

Cf. GP-Pro EX Reference Manual "System Settings [Display Unit] - [System Area]

Settings Guide"
Cf. Maintenance/Troubleshooting Guide "Main Unit - System Area Settings"
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3 Example of Communication Setting

Examples of communication settings of the Display and the External Device, recommended by Pro-face, are
shown.

3.1 Setting Example 1
W Settings of GP-Pro EX

4 Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Devica/PLC 1 |
Summary Change Device/PLC
M anufacturer ILS Industrial Systems Co., Ltd. Series HGT /<GB Series FEnet Port IEthemet [UDPF)
Text Data Mode IT LChange

Communication Settings

Port Mo, lm v Auto

Timeout m [zec]

Fietry m

‘it To Send o = ms Default |

Device-Specific Settings

Allowveable Mumber Add Device
of Devices/PLCs 32

Add Indirect
Mo, Device Name Settings Device
[&] 1 [P [t I address=192.168.000.001 Series=4GK.

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the external device and click [Settings] i .
To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add

Device] to add another External Device.

£ Individual Device Settings [ %]
FLC1
Series % WGK = XGIAXGR

" HBMABC i HEC
[If you change the series, please reconfim all
address zettings.]

I address 192 168 o 1

Default |
oK@ | Cancel |

@ Notes
e Check with a network administrator about IP address. Do not set the duplicate IP address.
» Set IP address on the External Device for IP address in Device-specific settings.

* You need to set IP address on the display in the offline mode of the display.
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B Settings of External Device
Use the LS Industrial Systems setting tool (XG-PD Editor) to configure communication settings for the External
Device.

Refer to your External Device manual for details.

@ EtherNet module Setting

1 Start up the setting tool.

2 From the [File] menu, select [New File], and create the project.

3 From the [Online] menu, select [Connect].

4 From the [Online] menu, select [Read 10 Information].

5 Double-click [FEnet] displayed in the tree view and set EtherNet module.

Setup Items Setup Description
IP Address 192.168.0.1
Subnet mask 255.255.255.0
Driver XGT server

6 Select [Write Parameter(Standard Settings,HS Link,P2P)] from the [Online] menu after selecting [Connect] from
the [Online] menu and connecting External Device with communication setting software.
7 Select [Reset] from the [Online] menu, and reboot External Device.

@ Notes

¢ Check with a network administrator about IP address.
Do not set the duplicate IP address.
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3.2 Setting Example 2
W Settings of GP-Pro EX

4 Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Devica/PLC 1 |
Summary Change Device/PLC
M anufacturer ILS Industrial Systems Co., Ltd. Series HGT /<GB Series FEnet Port IEthemet [UDPF)
Text Data Mode IT LChange

Communication Settings

Port Mo, lm v Auto

Timeout m [zec]

Fietry m

‘what To Send i} = [ms] Default |

Device-Specific Settings

Allowveable Mumber Add Device
of Devices/PLCs 32

Add Indirect
Mo. Device Mame Settings Device
IE 1 |F'LE1 E |IF' address=192.168.000.001 Series=+GI/ =GR

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the external device and click [Settings] [ .
To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add
Device] to add another External Device.

15 Individual Device Settings [ %]
PLCA
Series 7 HEK & HGIMGR

" HBMABC i HEC
[If you change the series, please reconfim all
address zettings.]

I address 192 168 o 1

Default |
oK@ | Cancel |

€ Notes
e Check with a network administrator about IP address. Do not set the duplicate IP address.
« Set IP address on the External Device for IP address in Device-specific settings.
* You need to set IP address on the display in the offline mode of the display.
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B Settings of External Device
Use the LS Industrial Systems setting tool (XG-PD Editor) to configure communication settings for the External
Device.

Refer to your External Device manual for details.

@ EtherNet module Setting

1 Start up the setting tool.

2 From the [File] menu, select [New File], and create the project.

3 From the [Online] menu, select [Connect].

4 From the [Online] menu, select [Read 10 Information].

5 Double-click [FEnet] displayed in the tree view and set EtherNet module.

Setup Items Setup Description
IP Address 192.168.0.1
Subnet mask 255.255.255.0
Driver XGT server

6 Select [Write Parameter(Standard Settings,HS Link,P2P)] from the [Online] menu after selecting [Connect] from
the [Online] menu and connecting External Device with communication setting software.
7 Select [Reset] from the [Online] menu, and reboot External Device.

@ Notes

¢ Check with a network administrator about IP address.
Do not set the duplicate IP address.

GP-Pro EX Device/PLC Connection Manual 9



XGT/XGB Series FEnet Driver

3.3 Setting Example 3
W Settings of GP-Pro EX

4 Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Devica/PLC 1 |

Summary Change Device/PLC
M anufacturer ILS Industrial Systems Co., Ltd. Series HGT /<GB Series FEnet Port IEthemet [UDPF)
Text Data Mode I 2 Change

Communication Settings

Port Mo, lm v Auto

Timeout m [zec]

Fietry m

‘it To Send o = ms Default |

Device-Specific Settings

Allowveable Mumber Add Device
of Devices/PLCs 32

Add Indirect
Mo. Device Mame Settings Device
IE 1 |F'LE1 E |IF' address=192.168.000.001 Series=+GI/ =GR

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the external device and click [Settings] [ .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add
Device] to add another External Device.

£ Individual Device Settings [ %]
FLC1
Series  WGK % XGIAXGR

" HBMABC i HEC
[If you change the series, please reconfim all
address zettings.]

I address 192 168 o 1

Default |
oK@ | Cancel |

 Notes

* When you use the Redundancy System of the External Device, the number of External Device you will set
varies depending on whether you use ONE IP Solution.
When you use the ONE IP Solution, one External Device number is to be set. When you do not use the ONE
IP Solution, you must set the A-Side and B-Side respectively as an individual External Device.

e Check with a network administrator about IP address. Do not set the duplicate IP address.

« Set IP address on the External Device for IP address in Device-specific settings.

* You need to set IP address on the display in the offline mode of the display.
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B Settings of External Device
Use the LS Industrial Systems setting tool (XG-PD Editor) to configure communication settings for the External
Device.

Refer to your External Device manual for details.

@ EtherNet module Setting

1 Start up the setting tool.

2 From the [File] menu, select [New File], and create the project.

3 From the [Online] menu, select [Connect].

4 From the [Online] menu, select [Read 10 Information].

5 Double-click [FEnet] displayed in the tree view and set EtherNet module.

Setup Items Setup Description
IP Address 192.168.0.1
Subnet mask 255.255.255.0
Driver XGT server

6 Select [Write Parameter(Standard Settings,HS Link,P2P)] from the [Online] menu after selecting [Connect] from
the [Online] menu and connecting External Device with communication setting software.
7 Select [Reset] from the [Online] menu, and reboot External Device.

@ Notes

¢ Check with a network administrator about IP address.
Do not set the duplicate IP address.

GP-Pro EX Device/PLC Connection Manual 11
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3.4 Setting Example 4
W Settings of GP-Pro EX

4 Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Devica/PLC 1 |
Summary Change Device/PLC
M anufacturer ILS Industrial Systems Co., Ltd. Series HGT /<GB Series FEnet Port IEthemet [UDPF)
Text Data Mode IT LChange

Communication Settings

Port Mo, lm v Auto

Timeout m [zec]

Fietry m

‘what To Send i} = [ms] Default |

Device-Specific Settings

Allowveable Mumber Add Device
of Devices/PLCs 32

Add Indirect
Mo, Device Mame Seftings Device
IE 1 |F'LE1 @ |IF' address=192.168.000.001 Series=+BM=BC

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the external device and click [Settings] [ .
To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add
Device] to add another External Device.

15 Individual Device Settings [ %]
PLCA
Series 7 HEK 7 HEIMHGR

& HBMABC i HEC
[If you change the series, please reconfim all
address zettings.]

I address 192 168 o 1

Default |
oK@ | Cancel |

€ Notes
e Check with a network administrator about IP address. Do not set the duplicate IP address.
« Set IP address on the External Device for IP address in Device-specific settings.
* You need to set IP address on the display in the offline mode of the display.
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B Settings of External Device
Use the LS Industrial Systems setting tool (XG-PD Editor) to configure communication settings for the External
Device.

Refer to your External Device manual for details.

@ EtherNet module Setting

1 Start up the setting tool.

2 From the [File] menu, select [New File], and create the project.

3 From the [Online] menu, select [Connect].

4 From the [Online] menu, select [Read 10 Information].

5 Double-click [FEnet] displayed in the tree view and set EtherNet module.

Setup Items Setup Description
IP Address 192.168.0.1
Subnet mask 255.255.255.0
Driver XGT server

6 Select [Write Parameter(Standard Settings,HS Link,P2P)] from the [Online] menu after selecting [Connect] from
the [Online] menu and connecting External Device with communication setting software.
7 Select [Reset] from the [Online] menu, and reboot External Device.

@ Notes

¢ Check with a network administrator about IP address.
Do not set the duplicate IP address.
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3.5 Setting Example 5
W Settings of GP-Pro EX

4 Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Devica/PLC 1 |
Summary Change Device/PLC
M anufacturer ILS Industrial Systems Co., Ltd. Series HGT /<GB Series FEnet Port IEthemet [UDPF)
Text Data Mode IT LChange

Communication Settings

Port Mo, lm v Auto

Timeout m [zec]

Fietry m

‘what To Send i} = [ms] Default |

Device-Specific Settings

Allowveable Mumber Add Device
of Devices/PLCs 32

Add Indirect
Mo. Device Mame Settings Device
[&] 1 [P [l 1P address=132.168.000.001 Series=XEC

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]
window, select the external device and click [Settings] [ .
To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add
Device] to add another External Device.

15 Individual Device Settings [ %]
PLCA
Series 7 HEK 7 HEIMHGR

" HBMABC &+ HEC
[If you change the series, please reconfim all
address zettings.]

I address 192 168 o 1

Default |
oK@ | Cancel |

€ Notes
e Check with a network administrator about IP address. Do not set the duplicate IP address.
« Set IP address on the External Device for IP address in Device-specific settings.
* You need to set IP address on the display in the offline mode of the display.
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B Settings of External Device
Use the LS Industrial Systems setting tool (XG-PD Editor) to configure communication settings for the External
Device.

Refer to your External Device manual for details.

@ EtherNet module Setting

1 Start up the setting tool.

2 From the [File] menu, select [New File], and create the project.

3 From the [Online] menu, select [Connect].

4 From the [Online] menu, select [Read 10 Information].

5 Double-click [FEnet] displayed in the tree view and set EtherNet module.

Setup Items Setup Description
IP Address 192.168.0.1
Subnet mask 255.255.255.0
Driver XGT server

6 Select [Write Parameter(Standard Settings,HS Link,P2P)] from the [Online] menu after selecting [Connect] from
the [Online] menu and connecting External Device with communication setting software.
7 Select [Reset] from the [Online] menu, and reboot External Device.

@ Notes

¢ Check with a network administrator about IP address.
Do not set the duplicate IP address.
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4 Setup Items

Set communication settings of the Display with GP-Pro EX or in offline mode of the Display.

The setting of each parameter must be identical to that of External Device.

F 3 Example of Communication Setting" (page 6)

NOTE | ¢ Setthe Display’s IP address in offline mode.

Cf.  Maintenance/Troubleshooting Manual "Ethernet Settings"

4.1 Setup Items in GP-Pro EX

B Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Devica/PLC 1 |
Summary Change Device/PLC
M anufacturer ILS Industrial Systems Co., Ltd. Series HGT /<GB Series FEnet Port IEthemet [UDPF)
Text Data Mode IT LChange

Communication Settings

Port Mo, lm v Auto

Timeout m [zec]

Fietry m

‘it To Send o = ms Default |

Device-Specific Settings

Allowveable Mumber Add Device
of Devices/PLCs 32

Add Indirect
Mo, Device Mame Settings Device
[&] 1 [P [t I address=192.168.000.001 Series=4GK.
Setup Items Setup Description
Port No Enter a port number of the Display, using 1024 to 65535. Check into [Auto], and a port

number is set automatically.

Use an integer from 1 to 127 to enter the time (s) for which Display waits for the response

Timeout from External Device.

In case of no response from the External Device, use an integer from 0 to 255 to enter how
Retry . - .

many times the Display retransmits the command.
Wait To Send Use an integer from 0 to 255 to enter standby time (ms) for the Display from receiving

packets to transmitting next commands.

NOTE | ¢ Refer to the GP-Pro EX Reference Manual for Indirect Device.

Cf. GP-Pro EX Reference Manual "Changing the Device/PLC at Runtime (Indirect
Device)"
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B Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] [ .
To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add

Device] to add another External Device.

ﬁ; Individual Device Settings [ %]
PLCA
Series &+ HEK 7 HEIMHGR

" HBMABC i HEC
[If you change the series, please reconfim all
address zettings.]

I address 192 168 o 1

Default |
oK@ | Cancel |

Setup Items Setup Description

Series Select the series of the External Device.

Set IP address of the External Device.

IP Address

» Check with a network administrator about IP address. Do not set the duplicate IP
address.

GP-Pro EX Device/PLC Connection Manual 17
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4.2 Setup Items in Offline Mode

NOTE | ¢ Referto the Maintenance/Troubleshooting manual for information on how to enter offline mode or
about the operation.

Cf.  Maintenance/Troubleshooting Manual "Offline Mode"

« The number of the setup items to be displayed for 1 page in the offline mode depends on the
Display in use. Please refer to the Reference manual for details.

B Communication Settings
To display the setting screen, touch [Device/PLC Settings] from [Peripheral Settings] in offline mode. Touch the

External Device you want to set from the displayed list.

| Cormm, Device

HGT/HGE Series FEnet [UDP] Page 1/1
Port No. o Fined * Auto
| 1024 [w | a|
Timeout(s) 3w A
Retry 7w |la
Wait To Send{ms) iw| a

. 2012/87/20
Enit . §1:20:09

Setup ltems Setup Description

Enter a port number of the Display.

Select either of "Fixed" "Auto". Enter a port number of the Display with "1024-65535",
when select "Fixed". Assign automatically without affecting the input value, when select
"Auto".

Port No.

Use an integer from 1 to 127 to enter the time (s) for which Display waits for the response

Timeout from External Device.

In case of no response from the External Device, use an integer from 0 to 255 to enter how

Retry many times the Display retransmits the command.

Use an integer from 0 to 255 to enter standby time (ms) for the Display from receiving

Wait To Send packets to transmitting next commands.
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B Device Setting

To display the setting screen, touch [Device/PLC Settings] from [Peripheral Settings]. Touch the External Device
you want to set from the displayed list, and touch [Device].

192 166 0 1

Setup ltems Setup Description

Select the External Device for device setting. Device name is a title of External Device set

Device/PLC Name with GP-Pro EX.(Initial value [PLC1])

Series Display the series of the External Device.

Set IP address of the External Device.

IP Address

« Check with a network administrator about IP address. Do not set the duplicate IP
address.
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5 Supported Device

Range of supported device address is shown in the table below. Please note that the actually supported range of
the devices varies depending on the External Device to be used. Please check the actual range in the manual of

your External Device.

51

XGK / XBM / XBC

[==== This address can be specified as system data area.

Device Bit address Word address 32 bits Remarks
Input / Output Relay P00000 - P2047F P0000 - P2047
Auxiliary Relay MO00000 - M2047F MO0000 - M2047
Keep Relay K00000 - K4095F K0000 - K4095 1
Link Relay L000000 - L11263F L00000 - L11263
Special Relay F00000 - F2047F FO000 - F2047 "2
Timer (Contact) TO000 - T2047 -
Counter (Contact) C0000 - C2047 -
Timer (Current Value) - T0000 - T2047 [LIH
Counter (Current Value) - CO0000 - C2047
Data Register - D00000 - D32767 ‘ |T_f‘|
Special Module Register - U00.00 - U7F.31 2 R
Index Register - Z000 - 2127
Communication Data Register - N00000 - N21503
File Register - R00000 - R32767 4 A
File Register - ZR00000 - ZR65535 *4 [eiil]

*1  If the CPU is XGK, the bit address is "K00000 - K2047F" and the word address is "K0000 - K2047".

*2  Write disable

*3  The feature of U Device is like this:

U7E.31.F

L> Bit Address (hO - hF)
Special Module Inner Word Number: word number per slot (00 - 31)
Slot Number (hO - hF)
Base Number (0 - 7)

*4  XBM does not support the File Register.
XBC supports only File Register R. (File Register R and ZR are the same device in the XBC.)

NOTE | ¢ Please refer to the GP-Pro EX Reference Manual for system data area.
Cf. GP-Pro EXReference Manual "LS Area (Direct Access Method Area)"
« Please refer to the precautions on manual notation for icons in the table.

&~ "Manual Symbols and Terminology"
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5.2 XGIl/ XGR / XEC
[E===) This address can be specified as system data area.
Device Bit address Word address 32 bits Remarks
Inout Points %1X000.00.00 - %IW000.00.0 - *1
P %I1X127.15.63 %IW127.15.3
. %QX000.00.00 - %QW000.00.0 - *1
Output Points %QX127.15.63 %QW127.15.3
Automatic Variable %AX0000000 - %AW000000 -
%AX4194303 %AW262143
%MX0000000 - %MWO000000 -
%MX2097151 %MW131071
Direct Variable %RX000000 - %RWO00000 -
%RX524287 %RW32767 LiH
%WX0000000 - %WWO000000 -
%W X8388607 %WW524287
Svstem Ela %FX00000 - %FWO0000 - *9
Y g %FX32767 %FW2047
PID Ela %KX000000 - %KWO0000 -
g %KX134399 %KW8399
HS link Fla %L_X000000 - %L WO00000 -
g 9L X180223 96LW11263
Anal fresh FI %UX0.00.000 - %UW0.00.00 - *3
nalog refresh Flag 9%UX7.15.511 ~9%UW?7.15.31
*1  The feature of device is like this:
%IX0.0.0 %0OW0.0.0

Module Contact Number (0 - 63)
Slot Number (0 - 15)
Base Number (0 - 127)

L pDevice Name (X: Bit size)

*2  Write disable
*3  The feature of device is like this:

%UX7.15.511

Channel Contact Number (0 - 511)
Slot Number (0 - 15)

Base Number (0 - 7)

L pDevice Name (X: Bit size)

Module Word Number (0 - 3)

Slot Number (0 - 15)

Base Number (0 - 127)
L pDevice Name (W: 16 Bit size)

%UW7.15.31

Channel Word Number (0 - 31)
Slot Number (0 - 15)

Base Number (0 - 7)

L pDevice Name (W: 16 Bit size)

NOTE | ¢ Please refer to the GP-Pro EX Reference Manual for system data area.
Cf. GP-Pro EXReference Manual "LS Area (Direct Access Method Area)"
» Please refer to the precautions on manual notation for icons in the table.

&~ "Manual Symbols and Terminology"

GP-Pro EX Device/PLC Connection Manual
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6 Device Code and Address Code

XGT/XGB Series FEnet Driver

Use device code and address code when you select "Device Type & Address" for the address type in data displays.

6.1 XGK / XBM / XBC
Device Device Name De\?ﬁg)((:)()de Address Code
Input / Output Relay P 0080 Word Address
Auxiliary Relay M 0082 Word Address
Keep Relay K 0083 Word Address
Link Relay L 0084 Word Address
Special Relay F 0085 Word Address”™
Timer (Current Value) T 0060 Word Address
Counter (Current Value) o 0061 Word Address
Data Register D 0000 Word Address
Special Module Register U 0002 Word Address ™
Index Register z 0063 Word Address
Communication Data Register N 0064 Word Address
File Register R 0001 Word Address
File Register ZR 0003 Word Address

*1  Write disable

*2  If the Word Address of Uxx.dd be specified indirectly, please calculate the following formula.
Word Address = [Convert 'xx' parts to the decimal value from the hexadecimal value] x 32 + [dd]
For example, 01.00 is 32, 10.00 is 512, 7F.00 is 4064.

GP-Pro EX Device/PLC Connection Manual
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6.2 XGIl/ XGR / XEC
. . Device Code
Device Device Name (HEX) Address Code
%IX Word Address
Input Points 0080 =
%IW Word Address™t
%QX Word Address
Output Points 0081 _
%QW Word Address ™t
%AX Word Address
Automatic Variable 0001
%AW Word Address
%MX Word Address
0000
%MW Word Address
%RX Word Address
Direct Variable 0002
%RW Word Address
%WX Word Address
0003
%WW Word Address
%FX Word Address
System Flag 0004
%FW Word Address
%KX Word Address
PID Flag 0005
%KW Word Address
%LX Word Address
HL Link Flag 0006
%LW Word Address
%UX Word Address
Analog refresh Flag 0082 >
%UW Word Address

*1  If the Word Address be specified indirectly, please calculate the following formula.
Word Address = [Base Number x 64] + [Slot Number x 4] + [Module Word Number]

*2  If the Word Address be specified indirectly, please calculate the following formula.
Word Address = [Base Number x 512] + [Slot Number x 32] + [Module Word Number]

GP-Pro EX Device/PLC Connection Manual

23



XGT/XGB Series FEnet Driver

7 Error Messages
Error messages are displayed on the screen of Display as follows: "No. : Device Name: Error Message (Error
Occurrence Area)". Each description is shown below.
Item Description
No. Error No.

Device Name

Name of External Device where error occurs. Device name is a title of External Device set
with GP-Pro EX.((Initial value [PLC1])

Error Message

Displays messages related to the error which occurs.

Error Occurrence Area

Displays IP address or device address of External Device where error occurs, or error codes
received from External Device.

« IP address is displayed such as "IP address (Decimal): MAC address (Hex)".
« Device address is displayed such as "Address: Device address".
» Received error codes are displayed such as "Decimal [Hex]".

Display Examples of Error Messages
"RHAAOQ35: PLC1: Error has been responded for device write command (Error Code: 2 [02H])"

NOTE | ¢ Refer to your External Device manual for details on received error codes.

« Refer to "Display-related errors" in "Maintenance/Troubleshooting Manual" for details on the error
messages common to the driver.
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