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Introduction

This manual describes how to connect the Display and the External Device (target PLC).

In this manual, the connection procedure will be described by following the below sections:

1 System Configuration

This section shows the types of External 

Devices which can be connected and SIO 

type.

"1 System Configuration" (page 3)

2 Selection of External Device

Select a model (series) of the External 

Device to be connected and connection 

method. 

"2 Selection of External Device" (page 5)

3 Example of Communication Settings

This section shows setting examples for 

communicating between the Display and 

the External Device. 

"3 Example of Communication Setting" 
(page 6)

4 Setup Items

This section describes communication 

setup items on the Display.

Set communication settings of the Display 

with GP-Pro EX or in offline mode.

"4 Setup Items" (page 18)

Operation
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1 System Configuration

The system configuration in the case when the External Device of LS Industrial Systems Co., Ltd. and the Display 

are connected is shown.

 Connection Configuration

• 1:1 Connection

Series CPU Link I/F Interface Setting Example

XGT

XGK-CPUU
XGK-CPUE
XGK-CPUS
XGK-CPUA
XGK-CPUH
XGK-CPUUN
XGK-CPUHN
XGK-CPUSN

XGL-EFMT
Ethernet
 (UDP, TCP)

Setting Example 1 
(page 6)

XGK-CPUUN
XGK-CPUHN
XGK-CPUSN

Port on CPU unit
Ethernet
 ( TCP)

Setting Example 6 
(page 16)

XGI-CPUU/D
XGI-CPUU
XGI-CPUH
XGI-CPUS
XGI-CPUE

XGL-EFMT
Ethernet
 (UDP, TCP)

Setting Example 2 
(page 8)

XGR-CPUH/T XGL-EFMT
Ethernet
 (UDP, TCP)

Setting Example 3 
(page 10)

XGB

XBM-D***S XBL-EMTA
Ethernet
 (UDP, TCP)

Setting Example 4 
(page 12)

XBC-D***H XBL-EMTA
Ethernet
 (UDP, TCP)

Setting Example 4 
(page 12)

XEC-D***H XBL-EMTA
Ethernet
 (UDP, TCP)

Setting Example 5 
(page 14)

• Check the combination of the CPU version and the link I/F version with the external device 

manufacturer. When the versions which are not supported are used, some features may not work 

properly. Check the versions with the label of each unit or manufacturer's software.
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• 1:n Connection

*1 The maximum 32 units connection by UDP connection, the maximum 16 units connection by TCP 
connection.

• n:1 Connection

• n:m Connection

*2 The maximum 32 units connection by UDP connection, the maximum 16 units connection by TCP 
connection.
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2 Selection of External Device

Select the External Device to be connected to the Display.

Setup Items Setup Description

Number of Devices/
PLCs

Enter an integer from 1 to 4 to define the number of Devices/PLCs to connect to the display.

Manufacturer
Select the manufacturer of the External Device to connect. Select "LS Industrial Systems Co., 
Ltd.".

Series

Select the External Device model (series) and the connection method. Select "XGT/XGB 
Series FEnet".
In System configuration, make sure the External Device you are connecting is supported by 
"XGT/XGB Series FEnet".

"1 System Configuration" (page 3)

Port Select the Display port to connect to the External Device.

Use System Area

Check this option to synchronize the system data area of the Display and the device (memory) 
of the External Device. When synchronized, you can use the External Device’s ladder program 
to switch the display or display the window on the Display.

Cf. GP-Pro EX Reference Manual "LS Area (Direct Access Method Area)"
This feature can also be set in GP-Pro EX or in the Display's offline mode.

Cf. GP-Pro EX Reference Manual "System Settings [Display Unit] - [System Area] 
Settings Guide"

Cf. Maintenance/Troubleshooting Guide "Main Unit - System Area Settings"
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3 Example of Communication Setting

Examples of communication settings of the Display and the External Device, recommended by Pro-face, are 

shown.

3.1 Setting Example 1

 Settings of GP-Pro EX

  Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings]  .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

• For other series that are not listed to the left• For GP3000, LT3000, or GP-4100 Series
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Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

• Set IP address on the External Device for IP address in Device-specific settings.

• You need to set IP address on the display in the offline mode of the display.

 Settings of External Device

Use the LS Industrial Systems setting tool (XG-PD Editor) to configure communication settings for the External 

Device.

Refer to your External Device manual for details.

EtherNet module Setting

1 Start up the setting tool.

2 From the [File] menu, select [New File], and create the project.

3 From the [Online] menu, select [Connect].

4 From the [Online] menu, select [Read IO Information].

5 Double-click [FEnet] displayed in the tree view and set EtherNet module.

6 Select [Write Parameter(Standard Settings,HS Link,P2P)] from the [Online] menu after selecting [Connect] from 

the [Online] menu and connecting External Device with communication setting software.

7 Select [Reset] from the [Online] menu, and reboot External Device.

Notes

• Check with a network administrator about IP address. 

Do not set the duplicate IP address.

Setup Items Setup Description

IP Address 192.168.0.1

Subnet mask 255.255.255.0

Driver XGT server
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3.2 Setting Example 2

 Settings of GP-Pro EX

  Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings]  .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

• For other series that are not listed to the left• For GP3000, LT3000, or GP-4100 Series
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Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

• Set IP address on the External Device for IP address in Device-specific settings.

• You need to set IP address on the display in the offline mode of the display.

 Settings of External Device

Use the LS Industrial Systems setting tool (XG-PD Editor) to configure communication settings for the External 

Device.

Refer to your External Device manual for details.

EtherNet module Setting

1 Start up the setting tool.

2 From the [File] menu, select [New File], and create the project.

3 From the [Online] menu, select [Connect].

4 From the [Online] menu, select [Read IO Information].

5 Double-click [FEnet] displayed in the tree view and set EtherNet module.

6 Select [Write Parameter(Standard Settings,HS Link,P2P)] from the [Online] menu after selecting [Connect] from 

the [Online] menu and connecting External Device with communication setting software.

7 Select [Reset] from the [Online] menu, and reboot External Device.

Notes

• Check with a network administrator about IP address. 

Do not set the duplicate IP address.

Setup Items Setup Description

IP Address 192.168.0.1

Subnet mask 255.255.255.0

Driver XGT server
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3.3 Setting Example 3

 Settings of GP-Pro EX

  Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings]  .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

• For other series that are not listed to the left• For GP3000, LT3000, or GP-4100 Series
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Notes

• When you use the Redundancy System of the External Device, the number of External Device you will set 

varies depending on whether you use ONE IP Solution.

When you use the ONE IP Solution, one External Device number is to be set. When you do not use the ONE 

IP Solution, you must set the A-Side and B-Side respectively as an individual External Device.

• Check with a network administrator about IP address. Do not set the duplicate IP address.

• Set IP address on the External Device for IP address in Device-specific settings.

• You need to set IP address on the display in the offline mode of the display.

 Settings of External Device

Use the LS Industrial Systems setting tool (XG-PD Editor) to configure communication settings for the External 

Device.

Refer to your External Device manual for details.

EtherNet module Setting

1 Start up the setting tool.

2 From the [File] menu, select [New File], and create the project.

3 From the [Online] menu, select [Connect].

4 From the [Online] menu, select [Read IO Information].

5 Double-click [FEnet] displayed in the tree view and set EtherNet module.

6 Select [Write Parameter(Standard Settings,HS Link,P2P)] from the [Online] menu after selecting [Connect] from 

the [Online] menu and connecting External Device with communication setting software.

7 Select [Reset] from the [Online] menu, and reboot External Device.

Notes

• Check with a network administrator about IP address. 

Do not set the duplicate IP address.

Setup Items Setup Description

IP Address 192.168.0.1

Subnet mask 255.255.255.0

Driver XGT server
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3.4 Setting Example 4

 Settings of GP-Pro EX

  Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings]  .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

• For other series that are not listed to the left• For GP3000, LT3000, or GP-4100 Series
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Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

• Set IP address on the External Device for IP address in Device-specific settings.

• You need to set IP address on the display in the offline mode of the display.

 Settings of External Device

Use the LS Industrial Systems setting tool (XG-PD Editor) to configure communication settings for the External 

Device.

Refer to your External Device manual for details.

EtherNet module Setting

1 Start up the setting tool.

2 From the [File] menu, select [New File], and create the project.

3 From the [Online] menu, select [Connect].

4 From the [Online] menu, select [Read IO Information].

5 Double-click [FEnet] displayed in the tree view and set EtherNet module.

6 Select [Write Parameter(Standard Settings,HS Link,P2P)] from the [Online] menu after selecting [Connect] from 

the [Online] menu and connecting External Device with communication setting software.

7 Select [Reset] from the [Online] menu, and reboot External Device.

Notes

• Check with a network administrator about IP address. 

Do not set the duplicate IP address.

Setup Items Setup Description

IP Address 192.168.0.1

Subnet mask 255.255.255.0

Driver XGT server
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3.5 Setting Example 5

 Settings of GP-Pro EX

  Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings]  .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

• For other series that are not listed to the left• For GP3000, LT3000, or GP-4100 Series
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Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

• Set IP address on the External Device for IP address in Device-specific settings.

• You need to set IP address on the display in the offline mode of the display.

 Settings of External Device

Use the LS Industrial Systems setting tool (XG-PD Editor) to configure communication settings for the External 

Device.

Refer to your External Device manual for details.

EtherNet module Setting

1 Start up the setting tool.

2 From the [File] menu, select [New File], and create the project.

3 From the [Online] menu, select [Connect].

4 From the [Online] menu, select [Read IO Information].

5 Double-click [FEnet] displayed in the tree view and set EtherNet module.

6 Select [Write Parameter(Standard Settings,HS Link,P2P)] from the [Online] menu after selecting [Connect] from 

the [Online] menu and connecting External Device with communication setting software.

7 Select [Reset] from the [Online] menu, and reboot External Device.

Notes

• Check with a network administrator about IP address. 

Do not set the duplicate IP address.

Setup Items Setup Description

IP Address 192.168.0.1

Subnet mask 255.255.255.0

Driver XGT server
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3.6 Setting Example 6

 Settings of GP-Pro EX

  Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings]  .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

• For other series that are not listed to the left• For GP3000, LT3000, or GP-4100 Series
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Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

• Set IP address on the External Device for IP address in Device-specific settings.

• You need to set IP address on the display in the offline mode of the display.

 Settings of External Device

Use the LS Industrial Systems programming tool (XG5000) to define External Device communication settings.

Refer to your External Device manual for details.

1 Start up the configuration tool.

2 From the [Project] menu, select [New Project].

3 Configure the [PLC Series] and [CPU type], and click [OK].

4 From the tree view, double-click [Local Ethernet Parameter] and configure the Local Ethernet Parameter as fol-

lows.

5 From the [Online] menu, select [Write] .

6 Select the External Device, and click [OK].

7 Restart the External Device.

Notes

• Check with a network administrator about IP address. 

Do not set the duplicate IP address.

Setup Items Setup Description

IP Address 192.168.0.1

Subnet mask 255.255.255.0

Driver XGT server
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4 Setup Items

Set communication settings of the Display with GP-Pro EX or in offline mode of the Display.

The setting of each parameter must be identical to that of External Device.

"3 Example of Communication Setting" (page 6)

4.1 Setup Items in GP-Pro EX

 Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

• Set the Display’s IP address in offline mode.

Cf. Maintenance/Troubleshooting Manual "Ethernet Settings"

Setup Items Setup Description

Port No.
Enter a port number of the Display, using 1024 to 65535. Check into [Auto], and a port 
number is set automatically.

Timeout
Use an integer from 1 to 127 to enter the time (s) for which Display waits for the response 
from External Device.

Retry
In case of no response from the External Device, use an integer from 0 to 255 to enter how 
many times the Display retransmits the command.

Wait To Send
Use an integer from 0 to 255 to enter standby time (ms) for the Display from receiving 
packets to transmitting next commands.

• Refer to the GP-Pro EX Reference Manual for Indirect Device.

Cf. GP-Pro EX Reference Manual "Changing the Device/PLC at Runtime (Indirect 
Device)"
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 Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings]  .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

Setup Items Setup Description

Series Select the series of the External Device.

IP Address

Set IP address of the External Device.

• Check with a network administrator about IP address. Do not set the duplicate IP 
address.

Use Tag Data

To use tag data (global label), select this check box and then select the tag data. You can 
use tag data when [Series] is set to either "XGI/XGR" or "XEC". 
To create new tag data, click [New]. 
To update existing tag data, click [Edit]. 

" Tag File Importing" (page 26)

• For other series that are not listed to the left• For GP3000, LT3000, or GP-4100 Series
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4.2 Setup Items in Offline Mode

 Communication Settings

To display the setting screen, touch [Device/PLC Settings] from [Peripheral Settings] in offline mode. Touch the 

External Device you want to set from the displayed list.

• Refer to the Maintenance/Troubleshooting manual for information on how to enter offline mode or 

about the operation.

Cf. Maintenance/Troubleshooting Manual "Offline Mode"

• The number of the setup items to be displayed for 1 page in the offline mode depends on the 

Display in use. Please refer to the Reference manual for details.

Setup Items Setup Description

Port No.

Enter a port number of the Display.
Select either of "Fixed" "Auto". Enter a port number of the Display with "1024-65535", 
when select "Fixed". Assign automatically without affecting the input value, when select 
"Auto".

Timeout
Use an integer from 1 to 127 to enter the time (s) for which Display waits for the response 
from External Device.

Retry
In case of no response from the External Device, use an integer from 0 to 255 to enter how 
many times the Display retransmits the command.

Wait To Send
Use an integer from 0 to 255 to enter standby time (ms) for the Display from receiving 
packets to transmitting next commands.
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 Device Setting

To display the setting screen, touch [Device/PLC Settings] from [Peripheral Settings]. Touch the External Device 

you want to set from the displayed list, and touch [Device].

Setup Items Setup Description

Device/PLC Name
Select the External Device for device setting. Device name is a title of External Device set 
with GP-Pro EX.(Initial value [PLC1])

Series Display the series of the External Device.

IP Address

Set IP address of the External Device.

• Check with a network administrator about IP address. Do not set the duplicate IP 
address.
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5 Supported Device

Range of supported device address is shown in the table below. Please note that the actually supported range of 

the devices varies depending on the External Device to be used. Please check the actual range in the manual of 

your External Device.

5.1 XGK-CPU* / XBM / XBC

This address can be specified as system data area.        

Device Bit address Word address 32 bits Remarks

Input / Output Relay P00000 - P2047F P0000 - P2047

Auxiliary Relay M00000 - M2047F M0000 - M2047

Keep Relay K00000 - K4095F K0000 - K4095 *1

*1 If the CPU is XGK, the bit address is "K00000 - K2047F" and the word address is "K0000 - K2047".

Link Relay L000000 - L11263F L00000 - L11263

Special Relay F00000 - F2047F F0000 - F2047 *2

*2 Write disable

Timer (Contact) T0000 - T2047 -

Counter (Contact) C0000 - C2047 -

Timer (Current Value) - T0000 - T2047

Counter (Current Value) - C0000 - C2047

Data Register - D00000 - D32767  

Special Module Register - U00.00 - U7F.31  *3      

*3 The feature of U Device is like this:

Index Register - Z000 - Z127

Communication Data Register - N00000 - N21503

File Register - R00000 - R32767  *4      

*4 XBM does not support the File Register.
XBC supports only File Register R. (File Register R and ZR are the same device in the XBC.)

File Register - ZR00000 - ZR65535  *4      

• Please refer to the GP-Pro EX Reference Manual for system data area.

Cf. GP-Pro EXReference Manual "LS Area (Direct Access Method Area)"
• Please refer to the precautions on manual notation for icons in the table.

"Manual Symbols and Terminology"

U 7 F . 3 1 . F

Bit Address (h0 - hF)
Special Module Inner Word Number: word number per slot (00 - 31) 
Slot Number (h0 - hF)
Base Number (0 - 7)
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5.2 XGK-CPUSN / XGK-CPUHN / XGK-CPUUN

This address can be specified as system data area.        

Device Bit address Word address 32 bits Remarks

Input / Output Relay P00000 - P4095F P0000 - P4095

Auxiliary Relay M00000 - M4095F M0000 - M4095

Keep Relay K00000 - K4095F K0000 - K4095

Link Relay L000000 - L11263F L00000 - L11263

Special Relay F00000 - F4095F F0000 - F4095 *1

*1 Write disable

Timer (Contact) T0000 - T8191 -

Counter (Contact) C0000 - C4095 -

Timer (Current Value) - T0000 - T8191

Counter (Current Value) - C0000 - C4095

Step Controller - S000 - S255

Data Register - D000000 - D524287  *2      

*2 If the CPU is XGK-CPUSN, the word address is "D000000 - D262143".

Special Module Register - U00.00 - U7F.31  *3 *4  

*3 The feature of U Device is like this:

*4 If the CPU is XGK-CPUSN, the word address is "U00.00 - U3F.31".

Index Register - Z000 - Z255

Communication Data Register - N00000 - N21503

File Register - R00000 - R32767

File Register - ZR000000 - ZR524287

• Please refer to the GP-Pro EX Reference Manual for system data area.

Cf. GP-Pro EXReference Manual "LS Area (Direct Access Method Area)"
• Please refer to the precautions on manual notation for icons in the table.

"Manual Symbols and Terminology"

U 7 F . 3 1 . F

Bit Address (h0 - hF)
Special Module Inner Word Number: word number per slot (00 - 31) 
Slot Number (h0 - hF)
Base Number (0 - 7)
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5.3 XGI / XGR / XEC

This address can be specified as system data area.        

Device Bit address Word address 32 bits Remarks

Input Points
%IX000.00.00 - 
%IX127.15.63

%IW000.00.0 - 
%IW127.15.3

*1

*1 The feature of device is like this:

Output Points
%QX000.00.00 - 
%QX127.15.63

%QW000.00.0 - 
%QW127.15.3

*1

Automatic Variable
%AX000000 - 
%AX8388607

%AW00000 - 
%AW524287

Direct Variable

%MX000000 - 
%MX4194303

%MW000000 - 
%MW262143

%RX000000 - 
%RX524287

%RW000000 - 
%RW32767

%WX000000 - 
%WX8388607

%WW000000 - 
%WW524287

System Flag
%FX000000 - 

%FX65535
%FW000000 - 

%FW4095
*2

*2 Write disable

PID Flag
%KX000000 - 
%KX134399

%KW0000 - 
%KW8399

HS link Flag
%LX000000 - 
%LX180223

%LW00000 - 
%LW11263

Analog refresh Flag
%UX0.00.000 - 
%UX7.15.511

%UW0.00.00 - 
%UW7.15.31

*3

*3 The feature of device is like this:

P2P Parameters Flag
%NX000000 - 
%NX401407

%NW00000 - 
%NW25087

• Please refer to the GP-Pro EX Reference Manual for system data area.

Cf. GP-Pro EXReference Manual "LS Area (Direct Access Method Area)"
• Please refer to the precautions on manual notation for icons in the table.

"Manual Symbols and Terminology"

%IX 0 . 0 . 0
Module Contact Number (0 - 63)
Slot Number (0 - 15)
Base Number (0 - 127)
Device Name (X: Bit size)

%QW 0 . 0 . 0
Module Word Number (0 - 3)
Slot Number (0 - 15)
Base Number (0 - 127)
Device Name (W: 16 Bit size)

%UX 7 . 15 . 511
Channel Contact Number (0 - 511)
Slot Number (0 - 15)
Base Number (0 - 7)
Device Name (X: Bit size)

%UW 7 . 15 . 31
Channel Word Number (0 - 31)
Slot Number (0 - 15)
Base Number (0 - 7)
Device Name (W: 16 Bit size)
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5.4 XGI / XGR / XEC (Tag Specification)

This address can be specified as system data area.        

Device Variable name Bit address Word address 32 bits Remarks

BOOL

Single <TAGNAME>

%*X* - -
*1

*2

*1 <TAGNAME>: For structures, the Tag Name includes the structure name. The maximum length of the Tag               
Name is 255 characters, including delimiters and the element number.

*2 The address format is as follows: 

1D Array <TAGNAME>(xl)

2D Array <TAGNAME>(xl)(yl)

3D Array <TAGNAME>(xl)(yl)(zl)

BYTE

SINT
USINT

Single <TAGNAME>

- %*B*
*1

*21D Array <TAGNAME>(xl)

2D Array <TAGNAME>(xl)(yl)

3D Array <TAGNAME>(xl)(yl)(zl)

INT
WORD
UINT
DATE

Single <TAGNAME>

- %*W*
*1

*2
1D Array <TAGNAME>(xl)

2D Array <TAGNAME>(xl)(yl)

3D Array <TAGNAME>(xl)(yl)(zl)

DINT
DWORD

UDINT
REAL
STRING
TIME
TIME_OF_
DAY

Single <TAGNAME>

- %*D*
*1

*2

1D Array <TAGNAME>(xl)

2D Array <TAGNAME>(xl)(yl)

3D Array <TAGNAME>(xl)(yl)(zl)

LWORD
LINT
LREAL
DATE_AND_
TIME

Single <TAGNAME>

- %*L*
*1

*2
1D Array <TAGNAME>(xl)

2D Array <TAGNAME>(xl)(yl)

3D Array <TAGNAME>(xl)(yl)(zl)

• Each element of the Array variable is treated as one independent variable in GP-Pro EX. Do not 

use the Array variable as a contiguous address.

• Please refer to the GP-Pro EX Reference Manual for system data area.

Cf. GP-Pro EXReference Manual "LS Area (Direct Access Method Area)"
• Please refer to the precautions on manual notation for icons in the table.

"Manual Symbols and Terminology"

%
Address number: For the range, refer to "5.3 XGI / XGR / XEC" (page 24).
Data type: X, B, W, D, L
Device name: I, Q, A, M, R, W, F, K, L, U

***
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 Tag File Importing

1 In GP-Pro EX, open the [Individual Device Setting] dialog box, and check [Use Tag Data].

2 Click [New].
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3 Click [Import].

4 Click [Browse...] of [Select File], and select the global label file.

5 Check the tags to import, and click [OK].
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6 Check the imported tags, and click [OK].

• For details on importing tags, refer to the GP-Pro EX Reference Manual, "Using Device/PLC 

Tags".
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6 Device Code and Address Code

Use device code and address code when you select "Device Type & Address" for the address type in data displays.

6.1 XGK / XBM / XBC

• When tag data is used in XGK/XGR/XEC, device code and address code are not available.

Device Device Name
Device Code

(HEX)
Address Code

Input / Output Relay P 0080 Word Address

Auxiliary Relay M 0082 Word Address

Keep Relay K 0083 Word Address

Link Relay L 0084 Word Address

Special Relay F 0085 Word Address*1

*1 Write disable

Timer (Current Value) T 0060 Word Address

Counter (Current Value) C 0061 Word Address

Data Register D 0000 Word Address

Special Module Register U 0002 Word Address*2

*2 If the Word Address of Uxx.dd be specified indirectly, please calculate the following formula.
Word Address = [Convert 'xx' parts to the decimal value from the hexadecimal value] x 32 + [dd]
For example, 01.00 is 32, 10.00 is 512, 7F.00 is 4064.

Index Register Z 0063 Word Address

Communication Data Register N 0064 Word Address

File Register R 0001 Word Address

File Register ZR 0003 Word Address
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6.2 XGI / XGR / XEC

Device Device Name
Device Code

(HEX)
Address Code

Input Points
%IX

0080
Word Address

%IW Word Address*1

*1 If the Word Address be specified indirectly, please calculate the following formula.
Word Address = [Base Number x 64] + [Slot Number x 4] + [Module Word Number]

Output Points
%QX

0081
Word Address

%QW Word Address*1

Automatic Variable
%AX

0001
Word Address

%AW Word Address

Direct Variable

%MX
0000

Word Address

%MW Word Address

%RX
0002

Word Address

%RW Word Address

%WX
0003

Word Address

%WW Word Address

System Flag
%FX

0004
Word Address

%FW Word Address

PID Flag
%KX

0005
Word Address

%KW Word Address

HL Link Flag
%LX

0006
Word Address

%LW Word Address

Analog refresh Flag
%UX

0082
Word Address

%UW Word Address*2

*2 If the Word Address be specified indirectly, please calculate the following formula.
Word Address = [Base Number x 512] + [Slot Number x 32] + [Module Word Number]

P2P Parameters Flag
%NX

0007
Word Address

%NW Word Address
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7 Error Messages

Error messages are displayed on the screen of Display as follows: "No. : Device Name: Error Message (Error 

Occurrence Area)". Each description is shown below.

Display Examples of Error Messages

"RHAA035: PLC1: Error has been responded for device write command (Error Code: 2 [02H])"

Item Description

No. Error No.

Device Name
Name of External Device where error occurs. Device name is a title of External Device set 
with GP-Pro EX.((Initial value [PLC1])

Error Message Displays messages related to the error which occurs.

Error Occurrence Area

Displays IP address or device address of External Device where error occurs, or error codes 
received from External Device.

• IP address is displayed such as "IP address (Decimal): MAC address (Hex)".
• Device address is displayed such as "Address: Device address".
• Received error codes are displayed such as "Decimal [Hex]".

• Refer to your External Device manual for details on received error codes.

• Refer to "Display-related errors" in "Maintenance/Troubleshooting Manual" for details on the error 

messages common to the driver.
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