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Introduction

This manual describes how to connect the Display and the External Device (target PLC).

In this manual, the connection procedure is described in the sections indentified below.

1 System Configuration

This section lists the types of External 

Devices and SIO that you can connect.

"1 System Configuration" (page 3)

2 External Device Selection

Select the model (series) of the External 

Device and its connection method.

"2 External Device Selection" (page 8)

3 Communication Settings

This section describes setting examples 

for communicating between the Display 

and the External Device.

"3 Communication Settings" (page 9)

4 Setup Items

This section describes communication 

setup items on the Display.

Set the Display’s communication settings 

in GP-Pro EX or in offline mode.

"4 Setup Items" (page 43)

5 Cable Diagrams

This section describes cables and 

adapters used to connect the Display and 

the External Device.

"5 Cable Diagrams" (page 48)

Operation
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1 System Configuration

The following table lists system configurations for connecting KEYENCE Corporation External Devices and the 

Display.

Series CPU Link I/F SIO Type Setting Example Cable Diagram

KV-700
Series

KV-700
KV-L20V
KV-L21V

RS-232C
(Port 1 connection)

Setting Example 1 
(page 9)

Cable Diagram 2 
(page 50)

RS-232C
(Port 2 connection)

Setting Example 2 
(page 11)

Cable Diagram 3 
(page 52)

RS-422/485 (4wire)
(Port 2 connection)

Setting Example 3 
(page 13)

Cable Diagram 4 
(page 54)

KV-1000
Series

KV-1000
KV-L20V
KV-L21V

RS-232C
(Port 1 connection)

Setting Example 1 
(page 9)

Cable Diagram 2 
(page 50)

RS-232C
(Port 2 connection)

Setting Example 2 
(page 11)

Cable Diagram 3 
(page 52)

RS-422/485 (4wire)
(Port 2 connection)

Setting Example 3 
(page 13)

Cable Diagram 4 
(page 54)

KV-3000
Series

KV-3000
KV-L20V
KV-L21V

RS-232C
(Port 1 connection)

Setting Example 4 
(page 15)

Cable Diagram 2 
(page 50)

RS-232C
(Port 2 connection)

Setting Example 5 
(page 17)

Cable Diagram 3 
(page 52)

RS-422/485 (4wire)
(Port 2 connection)

Setting Example 6 
(page 19)

Cable Diagram 4 
(page 54)

KV-5000
Series

KV-5000
KV-L20V
KV-L21V

RS-232C
(Port 1 connection)

Setting Example 4 
(page 15)

Cable Diagram 2 
(page 50)

RS-232C
(Port 2 connection)

Setting Example 5 
(page 17)

Cable Diagram 3 
(page 52)

RS-422/485 (4wire)
(Port 2 connection)

Setting Example 6 
(page 19)

Cable Diagram 4 
(page 54)

KV-5500
Series

KV-5500
KV-L20V
KV-L21V

RS-232C
(Port 1 connection)

Setting Example 4 
(page 15)

Cable Diagram 2 
(page 50)

RS-232C
(Port 2 connection)

Setting Example 5 
(page 17)

Cable Diagram 3 
(page 52)

RS-422/485 (4wire)
(Port 2 connection)

Setting Example 6 
(page 19)

Cable Diagram 4 
(page 54)
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KV-7000
Series

KV-7300

CPU Direct*1 RS232C
Setting Example 7 
(page 21)

Cable Diagram 1 
(page 48)

KV-L20V
KV-L21V

RS232C
(Port 1 connection)

Setting Example 8 
(page 23)

Cable Diagram 2 
(page 50)

RS232C
(Port 2 connection)

Setting Example 9 
(page 25)

Cable Diagram 3 
(page 52)

RS-422/485 (4wire)
(Port 2 connection)

Setting Example 10 
(page 27)

Cable Diagram 4 
(page 54)

KV-7500
KV-L20V
KV-L21V

RS232C
(Port 1 connection)

Setting Example 8 
(page 23)

Cable Diagram 2 
(page 50)

RS232C
(Port 2 connection)

Setting Example 9 
(page 25)

Cable Diagram 3 
(page 52)

RS-422/485 (4wire)
(Port 2 connection)

Setting Example 10 
(page 27)

Cable Diagram 4 
(page 54)

KV-Nano
Series

KV-N14
KV-N24
KV-N40
KV-N60

CPU Direct *1 RS232C
Setting Example 11 
(page 29)

Cable Diagram 1 
(page 48)

KV-N10L RS232C
Setting Example 12 
(page 31)

Cable Diagram 2 
(page 50)

KV-N11L RS-422/485 (4wire)
Setting Example 13 
(page 33)

Cable Diagram 4 
(page 54)

KV-NC32T

CPU Direct *1 RS232C
Setting Example 11 
(page 29)

Cable Diagram 1 
(page 48)

KV-NC10L RS232C
Setting Example 14 
(page 35)

Cable Diagram 1 
(page 48)

KV-NC20L

RS232C
(Port 1 connection)

Setting Example 15 
(page 37)

Cable Diagram 2 
(page 50)

RS232C
(Port 2 connection)

Setting Example 16 
(page 39)

Cable Diagram 3 
(page 52)

RS-422/485 (4wire)
(Port 2 connection)

Setting Example 17 
(page 41)

Cable Diagram 4 
(page 54)

*1 Using modular connector on CPU.

Series CPU Link I/F SIO Type Setting Example Cable Diagram
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 IPC COM Port

When connecting IPC with an External Device, the COM port used depends on the series and SIO type. Please 

refer to the IPC manual for details.

Usable port

Series
Usable Port

RS-232C RS-422/485(4 wire) RS-422/485(2 wire)

PS-2000B
COM1*1 , COM2, 
COM3*1, COM4

*1 The RI/5V can be switched. Use the IPC’s switch to change if necessary.

- -

PS-3450A, PS-3451A,
PS3000-BA, PS3001-BD

COM1, COM2*1*2 COM2*1*2 COM2*1*2

PS-3650A (T41 model),
PS-3651A (T41 model)

COM1*1 - -

PS-3650A (T42 model),
PS-3651A (T42 model)

COM1*1*2, COM2 COM1*1*2 COM1*1*2

PS-3700A (Pentium®4-M)
PS-3710A

COM1*1, COM2*1, 
COM3*2 , COM4

*2 Set up the SIO type with the DIP Switch. Please set up as follows according to SIO type to be used.

COM3*2 COM3*2

PS-3711A COM1*1, COM2*2 COM2*2 COM2*2

PS4000*3 COM1, COM2 - -

PL3000
COM1*1*2, COM2*1, 
COM3, COM4

COM1*1*2 COM1*1*2

PE-4000B Atom N270 COM1, COM2 - -

PE-4000B Atom N2600 COM1, COM2
COM3*4 , COM4*4, 
COM5*4, COM6*4

COM3*4, COM4*4, 
COM5*4, COM6*4

PS5000 (Slim Panel Type 
Core i3 Model) *5 *6 COM1, COM2*4 COM2*4 COM2*4

PS5000 (Slim Panel Type 
Atom Model) 
*5 *6

COM1, COM2*7 COM2*7 COM2*7

PS5000 (Enclosed Panel 
Type)*8 COM1 - -

PS5000 (Modular Type 
PFXPU/PFXPP)*5 *6

PS5000 (Modular Type 
PFXPL2B5-6)

COM1*7 COM1*7 COM1*7

PS5000 (Modular Type 
PFXPL2B1-4)

COM1, COM2*7 COM2*7 COM2*7

PS6000 (Advanced Box)
PS6000 (Standard Box)

COM1*9 *10 *10

PS6000 (Basic Box) COM1*9 COM1*9 COM1*9
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DIP Switch settings (PL3000 / PS3000 Series)

RS-232C

*3 When making communication between an External Device and COM port on the Expansion slot,
only RS-232C is supported. However, ER (DTR/CTS) control cannot be executed because of the
specification of COM port.
For connection with External Device, use user-created cables and disable Pin Nos. 1, 4, 6 and 9.
Please refer to the IPC manual for details of pin layout.

*4 Set up the SIO type with the BIOS. Please refer to the IPC manual for details of BIOS.

*5 When setting up communication between an External Device and the RS-232C/422/485 interface
module, use the IPC (RS-232C) or PS5000 (RS-422/485) cable diagrams. However, when using
PFXZPBMPR42P2 in a RS-422/485 (4-wire) configuration with no flow control, connect 7.RTS+
and 8.CTS+, and connect 6.RTS- and 9.CTS-.
When using RS-422/485 communication with External Devices, you may need to reduce the
transmission speed and increase the TX Wait time.

*6 To use RS-422/485 communication on the RS-232C/422/485 interface module, the DIP Switch
setting is required. Please refer to "Knowledge Base" (FAQs) on the support site. (http://www.pro-
face.com/trans/en/manual/1001.html)

*7 Set up the SIO type with the DIP Switch. Please refer to the IPC manual for details of DIP Switch.
The BOX Atom has not a switch to set the RS-232C, RS-422/485 mode. Use the BIOS for the
setting.

*8 For the connection with the External Device, on the user-created cable read as if the connector on
the Display-side is a M12 A-coding 8 pin socket. The pin assignment is the same as described in
the cable diagram. For the M12 A-coding connector, use PFXZPSCNM122.

*9 In addition to COM1, you can also use the COM port on the optional interface.

*10 Install the optional interface in the expansion slot.

DIP Switch Setting Description

1 OFF*1

*1 When using PS-3450A, PS-3451A, PS3000-BA and PS3001-BD, turn ON the set value.

Reserved (always OFF)

2 OFF
SIO type: RS-232C

3 OFF

4 OFF Output mode of SD (TXD) data: Always output

5 OFF Terminal resistance (220)  insertion to SD (TXD): None

6 OFF Terminal resistance (220)  insertion to RD (RXD): None

7 OFF Short-circuit of SDA (TXA) and RDA (RXA): Not available

8 OFF Short-circuit of SDB (TXB) and RDB (RXB): Not available

9 OFF
RS (RTS) Auto control mode: Disabled

10 OFF

Settings FAQ ID

PFXZPBMPR42P2, RS422/485 change method FA263858

PFXZPBMPR42P2 termination resistor setting FA263974

PFXZPBMPR44P2, RS422/485 change method FA264087

PFXZPBMPR44P2 termination resistor setting FA264088
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RS-422/485 (4 wire)

RS-422/485 (2 wire)

DIP Switch Setting Description

1 OFF Reserved (always OFF)

2 ON
SIO type: RS-422/485

3 ON

4 OFF Output mode of SD (TXD) data: Always output

5 OFF Terminal resistance (220)  insertion to SD (TXD): None

6 OFF Terminal resistance (220)  insertion to RD (RXD): None

7 OFF Short-circuit of SDA (TXA) and RDA (RXA): Not available

8 OFF Short-circuit of SDB (TXB) and RDB (RXB): Not available

9 OFF
RS (RTS) Auto control mode: Disabled

10 OFF

DIP Switch Setting Description

1 OFF Reserved (always OFF)

2 ON
SIO type: RS-422/485

3 ON

4 OFF Output mode of SD (TXD) data: Always output

5 OFF Terminal resistance (220)  insertion to SD (TXD): None

6 OFF Terminal resistance (220)  insertion to RD (RXD): None

7 ON Short-circuit of SDA (TXA) and RDA (RXA): Available

8 ON Short-circuit of SDB (TXB) and RDB (RXB): Available

9 ON
RS (RTS) Auto control mode: Enabled

10 ON
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2 External Device Selection

Select the External Device to connect to the Display.

Setup Items Setup Description

Number of Devices/
PLCs

Enter an integer from 1 to 4 to define the number of Devices/PLCs to connect to the display.

Manufacturer Select the manufacturer of the External Device to connect. Select "KEYENCE Corporation".

Series

Select the External Device model (series) and the connection method. Select "KV MODE 
(HOST LINK) SIO".
In System configuration, make sure the External Device you are connecting is supported by 
"KV MODE (HOST LINK) SIO".

"1 System Configuration" (page 3)

Port Select the Display port to connect to the External Device.

Use System Area

Check this option to synchronize the system data area of the Display and the device (memory) 
of the External Device. When synchronized, you can use the External Device’s ladder program 
to switch the display or display the window on the Display.

Cf. GP-Pro EX Reference Manual "LS Area (Direct Access Method Area)"
This feature can also be set in GP-Pro EX or in the Display's offline mode.

Cf. GP-Pro EX Reference Manual "System Settings [Display Unit] - [System Area] 
Settings Guide"

Cf. Maintenance/Troubleshooting Guide "Main Unit - System Area Settings"
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3 Communication Settings

This section provides examples of communication settings recommended by Pro-face for the Display and the 

External Device.

3.1 Setting Example 1

 GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .
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 External Device Settings

Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 8 or later) to configure communication 

settings for the External Device.

Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].

(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L2*V" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit 

placement area.

(6) Double-click "KV-L2*V" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.

Setup Items Setup Description

Port 1

Operation Mode KV MODE (HOST LINK)

Interface RS-232C (Fixed)

Baud Rate 9600

Data Bit Length 8 bits (Fixed)

Start Bit 1 bit (Fixed)

Stop Bit 1 bit (Fixed)

Parity Even (Fixed)

Check Sum None (Fixed)

RS/CS Flow Control Disabled

Station No. Station No. 0

Detail 
Settings

Transfer Timeout (sec.) 3 (Fixed)
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3.2 Setting Example 2

 GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .
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 External Device Settings

Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 8 or later) to configure communication 

settings for the External Device.

Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].

(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L2*V" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit 

placement area.

(6) Double-click "KV-L2*V" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.

Setup Items Setup Description

Port 2

Operation Mode KV MODE (HOST LINK)

Interface RS-232C

Baud Rate 9600

Data Bit Length 8 bits (Fixed)

Start Bit 1 bit (Fixed)

Stop Bit 1 bit (Fixed)

Parity Even (Fixed)

Check Sum None (Fixed)

Station No. Station No. 0

Detail 
Settings

Transfer Timeout (sec.) 3 (Fixed)
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3.3 Setting Example 3

 GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .
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 External Device Settings

Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 8 or later) to configure communication 

settings for the External Device.

Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].

(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L2*V" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit 

placement area.

(6) Double-click "KV-L2*V" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.

Setup Items Setup Description

Port 2

Operation Mode KV MODE (HOST LINK)

Interface RS-422A/485 (4wire)

Baud Rate 9600

Data Bit Length 8 bits (Fixed)

Start Bit 1 bit (Fixed)

Stop Bit 1 bit (Fixed)

Parity Even (Fixed)

Check Sum None (Fixed)

Station No. Station No. 0

Detail 
Settings

Transfer Timeout (sec.) 3 (Fixed)
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3.4 Setting Example 4

 GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .
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 External Device Settings

Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 8 or later) to configure communication 

settings for the External Device.

Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].

(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L2*V" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit 

placement area.

(6) Double-click "KV-L2*V" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.

Setup Items Setup Description

Port 1

Operation Mode KV MODE (HOST LINK)

Interface RS-232C (Fixed)

Baud Rate 9600

Data Bit Length 8 bits (Fixed)

Start Bit 1 bit (Fixed)

Stop Bit 1 bit (Fixed)

Parity Even (Fixed)

Check Sum None (Fixed)

RS/CS Flow Control Disabled

Station No. Station No. 0

Detail 
Settings

Transfer Timeout (sec.) 3 (Fixed)
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3.5 Setting Example 5

 GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .
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 External Device Settings

Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 8 or later) to configure communication 

settings for the External Device.

Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].

(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L2*V" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit 

placement area.

(6) Double-click "KV-L2*V" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.

Setup Items Setup Description

Port 2

Operation Mode KV MODE (HOST LINK)

Interface RS-232C

Baud Rate 9600

Data Bit Length 8 bits (Fixed)

Start Bit 1 bit (Fixed)

Stop Bit 1 bit (Fixed)

Parity Even (Fixed)

Check Sum None (Fixed)

Station No. Station No. 0

Detail 
Settings

Transfer Timeout (sec.) 3 (Fixed)
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3.6 Setting Example 6

 GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .
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 External Device Settings

Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 8 or later) to configure communication 

settings for the External Device.

Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].

(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L2*V" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit 

placement area.

(6) Double-click "KV-L2*V" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.

Setup Items Setup Description

Port 2

Operation Mode KV MODE (HOST LINK)

Interface RS-422A/485 (4wire)

Baud Rate 9600

Data Bit Length 8 bits (Fixed)

Start Bit 1 bit (Fixed)

Stop Bit 1 bit (Fixed)

Parity Even (Fixed)

Check Sum None (Fixed)

Station No. Station No. 0

Detail 
Settings

Transfer Timeout (sec.) 3 (Fixed)
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3.7 Setting Example 7

 GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .



KV MODE (HOST LINK) SIO Driver

GP-Pro EX Device/PLC Connection Manual 22

 External Device Settings

Use ladder software KV STUDIO Ver. 8 or later to define the External Device communication settings. Refer to 

your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and 

click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.

(5) Select the [Setup unit (2)] tab.

(6) Configure the setup items as follows.

(7) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(8) Click [Yes].

(9) From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(10)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are 

transferred.

This completes the setting of the External Device.

Setup Items Setup Description

Built-in serial Operation Mode KV MODE (HOST LINK)
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3.8 Setting Example 8

 GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .
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 External Device Settings

Use ladder software KV STUDIO Ver. 8 or later to define the External Device communication settings. Refer to 

your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and 

click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.

(5) On the [Select unit (1)] tab, from the displayed list of units select "KV-L2*V", then drag & drop to the unit 

placement area.

(6) In the unit placement area click "KV-L2*V" and then select the [Setup unit (2)] tab.

(7) Configure the setup items as follows.

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(12)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are 

transferred.

This completes the setting of the External Device.

Setup Items Setup Description

Port 1

Operation Mode KV MODE (HOST LINK)

Interface RS-232C (Fixed)

Baud Rate 9600

Data Bit Length 8 bits (Fixed)

Start Bit 1 bits (Fixed)

Stop Bit 1 bits (Fixed)

Parity Even (Fixed)

Check Sum none (Fixed)

RS/CS Flow Control Disabled

Base Node No. 0

Detail 
Settings

Transfer timeout time 
(secs)

3 (Fixed)
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3.9 Setting Example 9

 GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .
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 External Device Settings

Use ladder software KV STUDIO Ver. 8 or later to define the External Device communication settings. Refer to 

your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and 

click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.

(5) On the [Select unit (1)] tab, from the displayed list of units select "KV-L2*V", then drag & drop to the unit 

placement area.

(6) In the unit placement area click "KV-L2*V" and then select the [Setup unit (2)] tab.

(7) Configure the setup items as follows.

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(12)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are 

transferred.

This completes the setting of the External Device.

Setup Items Setup Description

Port 2

Operation Mode KV MODE (HOST LINK)

Interface RS-232C

Baud Rate 9600

Data Bit Length 8 bits (Fixed)

Start Bit 1 bits (Fixed)

Stop Bit 1 bits (Fixed)

Parity Even (Fixed)

Check Sum none (Fixed)

Base Node No. 0

Detail 
Settings

Transfer timeout time 
(secs)

3 (Fixed)
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3.10 Setting Example 10

 GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .
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 External Device Settings

Use ladder software KV STUDIO Ver. 8 or later to define the External Device communication settings. Refer to 

your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and 

click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.

(5) On the [Select unit (1)] tab, from the displayed list of units select "KV-L2*V", then drag & drop to the unit 

placement area.

(6) In the unit placement area click "KV-L2*V" and then select the [Setup unit (2)] tab.

(7) Configure the setup items as follows.

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(12)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are 

transferred.

This completes the setting of the External Device.

Setup Items Setup Description

Port 2

Operation Mode KV MODE (HOST LINK)

Interface RS-422A/485 (4wire)

Baud Rate 9600

Data Bit Length 8 bits (Fixed)

Start Bit 1 bits (Fixed)

Stop Bit 1 bits (Fixed)

Parity Even (Fixed)

Check Sum none (Fixed)

Base Node No. 0

Detail 
Settings

Transfer timeout time 
(secs)

3 (Fixed)



KV MODE (HOST LINK) SIO Driver

GP-Pro EX Device/PLC Connection Manual 29

3.11 Setting Example 11

 GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .



KV MODE (HOST LINK) SIO Driver

GP-Pro EX Device/PLC Connection Manual 30

 External Device Settings

Use ladder software KV STUDIO Ver. 8 or later to define the External Device communication settings. Refer to 

your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and 

click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.

(5) Select the [Setup unit (2)] tab.

(6) Configure the setup items as follows.

(7) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(8) Click [Yes].

(9) From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(10)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are 

transferred.

This completes the setting of the External Device.

Setup Items Setup Description

Built-in serial Operation Mode KV MODE (HOST LINK)
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3.12 Setting Example 12

 GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .
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 External Device Settings

Use ladder software KV STUDIO Ver. 8 or later to define the External Device communication settings. Refer to 

your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and 

click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.

(5) On the [Select unit (1)] tab, from the [Extension Cassette left (Port1)] area select "KV-N10L".

(6) Configure the setup items as follows.

(7) From the [Convert] menu, select [Auto-assign relay/DM].

(8) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(9) Click [Yes].

(10)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(11)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are 

transferred.

This completes the setting of the External Device.

Setup Items Setup Description

Port 1

Operation Mode KV MODE (HOST LINK)

Interface RS-232C (Fixed)

Baud Rate 9600

Data Bit Length 8 bits (Fixed)

Start Bit 1 bits (Fixed)

Stop Bit 1 bits (Fixed)

Parity Even (Fixed)

Check Sum none (Fixed)

RS/CS Flow Control Disabled

Base Node No. 0

Detail 
Settings

Transfer timeout time 
(secs)

3 (Fixed)
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3.13 Setting Example 13

 GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .
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 External Device Settings

Use ladder software KV STUDIO Ver. 8 or later to define the External Device communication settings. Refer to 

your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and 

click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.

(5) On the [Select unit (1)] tab, from the [Extension Cassette left (Port1)] area select "KV-N11L".

(6) Configure the setup items as follows.

(7) From the [Convert] menu, select [Auto-assign relay/DM].

(8) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(9) Click [Yes].

(10)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(11)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are 

transferred.

This completes the setting of the External Device.

Setup Items Setup Description

Port 1

Operation Mode KV MODE (HOST LINK)

Interface RS-422A/485 (4wire)

Baud Rate 9600

Data Bit Length 8 bits (Fixed)

Start Bit 1 bits (Fixed)

Stop Bit 1 bits (Fixed)

Parity Even (Fixed)

Check Sum none (Fixed)

Base Node No. 0

Detail 
Settings

Transfer timeout time 
(secs)

3 (Fixed)
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3.14 Setting Example 14

 GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .
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 External Device Settings

Use ladder software KV STUDIO Ver. 8 or later to define the External Device communication settings. Refer to 

your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and 

click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.

(5) On the [Select unit (1)] tab, from the [Extension Adapter Selection] area select "KV-NC10L".

(6) Configure the [Extension Adapter (Port1)] as follows.

(7) From the [Convert] menu, select [Auto-assign relay/DM].

(8) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(9) Click [Yes].

(10)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(11)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are 

transferred.

This completes the setting of the External Device.

Setup Items Setup Description

Port 1

Operation Mode KV MODE (HOST LINK)

Interface RS-232C (Fixed)

Baud Rate 9600

Data Bit Length 8 bits (Fixed)

Start Bit 1 bits (Fixed)

Stop Bit 1 bits (Fixed)

Parity Even (Fixed)

Check Sum none (Fixed)

RS/CS Flow Control Disabled

Base Node No. 0

Detail 
Settings

Transfer timeout time 
(secs)

3 (Fixed)
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3.15 Setting Example 15

 GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .
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 External Device Settings

Use ladder software KV STUDIO Ver. 8 or later to define the External Device communication settings. Refer to 

your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and 

click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.

(5) On the [Select unit (1)] tab, from the [Extension Adapter Selection] area select "KV-NC20L".

(6) Configure the [Extension Adapter (Port1)] as follows.

(7) From the [Convert] menu, select [Auto-assign relay/DM].

(8) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(9) Click [Yes].

(10)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(11)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are 

transferred.

This completes the setting of the External Device.

Setup Items Setup Description

Port 1

Operation Mode KV MODE (HOST LINK)

Interface RS-232C (Fixed)

Baud Rate 9600

Data Bit Length 8 bits (Fixed)

Start Bit 1 bits (Fixed)

Stop Bit 1 bits (Fixed)

Parity Even (Fixed)

Check Sum none (Fixed)

RS/CS Flow Control Disabled

Base Node No. 0

Detail 
Settings

Transfer timeout time 
(secs)

3 (Fixed)
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3.16 Setting Example 16

 GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .
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 External Device Settings

Use ladder software KV STUDIO Ver. 8 or later to define the External Device communication settings. Refer to 

your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and 

click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.

(5) On the [Select unit (1)] tab, from the [Extension Adapter Selection] area select "KV-NC20L".

(6) Configure the [Extension Adapter (Port2)] as follows.

(7) From the [Convert] menu, select [Auto-assign relay/DM].

(8) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(9) Click [Yes].

(10)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(11)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are 

transferred.

This completes the setting of the External Device.

Setup Items Setup Description

Port 2

Operation Mode KV MODE (HOST LINK)

Interface RS-232C

Baud Rate 9600

Data Bit Length 8 bits (Fixed)

Start Bit 1 bits (Fixed)

Stop Bit 1 bits (Fixed)

Parity Even (Fixed)

Check Sum none (Fixed)

RS/CS Flow Control Disabled

Base Node No. 0

Detail 
Settings

Transfer timeout time 
(secs)

3 (Fixed)
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3.17 Setting Example 17

 GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .
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 External Device Settings

Use ladder software KV STUDIO Ver. 8 or later to define the External Device communication settings. Refer to 

your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and 

click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.

(5) On the [Select unit (1)] tab, from the [Extension Adapter Selection] area select "KV-NC20L".

(6) Configure the [Extension Adapter (Port2)] as follows.

(7) From the [Convert] menu, select [Auto-assign relay/DM].

(8) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(9) Click [Yes].

(10)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(11)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are 

transferred.

This completes the setting of the External Device.

Setup Items Setup Description

Port 2

Operation Mode KV MODE (HOST LINK)

Interface RS-422A/485 (4wire)

Baud Rate 9600

Data Bit Length 8 bits (Fixed)

Start Bit 1 bits (Fixed)

Stop Bit 1 bits (Fixed)

Parity Even (Fixed)

Check Sum none (Fixed)

Base Node No. 0

Detail 
Settings

Transfer timeout time 
(secs)

3 (Fixed)
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4 Setup Items

Set up the Display’s communication settings in GP-Pro EX or in the Display’s offline mode.

The setting of each parameter must match that of the External Device.

"3 Communication Settings" (page 9)

4.1 Setup Items in GP-Pro EX

 Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Setup Items Setup Description

SIO Type Select the SIO type for communicating with the External Device.

Speed Select the communication speed between the External Device and the Display.

Data Length Select a data length.

Parity Select how to check parity.

Stop Bit Select a stop bit length.

Flow Control
Select the communication control method to prevent overflow of transmission and reception 
data.

Timeout
Enter the time (s) for which the Display waits for the response from the External Device, from 
"1 to 127".

Retry
In case of no response from the External Device, enter how many times the Display retransmits 
the command, from "0 to 255".

Wait To Send
Enter the standby time (ms) from when the Display receives packets until it transmits the next 
command, from "0 to 255".
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 Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .

RI/VCC
You can switch between RI/VCC for the 9th pin when you select RS-232C for SIO type.
To connect to the IPC, switch between RI/5V using the IPC selector switch. Refer to your IPC 
manual for details.

• Refer to the GP-Pro EX Reference Manual for Indirect Device.

Cf. GP-Pro EX Reference Manual "Changing the Device/PLC at Runtime (Indirect 
Device)"

Setup Items Setup Description

Series Select the series of the External Device.

Station No Enter the station number, from "0" to "9".

Setup Items Setup Description
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4.2 Setup Items in Offline Mode

 Communication Settings

To display the setting screen, touch [Device/PLC Settings] from [Peripheral Settings] in offline mode. Touch the 

External Device you want to set from the displayed list. 

• Refer to the Maintenance/Troubleshooting guide for information on how to enter offline mode 

or about the operation.

Cf. Maintenance/Troubleshooting Guide "Offline Mode"

• The number of the setup items to be displayed for 1 page in the offline mode depends on the 

Display in use. Please refer to the Reference manual for details.

Setup Items Setup Description

SIO Type

Select the SIO type for communicating with the External Device.

In the communication settings, set [SIO Type] correctly according to the serial interface 
specifications of the Display.
If you select an SIO type that the serial interface does not support, proper operation cannot 
be guaranteed.
Refer to your Display manual for details on the serial interface specifications.

Speed Select the communication speed between the External Device and the Display.

Data Length Data length is displayed.

Parity The parity check method is displayed.
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 Device Setting

To display the setting screen, touch [Device/PLC Settings] from [Peripheral Settings]. Touch the External Device 

you want to set from the list that appears, and touch [Device].

Stop Bit Stop bit length is displayed.

Flow Control
The communication control method to prevent overflow of transmission and reception 
data.

Timeout
Enter the time (s) for which the Display waits for the response from the External Device, 
from "1 to 127".

Retry
In case of no response from the External Device, enter how many times the Display 
retransmits the command, from "0 to 255".

Wait To Send
Enter the standby time (ms) from when the Display receives packets until it transmits the 
next command, from "0 to 255".

Setup Items Setup Description

Device/PLC Name
Select the External Device to set. Device/PLC Name is the title of the External Device set 
with GP-Pro EX. (Initial value [PLC1])

Series Displays the series of the External Device.

Station No Enter the station number, from "0" to "9".

Setup Items Setup Description
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 Option

To display the setting screen, touch [Device/PLC Settings] from [Peripheral Settings]. Touch the External Device 

you want to set from the list that appears, and touch [Option].

Setup Items Setup Description

RI/VCC
You can switch between RI/VCC for the 9th pin when you select RS-232C for SIO type.
To connect to the IPC, you need to switch between RI/5V using the IPC selector switch. 
Refer to your IPC manual for details.

• GP-4100 series, GP-4*01TM, GP-Rear Module, LT-4*01TM and LT-Rear Module do not 

have the [Option] setting in the offline mode.
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5 Cable Diagrams

The cable diagrams shown below may be different from the cable diagrams recommended by KEYENCE 

Corporation. Please be assured there is no operational problem in applying the cable diagrams shown in this 

manual.

• The FG pin on the External Device must be D-class grounded. Refer to your External Device manual for 

details.

• The SG and FG are connected inside the Display. If you connect the External Device to the SG, do not form 

any short-circuit loop in the system design.

• If the communication is not stable because of noise or other factors, connect an isolation unit.

Cable Diagram 1

1A)

Display

(Connection Port)
Cable Remarks

GP4000*1 (COM1)
SP5000*2 (COM1/2)
SP-5B00 (COM1)
ST6000 (COM1)
STM6000 (COM1)
STC6000 (COM1)
ET6000 (COM1)
IPC*3

PC/AT

*1 All GP4000 models except GP-4100 Series and GP-4203T

*2 Except SP-5B00

*3 Available only with COM ports that support RS-232C.
 IPC COM Port (page 5)

1A

D-sub 9Pin by KEYENCE Corporation
OP-26486

+
Modular cable by KEYENCE Corporation

OP-26487 (2.5m)

GP-4105 (COM1)
GP-4115T (COM1) 
GP-4115T3 (COM1)

1B

User-created cable
+

D-sub 9Pin by KEYENCE Corporation
OP-26486

+
Modular cable by KEYENCE Corporation

OP-26487 (2.5m)

Display

OP-26486

D-sub 9 pin (socket)

OP-26487

Modular connector 6 pin (plug)

External Device
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1B)

OP-26486

D-sub 9 pin (socket)

OP-26487

Modular connector 6 pin (plug)

External Device
Display

Display side

Terminal block

Signal
name

RD(RXD)

SD(TXD)

ER(DTR)

SG

RS(RTS)

CS(CTS)

External Device side

D-sub 9 pin (plug)

Pin

2

3

4

5

7

8

RD(RXD)

SD(TXD)

ER(DTR)

SG

RS(RTS)

CS(CTS)

Shield

Signal
name

User-created cable
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Cable Diagram 2

2A)

Display

(Connection Port)
Cable Remarks

GP4000*1 (COM1)
SP5000*2 (COM1/2)
SP-5B00 (COM1)
ST6000 (COM1)
STM6000 (COM1)
STC6000 (COM1)
ET6000 (COM1)
IPC*3

PC/AT

*1 All GP4000 models except GP-4100 Series and GP-4203T

*2 Except SP-5B00

*3 Available only with COM ports that support RS-232C.
 IPC COM Port (page 5)

2A User-created cable 
The cable length must be 15m 
or less.

GP-4105 (COM1)
GP-4115T (COM1) 
GP-4115T3 (COM1)

2B User-created cable
The cable length must be 15m 
or less.

LT-4*01TM (COM1)
LT-Rear Module 
(COM1)

2C
RJ45 RS-232C Cable (5m) by Pro-face

PFXZLMCBRJR21
The cable length must be 5m or 
less.

Display

Dsub 9 pin (socket) Shield
External Device side

Dsub 9 pin (socket)

Pin

2

3

4

5

8

Shell

Signal name

RD(RXD)

SD(TXD)

ER(DTR)

SG

CS(CTS)

FG

Pin

2

3

5

7

8

Signal name

SG

Display side

RD(RXD)

SD(TXD)

RS(RTS)

CS(CTS)
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2B)

2C)

Legend Name Note

(1)
RJ45 RS-232C Cable (5m) by Pro-face

PFXZLMCBRJR21

Display

Shield
External Device side

Dsub 9 pin (socket)

Signal name

RD(RXD)

SD(TXD)

ER(DTR)

SG

CS(CTS)

Pin

2

3

5

7

8

Signal name

SG

RD(RXD)

SD(TXD)

RS(RTS)

CS(CTS)

 Terminal block

Display side

Display

External Device side

Dsub 9 pin (socket)

Pin

2

3

5

7

8

Signal name

SG

RD(RXD)

SD(TXD)

RS(RTS)

CS(CTS)

GND

RXD

TXD

(1)
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Cable Diagram 3

3A)

Display

(Connection Port)
Cable Remarks

GP4000*1 (COM1)
SP5000*2 (COM1/2)
SP-5B00 (COM1)
ST6000 (COM1)
STM6000 (COM1)
STC6000 (COM1)
ET6000 (COM1)
IPC*3

PC/AT

*1 All GP4000 models except GP-4100 Series and GP-4203T

*2 Except SP-5B00

*3 Available only with COM ports that support RS-232C.
 IPC COM Port (page 5)

3A User-created cable 
The cable length must be 15m 
or less.

GP-4105 (COM1)
GP-4115T (COM1) 
GP-4115T3 (COM1)

3B User-created cable
The cable length must be 15m 
or less.

LT-4*01TM (COM1)
LT-Rear Module 
(COM1)

3C
RJ45 RS-232C Cable (5m) by Pro-face

PFXZLMCBRJR21
The cable length must be 5m or 
less.

• Set the PORT2 toggle switch on the External Device to "232C".

Signal name

SG

FG

Pin

2

3

4

5

8

Shell

Display

ShieldDsub 9 pin (socket)
External Device side

 Terminal block

Pin

1

3

5

Signal name

SG

Display side

RD(RXD)

SD(TXD)

ER(DTR)

CS(CTS)

SD(TXD)

RD(RXD)
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3B)

3C)

Legend Name Note

(1)
RJ45 RS-232C Cable (5m) by Pro-face

PFXZLMCBRJR21

Signal name

SG

Display

Shield
External Device side

 Terminal block

Pin

1

3

5

Signal name

SGRD(RXD)

SD(TXD)

ER(DTR)

CS(CTS)

SD(TXD)

RD(RXD)

 Terminal block

Display side

Display

External Device side

 Terminal block

Pin

1

3

5

Signal name

SG

SD(TXD)

RD(RXD)
TXD

RXD

GND

(1)
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Cable Diagram 4

Display

(Connection Port)
Cable Remarks

GP-4*01TM (COM1)
GP-Rear Module 
(COM1)
IPC*1

*1 Available only with COM ports that support RS-422/485 (4wire).  (Except PE-4000B, PS5000, and PS6000)
 IPC COM Port (page 5)

4A

COM port conversion adapter by Pro-face
CA3-ADPCOM-01

+
Connector terminal block conversion adapter by Pro-face

CA3-ADPTRM-01
+

User-created cable 

The cable length 
must be 1000m or 
less.

4B User-created cable 

GP-4106 (COM1)
GP-4116T (COM1)

4C User-created cable
The cable length 
must be 1000m or 
less.

GP4000*2 (COM2)
GP-4201T (COM1)
SP5000*3 (COM1/2)
SP-5B00 (COM2)
ST6000*4 (COM2)
ST-6200 (COM1)
STM6000 (COM1)
STC6000 (COM1)
ET6000*5 (COM2)
PS6000 (Basic Box) 
(COM1/2)

*2 All GP4000 models except GP-4100 Series, GP-4*01TM, GP-Rear Module, GP-4201T and GP-4*03T

*3 Except SP-5B00

*4 Except ST-6200

*5 Due to the COM port specifications, flow control is not possible. Omit wiring the control pins on the Display
side of the cable diagram.

4D

RS-422 Terminal Block Conversion Adapter by Pro-face
PFXZCBADTM1*6

+
User-created cable

*6 When using a Terminal Block Conversion Adapter (CA3-ADPTRM-01) instead of the RS-422 Terminal Block
Conversion Adapter, refer to Cable Diagram 4A.

The cable length 
must be 1000m or 
less.

4B User-created cable

PE-4000B*7

PS5000*7

PS6000 (Optional 
Interface)*7

*7 Available only with COM ports that support RS-422/485 (4wire).
 IPC COM Port (page 5)

4E User-created cable 
The cable length 
must be 1000m or 
less.
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4A)

• Terminal number to be used for communication varies depending on the External 
Device. Terminal numbers corresponding to each series are shown below.

• Set the PORT2 toggle switch on the External Device to "422A 485(4)". Also, turn ON the 

switch of the terminator.

• Pay attention that pole A and pole B are reversely named for the Display and the External 

Device.

Pin
KV-L20V

KV-L21V

KV-N11L

KV-NC20L

SDB(+) 5 2

SDA(-) 3 1

RDB(+) 4 4

RDA(-) 2 3

SG 1 5

Signal name

RDA

RDB

SDA

SDB

SG

FG

TERMRX

Display CA3-ADPCOM-01

CA3-ADPTRM-01

Shield

External Device side

   Terminal block

Signal name

SDB(+)

SDA(-)

RDB(+)

RDA(-)

SG

Pin

5

3

4

2

1

User-created cable

  Display side 

Terminal block
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4B)

Signal name

RDA

RDB

SDA

SDB

SG

ERA

CSA

ERB

CSB

FG

Pin

1

2

3

7

5

4

8

9

6

Shell

Pin

5

3

4

2

1

Signal name

SDB(+)

SDA(-)

RDB(+)

RDA(-)

SG

Display

Shield

External Device side

  Terminal blockD-Sub 9 pin (socket)

Display side
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4C)

*1 The resistance in the Display is used as the termination resistance. Set the value of the DIP Switch on the 
rear of the Display as shown in the table below.  

4D)

DIP Switch No. Set Value

1 OFF

2 ON

3 OFF

4 ON

Signal name

RDA

RDB

SDA

SDB

SG

ERA

CSA

ERB

CSB

Pin

5

3

4

2

1

Signal name

SDB(+)

SDA(-)

RDB(+)

RDA(-)

SG

Display

Shield
External Device side

  Terminal block Terminal block

Display side

*1

*1

Signal name

RDA

RDB

SDA

SDB

SG

FG

TERMRX

Display

PFXZCBADTM1

Shield

External Device side

   Terminal block

Signal name

SDB(+)

SDA(-)

RDB(+)

RDA(-)

SG

Pin

5

3

4

2

1

User-created cable

  Display side 

Terminal block
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4E)

Signal name

Rx+

Rx-

Tx+

Tx-

GND

NC

NC

NC

NC

FG

Pin

3

4

2

1

5

7

8

9

6

Shell

Pin

5

3

4

2

1

Signal name

SDB(+)

SDA(-)

RDB(+)

RDA(-)

SG

Display

Shield

External Device side

  Terminal blockD-Sub 9 pin (socket)

Display side



KV MODE (HOST LINK) SIO Driver

GP-Pro EX Device/PLC Connection Manual 59

6 Supported Device

The range of supported device addresses is shown in the table below. Please note that the actual supported range 

for devices varies depending on the external device that is used. Please check the actual range in the external 

device manual.

6.1 KV-700 Series

: This address can be specified as system data area.

Device Bit Address Word Address 32 bits Remarks

Input Relay

00000 - 59915 000 - 599Output Relay

Internal Auxiliary Relay

Control Relay CR0000 - CR3915 CR00 - CR39

Timer (Contact) T000 - T511 ------

-
Counter (Contact) C000 - C511 ------

High-speed Counter 
Comparator (Contact)

CTC0 - CTC3 ------ *1

*1 Write disable

Timer (Setting Value) ------ TS000 - TS511 *2

*2 32-bit device

Counter (Setting Value) ------ CS000 - CS511 *2

Timer (Current Value) ------ TC000 - TC511 *2

Counter (Current Value) ------ CC000 - CC511 *2

Data Memory ------ DM00000 - DM39999

Temporary Data Memory ------ TM000 - TM511

Control Memory ------ CM0000 - CM3999

Digital Trimmer ------ TRM0 - TRM7 *2

High-speed Counter 
(Current Value)

------ CTH0 - CTH1 *2

High-speed Counter 
Comparator (Setting Value)

------ CTC0 - CTC3 *2

• When connecting KV-700 Series, use settings within the device address ranges above.

• If you try to access device addresses supported only by the KV-1000 Series devices, the following 

error messages display: "Error has been responded for device read command (Error 

Code(14)[(0x0E)]" or "Error has been responded for device write command (Error 

Code(14)[(0x0E)]".
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• Refer to the GP-Pro EX Reference Manual for system data area.

Cf. GP-Pro EXReference Manual "LS Area (Direct Access Method Area)"

• Refer to the precautions on manual notation for icons in the table.

"Manual Symbols and Terminology"



KV MODE (HOST LINK) SIO Driver

GP-Pro EX Device/PLC Connection Manual 61

6.2 KV-1000 Series

 : This address can be specified as system data area.

Device Bit Address Word Address 32 bits Remarks

Input Relay

00000 - 59915 000 - 599

*1

*1 R000 to R599 (R00000 to R59915) are shown in KV-1000, but 000 to 599 (00000 to 59915) in GP-Pro EX.

Output Relay *1

Internal Auxiliary Relay *1

Internal Auxiliary Relay MR00000 - MR99915 MR000 - MR999

Latch Relay LR00000 - LR99915 LR000 - LR999

Control Relay CR0000 - CR3915 CR00 - CR39

Timer (Contact) T0000 - T3999 ------

-
Counter (Contact) C0000 - C3999 ------

High-speed Counter 
Comparator (Contact)

CTC0 - CTC3 ------ *2

*2 Write disable

Timer (Setting Value) ------ TS0000 - TS3999 *3

*3 32-bit device

Counter (Setting Value) ------ CS0000 - CS3999 *3

Timer (Current Value) ------ TC0000 - TC3999 *3

Counter (Current Value) ------ CC0000 - CC3999 *3

Data Memory ------ DM00000 - DM65534

Extension Data Memory EM ------ EM00000 - EM65534

Extension Data Memory FM ------ FM00000 - FM32766

Temporary Data Memory ------ TM000 - TM511

Control Memory ------ CM00000 - CM11998

Index Register ------ Z01 - Z12 *4

*4 Do not write to the addresses Z11 and Z12. They are used in the system of the External Device.

Digital Trimmer ------ TRM0 - TRM7 *3

High-speed Counter 
(Current Value)

------ CTH0 - CTH1 *3

High-speed Counter 
Comparator (Setting Value)

------ CTC0 - CTC3 *3
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• Refer to the GP-Pro EX Reference Manual for system data area.

Cf. GP-Pro EX Reference Manual "LS Area (Direct Access Method Area)"

• Refer to the precautions on manual notation for icons in the table.

"Manual Symbols and Terminology"
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6.3 KV-3000/5000/5500 Series

 : This address can be specified as system data area.

Device Bit Address Word Address 32 bits Remarks

Input Relay

R00000 - R99915 R000 - R999Output Relay

Internal Auxiliary Relay

Link Relay B0000 - B3FFF B000 - B3FF

Internal Auxiliary Relay MR00000 - MR99915 MR000 - MR999

Latch Relay LR00000 - LR99915 LR000 - LR999

Control Relay CR0000 - CR3915 CR00 - CR39

Work Relay VB0000 - VB3FFF VB000 - VB3FF

Timer (Contact) T0000 - T3999 ------

-
Counter (Contact) C0000 - C3999 ------

High-speed Counter 
Comparator (Contact)

CTC0 - CTC3 ------ *1

*1 Write disable

Timer (Setting Value) ------ TS0000 - TS3999 *2

Counter (Setting Value) ------ CS0000 - CS3999 *2

Timer (Current Value) ------ TC0000 - TC3999 *2

Counter (Current Value) ------ CC0000 - CC3999 *2

Data Memory ------ DM00000 - DM65534

Extension Data Memory ------ EM00000 - EM65534

File 
Register

Current Bank ------ FM00000 - FM32767

Serial Number 
System

------ ZF000000 - ZF131071

Temporary Data Memory ------ TM000 - TM511

Control Memory ------ CM00000 - CM05999

Link Register ------ W0000 - W3FFF

Work Memory ------ VM00000 - VM59999

Index Register ------ Z01 - Z12 *2 *3

Digital Trimmer ------ TRM0 - TRM7 *2

High-speed Counter (Current 
Value)

------ CTH0 - CTH1 *2

High-speed Counter 
Comparator (Setting Value)

------ CTC0 - CTC3 *2
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*2 32-bit device

*3 Do not write to the addresses Z11 and Z12. They are used in the system of the External Device.

• Refer to the GP-Pro EX Reference Manual for system data area.

Cf. GP-Pro EX Reference Manual "LS Area (Direct Access Method Area)"

• Refer to the precautions on manual notation for icons in the table.

"Manual Symbols and Terminology"
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6.4 KV-7000 Series

 : This address can be specified as system data area.

Device Bit Address Word Address 32 bits Remarks

Input Relay

R000000 - R199915 R0000 - R1999

*1

*1 When using KV-L20V and KV-L21V, the bit address range is R000000-R99915 and the word address range is
R000-R999.

Output Relay *1

Internal Auxiliary Relay *1

Link Relay B0000 - B7FFF B000 - B7FF

Internal Auxiliary Relay MR000000 - MR399915 MR0000 - MR3999 *2

*2 When using KV-L20V and KV-L21V, the bit address range is MR000000-MR99915 and the word address
range is MR000-MR999.

Latch Relay LR00000 - LR99915 LR000 - LR999

Control Relay CR0000 - CR7915 CR00 - CR79

Work Relay VB0000 - VBF9FF VB000 - VBF9F

Timer (Contact) T0000 - T3999 ------
-

Counter (Contact) C0000 - C3999 ------

Timer (Setting Value) ------ TS0000 - TS3999 *3

*3 32-bit device

Counter (Setting Value) ------ CS0000 - CS3999 *3

Timer (Current Value) ------ TC0000 - TC3999 *3

Counter (Current Value) ------ CC0000 - CC3999 *3

Data Memory ------ DM00000 - DM65534

Extension Data Memory ------ EM00000 - EM65534

File 
Register

Current Bank ------ FM00000 - FM32767

Serial Number 
System

------ ZF000000 - ZF524287

Temporary Data Memory ------ TM000 - TM511

Control Memory ------ CM0000 - CM5999

Link Register ------ W0000 - W7FFF

Work Memory ------ VM00000 - VM50999

Index Register ------ Z01 - Z12 *3*4

*4 Do not write to the addresses Z11 and Z12. They are used in the system of the External Device.

Digital Trimmer ------ TRM0 - TRM7 *3*5

*5 Write disable
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• Refer to the GP-Pro EX Reference Manual for system data area.

Cf. GP-Pro EX Reference Manual "LS Area (Direct Access Method Area)"

• Refer to the precautions on manual notation for icons in the table.

"Manual Symbols and Terminology"
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6.5 KV-Nano Series

 : This address can be specified as system data area.

Device Bit Address Word Address 32 bits Remarks

Input Relay

R00000 - R59915 R000 - R599Output Relay

Internal Auxiliary Relay

Link Relay B0000 - B1FFF B000 - B1FF

Internal Auxiliary Relay MR00000 - MR59915 MR000 - MR599

Latch Relay LR00000 - LR19915 LR000 - LR199

Control Relay CR0000 - CR8915 CR00 - CR89

Work Relay VB0000 - VB1FFF VB000 - VB1FF

Timer (Contact) T000 - T511 ------

-
Counter (Contact) C000 - C255 ------

High-speed Counter 
Comparator (Contact)

CTC0 - CTC7 ------ *1

*1 Write disable

Timer (Setting Value) ------ TS000 - TS511 *2

*2 32-bit device

Counter (Setting Value) ------ CS000 - CS255 *2

Timer (Current Value) ------ TC000 - TC511 *2

Counter (Current Value) ------ CC000 - CC255 *2

Data Memory ------ DM00000 - DM32767

Temporary Data Memory ------ TM000 - TM511

Control Memory ------ CM0000 - CM8999

Link Register ------ W0000 - W3FFF

Work Memory ------ VM0000 - VM9499

Index Register ------ Z01 - Z12 *2*3

*3 Do not write to the addresses Z11 and Z12. They are used in the system of the External Device.

High-speed Counter (Current 
Value)

------ CTH0 - CTH3 *2*4

*4 In the case of KV-NC32T, the maximum value of the address is CTH2. Reading of CTH3 is not a read error,
but the value will be 0. If the written, it will write error.

High-speed Counter 
Comparator (Setting Value)

------ CTC0 - CTC7 *2*5

*5 In the case of KV-NC32T, the maximum value of the address is CTC5. Reading of CTC6 and CTC7 is not a
read error, but the value will be 0. If the written, it will write error.
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• Refer to the GP-Pro EX Reference Manual for system data area.

Cf. GP-Pro EX Reference Manual "LS Area (Direct Access Method Area)"

• Refer to the precautions on manual notation for icons in the table.

"Manual Symbols and Terminology"
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7 Device Code and Address Code

Use device code and address code if you select "Device Type & Address" for the address type in Data displays.

7.1 KV-700 Series

Device Device Name
Device Code

(HEX)
Address Code

Input Relay

------ 0080 Word AddressOutput Relay

Internal Auxiliary Relay

Control Relay CR 008A Word Address

Timer (Setting Value) TS 0062 Double Word Address

Counter (Setting Value) CS 0063 Double Word Address

Timer (Current Value) TC 0060 Double Word Address

Counter (Current Value) CC 0061 Double Word Address

Data Memory DM 0000 Word Address

Temporary Data Memory TM 0001 Word Address

Control Memory CM 0002 Word Address

Digital Trimmer TRM 0064 Double Word Address

High-speed Counter (Current Value) CTH 0065 Double Word Address

High-speed Counter Comparator 
(Setting Value)

CTC 0066 Double Word Address
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7.2 KV-1000 Series

Device Device Name
Device Code

(HEX)
Address Code

Input Relay

------ 0080 Word AddressOutput Relay

Internal Auxiliary Relay

Internal Auxiliary Relay MR 0082 Word Address

Latch Relay LR 0084 Word Address

Control Relay CR 008A Word Address

Timer (Setting Value) TS 0062 Double Word Address

Counter (Setting Value) CS 0063 Double Word Address

Timer (Current Value) TC 0060 Double Word Address

Counter (Current Value) CC 0061 Double Word Address

Data Memory DM 0000 Word Address

Extension Data Memory EM 0010 Word Address

Extension Data Memory FM 0011 Word Address

Temporary Data Memory TM 0001 Word Address

Control Memory CM 0002 Word Address

Index Register Z 0003 Word Address *1

*1 The "Z" device code on the KV-1000 is different from other series. If you change the external device series in
the editor software, the device code also changes automatically.

Digital Trimmer TRM 0064 Double Word Address

High-speed Counter (Current Value) CTH 0065 Double Word Address

High-speed Counter Comparator 
(Setting Value)

CTC 0066 Double Word Address



KV MODE (HOST LINK) SIO Driver

GP-Pro EX Device/PLC Connection Manual 71

7.3 KV-3000/5000/5500 Series

Device Device Name
Device Code

(HEX)
Address Code

Input Relay

R 0080 Word AddressOutput Relay

Internal Auxiliary Relay

Link Relay B 008B Word Address

Internal Auxiliary Relay MR 0082 Word Address

Latch Relay LR 0084 Word Address

Control Relay CR 008A Word Address

Work Relay VB 008C Word Address

Timer (Setting Value) TS 0062 Double Word Address

Counter (Setting Value) CS 0063 Double Word Address

Timer (Current Value) TC 0060 Double Word Address

Counter (Current Value) CC 0061 Double Word Address

Data Memory DM 0000 Word Address

Extension Data Memory EM 0010 Word Address

File Register

Current Bank FM 0011 Word Address

Serial Number 
System

ZF 0012 Word Address

Temporary Data Memory TM 0001 Word Address

Control Memory CM 0002 Word Address

Link Register W 0013 Word Address

Work Memory VM 0014 Word Address

Index Register Z 0067 Double Word Address

Digital Trimmer TRM 0064 Double Word Address

High-speed Counter (Current Value) CTH 0065 Double Word Address

High-speed Counter Comparator 
(Setting Value)

CTC 0066 Double Word Address
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7.4 KV-7000 Series

Device Device Name
Device Code

(HEX)
Address Code

Input Relay

R 0080 Word AddressOutput Relay

Internal Auxiliary Relay

Link Relay B 008B Word Address

Internal Auxiliary Relay MR 0082 Word Address

Latch Relay LR 0084 Word Address

Control Relay CR 008A Word Address

Work Relay VB 008C Word Address

Timer (Setting Value) TS 0062 Double Word Address

Counter (Setting Value) CS 0063 Double Word Address

Timer (Current Value) TC 0060 Double Word Address

Counter (Current Value) CC 0061 Double Word Address

Data Memory DM 0000 Word Address

Extension Data Memory EM 0010 Word Address

File Register

Current Bank FM 0011 Word Address

Serial Number 
System

ZF 0012 Word Address

Temporary Data Memory TM 0001 Word Address

Control Memory CM 0002 Word Address

Link Register W 0013 Word Address

Work Memory VM 0014 Word Address

Index Register Z 0067 Double Word Address

Digital Trimmer TRM 0064 Double Word Address
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7.5 KV-Nano Series

Device Device Name
Device Code

(HEX)
Address Code

Input Relay

R 0080 Word AddressOutput Relay

Internal Auxiliary Relay

Link Relay B 008B Word Address

Internal Auxiliary Relay MR 0082 Word Address

Latch Relay LR 0084 Word Address

Control Relay CR 008A Word Address

Work Relay VB 008C Word Address

Timer (Setting Value) TS 0062 Double Word Address

Counter (Setting Value) CS 0063 Double Word Address

Timer (Current Value) TC 0060 Double Word Address

Counter (Current Value) CC 0061 Double Word Address

Data Memory DM 0000 Word Address

Temporary Data Memory TM 0001 Word Address

Control Memory CM 0002 Word Address

Link Register W 0013 Word Address

Work Memory VM 0014 Word Address

Index Register Z 0067 Double Word Address

High-speed Counter (Current Value) CTH 0065 Double Word Address

High-speed Counter Comparator 
(Setting Value)

CTC 0066 Double Word Address
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8 Error Messages

Error messages are displayed on the Display screen as follows: "No.: Device Name: Error Message (Error 

Occurrence Area)". Each description is shown below.

Display Examples of Error Messages

"RHAA035: PLC1: Error has been responded for device write command (Error Code: 1 [01H])"

Error Codes Specific to the External Device

Item Description

No. Error No.

Device Name
Name of the External Device where an error has occurred. Device name is a title of the 
External Device set with GP-Pro EX. (Initial value [PLC1])

Error Message Displays messages related to an error that has occurred.

Error Occurrence Area

Displays the IP address or device address of the External Device where an error has 
occurred, or error codes received from the External Device.

• IP address is displayed as "IP address (Decimal): MAC address (Hex)".
• Device address is displayed as "Address: Device address".
• Received error codes are displayed as "Decimal [Hex]".

• Refer to your External Device manual for details on received error codes.

• Refer to "Display-related errors" in "Maintenance/Troubleshooting Manual" for details on the 

error messages common to the driver.

Error 

Code
Error Description Cause

E0 Device number error

• The specified External Device number, bank number, unit number, or 
address is out of range.

• Specified a timer, counter, high-speed counter (current value), or 
high-speed counter comparator (setting value) number that is not used 
in the program.

• An attempt was made to read an unregistered Display.

E1 Command error

• Sent a command that is not supported by the CPU unit.
• The command specification format is incorrect.
• Before communication was established, sent a command but it was 

not the CR command.

E2 No program registered

• The “M1 (Switch to RUN mode)” command was sent without the 
program registered in the CPU unit.

• The “M1 (Switch to RUN mode)” command was sent with the RUN / 
PROG switch on the CPU unit set to PROG.

E4 Write protected
• In a write-protected program, an attempt was made to change the 

setting value of timer, counter, or high-speed counter comparator 
(setting value).
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E5 Main unit error
• The “M1 (Switch to RUN mode)” command was sent without first 

clearing the CPU module error.

E6 No comment
• No comment is registered to the External Device specified by the 

“RDC (Read Comment)” command.

Error 

Code
Error Description Cause
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