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KV-700 - 8000 SIO Driver

Introduction
This manual describes how to connect the Display and the External Device (target PLC).

In this manual, the connection procedure is described in the sections indentified below.

1 System Configuration
This section lists the types of External
Devices and SIO that you can connect.

& System Configuration” (page 3)

<

2 External Device Selection
Select the model (series) of the External
Device and its connection method.

&~ "2 External Device Selection” (page 11)

<=

3 || Communication Settings
This section describes setting examples
for communicating between the Display
and the External Device.

&~ "3 Communication Settings" (page 12)

<

4 || Setup ltems

This section describes communication
setup items on the Display.

Set the Display’s communication settings
in GP-Pro EX or in offline mode.

&y Setup Items" (page 81)

5 || Cable Diagrams

This section describes cables and
adapters used to connect the Display and
the External Device.

&~ "5 Cable Diagrams" (page 86)

Operation
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KV-700 - 8000 SIO Driver

1 System Configuration

The following table lists system configurations for connecting KEYENCE Corporation External Devices and the

Display.
) ) Setting Cable
Series CPU Link I/F SIO Type )
Example Diagram
Setting Cable
CPU Direct”! RS-232C Example 1 Diagram 1
(page 12) (page 86)
Setting Cable
RS-232C . Example 2 Diagram 2
(Port 1 connection) (page 14) (page 88)
Setting Cable
KV-L20 RS-232C . Example 4 Diagram 3
(Port 2 connection) (page 18) (page 90)
. Settin Cable
RS-422/485 (4wire) Examﬁle 6 | Dingram 4
(Port 2 connection) (page 22) (page 92)
Setting Cable
RS-232C . Example 3 Diagram 2
(Port 1 connection)
KV-700 (page 16) (page 88)
Series Kv=700 Setti Cabl
etting able
KV-L20R RS-232C . Example 5 Diagram 3
(Port 2 connection) (page 20) (page 90)
. Settin Cable
RS-422/485 (4wire) Examﬁle 7 Diagram 4
(Port 2 connection) (page 24) (page 92)
Setting Cable
RS-232C . Example 8 Diagram 2
(Port 1 connection) (page 26) (page 88)
Setting Cable
KV-L20V™*2 RS-232C . Example 9 Diagram 3
(Port 2 connection) (page 28) (page 90)
. Setting Cable
RS-422/485 (4ere) Example 10 | Diagram 4
(Port 2 connection) (page 30) (page 92)

GP-Pro EX Device/PLC Connection Manual 3



KV-700 - 8000 SIO Driver

) ) Setting Cable
Series CPU Link I/F SIO Type .
Example Diagram
Setting Cable
CPU Direct”! RS-232C Example 1 Diagram 1
(page 12) (page 86)
RS-232C Setting Cable

Example 3 Diagram 2

(Port 1 connection) (page 16) (page 88)

Setting Cable
KV-L20R E’So_rzt?cconnection) Example 5 Diagram 3
(page 20) (page 90)
. Setting Cable
KV-1000 -
Seri KV-1000 ésorizzzéiiiéjt\;vc:;e)) Example 7 Diagram 4
eries (page 24) (page 92)
RS-232C Setting Cable

Example 8 Diagram 2
(page 26) (page 88)
Setting Cable

(Port 1 connection)

KV-L20V ™2 és()_rztz2§()nnecti0n) Example 9 Diagram 3
(page 28) (page 90)
RS-422/485 (4wire) | Scting Cable
(Port 2 connection) Example 10 | Diagram 4
(page 30) (page 92)
Setting Cable
CPU Direct”! RS-232C Example 11 | Diagram 1
(page 32) (page 86)
RS-232C Setting Ce.lble
(Port 1 connection) Example 12 | Diagram 2
KV-3000 (page 33) (page 88)
. KV-3000
Series RS.239C Setting Cable
KV-L20V*2 (Port 2 connection) Example 13 | Diagram 3
(page 35) (page 90)
RS-422/485 (4wire) | oiung Cable
(Port 2 connection) Example 14 | Diagram 4
(page 37) (page 92)
RS-232C Setting Ce.lble
(Port 1 connection) Example 12 | Diagram 2
ort 1 connectio (page 33) (page 88)
Setting Cable
KV-5000 KV-5000 KV-L20V*2 RS-232C . Example 13 | Diagram 3
Series (Port 2 connection)

(page 35) (page 90)

Setting Cable
Example 14 | Diagram 4

(page 37) (page 92)

RS-422/485 (4wire)
(Port 2 connection)
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KV-700 - 8000 SIO Driver

) ) Setting Cable
Series CPU Link I/F SIO Type .
Example Diagram
RS-232C Setting Cable

Example 15 | Diagram 2
(page 39) (page 88)
Setting Cable

(Port 1 connection)

KV-5500 KV-5500 KV-L20V"3 RS-232C . Example 16 | Diagram 3
Series (Port 2 connection)
(page 41) (page 90)
RS-422/485 (4wire) | ciuing Cable
(Port 2 connection) Example 17 | Diagram 4
(page 43) (page 92)
Setting Cable Dia-
CPU Direc ! RS232C Example 19 | gram 1 (page
(page 47) 86)
RS232C Setting Ca_tble
(Port 1 connection) Example 20 | Diagram 2
(page 49) (page 88)
Setting Cable
KV-L20V és()zrtg)gionnection) Example 21 | Diagram 3
(page 51) (page 90)
RS-422/485 (4wire) | Scting Cable
. Example 22 | Diagram 4
(Port 2 connection) (page 53) (page 92)
KV-7000 KV-7300™

Series i
RS232C Setting Ca_lble
(Port 1 connection) Example 20 | Diagram 2
(page 49) (page 88)

Setting Cable
Example 21 | Diagram 3

(page 51) (page 90)

Setting Cable
Example 22 | Diagram 4

(page 53) (page 92)

Setting Cable
Example 23 | Diagram 5

(page 55) (page 98)

RS232C
(Port 2 connection)

KV-L21V

RS-422/485 (4wire)
(Port 2 connection)

RS-422/485 (2wire)
(Port 2 connection)

(@) |
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KV-700 - 8000 SIO Driver

) ) Setting Cable
Series CPU Link I/F SIO Type E | 5
xample iagram
Setting Cable
g’sozrsfcconnec tion) Example 20 | Diagram 2
(page 49) (page 88)
Setting Cable
KV-L20V g’sozfgcc‘:onnection) Example 21 | Diagram 3
(page 51) (page 90)
RS-422/485 (4wire) | SorINe Cable
(Port 2 connection) Example 22 | Diagram 4
(page 53) (page 92)
Setting Cable
g\e/;rezoo KV-7500"4 ésozjicconnection) Example 20 | Diagram 2
(page 49) (page 88)
Setting Cable
RS232C . Example 21 | Diagram 3
(Port 2 connection) (page 51) (page 90)
KV-L21V
RS-422/485 (4wire) | ctuing Cable
(Port 2 connection) Example 22 | Diagram 4
(page 53) (page 92)
RS-422/485 (2wire) | Soting Cable
(Port 2 connection) Example 23 | Diagram 5
(page 55) (page 98)
KV-N14 Setting Cable
KV-N24 CPU Direc 1" | RS232C Example 18 | Diagram 1
KV-N40 (page 45) (page 86)
Setting Cable
CPU Direc " RS232C Example 18 | Diagram 1
(page 45) (page 86)
Setting Cable Dia-
KV-.N ano KV-N10L RS232C Example 24 | gram 2 (page
Series (page 57) $8)
KV-N60"
Setting Cable Dia-
RS-422/485 (4wire) Example 25 | gram 4 (page
(page 59) 92)
KV-N11L
Setting Cable
RS-422/485 (2wire) Example 26 | Diagram 5
(page 61) (page 98)
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KV-700 - 8000 SIO Driver

) ) Setting Cable
Series CPU Link I/F SIO Type .
Example Diagram
Setting Cable
CPU Direc ! RS232C Example 18 | Diagram 1
(page 45) (page 86)
Setting Cable Dia-
KV-NC10L RS232C Example 27 | gram 2 (page
(page 63) 88)
RS232C Setting Cable

Example 28 | Diagram 2
2 . age 65 age 88

KV-Nano KV-NC32T 6 (page 65) (page 88)

Series Setting Cable

ésoigcconnection) Example 29 | Diagram 3
(page 67) (page 90)

(Port 1 connection)

KV-NC20L
. Setting Cable
RS-422/485 (4ere) Example 30 | Diagram 4
(Port 2 connection) (page 69) (page 92)
. Setting Cable
RS-422/485 (ZWIre) Example 31 | Diagram 5
(Port 2 connection) (page 71) (page 98)
Setting Cable
RS232€ . Example 32 | Diagram 2
(Port 1 connection) (page 73) (page 88)
Setting Cable
KV-L20V RS232C . Example 33 | Diagram 3
(Port 2 connection) (page 75) (page 90)
. Setting Cable
RS-422/485 (4ere) Example 34 | Diagram 4
(Port 2 connection) (page 77) (page 92)
Setting Cable
g\e/;i?azoo KV-8000"7 ésozjicconnection) Example 32 | Diagram 2
(page 73) (page 88)
Setting Cable
RS232C . Example 33 | Diagram 3
(Port 2 connection) (page 75) (page 90)
KV-L21V

Setting Cable
Example 34 | Diagram 4

(page 77) (page 92)

Setting Cable
Example 35 | Diagram 5

(page 79) (page 98)

RS-422/485 (4wire)
(Port 2 connection)

RS-422/485 (2wire)
(Port 2 connection)

*1  Using modular connector on CPU.

*2  For communication settings, KV STUDIO Ver. 4 or later ladder software is required.
*3  For communication settings, KV STUDIO Ver. 6 or later ladder software is required.
*4  For communication settings, KV STUDIO Ver. 8 or later ladder software is required.
*S  For communication settings, KV STUDIO Ver. 7 or later ladder software is required.
*6  For communication settings, KV STUDIO Ver. 7.1 or later ladder software is required.

*7  For communication settings, KV STUDIO Ver. 10 or later ladder software is required.
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m |[PC COM Port

KV-700 - 8000 SIO Driver

When connecting IPC with an External Device, the COM port used depends on the series and SIO type. Please

refer to the IPC manual for details.

Usable port
Usable Port
Series
RS-232C RS-422/485(4 wire) | RS-422/485(2 wire)

coM1™!', comz,
PS-2000B cOM3*L COM4 - -
PS-3450A, PS-3451A, 10 . 1
PS3000-BA, PS3001-8p | COMI, COM2 COM2 CoM2
PS-3650A (T41 model), -
PS-3651A (T41 model) CoMI ) )
PS-3650A (T42 model), *1%) *1%) *]%)
PS-3631A (T42 model) coM1™1"2, com2 COMI COMI
PS-3700A (Pentium®4-M) | COM1*!, cOM2™!, o o
PS-3710A COM3™2 , COM4 COM3 COM3
PS-3711A coM1™!, com2™ com2™ coMm2™
PS4000"3 COM1, COM2 - -

coM1*"2, com2™, 1% 1%
PL3000 COMS3, COM4 COMI COMI
PE-4000B Atom N270 COM1, COM2 - -

COM3™ , COM4™, | cCOM3™, coM4™,

PE-4000B Atom N2600 COMI, COM2 CoMs™ come™ | CoMs™ COME™
PS5000 (Slim Panel Type 4 4 4
Core i3 Model) *> *6 COM1, COM2 COM2 COM2
PS5000 (Slim Panel Type
Atom Model) coM1, com2™7 com2™7 com2™?
*5 %6
PSSOQ% (Enclosed Panel COMI ) )
Type)
PS5000 (Modular Type
PFXPU/PFXPP)"> *6 7 7 o
PS5000 (Modular Type CoMI coMl CoMl
PFXPL2B5-6)
PS5000 (Modular Type *7 *7 *7
PFXPL2BI-4) COM1, COM2 COM2 COM2
PS6000 (Advanced Box) 9 *10 #10
PS6000 (Standard Box) COM1
PS6000 (Basic Box) coM1™ com1™ com1™

*1  The RI/5V can be switched. Use the IPC’s switch to change if necessary.

*2  Set up the SIO type with the DIP Switch. Please set up as follows according to SIO type to be used.

GP-Pro EX Device/PLC Connection Manual



KV-700 - 8000 SIO Driver

*3  When making communication between an External Device and COM port on the Expansion slot,
only RS-232C is supported. However, ER (DTR/CTS) control cannot be executed because of the
specification of COM port.

For connection with External Device, use user-created cables and disable Pin Nos. 1, 4, 6 and 9.
Please refer to the IPC manual for details of pin layout.

*4  Set up the SIO type with the BIOS. Please refer to the IPC manual for details of BIOS.

*5  When setting up communication between an External Device and the RS-232C/422/485 interface
module, use the IPC (RS-232C) or PS5000 (RS-422/485) cable diagrams. However, when using
PFXZPBMPR42P2 in a RS-422/485 (4-wire) configuration with no flow control, connect 7.RTS+
and 8.CTS+, and connect 6.RTS- and 9.CTS-.

When using RS-422/485 communication with External Devices, you may need to reduce the
transmission speed and increase the TX Wait time.

*6  To use RS-422/485 communication on the RS-232C/422/485 interface module, the DIP Switch
setting is required. Please refer to "Knowledge Base" (FAQs) on the support site. (http://www.pro-
face.com/trans/en/manual/1001.html)

Settings FAQ ID
PFXZPBMPR42P2, RS422/485 change method FA263858
PFXZPBMPR42P2 termination resistor setting FA263974
PFXZPBMPR44P2, RS422/485 change method FA264087
PFXZPBMPRA44P2 termination resistor setting FA264088

*7  Set up the SIO type with the DIP Switch. Please refer to the IPC manual for details of DIP Switch.
The BOX Atom has not a switch to set the RS-232C, RS-422/485 mode. Use the BIOS for the
setting.

*8  For the connection with the External Device, on the user-created cable read as if the connector on
the Display-side is a M12 A-coding 8 pin socket. The pin assignment is the same as described in
the cable diagram. For the M12 A-coding connector, use PEXZPSCNM122.

*9  In addition to COM1, you can also use the COM port on the optional interface.

*10 Install the optional interface in the expansion slot.

DIP Switch settings (PL3000 / PS3000 Series)

RS-232C
DIP Switch Setting Description
1 OFF"! Reserved (always OFF)
2 OFF
SIO type: RS-232C
3 OFF
4 OFF Output mode of SD (TXD) data: Always output
5 OFF Terminal resistance (220Q2) insertion to SD (TXD): None
6 OFF Terminal resistance (220Q2) insertion to RD (RXD): None
7 OFF Short-circuit of SDA (TXA) and RDA (RXA): Not available
8 OFF Short-circuit of SDB (TXB) and RDB (RXB): Not available
9 OFF
RS (RTS) Auto control mode: Disabled
10 OFF

*1  When using PS-3450A, PS-3451A, PS3000-BA and PS3001-BD, turn ON the set value.
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KV-700 - 8000 SIO Driver

RS-422/485 (4 wire)

DIP Switch Setting Description
1 OFF Reserved (always OFF)
2 ON
SIO type: RS-422/485
3 ON
4 OFF Output mode of SD (TXD) data: Always output
5 OFF Terminal resistance (220€2) insertion to SD (TXD): None
6 OFF Terminal resistance (220€2) insertion to RD (RXD): None
7 OFF Short-circuit of SDA (TXA) and RDA (RXA): Not available
8 OFF Short-circuit of SDB (TXB) and RDB (RXB): Not available
9 OFF
RS (RTS) Auto control mode: Disabled
10 OFF
RS-422/485 (2 wire)
DIP Switch Setting Description
1 OFF Reserved (always OFF)
2 ON
SIO type: RS-422/485
3 ON
4 OFF Output mode of SD (TXD) data: Always output
5 OFF Terminal resistance (220Q2) insertion to SD (TXD): None
6 OFF Terminal resistance (220€2) insertion to RD (RXD): None
7 ON Short-circuit of SDA (TXA) and RDA (RXA): Available
8 ON Short-circuit of SDB (TXB) and RDB (RXB): Available
9 ON
RS (RTS) Auto control mode: Enabled
10 ON

GP-Pro EX Device/PLC Connection Manual 10



KV-700 - 8000 SIO Driver

2 External Device Selection

Select the External Device to connect to the Display.

% Welcome to GP-Pro EX

I Device/PLC
E‘P"fpfﬂl' ( Number of Devices/PLCs |1 Bl
Device/PLC 1
Manufacturer | KEYENCE Corporation
Series K\-700 - 8000 SIO v
Port COM1

Befer to the manual of this Device/PLC
Becent Device/PLC

} ‘ [] Use System Area

Device Information

Back (B) Communication Settings Mew Logic Cancel

Setup Items Setup Description
Number of Devi . . .
PtCsbe of Devices/ Enter an integer from 1 to 4 to define the number of Devices/PLCs to connect to the display.
Manufacturer Select the manufacturer of the External Device to connect. Select "KEYENCE Corporation".
Select the External Device model (series) and the connection method. Select "KV-700 - 8000
S10".
Series In System configuration, make sure the External Device you are connecting is supported by

"KV-700 - 8000 SIO".
! System Configuration” (page 3)

Port Select the Display port to connect to the External Device.

Check this option to synchronize the system data area of the Display and the device (memory)
of the External Device. When synchronized, you can use the External Device’s ladder program
to switch the display or display the window on the Display.

Cf. GP-Pro EX Reference Manual "LS Area (Direct Access Method Area)"
This feature can also be set in GP-Pro EX or in the Display's offline mode.

Cf. GP-Pro EX Reference Manual "System Settings [Display Unit] - [System Area]

Settings Guide"
Cf. Maintenance/Troubleshooting Guide "Main Unit - System Area Settings"

Use System Area

GP-Pro EX Device/PLC Connection Manual 11



KV-700 - 8000 SIO Driver

3 Communication Settings

This section provides examples of communication settings recommended by Pro-face for the Display and the

External Device.

3.1 Setting Example 1
B GP-Pro EX Settings

4 Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1
Summary Change Device/PLC
[KEYENCE Corporation Series  [KV-700 - 8000 SIO | Port [com
Text Data Mode Change
Communication Settings
SI0 Type (®) R5232C () R5422/485(2wire) () R5422/485(4wire)
Speed 19200 ~
Data Length 7 8
Parity NONE EVEN
Stop Bit 1 2
Flow Control NONE ER(DTRICTS)
Timeout 3 + (sec)
Retry 2 =
‘Wit To Send 0 = (ms)
RI/WCC ® Rl ovee
In the case of RS232C, you can select the Sth pin to Rl (Input)
or VCC (5V Power Supply). If you use the Digital's
|zolation Unit, please select it to VCC.
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
Add Indirect
Mo. Device Name Settings Device
& 1 [pC | ] [Series=Kv-700/1000 ]
NOTE * You can set the speed to 9600-57600bps for KV-700 Series, and 9600-115200 bps for KV-

1000 Series.

GP-Pro EX Device/PLC Connection Manual
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KV-700 - 8000 SIO Driver
|

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | SR

% Individual Device Settings

PLC1

Series KV-700/1000 i

Flease reconfirm all of address settings that
you are using if you have changed the series.

Bit set in word address operation

Other bits in this word (® Clear

(O Do not clear
Mote on when selecting "Do not clear” : If
the ladder program writes data to the word

address during the read/write process, the
resulting data may be incorrect.

Default

OK (0) Cancel

B External Device Settings

There are no settings on the External Device. The speed automatically switches according to the Display settings.

GP-Pro EX Device/PLC Connection Manual 13
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3.2 Setting Example 2
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1
Summary Change Device/PLC
Manuf [KEYENCE Corporation Series  [KV-700 - 8000 SIO | Port [com
Text Data Mode Chance
Communication Settings
SI0 Type (®) R5232C () R5422/485(2wire) () R5422/485(4wire)
Specd .
Data Length 7 8
Parity NONE EVEN ooD
Stop Bit 1 2
Flow Control NONE ER(DTRICTS) XONXOFF
Timeout ec)
Retry
‘Wit To Send 0 ms)
RI/WCC ® Rl ovee
In the case of RS232C, you can select the Sth pin to Rl (Input)
or VCC (5V Power Supply). If you use the Digital's RS232C
|zolation Unit, please select it to VCC.
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
Add Indirect
Mo. Device Name Settings Device
PLCT [Series=Kv-700/1000

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] B

Series KV-700/1000 i

Flease reconfirm all of address settings that
you are using if you have changed the series.

Bit set in word address operation

Other bits in this word (® Clear

(O Do not clear
Mote on when selecting "Do not clear” : If
the ladder program writes data to the word

address during the read/write process, the
resulting data may be incorrect.

Default

OK (0) Cancel

GP-Pro EX Device/PLC Connection Manual 14
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B External Device Settings
Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 4 or later) to configure communication

settings for the External Device.

Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].
(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L20" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit placement

area.
(6) Double-click "KV-L20" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

Setup Items Setup Description
Operation Mode KV BUILDER mode
Interface RS-232C
Baud Rate Auto
Data Bit Length 8 bits
Port 1 Start Bit 1 bit
Stop Bit 1 bit
Parity Even
Check Sum None
RS/CS Flow Control Disabled

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.
(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.

GP-Pro EX Device/PLC Connection Manual 15
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3.3 Setting Example 3
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1
Summary Change Device/PLC
Manuf [KEYENCE Corporation Series  [KV-700 - 8000 SIO | Port [com
Text Data Mode Change
Communication Settings
SI0 Type (®) R5232C () R5422/485(2wire) () R5422/485(4wire)
Data Length 7 8
Parity NONE EVEN ooD
Stop Bit 1 2
Flow Control NONE ER(DTRICTS) XONXOFF
Timeout ec)
Retry
‘Wit To Send 0 ms)
RI/WCC ® Rl ovee
In the case of RS232C, you can select the Sth pin to Rl (Input)
or VCC (5V Power Supply). If you use the Digital's RS232C
|zolation Unit, please select it to VCC.
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
Add Indirect
Mo. Device Name Settings Device
1 [PLc [Series=Kv-700/1000

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] I

Series KV-700/1000 i

Flease reconfirm all of address settings that
you are using if you have changed the series.

Bit set in word address operation

Other bits in this word (® Clear

(O Do not clear
Mote on when selecting "Do not clear” : If
the ladder program writes data to the word

address during the read/write process, the
resulting data may be incorrect.

Default

OK (0) Cancel

GP-Pro EX Device/PLC Connection Manual 16



KV-700 - 8000 SIO Driver

B External Device Settings
Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 4 or later) to configure communication

settings for the External Device.

Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].
(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L20R" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit

placement area.
(6) Double-click "KV-L20R" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-232C
Baud Rate Auto
Data Bit Length 8 bits
Port 1 Start Bit 1 bit
Stop Bit 1 bit
Parity Even
Check Sum None
RS/CS Flow Control Disabled
Station No. | Station No. 0
gee’::ri:gs Transfer Timeout (sec.) | 3

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.
(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.

GP-Pro EX Device/PLC Connection Manual 17



KV-700 - 8000 SIO Driver

3.4 Setting Example 4
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1
Summary Change Device/PLC
Manuf [KEYENCE Corporation Series  |KV-700 - 8000 510 | Port [com
Text Data Mode Change
Communication Settings
SI0 Type (®) R5232C () R5422/485(2wire) () R5422/485(4wire)
Specd - .
Data Length 7 8
Parity NONE EVEN ooD
Stop Bit 1 2
Flow Control NONE ER(DTRICTS) XONXOFF
Timeout ec)
Retry
‘Wit To Send 0 ms)
RI/WCC ® Rl ovee
In the case of RS232C, you can select the Sth pin to Rl (Input)
or VCC (5V Power Supply). If you use the Digital's RS232C
|zolation Unit, please select it to VCC.
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
Add Indirect
Mo. Device Name Settings Device
1 [pLct [Series=Kv-700/1000

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | TR

Series KV-700/1000 i

Flease reconfirm all of address settings that
you are using if you have changed the series.

Bit set in word address operation

Other bits in this word (® Clear

(O Do not clear
Mote on when selecting "Do not clear” : If
the ladder program writes data to the word

address during the read/write process, the
resulting data may be incorrect.

Default

OK (0) Cancel
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B External Device Settings
Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 4 or later) to configure communication

settings for the External Device.

Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].
(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L20" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit placement

area.
(6) Double-click "KV-L20" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

Setup Items Setup Description
Operation Mode KV BUILDER mode
Interface RS-232C
Station No. 0
Baud Rate Auto
Port 2 Data Bit Length 8 bits
Start Bit 1 bit
Stop Bit 1 bit
Parity Even
Check Sum None

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.
(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.
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3.5 Setting Example 5
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1
Summary Change Device/PLC
Manuf [KEYENCE Corporation Series  |KV-700 - 8000 510 | Port [com
Text Data Mode Change
Communication Settings
SI0 Type (®) R5232C () R5422/485(2wire) () R5422/485(4wire)
Specd : .
Data Length 7 8
Parity NONE EVEN ooD
Stop Bit 1 2
Flow Control NONE ER(DTRICTS) XONXOFF
Timeout
Retry
‘wait To Send
RI/WCC ® Rl ovee
In the case of RS232C, you can select the Sth pin to Rl (Input)
or VCC (5V Power Supply). If you use the Digital's RS232C
|zolation Unit, please select it to VCC.
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
Add Indirect
Mo. Device Name Settings Device
1 [pLct [Series=Kv-700/1000

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | IR

& Individual Dy
PLC1
Series KV-700/1000 ~

Flease reconfirm all of address settings that
you are using if you have changed the series.

Bit set in word address operation

Other bits in this word (® Clear

(O Do not clear
Mote on when selecting "Do not clear” : If
the ladder program writes data to the word

address during the read/write process, the
resulting data may be incorrect.

Default

OK (0) Cancel
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B External Device Settings
Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 4 or later) to configure communication

settings for the External Device.

Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].
(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L20R" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit

placement area.
(6) Double-click "KV-L20R" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-232C
Baud Rate Auto
Data Bit Length 8 bits
Port 2
Start Bit 1 bit
Stop Bit 1 bit
Parity Even
Check Sum None
Station No. Station No. 0
g:::ri:gs Transfer Timeout (sec.) | 3

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.
(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.
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|

3.6 Setting Example 6
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1
Summary Change Device/PLC
Manuf [KEYENCE Corporation Series  |KV-700- 8000 510 | Port [com
Text Data Mode Change
Communication Settings
SI0 Type (O RS232C () R5422/485(2wire) (@) RS5422/485(4wire)
[iata Length 7 2
Parity NONE EVEN ooD
Stop Bit 1 2
Flow Control NONE ER(DTRICTS) XONXOFF
Timeout (sec)
Retry
‘Wit To Send (ms)
RI/WCC Rl VCC

In the case of RS232C, you can select the Sth pin to Rl (Input)
or VCC (5 Power Supply). If you use the Digital's RS232C
|zolation Unit, please select it to VCC.

Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
Add Indirect
Mo, Device Name Settings Device
PLCT [Series=Kv-700/1000 =

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | SR

PLC1

Series KV-700/1000 i

Flease reconfirm all of address settings that
you are using if you have changed the series.

Bit set in word address operation

Other bits in this word (® Clear

(O Do not clear
Mote on when selecting "Do not clear” : If
the ladder program writes data to the word

address during the read/write process, the
resulting data may be incorrect.

Default

OK (0) Cancel
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B External Device Settings
Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 4 or later) to configure communication

settings for the External Device.

Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].
(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L20" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit placement

area.
(6) Double-click "KV-L20" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

Setup Items Setup Description
Operation Mode KV BUILDER mode
Interface RS-422A
Station No. 0
Baud Rate Auto
Port 2 Data Bit Length 8 bits
Start Bit 1 bit
Stop Bit 1 bit
Parity Even
Check Sum None

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.
(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.
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3.7 Setting Example 7
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1
Summary Change Device/PLC
Manuf [KEYENCE Corporation Series  |KV-700- 8000 510 | Port [com
Text Data Mode Change
Communication Settings
SI0 Type (O RS232C () R5422/485(2wire) (@) RS5422/485(4wire)
Speed [13200 |
[iata Length 7 2
Parity NONE EVEN ooD
Stop Bit 1 2
Flow Control NONE ER(DTRICTS) XONXOFF
Timeout
Retry
‘wiait To Send
RI/WCC Rl VCC
In the case of RS232C, you can select the Sth pin to Rl (Input)
or VCC (5 Power Supply). If you use the Digital's RS232C
|zolation Unit, please select it to VCC.
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
Add Indirect
Mo, Device Name Settings Device
1 [pLct [Series=Kv-700/1000

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | TR

PLC1

Series KV-700/1000 i

Flease reconfirm all of address settings that
you are using if you have changed the series.

Bit set in word address operation

Other bits in this word (® Clear

(O Do not clear
Mote on when selecting "Do not clear” : If
the ladder program writes data to the word

address during the read/write process, the
resulting data may be incorrect.

Default

OK (0) Cancel
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B External Device Settings
Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 4 or later) to configure communication

settings for the External Device.

Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].
(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L20R" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit

placement area.
(6) Double-click "KV-L20R" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-422A/485 (4wire)
Baud Rate Auto
Data Bit Length 8 bits
Port 2
Start Bit 1 bit
Stop Bit 1 bit
Parity Even
Check Sum None
Station No. Station No. 0
g:::ri:gs Transfer Timeout (sec.) | 3

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.
(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.
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3.8 Setting Example 8
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1
Summary Change Device/PLC
Manuf [KEYENCE Corporation Series  [KV-700 - 8000 SIO | Port [com
Text Data Mode Change
Communication Settings
SI0 Type (®) R5232C () R5422/485(2wire) () R5422/485(4wire)
Speed |
Data Length 7 8
Parity NONE EVEN ooD
Stop Bit 1 2
Flow Control NONE ER(DTRICTS) XONXOFF
Timeout 5EC)
Retry
‘Wit To Send ms)
RI/WCC ® Rl ovee
In the case of RS232C, you can select the Sth pin to Rl (Input)
or VCC (5V Power Supply). If you use the Digital's RS232C
Isclation Unit, please select it to WVCC.
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
Add Indirect
Mo. Device Name Settings Device
1 |PLCT Series=KV-700/1000

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | TR

&% Individual D
PLC1
Series KV-700/1000 ~

Flease reconfirm all of address settings that
you are using if you have changed the series.

Bit set in word address operation

Other bits in this word (® Clear

(O Do not clear
Mote on when selecting "Do not clear” : If

the ladder program writes data to the word

address during the read/write process, the
resulting data may be incorrect.

Default

OK (0) Cancel

GP-Pro EX Device/PLC Connection Manual 26



KV-700 - 8000 SIO Driver

B External Device Settings
Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 4 or later) to configure communication

settings for the External Device.

Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].
(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L20V" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit

placement area.
(6) Double-click "KV-L20V" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-232C
Baud Rate Auto
Data Bit Length 8 bits
Port 1 Start Bit 1 bit
Stop Bit 1 bit
Parity Even
Check Sum None
RS/CS Flow Control Disabled
Station No. | Station No. 0
gee’::ri:gs Transfer Timeout (sec.) | 3

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.
(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.
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3.9 Setting Example 9
B SGP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1
Summary Change Device/PLC
Manuf [KEYENCE Corporation Series  |KV-700 - 8000 510 | Port [com
Text Data Mode Change
Communication Settings
SI0 Type (®) R5232C () R5422/485(2wire) () R5422/485(4wire)
Speed [19200 |
Data Length 7
Parity NONE ooD
Stop Bit 1 2
Flow Control NONE ER(DTRICTS) XONXOFF
Timeout ec)
Retry
‘Wit To Send ms)
RI/WCC ® Rl ovee
In the case of RS232C, you can select the Sth pin to Rl (Input)
or VCC (5V Power Supply). If you use the Digital's RS232C
|zolation Unit, please select it to VCC.
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
Add Indirect
Mo. Device Name Settings Device
PLCT [Series=Kv-700/1000

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | SR

& Individual Dy
B
Series KV-700/1000 t

Flease reconfirm all of address settings that
you are using if you have changed the series.

Bit set in word address operation

Other bits in this word (® Clear

(O Do not clear
Mote on when selecting "Do not clear” : If
the ladder program writes data to the word

address during the read/write process, the
resulting data may be incorrect.

Default

OK (0) Cancel
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B External Device Settings
Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 4 or later) to configure communication

settings for the External Device.

Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].
(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L20V" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit

placement area.
(6) Double-click "KV-L20V" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-232C
Baud Rate Auto
Data Bit Length 8 bits
Port 2
Start Bit 1 bit
Stop Bit 1 bit
Parity Even
Check Sum None
Station No. Station No. 0
g:::ri:gs Transfer Timeout (sec.) | 3

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.
(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.
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3.10 Setting Example 10
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1
Summary Change Device/PLC
Manuf [KEYENCE Corporation Series  [KV-700 - 8000 SIO | Port [com
Text Data Mode Change
Communication Settings
SI0 Type (O RS232C () R5422/485(2wire) (@) RS5422/485(4wire)
Speed [13200 |
[iata Length 7 2
Parity NONE EVEN ooD
Stop Bit 1 2
Flow Control NONE ER(DTRICTS) XONXOFF
Timeout
Retry
‘wiait To Send
RI/WCC Rl VCC
In the case of RS232C, you can select the Sth pin to Rl (Input)
or VCC (5 Power Supply). If you use the Digital's RS232C
|zolation Unit, please select it to VCC.
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
Add Indirect
Mo, Device Name Settings Device
1 [pLct [Series=Kv-700/1000 =

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | TR

Series KV-700/1000 i

Flease reconfirm all of address settings that
you are using if you have changed the series.

Bit set in word address operation

Other bits in this word (® Clear

(O Do not clear
Mote on when selecting "Do not clear” : If
the ladder program writes data to the word

address during the read/write process, the
resulting data may be incorrect.

Default

OK (0) Cancel
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B External Device Settings
Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 4 or later) to configure communication

settings for the External Device.

Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].
(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L20V" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit

placement area.
(6) Double-click "KV-L20V" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-422A/485 (4wire)
Baud Rate Auto
Data Bit Length 8 bits
Port 2
Start Bit 1 bit
Stop Bit 1 bit
Parity Even
Check Sum None
Station No. Station No. 0
g:::ri:gs Transfer Timeout (sec.) | 3

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.
(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.
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3.1 Setting Example 11
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1
Summary Change Device/PLC
[KEYENCE Corporation Series  [KV-700 - 8000 SIO | Port [com
Text Data Mode Chance
Communication Settings
SI0 Type (®) R5232C () R5422/485(2wire) () R5422/485(4wire)
Speed 19200 ~
Data Length 7 2
Parity NONE EVEN ooD
Stop Bit 1 2
Flow Control NONE ER(DTRICTS) XONXOFF
Timeout 3 + (sec)
Retry 2 3
‘Wit To Send 0 = (ms)
RI/WCC ® Rl ovee
In the case of RS232C, you can select the Sth pin to Rl (Input)
or VCC (5V Power Supply). If you use the Digital's RS232C
|zolation Unit, please select it to VCC. Default
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
Add Indirect
Mo. Device Name Settings Device
& 1 [pC | ] [Series=Kv-3000/5000 =]

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] I

&% Individual Devi
PLC1
Series KV-3000/5000 ~

Flease reconfirm all of address settings that
you are using if you have changed the series.

Bit set in word address operation

Other bits in this word (® Clear

(O Do not clear
Mote on when selecting "Do not clear” : If
the ladder program writes data to the word

address during the read/write process, the
resulting data may be incorrect.

Default

OK (0) Cancel

B External Device Settings

There are no settings on the External Device. The speed automatically switches according to the Display setting.
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3.12 Setting Example 12
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1
Summary Change Device/PLC
Manuf [KEYENCE Corporation Series  [KV-700 - 8000 SIO | Port [com
Text Data Mode Chance
Communication Settings
SI0 Type (®) R5232C () R5422/485(2wire) () R5422/485(4wire)
Speed [
Data Length 7 2
Parity NONE EVEN ooD
Stop Bit 1 2
Flow Control NONE ER(DTRICTS) XONXOFF
Timeout ec)
Retry
‘Wit To Send 0 ms)
RI/WCC ® Rl ovee
In the case of RS232C, you can select the Sth pin to Rl (Input)
or VCC (5V Power Supply). If you use the Digital's RS232C
|zolation Unit, please select it to VCC.
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
Add Indirect
Mo. Device Name Settings Device
1 [pLct | Series=Kv-3000/5000

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | SR

&% Individual Dy
PLC1
Series KV-3000/5000 ~

Flease reconfirm all of address settings that
you are using if you have changed the series.

Bit set in word address operation

Other bits in this word (® Clear

(O Do not clear
Mote on when selecting "Do not clear” : If
the ladder program writes data to the word

address during the read/write process, the
resulting data may be incorrect.

Default

OK (0) Cancel

GP-Pro EX Device/PLC Connection Manual 33



KV-700 - 8000 SIO Driver

B External Device Settings
Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 4 or later) to configure communication

settings for the External Device.

Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].
(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L20V" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit

placement area.
(6) Double-click "KV-L20V" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-232C
Baud Rate Auto
Data Bit Length 8 bits
Port 1 Start Bit 1 bit
Stop Bit 1 bit
Parity Even
Check Sum None
RS/CS Flow Control Disabled
Station No. | Station No. 0
gee’::ri:gs Transfer Timeout (sec.) | 3

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.
(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.
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3.13 Setting Example 13
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1
Summary Change Device/PLC
Manuf [KEYENCE Corporation Series  [KV-700 - 8000 SIO | Port [com
Text Data Mode Chance
Communication Settings
SI0 Type (®) R5232C () R5422/485(2wire) () R5422/485(4wire)
Data Length 7 2
Parity NONE EVEN ooD
Stop Bit 1 2
Flow Control NONE ER(DTRICTS) XONXOFF
Timeout 5EC)
Retry
‘wiait To Send ms)
RI/WCC ® Rl ovee
In the case of RS232C, you can select the Sth pin to Rl (Input)
or VCC (5V Power Supply). If you use the Digital's RS232C
Isclation Unit, please select it to WVCC.
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
Add Indirect
Mo. Device Name Settings Device
1 |PLCT Series=KV-3000/5000

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | TR

&% Individual D
PLC1
Series KV-3000/5000 ~

Flease reconfirm all of address settings that
you are using if you have changed the series.

Bit set in word address operation

Other bits in this word (® Clear

(O Do not clear
Mote on when selecting "Do not clear” : If

the ladder program writes data to the word

address during the read/write process, the
resulting data may be incorrect.

Default

OK (0) Cancel
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B External Device Settings
Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 4 or later) to configure communication

settings for the External Device.

Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].
(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L20V" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit

placement area.
(6) Double-click "KV-L20V" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-232C
Baud Rate Auto
Data Bit Length 8 bits
Port 2
Start Bit 1 bit
Stop Bit 1 bit
Parity Even
Check Sum None
Station No. Station No. 0
g:::ri:gs Transfer Timeout (sec.) | 3

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.
(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.
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|

3.14 Setting Example 14
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1
Summary Change Device/PLC
Manuf [KEYENCE Corporation Series  |KV-700 - 8000 510 | Port [com
Text Data Mode Change
Communication Settings
SI0 Type (O RS232C () R5422/485(2wire) (@) RS5422/485(4wire)
Spect T
[iata Length 7 2
Parity NONE EVEN ooD
Stop Bit 1 2
Flow Control NONE ER(DTRICTS) XONXOFF
Timeout f (sec)
Retry
‘Wit To Send (ms)
RI/WCC Rl WCC

In the case of RS232C, you can select the Sth pin to Rl (Input)
or VCC (5 Power Supply). If you use the Digital's RS232C
|zolation Unit, please select it to VCC.

Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
Add Indirect
Mo, Device Name Settings Device

PLCT | [Series=Kv-3000/5000

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] B

Series KV-3000/5000 ~

Flease reconfirm all of address settings that
you are using if you have changed the series.

Bit set in word address operation

Other bits in this word (® Clear

(O Do not clear
Mote on when selecting "Do not clear” : If
the ladder program writes data to the word

address during the read/write process, the
resulting data may be incorrect.

Default

OK (0) Cancel

GP-Pro EX Device/PLC Connection Manual 37



KV-700 - 8000 SIO Driver

B External Device Settings
Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 4 or later) to configure communication

settings for the External Device.

Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].
(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L20V" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit

placement area.
(6) Double-click "KV-L20V" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-422A/485 (4wire)
Baud Rate Auto
Data Bit Length 8 bits
Port 2
Start Bit 1 bit
Stop Bit 1 bit
Parity Even
Check Sum None
Station No. Station No. 0
g:::ri:gs Transfer Timeout (sec.) | 3

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.
(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.
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3.15 Setting Example 15
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1
Summary Change Device/PLC
[KEYENCE Corporation Series  [KV-700 - 8000 SIO | Port [com
Text Data Mode Change
Communication Settings
SI0 Type (®) R5232C () R5422/485(2wire) () R5422/485(4wire)
Speed 19200 ~
Data Length 7 2
Parity NONE EVEN ooD
Stop Bit 1 2
Flow Control NONE ER(DTRICTS) XONXOFF
Timeout 3 + (sec)
Retry 2 3
‘Wit To Send 0 = (ms)
RI/WCC ® Rl ovee
In the case of RS232C, you can select the Sth pin to Rl (Input)
or VCC (5V Power Supply). If you use the Digital's RS232C
Isclation Unit, please select it to WVCC. Default
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
Add Indirect
Mo. Device Name Settings Device
& 1 [Pt | ] [Series=Kv-3000/5000 a
@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | IR

B Individual

PLC1

Series KV-3000/5000 ~

Flease reconfirm all of address settings that
you are using if you have changed the series.

Bit set in word address operation

Other bits in this word (® Clear

(O Do not clear
Mote on when selecting "Do not clear” : If
the ladder program writes data to the word

address during the read/write process, the
resulting data may be incorrect.

Default

OK (0) Cancel

& Note

e Ifyou are using a KV-5500 series device, select [KV-3000/5000] from the [Series] list.
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B External Device Settings

Use ladder software KV STUDIO Ver. 6 or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.
(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and
click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.

(5) On the [Select unit (1)] tab, from the displayed list of units select "KV-L20V", then drag & drop to the unit

placement area.
(6) In the unit placement area click "KV-L20V" and then select the [Setup unit (2)] tab.

(7) Configure the setup items as follows.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-232C (Fixed)
Baud Rate Auto (Fixed)
Data Bit Length 8 bits (Fixed)
Port 1 Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
RS/CS Flow Control Disabled
Base Node No. 0
gee:::gs ;I'Sr:crzss;‘er timeout time 3 (Fixed)

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(12)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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3.16 Setting Example 16
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1
Summary Change Device/PLC
[KEYENCE Corporation Series  [KV-700 - 8000 SIO | Port [com
Text Data Mode Change
Communication Settings
SI0 Type (®) R5232C () R5422/485(2wire) () R5422/485(4wire)
Speed 19200 ~
Data Length 7 2
Parity NONE EVEN ooD
Stop Bit 1 2
Flow Control NONE ER(DTRICTS) XONXOFF
Timeout 3 + (sec)
Retry 2 3
‘Wit To Send 0 = (ms)
RI/WCC ® Rl ovee
In the case of RS232C, you can select the Sth pin to Rl (Input)
or VCC (5V Power Supply). If you use the Digital's RS232C
Isclation Unit, please select it to WVCC. Default
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
Add Indirect
Mo. Device Name Settings Device
& 1 [Pt | ] [Series=Kv-3000/5000 a
@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | IR

£ Individual

PLC1

Series KV-3000/5000 ~
Flease reconfirm all of address settings that
you are using if you have changed the series.

Bit set in word address operation

Other bits in this word (® Clear

(O Do not clear
Mote on when selecting "Do not clear” : If
the ladder program writes data to the word

address during the read/write process, the
resulting data may be incorrect.

Default

OK (0) Cancel

4 Note

* Ifyou are using a KV-5500 series device, select [KV-3000/5000] from the [Series] list.
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B External Device Settings

Use ladder software KV STUDIO Ver. 6 or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.
(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and
click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.

(5) On the [Select unit (1)] tab, from the displayed list of units select "KV-L20V", then drag & drop to the unit

placement area.
(6) In the unit placement area click "KV-L20V" and then select the [Setup unit (2)] tab.

(7) Configure the setup items as follows.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-232C
Baud Rate Auto (Fixed)
Port 2 Data Bit Length 8 bits (Fixed)
Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
Base Node No. 0
g::::gs ;I;r:gss;‘er timeout time 3 (Fixed)

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(12)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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3.17 Setting Example 17
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1
Summary Change Device/PLC
Manuf [KEYENCE Corporation Series  |KV-700 - 8000 510 | Port [com
Text Data Mode Change
Communication Settings
SI0 Type (O RS232C () R5422/485(2wire) (@) RS5422/485(4wire)
Speed | 19200 ~|
[iata Length 7 2
Parity NONE EVEN ooD
Stop Bit 1 2
Flow Control NONE ER(DTRICTS) XONXOFF
Timeout
Retry
‘wait To Send
RI/WCC Rl iCC
In the case of RS232C, you can select the Sth pin to Rl (Input)
or VCC (5 Power Supply). If you use the Digital's RS232C
|zolation Unit, please select it to VCC.
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
Add Indirect
Mo, Device Name Settings Device
PLCY It [Series=KV-3000/5000 Iz

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | TR

&% Individual Dy
PLC1
Series KV-3000/5000 ~

Flease reconfirm all of address settings that
you are using if you have changed the series.

Bit set in word address operation

Other bits in this word (® Clear

(O Do not clear
Mote on when selecting "Do not clear” : If
the ladder program writes data to the word

address during the read/write process, the
resulting data may be incorrect.

Default

OK (0) Cancel

¢ Note

» Ifyou are using a KV-5500 series device, select [KV-3000/5000] from the [Series] list.
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B External Device Settings

Use ladder software KV STUDIO Ver. 6 or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.
(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and
click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.

(5) On the [Select unit (1)] tab, from the displayed list of units select "KV-L20V", then drag & drop to the unit

placement area.
(6) In the unit placement area click "KV-L20V" and then select the [Setup unit (2)] tab.

(7) Configure the setup items as follows.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-422A/485 (4wire)
Baud Rate Auto (Fixed)
Port 2 Data Bit Length 8 bits (Fixed)
Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
Base Node No. 0
g::::gs ;I;r:gss;‘er timeout time 3 (Fixed)

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(12)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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3.18 Setting Example 18
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1
Summary Change Device/PLC
Manuf [KEYENCE Corporation Series  |KV-700 - 8000 510 | Port [com
Text Data Mode Change
Communication Settings
SI0 Type (®) R5232C () R5422/485(2wire) () R5422/485(4wire)
Speed
[Diata Length 7 8
Parity NONE EVEN ooD
Stop Bit 1 2
Flow Control NONE ER(DTRICTS) XONXOFF
Timeout l
Retry
‘wiait To Send
RI/WCC ® Rl ovee
In the case of RS232C, you can select the Sth pin to Rl (Input)
or VCC (5V Power Supply). If you use the Digital's RS232C
|zolation Unit, please select it to VCC. Default
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
Add Indirect
Mo. Device Name Settings Device
PLCY ]
@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | SR

B Individual

PLC1

Series KV-Nano ~

Flease reconfirm all of address settings that
you are using if you have changed the series.

Bit set in word address operation

Other bits in this word (® Clear

(O Do not clear
Mote on when selecting "Do not clear” : If
the ladder program writes data to the word

address during the read/write process, the
resulting data may be incorrect.

Default

QK {0) Cancel
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B External Device Settings

Use ladder software KV STUDIO Ver. § or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.
(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and
click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.
(5) Select the [Setup unit (2)] tab.

(6) Configure the setup items as follows.

Setup Items Setup Description

Built-in serial Operation Mode KV STUDIO mode

(7) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.
(8) Click [Yes].
(9) From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(10)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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3.19 Setting Example 19
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1
Summary Change Device/PLC
Manuf [KEYENCE Corporation Series  [KV-700 - 8000 SIO | Port [com
Text Data Mode Chance
Communication Settings
SI0 Type (®) R5232C () R5422/485(2wire) () R5422/485(4wire)
Speed
Data Length 7 8
Parity NONE EVEN ooD
Stop Bit 1 2
Flow Control NONE ER(DTRICTS) XONXOFF
Timeout ec)
Retry
‘wiait To Send ms)
RI/WCC ® Rl ovee
In the case of RS232C, you can select the Sth pin to Rl (Input)
or VCC (5 Power Supply). If you use the Digital's RS232C
|zolation Unit, please select it to VCC. Default |
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
Add Indirect
Mo. Device Name Settings Device
1 |PLCT

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | IR

B Individual

PLC1

Series KV-7000 i

Flease reconfirm all of address settings that
you are using if you have changed the series.

Bit set in word address operation

Other bits in this word (® Clear

(O Do not clear
Mote on when selecting "Do not clear” : If
the ladder program writes data to the word

address during the read/write process, the
resulting data may be incorrect.

Default

OK (0) Cancel
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B External Device Settings

Use ladder software KV STUDIO Ver. § or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.
(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and
click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.
(5) Select the [Setup unit (2)] tab.

(6) Configure the setup items as follows.

Setup Items Setup Description

Built-in serial Operation Mode KV STUDIO mode

(7) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.
(8) Click [Yes].
(9) From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(10)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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3.20 Setting Example 20
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1
Summary Change Device/PLC
Manuf [KEYENCE Corporation Series  [KV-700 - 8000 SIO | Port [com
Text Data Mode Chance
Communication Settings
SI0 Type (®) R5232C () R5422/485(2wire) () R5422/485(4wire)
Speed
Data Length 7 8
Parity NONE EVEN ooD
Stop Bit 1 2
Flow Control NONE ER(DTRICTS) XONXOFF
Timeout
Retry
‘wiait To Send
RI/WCC ® Rl ovee
In the case of RS232C, you can select the Sth pin to Rl (Input)
or VCC (5 Power Supply). If you use the Digital's RS232C
|zolation Unit, please select it to VCC. I Defadt |
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
Add Indirect
Mo. Device Name Settings Device
1 |PLCT

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] I

B Individual

PLC1

Series KV-7000 t
Flease reconfirm all of address settings that
you are using if you have changed the series.

Bit set in word address operation

Other bits in this word (® Clear

(O Do not clear
Mote on when selecting "Do not clear” : If
the ladder program writes data to the word

address during the read/write process, the
resulting data may be incorrect.

Default

OK (0) Cancel
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B External Device Settings

Use ladder software KV STUDIO Ver. § or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.
(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and
click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.

(5) On the [Select unit (1)] tab, from the displayed list of units select "KV-L20V", then drag & drop to the unit

placement area.
(6) In the unit placement area click "KV-L20V" and then select the [Setup unit (2)] tab.

(7) Configure the setup items as follows.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-232C (Fixed)
Baud Rate Auto (Fixed)
Data Bit Length 8 bits (Fixed)
Port 1 Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
RS/CS Flow Control Disabled
Base Node No. 0
gee:::gs ;I'Sr:crzss;‘er timeout time 3 (Fixed)

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(12)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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3.21 Setting Example 21
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1
Summary Change Device/PLC
Manuf [KEYENCE Corporation Series  [KV-700 - 8000 SIO | Port [com
Text Data Mode Chance
Communication Settings
SI0 Type (®) R5232C () R5422/485(2wire) () R5422/485(4wire)
Speed
Data Length 7 8
Parity NONE EVEN ooD
Stop Bit 1 2
Flow Control NONE ER(DTRICTS) XONXOFF
Timeout |2l (sec)
Retry
‘wiait To Send (ms)
RI/WCC ® Rl ovee
In the case of RS232C, you can select the Sth pin to Rl (Input)
or VCC (5 Power Supply). If you use the Digital's RS232C -
|zolation Unit, please select it to VCC. Default |
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
Add Indirect
Mo. Device Name Settings Device
1 |PLCT i

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | SR

B Individual

PLC1

Series KV-7000

Flease reconfirm all of address settings that
you are using if you have changed the series.

£

Bit set in word address operation

Other bits in this word (® Clear

(O Do not clear
Mote on when selecting "Do not clear” : If
the ladder program writes data to the word

address during the read/write process, the
resulting data may be incorrect.

Default

Cancel
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B External Device Settings

Use ladder software KV STUDIO Ver. § or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.
(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and
click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.

(5) On the [Select unit (1)] tab, from the displayed list of units select "KV-L20V", then drag & drop to the unit

placement area.
(6) In the unit placement area click "KV-L20V" and then select the [Setup unit (2)] tab.

(7) Configure the setup items as follows.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-232C
Baud Rate Auto (Fixed)
Port 2 Data Bit Length 8 bits (Fixed)
Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
Base Node No. 0
g::::gs ;I;r:gss;‘er timeout time 3 (Fixed)

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(12)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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3.22 Setting Example 22
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1
Summary Change Device/PLC
Manuf [KEYENCE Corporation Series  [KV-700 - 8000 SIO | Port [com
Text Data Mode Chanoe
Communication Settings
SI0 Type (O RS232C () R5422/485(2wire) (@) RS5422/485(4wire)
Speed
[iata Length 7 2
Parity NONE EVEN ooD
Stop Bit 1 2
Flow Control NONE ER(DTRICTS) XONXOFF
Timeout f
Retry
‘wiait To Send
RI/WCC Rl VCC
In the case of RS232C, you can select the Sth pin to Rl (Input)
or VICC (5 Power Supply). If you use the Digital's RS232C
|zolation Unit, please select it to VCC.
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
Add Indirect
Mo, Device Name Settings Device
|1 [Pt | ] [Series=Kv-7000 Iz
@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] I

&% Individual Dy
BIE]
Series KV-7000 t

Flease reconfirm all of address settings that
you are using if you have changed the series.

Bit set in word address operation

Other bits in this word (® Clear

(O Do not clear
Mote on when selecting "Do not clear” : If
the ladder program writes data to the word

address during the read/write process, the
resulting data may be incorrect.

Default

OK (0) Cancel
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B External Device Settings

Use ladder software KV STUDIO Ver. § or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.
(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and
click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.

(5) On the [Select unit (1)] tab, from the displayed list of units select "KV-L20V", then drag & drop to the unit

placement area.
(6) In the unit placement area click "KV-L20V" and then select the [Setup unit (2)] tab.

(7) Configure the setup items as follows.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-422A/485 (4wire)
Baud Rate Auto (Fixed)
Port 2 Data Bit Length 8 bits (Fixed)
Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
Base Node No. 0
g::::gs ;I;r:gss;‘er timeout time 3 (Fixed)

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(12)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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3.23 Setting Example 23
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1
Summary Change Device/PLC
Manuf [KEYENCE Corporation Series  [KV-700 - 8000 SIO | Port [com
Text Data Mode Chanoe
Communication Settings
SI0 Type (O RS232C (@) RS5422/485(2wire) () R5422/485(4wire)
Speed
[iata Length 7 2
Parity NONE EVEN ooD
Stop Bit 1 2
Flow Control NONE ER(DTRICTS) XONXOFF
Timeout f |
Retry
‘wiait To Send
RI/WCC Rl VCC
In the case of RS232C, you can select the Sth pin to Rl (Input)
or VCC (5 Power Supply). If you use the Digital's RS232C
|zolation Unit, please select it to VCC.
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
Add Indirect
Mo, Device Name Settings Device
|1 [Pt | ] [Series=Kv-7000

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | IR

Series KV-7000 i

Flease reconfirm all of address settings that
you are using if you have changed the series.

Bit set in word address operation

Other bits in this word (® Clear

(O Do not clear
Mote on when selecting "Do not clear” : If
the ladder program writes data to the word

address during the read/write process, the
resulting data may be incorrect.

Default

OK (0) Cancel
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B External Device Settings

Use ladder software KV STUDIO Ver. § or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.
(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and
click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.

(5) On the [Select unit (1)] tab, from the displayed list of units select "KV-L20V", then drag & drop to the unit

placement area.
(6) In the unit placement area click "KV-L20V" and then select the [Setup unit (2)] tab.

(7) Configure the setup items as follows.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-422A/485 (2wire)
Baud Rate Auto (Fixed)
Port 2 Data Bit Length 8 bits (Fixed)
Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
Base Node No. 0
g::::gs ;I;r:gss;‘er timeout time 3 (Fixed)

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(12)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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3.24 Setting Example 24
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1
Summary Change Device/PLC
Manuf [KEYENCE Corporation Series  |KV-700 - 8000 510 | Port [com
Text Data Mode Change
Communication Settings
SI0 Type (®) R5232C () R5422/485(2wire) () R5422/485(4wire)
Speed
[Diata Length
Parity NONE EVEN ooD
Stop Bit 1 2
Flow Control NONE ER(DTRICTS) XONXOFF
Timeout
Retry
‘wiait To Send
RI/WCC ® Rl ovee
In the case of RS232C, you can select the Sth pin to Rl (Input)
or VCC (5V Power Supply). If you use the Digital's RS232C
|zolation Unit, please select it to VCC. Default
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
Add Indirect
Mo. Device Name Settings Device
1 |PLCT

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | IR

B Individual

PLC1

Series KV-Nano ~
Flease reconfirm all of address settings that
you are using if you have changed the series.

Bit set in word address operation

Other bits in this word (® Clear

(O Do not clear
Mote on when selecting "Do not clear” : If
the ladder program writes data to the word

address during the read/write process, the
resulting data may be incorrect.

Default

QK {0) Cancel
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B External Device Settings

Use ladder software KV STUDIO Ver. § or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.
(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and
click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.
(5) On the [Select unit (1)] tab, from the [Extension Cassette left (Portl)] area select "KV-N10L".

(6) Configure the setup items as follows.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-232C (Fixed)
Baud Rate Auto (Fixed)
Data Bit Length 8 bits (Fixed)
Port 1 Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
RS/CS Flow Control Disabled
Base Node No. 0
gee:::gs ;I'Sr:crzss;‘er timeout time 3 (Fixed)

(7) From the [Convert] menu, select [Auto-assign relay/DM].

(8) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(9) Click [Yes].

(10)From the [Monitor/Simulator] menu, select [ Transfer to PLC] to display the [Transfer Program] dialog box.

(11)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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3.25 Setting Example 25
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1
Summary Change Device/PLC
Manuf [KEYENCE Corporation Series  |KV-700 - 8000 510 | Port [com
Text Data Mode Change
Communication Settings
SI0 Type (O RS232C () R5422/485(2wire) (@) RS5422/485(4wire)
Speed
[iata Length 7 g
Parity NONE EVEN ooD
Stop Bit 1 2
Flow Control NONE ER(DTRICTS) XONXOFF
Timeout f
Retry
‘wait To Send
RI/WCC Rl VCC
In the case of RS232C, you can select the Sth pin to Rl (Input)
or VICC (5 Power Supply). If you use the Digital's RS232C
|zolation Unit, please select it to VCC.
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
Add Indirect
Mo, Device Name Settings Device
1 [pLct t| [Series=KV-Nano |

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | SR

& Individual Dy
B
Series KV-Nano ~

Flease reconfirm all of address settings that
you are using if you have changed the series.

Bit set in word address operation

Other bits in this word (® Clear

(O Do not clear
Mote on when selecting "Do not clear” : If
the ladder program writes data to the word

address during the read/write process, the
resulting data may be incorrect.

Default

QK {0) Cancel
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B External Device Settings

Use ladder software KV STUDIO Ver. § or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.
(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and
click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.
(5) On the [Select unit (1)] tab, from the [Extension Cassette left (Portl)] area select "K' V-N11L".

(6) Configure the setup items as follows.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-422A/485 (4wire)
Baud Rate Auto (Fixed)
Data Bit Length 8 bits (Fixed)
Port 1 Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
RS/CS Flow Control Disabled
Base Node No. 0
gee:::gs ;I'Sr:crzss;‘er timeout time 3 (Fixed)

(7) From the [Convert] menu, select [Auto-assign relay/DM].

(8) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(9) Click [Yes].

(10)From the [Monitor/Simulator] menu, select [ Transfer to PLC] to display the [Transfer Program] dialog box.

(11)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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3.26

Setting Example 26

B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1

Summary

Change Device/PLC

Manuf [KEYENCE Corporation Series  [KV-700 - 8000 SIO | Port [com

Text Data Mode Change

Communication Settings
SI0 Type (O RS232C (@) RS5422/485(2wire)
Speed
[iata Length 7 . ( 2
Parity NONE EVEN

Stop Bit 1 2

Flow Control NONE ER(DTRICTS)
Timeout f (sec)
Retry

‘Wit To Send (ms)

RI/WCC Rl VCC
In the case of RS232C, you can select the Sth pin to Rl (Input)
or VCC (5 Power Supply). If you use the Digital's RS232C
|zolation Unit, please select it to VCC.

Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1

Mo. Device Name Settings

(O RS422/485(4wire)

ooD

KOMNXOFF

Add Indirect
Device

PLCT b [Series=KV-Nano

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | SR

& Individual Dy
B
Series KV-Nano ~

Bit set in word address operation

Other bits in this word

resulting data may be incorrect.

Flease reconfirm all of address settings that
you are using if you have changed the series.

(® Clear
(O Do not clear
Mote on when selecting "Do not clear” : If

the ladder program writes data to the word
address during the read/write process, the

Default

Cancel
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B External Device Settings

Use ladder software KV STUDIO Ver. § or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.
(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and
click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.
(5) On the [Select unit (1)] tab, from the [Extension Cassette left (Portl)] area select "K' V-N11L".

(6) Configure the setup items as follows.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-422A/485 (2wire)
Baud Rate Auto (Fixed)
Data Bit Length 8 bits (Fixed)
Port 1 Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
RS/CS Flow Control Disabled
Base Node No. 0
gee:::gs ;I'Sr:crzss;‘er timeout time 3 (Fixed)

(7) From the [Convert] menu, select [Auto-assign relay/DM].

(8) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(9) Click [Yes].

(10)From the [Monitor/Simulator] menu, select [ Transfer to PLC] to display the [Transfer Program] dialog box.

(11)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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3.27 Setting Example 27
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1
Summary Change Device/PLC
Manuf [KEYENCE Corporation Series  |KV-700 - 8000 510 | Port [com
Text Data Mode Change
Communication Settings
SI0 Type (®) R5232C () R5422/485(2wire) () R5422/485(4wire)
Speed
[Diata Length
Parity NONE EVEN ooD
Stop Bit 1 2
Flow Control NONE ER(DTRICTS) XONXOFF
Timeout
Retry
‘wiait To Send
RI/WCC ® Rl ovee
In the case of RS232C, you can select the Sth pin to Rl (Input)
or VCC (5V Power Supply). If you use the Digital's RS232C
|zolation Unit, please select it to VCC. Default
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
Add Indirect
Mo. Device Name Settings Device
1 |PLCT

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | SR

B Individual

PLC1

Series KV-Nano ~
Flease reconfirm all of address settings that
you are using if you have changed the series.

Bit set in word address operation

Other bits in this word (® Clear

(O Do not clear
Mote on when selecting "Do not clear” : If
the ladder program writes data to the word

address during the read/write process, the
resulting data may be incorrect.

Default

QK {0) Cancel
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B External Device Settings

Use ladder software KV STUDIO Ver. § or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.
(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and
click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.
(5) On the [Select unit (1)] tab, from the [Extension Adapter Selection] area select "KV-NC10L".

(6) Configure the [Extension Adapter (Port1)] as follows.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-232C (Fixed)
Baud Rate Auto (Fixed)
Data Bit Length 8 bits (Fixed)
Port 1 Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
RS/CS Flow Control Disabled
Base Node No. 0
gee:::gs ;I'Sr:crzss;‘er timeout time 3 (Fixed)

(7) From the [Convert] menu, select [Auto-assign relay/DM].

(8) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(9) Click [Yes].

(10)From the [Monitor/Simulator] menu, select [ Transfer to PLC] to display the [Transfer Program] dialog box.

(11)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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3.28 Setting Example 28
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1
Summary Change Device/PLC
Manuf [KEYENCE Corporation Series  [KV-700 - 8000 SIO | Port [com
Text Data Mode Chanoe
Communication Settings
SI0 Type (®) R5232C () R5422/485(2wire) () R5422/485(4wire)
Speed
[Diata Length 7 8
Parity NONE EVEN ooD
Stop Bit 1 2
Flow Control NONE ER(DTRICTS) XONXOFF
Timeout l
Retry
‘wiait To Send
RI/WCC ® Rl ovee
In the case of RS232C, you can select the Sth pin to Rl (Input)
or VCC (5V Power Supply). If you use the Digital's RS232C
|zolation Unit, please select it to VCC. Default
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
Add Indirect
Mo. Device Name Settings Device
PLCY ]
@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | IR

B Individual

PLC1

Series KV-Nano ~

Flease reconfirm all of address settings that
you are using if you have changed the series.

Bit set in word address operation

Other bits in this word (® Clear

(O Do not clear
Mote on when selecting "Do not clear” : If
the ladder program writes data to the word

address during the read/write process, the
resulting data may be incorrect.

Default

QK {0) Cancel
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B External Device Settings

Use ladder software KV STUDIO Ver. § or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.
(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and
click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.
(5) On the [Select unit (1)] tab, from the [Extension Adapter Selection] area select "KV-NC20L".

(6) Configure the [Extension Adapter (Port1)] as follows.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-232C (Fixed)
Baud Rate Auto (Fixed)
Data Bit Length 8 bits (Fixed)
Port 1 Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
RS/CS Flow Control Disabled
Base Node No. 0
gee:::gs ;I'Sr:crzss;‘er timeout time 3 (Fixed)

(7) From the [Convert] menu, select [Auto-assign relay/DM].

(8) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(9) Click [Yes].

(10)From the [Monitor/Simulator] menu, select [ Transfer to PLC] to display the [Transfer Program] dialog box.

(11)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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3.29 Setting Example 29
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1
Summary Change Device/PLC
Manuf [KEYENCE Corporation Series  |KV-700 - 8000 510 | Port [com
Text Data Mode Change
Communication Settings
SI0 Type (®) R5232C () R5422/485(2wire) () R5422/485(4wire)
Speed
[Diata Length 7 8
Parity NONE EVEN ooD
Stop Bit 1 2
Flow Control NONE ER(DTRICTS) XONXOFF
Timeout l
Retry
‘wiait To Send
RI/WCC ® Rl ovee
In the case of RS232C, you can select the Sth pin to Rl (Input)
or VCC (5V Power Supply). If you use the Digital's RS232C
|zolation Unit, please select it to VCC. Default
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
Add Indirect
Mo. Device Name Settings Device
PLCY ]
@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] I

B Individual

PLC1

Series KV-Nano ~

Flease reconfirm all of address settings that
you are using if you have changed the series.

Bit set in word address operation

Other bits in this word (® Clear

(O Do not clear
Mote on when selecting "Do not clear” : If
the ladder program writes data to the word

address during the read/write process, the
resulting data may be incorrect.

Default

QK {0) Cancel

GP-Pro EX Device/PLC Connection Manual 67



KV-700 - 8000 SIO Driver

B External Device Settings

Use ladder software KV STUDIO Ver. § or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.
(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and
click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.
(5) On the [Select unit (1)] tab, from the [Extension Adapter Selection] area select "KV-NC20L".

(6) Configure the [Extension Adapter (Port2)] as follows.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-232C (Fixed)
Baud Rate Auto (Fixed)
Data Bit Length 8 bits (Fixed)
Port 2 Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
RS/CS Flow Control Disabled
Base Node No. 0
gee:::gs ;I'Sr:crzss;‘er timeout time 3 (Fixed)

(7) From the [Convert] menu, select [Auto-assign relay/DM].

(8) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(9) Click [Yes].

(10)From the [Monitor/Simulator] menu, select [ Transfer to PLC] to display the [Transfer Program] dialog box.

(11)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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3.30 Setting Example 30
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1
Summary Change Device/PLC
Manuf [KEYENCE Corporation Series  |KV-700 - 8000 510 | Port [com
Text Data Mode Change
Communication Settings
SI0 Type (O RS232C () R5422/485(2wire) (@) RS5422/485(4wire)
Speed
[iata Length 7 g
Parity NONE EVEN ooD
Stop Bit 1 2
Flow Control NONE ER(DTRICTS) XONXOFF
Timeout f |
Retry
‘wait To Send
RI/WCC Rl VCC
In the case of RS232C, you can select the Sth pin to Rl (Input)
or VICC (5 Power Supply). If you use the Digital's RS232C
|zolation Unit, please select it to VCC.
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
Add Indirect
Mo, Device Name Settings Device
1 [pLct t| [Series=KV-Nano |

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] I

Series KV-Nano ~

Flease reconfirm all of address settings that
you are using if you have changed the series.

Bit set in word address operation

Other bits in this word (® Clear

(O Do not clear
Mote on when selecting "Do not clear” : If
the ladder program writes data to the word

address during the read/write process, the
resulting data may be incorrect.

Default

QK {0) Cancel
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B External Device Settings

Use ladder software KV STUDIO Ver. § or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.
(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and
click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.
(5) On the [Select unit (1)] tab, from the [Extension Adapter Selection] area select "KV-NC20L".

(6) Configure the [Extension Adapter (Port2)] as follows.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-422A/485 (4wire)
Baud Rate Auto (Fixed)
Data Bit Length 8 bits (Fixed)
Port 2 Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
RS/CS Flow Control Disabled
Base Node No. 0
gee:::gs ;I'Sr:crzss;‘er timeout time 3 (Fixed)

(7) From the [Convert] menu, select [Auto-assign relay/DM].

(8) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(9) Click [Yes].

(10)From the [Monitor/Simulator] menu, select [ Transfer to PLC] to display the [Transfer Program] dialog box.

(11)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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3.31 Setting Example 31
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1
Summary Change Device/PLC
Manuf [KEYENCE Corporation Series  |KV-700 - 8000 510 | Port [com
Text Data Mode Change
Communication Settings
SI0 Type (O RS232C (@) RS5422/485(2wire) () RS5422/485(4wire)
Speed
[iata Length 7 2
Parity NONE EVEN ooD
Stop Bit 1 2
Flow Control NONE ER(DTRICTS) XONXOFF
Timeout [
Retry
‘wait To Send
RI/WCC Rl VCC
In the case of RS232C, you can select the Sth pin to Rl (Input)
or VCC (5 Power Supply). If you use the Digital's RS232C
|zolation Unit, please select it to VCC.
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
Add Indirect
Mo, Device Name Settings Device
1 [pLct [Series=Kv-Nano

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] I

Series KV-Nano ~

Flease reconfirm all of address settings that
you are using if you have changed the series.

Bit set in word address operation

Other bits in this word (® Clear

(O Do not clear
Mote on when selecting "Do not clear” : If
the ladder program writes data to the word

address during the read/write process, the
resulting data may be incorrect.

Default

QK {0) Cancel
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B External Device Settings

Use ladder software KV STUDIO Ver. § or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.
(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and
click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.
(5) On the [Select unit (1)] tab, from the [Extension Adapter Selection] area select "KV-NC20L".

(6) Configure the [Extension Adapter (Port2)] as follows.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-422A/485 (2wire)
Baud Rate Auto (Fixed)
Data Bit Length 8 bits (Fixed)
Port 2 Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
RS/CS Flow Control Disabled
Base Node No. 0
gee:::gs ;I'Sr:crzss;‘er timeout time 3 (Fixed)

(7) From the [Convert] menu, select [Auto-assign relay/DM].

(8) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(9) Click [Yes].

(10)From the [Monitor/Simulator] menu, select [ Transfer to PLC] to display the [Transfer Program] dialog box.

(11)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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|

3.32 Setting Example 32
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1

Summary Change Device/PLC
Manuf [KEYENCE Corporation Series  [KV-700 - 8000 SIO | Port [com

Text Data Mode Change

Communication Settings
SI0 Type (®) R5232C () R5422/485(2wire) () R5422/485(4wire)
Speed
Data Length
Parity NONE EVEN ooD
Stop Bit 1 2
Flow Control NONE ER(DTRICTS) XONXOFF

Timeout

Retry

‘wiait To Send

RI/WCC @RI owce

In the case of RS232C, you can select the Sth pin to Rl (Input)
or VCC (5V Power Supply). If you use the Digital's
|zolation Unit, please select it to VCC.

e
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
Add Indirect
Mo. Device Name Settings Device

1 |PLCT

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | TR

B Individual

PLC1

Series KV-8000 i

Flease reconfirm all of address settings that
you are using if you have changed the series.

Bit set in word address operation

Other bits in this word (® Clear

(O Do not clear
Mote on when selecting "Do not clear” : If
the ladder program writes data to the word

address during the read/write process, the
resulting data may be incorrect.

Default

OK (0) Cancel
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B External Device Settings

Use ladder software KV STUDIO Ver. 10 or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.
(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and
click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.

(5) On the [Select unit (1)] tab, from the displayed list of units select "KV-L20V", then drag & drop to the unit

placement area.
(6) In the unit placement area click "KV-L20V" and then select the [Setup unit (2)] tab.

(7) Configure the setup items as follows.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-232C (Fixed)
Baud Rate Auto (Fixed)
Data Bit Length 8 bits (Fixed)
Port 1 Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
RS/CS Flow Control Disabled
Base Node No. 0
gee:::gs ;I'Sr:crzss;‘er timeout time 3 (Fixed)

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(12)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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3.33 Setting Example 33
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1
Summary Change Device/PLC
Manuf [KEYENCE Corporation Series  [KV-700 - 8000 SIO | Port [com
Text Data Mode Chance
Communication Settings
SI0 Type (®) R5232C () R5422/485(2wire) () R5422/485(4wire)
Specd .
Data Length 7 8
Parity NONE EVEN ooD
Stop Bit 1 2
Flow Control NONE ER(DTRICTS) XONXOFF
Timeout
Retry
‘wiait To Send
RI/WCC ® Rl ovee
In the case of RS232C, you can select the Sth pin to Rl (Input)
or VCC (5 Power Supply). If you use the Digital's RS232C
|zolation Unit, please select it to VCC. I Defadt |
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
Add Indirect
Mo. Device Name Settings Device
PLCT (it | [Series=Kv-2000

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | SR

B Individual

PLC1

Series KV-8000 i

Flease reconfirm all of address settings that
you are using if you have changed the series.

Bit set in word address operation

Other bits in this word (® Clear

(O Do not clear
Mote on when selecting "Do not clear” : If
the ladder program writes data to the word

address during the read/write process, the
resulting data may be incorrect.

Default

OK (0) Cancel
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B External Device Settings

Use ladder software KV STUDIO Ver. 10 or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.
(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and
click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.

(5) On the [Select unit (1)] tab, from the displayed list of units select "KV-L20V", then drag & drop to the unit

placement area.
(6) In the unit placement area click "KV-L20V" and then select the [Setup unit (2)] tab.

(7) Configure the setup items as follows.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-232C
Baud Rate Auto (Fixed)
Port 2 Data Bit Length 8 bits (Fixed)
Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
Base Node No. 0
g::::gs ;I;r:gss;‘er timeout time 3 (Fixed)

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(12)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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3.34 Setting Example 34
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1
Summary Change Device/PLC
Manuf [KEYENCE Corporation Series  [KV-700 - 8000 SIO | Port [com
Text Data Mode Change
Communication Settings
SI0 Type (O RS232C () R5422/485(2wire) (W) RS5422/485(4wire)
Speed [13200 |
[iata Length 7 2
Parity NONE EVEN ooD
Stop Bit 1 2
Flow Control NONE ER(DTRICTS) XONXOFF
Timeout
Retry
‘wiait To Send
RI/WCC Rl VCC
In the case of RS232C, you can select the Sth pin to Rl (Input)
or VCC (5 Power Supply). If you use the Digital's RS232C
|zolation Unit, please select it to VCC.
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
Add Indirect
Mo, Device Name Settings Device
1 [Pt [Series=Kv-8000 Iz

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | SR

Series KV-8000 t
Flease reconfirm all of address settings that
you are using if you have changed the series.

Bit set in word address operation

Other bits in this word (® Clear

(O Do not clear
Mote on when selecting "Do not clear” : If
the ladder program writes data to the word

address during the read/write process, the
resulting data may be incorrect.

Default

OK (0) Cancel
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B External Device Settings

Use ladder software KV STUDIO Ver. 10 or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.
(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and
click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.

(5) On the [Select unit (1)] tab, from the displayed list of units select "KV-L20V", then drag & drop to the unit

placement area.
(6) In the unit placement area click "KV-L20V" and then select the [Setup unit (2)] tab.

(7) Configure the setup items as follows.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-422A/485 (4wire)
Baud Rate Auto (Fixed)
Port 2 Data Bit Length 8 bits (Fixed)
Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
Base Node No. 0
g::::gs ;I;r:gss;‘er timeout time 3 (Fixed)

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(12)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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3.35 Setting Example 35
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1
Summary Change Device/PLC
Manuf [KEYENCE Corporation Series  [KV-700 - 8000 SIO | Port [com
Text Data Mode Change
Communication Settings
SI0 Type (O RS232C (@) RS5422/485(2wire) () R5422/485(4wire)
Speed [13200 |
[iata Length 7 2
Parity NONE EVEN ooD
Stop Bit 1 2
Flow Control NONE ER(DTRICTS) XONXOFF
Timeout
Retry
‘wiait To Send
RI/WCC Rl VCC
In the case of RS232C, you can select the Sth pin to Rl (Input)
or VCC (5 Power Supply). If you use the Digital's RS232C
|zolation Unit, please select it to VCC.
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
Add Indirect
Mo, Device Name Settings Device
1 [Pt [Series=Kv-8000 Iz

@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | SR

PLC1

Series KV-8000 i

Flease reconfirm all of address settings that
you are using if you have changed the series.

Bit set in word address operation

Other bits in this word (® Clear

(O Do not clear
Mote on when selecting "Do not clear” : If
the ladder program writes data to the word

address during the read/write process, the
resulting data may be incorrect.

Default

OK (0) Cancel
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B External Device Settings

Use ladder software KV STUDIO Ver. 10 or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.
(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and
click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.

(5) On the [Select unit (1)] tab, from the displayed list of units select "KV-L20V", then drag & drop to the unit

placement area.
(6) In the unit placement area click "KV-L20V" and then select the [Setup unit (2)] tab.

(7) Configure the setup items as follows.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-485 (2wire)
Baud Rate Auto (Fixed)
Port 2 Data Bit Length 8 bits (Fixed)
Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
Base Node No. 0
g::::gs ;I;r:gss;‘er timeout time 3 (Fixed)

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(12)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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4 Setup Items

Set up the Display’s communication settings in GP-Pro EX or in the Display’s offline mode.
The setting of each parameter must match that of the External Device.

&~ 3 Communication Settings" (page 12)

4.1 Setup ltems in GP-Pro EX

B Communication Settings
To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1

Summary Change Device/PLC
Manufacturer |KEYENCE Corporation Series  [KV-700 - 8000 SIO | Port [com
Text Data Mode Change

Communication Settings

SI0 Type (®) R5232C () R5422/485(2wire) () R5422/485(4wire)
Speed 19200 ~

Data Length 7 8

Parity NONE EVEN ooD

Stop Bit 1 2

Flow Control NONE ER(DTRICTS) XONXOFF

Timeout 3 + (sec)

Retry 2 3

‘wait To Send 0 + (ms)

RI/VCC ® Rl ovee

In the case of RS232C, you can select the Sth pin to Rl (Input)
or VCC (5V Power Supply). If you use the Digital's RS232C

|zolation Unit, please select it to VCC. Default
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
Add Indirect
Mo. Device Name Settings Device
& 1 [Pt | ] [Series=Kv-700/1000 a
Setup Items Setup Description
SIO Type Select the SIO type for communicating with the External Device.
Speed Select the communication speed between the External Device and the Display.
Data Length Select a data length.
Parity Select how to check parity.
Stop Bit Select a stop bit length.
Select the communication control method to prevent overflow of transmission and reception
Flow Control
data.
) Enter the time (s) for which the Display waits for the response from the External Device, from
Timeout N "
1to 127".
In case of no response from the External Device, enter how many times the Display retransmits
Retry " "
the command, from "0 to 255".
Wait To Send Enter the standby time (ms) from when the Display receives packets until it transmits the next

command, from "0 to 255".
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Setup Items Setup Description

You can switch between RI/VCC for the 9th pin when you select RS-232C for SIO type.
RI/VCC To connect to the IPC, switch between RI/5V using the IPC selector switch. Refer to your IPC
manual for details.

NOTE e Refer to the GP-Pro EX Reference Manual for Indirect Device.

Cf.  GP-Pro EX Reference Manual "Changing the Device/PLC at Runtime (Indirect
Device)"

W Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | IR

2 Individual Device Settings

PLC1

Series KV-700/1000 i

Flease reconfirm all of address settings that
you are using if you have changed the series.

Bit set in word address operation

Other bits in this word (® Clear

(O Do not clear
Mote on when selecting "Do not clear” : If
the ladder program writes data to the word

address during the read/write process, the
resulting data may be incorrect.

Default

QK {0) Cancel

Setup Iltems Setup Description

Series Select the series of the External Device.

Select "Clear" or "Do not clear" for the handling of other bit data in the same word when a

Other bits in this word bit operation is performed to a bit specified word address.
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4.2 Setup Items in Offline Mode
NOTE » Refer to the Maintenance/Troubleshooting guide for information on how to enter offline mode

or about the operation.
Cf.  Maintenance/Troubleshooting Guide "Offline Mode"

* The number of the setup items to be displayed for 1 page in the offline mode depends on the

Display in use. Please refer to the Reference manual for details.

B Communication Settings

To display the setting screen, touch [Device/PLC Settings] from [Peripheral Settings] in offline mode. Touch the

External Device you want to set from the displayed list.

Cormm, Device Option
KyY=TH0 - 8000 S10 [COM1] Page 1/1
510 Tvpe 52320 ]
Speed 19200 I~
Data Length 8
Farity EVEN
Stop Bit 1
Flow Control MONE
Timeout(s) 3w | A
Retry 7w | A
Wait to Send(ms) i - a
; ZH22 /0126
Setup Items Setup Description

Select the SIO type for communicating with the External Device.

In the communication settings, set [SIO Type] correctly according to the serial interface

SIO Type specifications of the Display.
If you select an SIO type that the serial interface does not support, proper operation cannot
be guaranteed.
Refer to your Display manual for details on the serial interface specifications.

Speed Select the communication speed between the External Device and the Display.

Data Length Data length is displayed.
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Setup Items Setup Description
Parity The parity check method is displayed.
Stop Bit Stop bit length is displayed.
The communication control method to prevent overflow of transmission and reception
Flow Control
data.
) Enter the time (s) for which the Display waits for the response from the External Device,
Timeout
from "1 to 127".
Ret In case of no response from the External Device, enter how many times the Display
ry retransmits the command, from "0 to 255".
Wait To Send Enter the standby time (ms) from when the Display receives packets until it transmits the

next command, from "0 to 255".

W Device Setting

To display the setting screen, touch [Device/PLC Settings] from [Peripheral Settings]. Touch the External Device

you want to set from the list that appears, and touch [Device].

Gomm, Device Option
KyV=TRE - SA0A 510 [COM] ] Page 1/1
Device/PLC Name [PLCT >
Series K\V=TRA, 1RBR
Bit set in word address operation
Other bits Clear
Setup Items Setup Description

Device/PLC Name

Select the External Device to set. Device/PLC Name is the title of the External Device set
with GP-Pro EX. (Initial value [PLC1])

Series

Displays the series of the External Device.

Bit set in word address
operation

Displays "Clear" or "Do not clear" for the handling of other bit data in the same word when
a bit operation is performed to a bit specified word address. (Cannot be set in offline
mode.)
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]

W Option
To display the setting screen, touch [Device/PLC Settings] from [Peripheral Settings]. Touch the External Device

you want to set from the list that appears, and touch [Option].

Setup Items Setup Description

You can switch between RI/VCC for the 9th pin when you select RS-232C for SIO type.
RI/VCC To connect to the IPC, you need to switch between RI/5V using the IPC selector switch.
Refer to your IPC manual for details.

NOTE e GP-4100 series, GP-4*01TM, GP-Rear Module, LT-4*01TM and LT-Rear Module do not
have the [Option] setting in the offline mode.
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5 Cable Diagrams

The cable diagrams shown below may be different from the cable diagrams recommended by KEYENCE

Corporation. Please be assured there is no operational problem in applying the cable diagrams shown in this

manual.

* The FG pin on the External Device must be D-class grounded. Refer to your External Device manual for
details.

* The SG and FG are connected inside the Display. If you connect the External Device to the SG, do not form
any short-circuit loop in the system design.

e If the communication is not stable because of noise or other factors, connect an isolation unit.

Cable Diagram 1

Display
. Cable Remarks
(Connection Port)

GP3000 (COM1)
GP4000"! (COM1)
SP5000"% (COM1/2)
SP-5B00 (COMT) D-sub 9Pin by KEYENCE Corporation
ST3000 (COM1) OP-26436
ST6000 (COM1) 1A +
STM6000 (COMI) Modular cable by KEYENCE Corporation
STC6000 (COM1) OP-26487 (2.5m)
ET6000 (COM1) ’
LT3000 (COM1)
IPC*
PC/AT

User-created cable

+
GP-4105 (COM1) D-sub 9Pin by KEYENCE Corporation
GP-4115T (COM1) 1B OP-26486
GP-4115T3 (COM1) +
Modular cable by KEYENCE Corporation
OP-26487 (2.5m)

*1  All GP4000 models except GP-4100 Series and GP-4203T
*2  Except SP-5B00

*3  Available only with COM ports that support RS-232C.
‘5" m |PC COM Port (page 8)

1A)
Display

External Device

OP-26486

@ - OP-26487 O

NS

Modular connector 6 pin (plug)

D-sub 9 pin (socket)
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1B)

Display side External Device side

Terminal block Shield D-sub 9 pin (plug)

- Sord R [ [ o
RD(RXD) T T 2 RD(RXD)
SD(TXD) : : 3 SD(TXD)
ER(DTR) T 4 ER(DTR)

SG 5 SG

RS(RTS) 7 RS(RTS)
CS(CTS) * 8 |cs(cTs)

1

User-created cable

OP-26486
[,

OP-26487

D-sub 9 pin (socket)

O

e

Modular connector 6 pin (plug)

External Device
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Display
(Connection Port)

Cable

Remarks

GP3000 (COM1)
GP4000"! (COM1)
SP5000"% (COM1/2)
SP-5B00 (COM1)
ST3000 (COM1)
ST6000 (COM1)
STM6000 (COM1)
STC6000 (COM1)
ET6000 (COM1)
LT3000 (COM1)
IPC*3

PC/AT

2A

User-created cable

The cable length must be 15m
or less.

GP-4105 (COMI)
GP-4115T (COM1)
GP-4115T3 (COM1)

2B

User-created cable

The cable length must be 15m
or less.

LT-4*01TM (COM1)
LT-Rear Module
(COM1)

2C

RJ45 RS-232C Cable (5m) by Pro-face
PFXZLMCBRIJR21

The cable length must be 5m or
less.

*1  All GP4000 models except GP-4100 Series and GP-4203T

*2  Except SP-5B00

*3  Available only with COM ports that support RS-232C.

& m |PC COM Port (page 8)

2A)

Display

Display side External Device side
Dsub 9 pin (socket) Shield Dsub 9 pin (socket)
Pin Signal name ‘,’" ,l'“"= Pin Signal name
2 RD(RXD) ,' . 2 RD(RXD)
3 SD(TXD) :;:><:: 3 SD(TXD)
| .
4 ER(DTR) - : , 5 SG
5 SG ; . 7 | RS(RTS)
8 |cs(cTs) e} 8 |cscTy)
Shell FG —o_ i
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2B)
Display side External Device side
Terminal block Shield Dsub 9 pin (socket)
Signal name :'" ',"“",' Pin  |Signal name
Display RD(RXD) 4—§><-§—":—> 2 RD(RXD)
SD(TXD) 3 SD(TXD)
ER(DTR) 5 SG
SG _l ' . 7 RS(RTS)
CS(CTS) <J I—_> 8 | cs(cTs)
' ¥
\.------------.l
2C)
External Device side
Dsub 9 pin (socket)
. Pin Signal name
Display TXD 5 RD(RXD)
RXD 3 | sp(rxp)
(1) Shb 5 SG
7 RS(RTS)
I—_> 8 CS(CTS)
Legend Name Note
RJ45 RS-232C Cable (5m) by Pro-face
) PFXZLMCBRIR21
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KV-700 - 8000 SIO Driver

Display
(Connection Port)

Cable

Remarks

GP3000 (COM1)
GP4000"! (COM1)
SP5000"% (COM1/2)
SP-5B00 (COM1)
ST3000 (COM1)
ST6000 (COM1)
STM6000 (COM1)
STC6000 (COM1)
ET6000 (COM1)
LT3000 (COM1)
IPC*3

PC/AT

3A

User-created cable

The cable length must be 15m
or less.

GP-4105 (COMI)
GP-4115T (COM1)
GP-4115T3 (COM1)

3B

User-created cable

The cable length must be 15m
or less.

LT-4*01TM (COM1)
LT-Rear Module
(COM1)

3C

RJ45 RS-232C Cable (5m) by Pro-face
PFXZLMCBRIJR21

The cable length must be 5Sm or
less.

*1  All GP4000 models except GP-4100 Series and GP-4203T

*2  Except SP-5B00

*3  Available only with COM ports that support RS-232C.
& m |PC COM Port (page 8)

NOTE I

+ Set the PORT?2 toggle switch on the External Device to "232C".

3A)

Display side External Device side
Dsub 9 pin (socket) Shield Terminal block
I' ,T‘\ .
Pin Signal name ! [ Pin Signal name
i P
2 RD(RXD) i — 1 SG
. ' o
Display 3 SD(TXD) ! : ; 3 |spxp)
] 1 1
4 ER(DTR) i — 5 RD(RXD)
5 SG :
i I
8 CS(CTS) ': Vo
\ Vo
Shell FG |—=
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3B)
Display side External Device side
Terminal block Shield Terminal block
Signal name ," \ Pin Signal name
] ]
RD(RXD) v 1 SG
Display SD(TXD) 3 [sD(TxD)
ER(DTR) 5 RD(RXD)
SG
CS(CTS)
3C)
External Device side
Terminal block
Pin Signal name
Display GND
1 SG
RXD
3 SD(TXD)
1 TXD
(1) 5 RD(RXD)
Legend Name Note

(1)

RJ45 RS-232C Cable (5m) by Pro-face

PFXZLMCBRJR21
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KV-700 - 8000 SIO Driver

Display
. Cable Remarks
(Connection Port)
GP3000"! (COM1) COM port conversion adapter by Pro-face
AGP-3302B (COM2) CA3-ADPCOM-01
GP-4*01TM (COM1) _ T
4A Connector terminal block conversion adapter by Pro-face The cable length
GP-Rear Module
(COM1) CA3-ADPTRM-01 must be 500m or
ST30002 (COM2) + less.
LT3000 (COM1) User-created cable
*3
IpC 4B User-created cable
Online adapter by Pro-face
CA4-ADPONL-01
+
4AC Connector terminal block conversion adapter by Pro-face
CA3-ADPTRM-01
+ The cable length
GP3000"1(COM2) User-created cable must be 500m or
less.
Online adapter by Pro-face
CA4-ADPONL-01
4D N
User-created cable
The cable length
GP-4106 (COM1)
GP-4116T (COMI) 4E User-created cable must be 500m or
less.
GP4000"™ (COM2) RS-422 Terminal Block Conversion Adapter by Pro-face
GP-4201T (COM1) AF PFXZCBADTM1"®
SP5000™ (COM1/2) +
SP-5B00 (COM2) User-created cable
ST6000°° (COM2) The cable length
ST-6200 (COM1) must be 500m or
STM6000 (COM1) less.
STC60097(COM1) 4B User-created cable
ET6000 ' (COM2)
PS6000 (Basic Box)
(COM1/2)
*9
PE_4002]; The cable length
PS5000 4G User-created cable must be 500m or
PS6000 (Optional Jess
Interface)*9 '
*1  All GP3000 models except AGP-3302B
*2  Except AST-3211A and AST-3302B
*3  Available only with COM ports that support RS-422/485 (4wire). (Except PE-4000B, PS5000, and PS6000)
" m |IPC COM Port (page 8)
*4  All GP4000 models except GP-4100 Series, GP-4*01TM, GP-Rear Module, GP-4201T and GP-4*03T
*5  Except SP-5B00
*6  Except ST-6200
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*7  Due to the COM port specifications, flow control is not possible. Omit wiring the control pins on the Display
side of the cable diagram.

*8  When using a Terminal Block Conversion Adapter (CA3-ADPTRM-01) instead of the RS-422 Terminal Block
Conversion Adapter, refer to Cable Diagram 4A.

*9  Available only with COM ports that support RS-422/485 (4wire).
" m |IPC COM Port (page 8)

[ IMPORTANT | + Terminal number to be used for communication varies depending on the External
Device. Terminal numbers corresponding to each series are shown below.
Pin KV-L20V KV-N11L
KV-L21V KV-NC20L
SDB(+) 5 2
SDA(-) 3 1
RDB(+) 4 3
RDA(-) 2 4
SG 1 5
» Set the PORT2 toggle switch on the External Device to "422A 485(4)". Also, turn ON the

switch of the terminator.
 Pay attention that pole A and pole B are reversely named for the Display and the External

Device.
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4A)
Termination Display side External Device side
resistance 1€rminal block I____S_}'lig_lc_i___’ Terminal block
2200 14w Signal name ‘;" ',” |‘.| Pin Signal name
Display ~CA3-ADPCOM-01 RDA |« .: /\\ :: :: 5 SDB(+)
] ) )
(= RDB (e T 3 SDA(-)
, =3 /\ !
/ { SDA / \ > 4 RDB(+)
CA3-ADPTRM-01 SDB > 5 RDA(-)
Termination SG ! [ 1 SG
resistance FG & I
220Q 1/4W ',‘ ! ::
|}
TERMRX ‘.\_ ___________ \/
D User-created cable "
4B)
Terminati Display side External Device side
o D-Sub 9 pin (socket) Shield Terminal block
220Q 1/4W Pin Signal name Pin Signal name

SDB(+)

1 RDA |e 5
Display { RDB <—-J \——— 3 SDA(-)
SDA > 4 RDB(+)

{ SDB /\ 2

RDA(-)

/

OClo|h|lOIN]|]W|IN

SG 1 SG
Termination
resistance ERA :I
220Q 1/4W |
CSA ': |
ERB :I b
6 CSB '; b
Shell FG |— V
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|

4C)
. Display side External Device side
Terrpmatnon Terminal block Shield Terminal block
resistance [T
220Q 1/4W | Signal name ! i Pin  [Signal name
| [
Display  CA4-ADPONL-01 { RDA  |&— //\\ i 5 SDB(+)
' b
= RDB |« : 3 SDA()
[ /E /\
/ SDA » 4 RDB(+)
CA3-ADPTRM-01 { SDB / \ ; > 5 RDA()
. .
' ]
Termination SG :. V) 1 SG
resistance FG Y b
220Q 1/4W ! v
TERMRX \ Vi
User-created cable
4D)
Termination Display side _ Externa] Device side
resistance  D-Sub 9 pin (plug) Shield Terminal block
2200 /4w Pin Signal name '." .'“\l Pin Signal name
- 2 RDA |Je—— A1
Display  a4-aDPONL-01 { / \ ' 5 SDB(+)
7 RDB |« L 3 SDA(-)
{ 3 SDA /\\ » 4 RDB(+)
Vs 8 SDB ‘ > 2 RDA(-)
Termination 5 SG ‘.| ‘.' ,' 1 SG
resistance \ v/
2200 14w | Shell FG o ~

User-created cable
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4E)

Display side External Device side
Termination Terminal block Shield Terminal block
resistance 1 Signal name u'l ,"\'u Pin Signal name
i [
- { RDA |« A 5 SDB(+)
i RDB |e—— M4+ 1 3 SDA(-)
AN i
{ SDA : / \ = 4 RDB(+)
SDB > 2 RDA(-)
/ SG 1 SG
Termination ' H
resistance*1| ERA i i
CSA i ;
] ]
ERB :l
] ]
CSB i L
\ [
\ Vi

*1 The resistance in the Display is used as the termination resistance. Set the value of the DIP Switch on the
rear of the Display as shown in the table below.

DIP Switch No. Set Value
1 OFF
2 ON
3 OFF
4 ON
4F)
Termination Display side External Device side
resistance 1erminal block ____S_rliglq___’ Terminal block
2200 4 Signal name ." .'I “. Pin Signal name
i i A I
Display £ RDA [ \ — 5 | spB+)
) ] 1
| = RDB [ ¥ 3 SDA(-)
, =3 ! A
{ SDA y / \ > 4 RDB(+)
PFXZCBADTM1 SDB ; l > > RDAQ)
] ] ]
L] ] ]
Termination SG ] vl 1 SG
resistance FG Y ]
220Q 1/4W :‘ 'll "'
TERMRX |L \/

User-created cable
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4G)
o Display side External Device side
Termination  _gyp 9 pin (socket) Shield Terminal block
resistance , o
220Q 174w Pin Signal name / i Pin Signal name
| /\ [
{ 3 Rx+ < ,' 1 " 5 SDB(+)
Displ i/ P
isplay 4 Rx- . 3 SDA(-)
{ 2 Tx+ //\\ > 4 RDB(+)
1 Tx- —> 2 RDA(-)
/ 5 GND 1 SG
Termination
resistance 7 NC
220Q 1/4W
8 NC
9 NC ; b
1 H
6 NC '- b
\ Vi
Shell FG |—% v
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Cable Diagram 5

KV-700 - 8000 SIO Driver

Display
. Cable Notes
(Connection Port)
COM port conversion adapter by Pro-face
AGP-3302B (COM2) _ +
GP-4%01TM (COM1) S5A Terminal block conversion adapter by Pro-face Cable length:
GP-Rear Module (COM1) CA3-ADPTRM-01 1000m or less
ST3000"2 (COM2) *
LT3000 (COM1) User-created cable
5B User-created cable
Online adapter by Pro-face
CA4-ADPONL-01
+
5C Terminal block conversion adapter by Pro-face
CA3-ADPTRM-01
GP3000*3 (COM2) +
User-created cable
Online adapter by Pro-face
5D CA4-ADPONL-01
+ Cable length:
User-created cable 1000m or less
COM port conversion adapter by Pro-face
CA3-ADPCOM-01
+
‘4 SE Terminal block conversion adapter by Pro-face
IPC CA3-ADPTRM-01
+
User-created cable
S5F User-created cable
GP-4106 (COM1) Cable length:
GP-4116T (COMI) >G User-created cable 1000m or less
GP-4107 (COM1) )
GP-4*03T"5 (COM2) 5H User-created cable lcgg(l);li‘ﬁhs's
GP-4203T (COM1)
GP4000"° (COM2) RS-422 Terminal Block Conversion Adapter by Pro-face
GP-4201T (COM1) 5 PFXZCBADTM1 10
SP5000"7 (COM1/2) +
SP-5B00 (COM2) User-created cable
ST6000"8 (COM2) ,
caei
STM6000 (COM1)
STC6OO,99 (COMI) 5B User-created cable
ET6000 ~ (COM2)
PS6000 (Basic Box)
(COM1/2)
LT-4*01TM (COM1) RJ45 RS-485 Cable (5m) by Pro-face Cable lenath:
LT-Rear Module (COM1) 5] PFXZLMCBRIJRS1 gt

200m or less
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(Connection Port)

Displ
Isplay Cable Notes

PE-4000B™!!
PS5000*!! Cable length:

5K User-created cable

PS6000 (Optional 1000m or less
Interface)* 1

*]
%)
*3
*4

*5
*6
*7
*8
*9

*10

*11

All GP3000 models except AGP-3302B
Except AST-3211A and AST-3302B
All GP3000 models except GP-3200 series and AGP-3302B

Only the COM port which can communicate by RS-422/485 (2 wire) can be used. (Except PE-4000B, PS5000,
and PS6000)
&” m |PC COM Port (page 8)

Except GP-4203T

All GP4000 models except GP-4100 Series, GP-4*01TM, GP-Rear Module, GP-4201T and GP-4*03T
Except SP-5B00

Except ST-6200

Due to the COM port specifications, flow control is not possible. Omit wiring the control pins on the Display
side of the cable diagram.

When using a Terminal Block Conversion Adapter (CA3-ADPTRM-01) instead of the RS-422 Terminal Block
Conversion Adapter, refer to Cable Diagram 5A.

Onélthe COM port which can communicate by RS-422/485 (2 wire) can be used.
m |[PC COM Port (page 8)

» Terminal number to be used for communication varies depending on the External Device.
Terminal numbers corresponding to each series are shown below.

bin KV-L20V KV-N11L
KV-L21V KV-NC20L
SG 1 5
S/R(-) 3 1
S/R(+) 5 2
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5A)
Display side
Terminal block
Termination Signal Shield
reS'S‘ZaZ";S | name | /~"""""==-m, External Device side
Display CA3-ADPCOM-01 RDA |« ,'l / \  Terminal block
! ! \ Signal
RDB |e—f . name
| | sba i At——»l SIR(+)
[, = A =
SDB 4 ' S/R(-) -
! \ H Termination
CA3-ADPTRM-01 SG \ R SG |resistance
FG AN 4 2200
User-created cable
5B)
Display side
Display D-sub 9 pin (socket)
Pin Signal Shield
name T =, External Device side
% 1 RDA [¢— /% Terminal block
! ! \ Signal
Termination 2 RDB |« | :" "n name
resistance | 3 SDA /A\i > S/R(+) %
7 | SbB — > SRO) =T
\ \ ! Termination
5 SG 2 s SG |resistance
2 | N, A 2200
ERA
8 CSA 4—,
9 ERB
6 CSB |«
Shell FG
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5C)
Display side
Terminal block
Termination Signal Shield
T e [—name oo ~, External Device side
Display CA4-ADPONL-01 % RDA |« // '/I \“ Termn;nal block
ROB et {1 [
- = P R
[ SDA E / i ! S/R(+) %
7 SDB 1 “——» S/R(-
"‘ '\ H () Termination
CA3-ADPTRM-01 sSG \ - SG |resistance
G N\ v 2200
_.---------\f'
User-created cable
5D)
Display side
D-sub 9 pin (plug)
Termination -
) ; Signal .
Raliiog Pin_| name ~-3hield ____ External Device side
Disol 2 RDA [ /7 Terminal block
Isplay % L / \ Signal
7 RDB |« i ‘,' ‘ll name
3 | SDA [ /‘\ T SIR(H) %
\ \ 1 o ~
8 SDB \\ '\\ /" > S/RC) Termination
CA4-ADPONL-01 5 SG N 7 SG_ [fesistance
shell | FG —
User-created cable
5E)
Display side External Device side
~_ Terminal block Shield Terminal block
Temalen FSena) S [ S
2200 name "I I, \‘ name
CA3-ADPCOM-01 RDA A————> S/R(+)
Display % — ! /\! I‘. %
1 S/R(-
| ! ' ) Termination
[ % SDA E ' " SG |resistance
i / ] 2200
7; SDB : Voo
CA3-ADPTRM-01 SG \ Vo
\ o
FG ooV

v

F 3

User-created cable
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5F)

Display side

Display

D-sub 9 pin (socket)

Shield

Pin

Signal /
name

External Device side
Terminal block

DATA+ |«

=

Termination

DATA-

resistance
220Q

Signal

name
Termination

SIR(+)
SIR(-)

SG |resistance
220Q

SG(GND)

NC

NC

ERA

CSA

Ol |IN|W|O|IN|-

ERB

CSB

A

Shell

FG

5G)

Display side

Display

Terminal block

Shield

Signal / 7\
\ name

name

External Device side
Terminal block

F 3

RDA

=]

Termination

A

RDB

resistance
2200

SDA

~~
~<

SDB

SG ; »

ERA

CSA

ERB

A

CSB

*1

rear of the Display as shown in the table below.

DIP Switch No.

Set Value

1

OFF

OFF

OFF

2
3
4

ON

SIR(+)
SIR(-)
SG

Signal

Termination
resistance
2200

The resistance in the Display is used as the termination resistance. Set the value of the DIP Switch on the
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5H)
Display side External Device side
Display D-sub 9 pin .(plug) ___Shield____ Termsinal tIJIock
Pin | “sma | 7 name
3 LINE+ & AT —>| S/R(+) %
Termination 8 LINE- ! H ! S/R(_) Termination
resistance 5 SG(GND) \ \ ] SG |resistance
2200 \ \ K 2200
1 NC N\ \ J
2 N | [T -
4 RS(RTS)
6 5V
7 NC
9 NC
Shell FG

e In COM on the GP-4107, the SG and FG terminals are isolated.

51)
Display side
Terminal block
Termination Signal Shield
reSIstzaznocS name T ~, External Device side
Display RDA |« ',' / \‘ Termihal block
RDB |e—t fo Pane
o | !
—J ! A+———»| SIR(+
= BPRA TN WiZ
SDB 0 1 S/R(-) -
\ \ H Termination
PFXZCBADTM1 SG \ S SG |resistance
RWRX| N 2200
o]

\ 4

A

User-created cable
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5J)
External Device side
Terminal block
Signal
name
Displ D1(+
isplay ) SIR(+) %
20 SRO
ermination
(1) GND SG |[resistance
2200
Number Name Notes
RJ45 RS-485 Cable (5m) by Pro-face
(1) PFXZLMCBRIJRS1
5K)
Display side External Device side
Display D-sub 9 pin (socket) Shield Terminal block
- i '"""“"',7\\ Si |
e[Sl N [
\
% 2 |DATA+|e— /" > SIR(+) %
! \! .
Termination 1 DATA- |« ! ! | SRO) Termination
resistance 3 NC 1 ! SG |[resistance
2200 ". ', 2200
7 NC \ \
\ \
5 | GND E |
4 NC
8 NC
9 NC
6 NC
Shell FG
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6 Supported Device

The range of supported device addresses is shown in the table below. Please note that the actual supported range
for devices varies depending on the external device that is used. Please check the actual range in the external

device manual.

6.1 KV-700 Series
[==——1 : This address can be specified as system data area.
Device Bit Address Word Address 32 bits Remarks
Input Relay
Output Relay 00000 - 59915 000 - 599 rLIH)
Internal Auxiliary Relay
Control Relay CRO0000 - CR3915 CROO - CR39
Timer (Contact) TOOO-T511 |  —eeee
Counter (Contact) cooo-Ccs511 | e )
High-speed Counter *]
Comparator (Contact) creo-cres o e
Timer (Setting Value) | = —— TS000 - TS511 2
Counter (Setting Value) | - CS000 - CS511 2
Timer (Current Value) | - TC000 - TC511 2
Counter (Current Value) | = - CC000 - CC511 2
Data Memory | DM00000 - DM39999 6
Temporary Data Memory | = - TMO000 - TM511 LIH 157
Control Memory | - CMO0000 - CM3999 15"
Digital Trimmer | - TRMO - TRM7 "2
High-speed Counter )
(CurrentVvalue) | 7 CTHO - CTHI
High-speed Counter )
Comparator (Setting Value) | CTC0 - CTC3

*1  Write disable
*2  32-bit device

*3  The access method when specifying bits is different depending on the setting of "Other bits in this word" in
"Individual Device Settings".

[Do not clear] ..... When bits are written, the Display reads the corresponding word address from the External
Device, sets particular bits of that word address to ON, and then returns the resulting address
to the External Device. Note that the data may not be written correctly if you write to the word
address using the ladder program while the Display is reading data from, and writing data to,
the External Device.
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* When connecting KV-700 Series, use settings within the device address ranges above.

* Ifyou try to access device addresses supported only by the KV-1000 Series devices, the following
error messages display: "Error has been responded for device read command (Error
Code(02)[(0x02)]" or "Error has been responded for device write command (Error
Code(02)[(0x02)]".

NOTE | * Refer to the GP-Pro EX Reference Manual for system data area.
Cf.  GP-Pro EXReference Manual "LS Area (Direct Access Method Area)"

» Refer to the precautions on manual notation for icons in the table.

&~ "Manual Symbols and Terminology"
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6.2 KV-1000 Series
[=== : This address can be specified as system data area.
Device Bit Address Word Address 32 bits Remarks
Input Relay *l
Output Relay 00000 - 59915 000 - 599 *
Internal Auxiliary Relay rLIH|
Internal Auxiliary Relay MRO00000 - MR99915 MRO000 - MR999
Latch Relay LR00000 - LR99915 LRO00 - LR999
Control Relay CR0000 - CR3915 CROO - CR39
Timer (Contact) T0000-T3999 | -
Counter (Contact) C0000-C3999 | - i
High-speed Counter 2
Comparator (Contact) creo-cres e
Timer (Setting Value) | - TS0000 - TS3999 "3
Counter (Setting Value) | - CS0000 - CS3999 3
Timer (Current Value) | - TC0000 - TC3999 3
Counter (Current Value) | - CC0000 - CC3999 3
Data Memory | e DMO00000 - DM65534 A5
Extension Data Memory EM | - EMO00000 - EM65534 o L
Extension Data Memory FM | - FMO00000 - FM32766 o *4
y Lim | E 15
Temporary Data Memory | - TMO000 - TM511 — 15"
Control Memory | CMO00000 - CM11998 15
Index Register | e Z01-2712 157
Digital Trimmer | TRMO - TRM7 "3
High-speed Counter *3
(CurrentValue) | T CTHO - CTHI
High-speed Counter *3
Comparator (Setting Value) | CTCO-CTC3

*1  R000 to R599 (RO0000 to R59915) are shown in KV-1000, but 000 to 599 (00000 to 59915) in GP-Pro EX.

*2  Write disable
*3  32-bit device
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*4  The access method when specifying bits is different depending on the setting of "Other bits in this word" in
"Individual Device Settings".

[Do not clear] ..... When bits are written, the Display reads the corresponding word address from the External
Device, sets particular bits of that word address to ON, and then returns the resulting address
to the External Device. Note that the data may not be written correctly if you write to the
word address using the ladder program while the Display is reading data from, and writing
data to, the External Device.

*5 Do not write to the addresses Z11 and Z12. They are used in the system of the External Device.

NOTE | * Refer to the GP-Pro EX Reference Manual for system data area.
Cf.  GP-Pro EX Reference Manual "LS Area (Direct Access Method Area)"

« Refer to the precautions on manual notation for icons in the table.

&~ "Manual Symbols and Terminology"
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6.3 KV-3000/5000/5500 Series
[=== : This address can be specified as system data area.
Device Bit Address Word Address 32 bits | Remarks

Input Relay
Output Relay R00000 - R99915 R0O00 - R999
Internal Auxiliary Relay
Link Relay B0000 - B3FFF B000 - B3FF rLIH|
Internal Auxiliary Relay MRO00000 - MR99915 MRO000 - MR999
Latch Relay LRO00000 - LR99915 LRO000 - LR999
Control Relay CRO000 - CR3915 CROO - CR39
Work Relay VB0000 - VB3FFF VBO000 - VB3FF
Timer (Contact) T0000 -T3999 | e
Counter (Contact) C0000-C3999 | - )
Comparator Contact) e §
Timer (Setting Value) | TS0000 - TS3999 2
Counter (Setting Value) | - CS0000 - CS3999 2
Timer (Current Value) | = - TC0000 - TC3999 "2
Counter (Current Value) |  —— CC0000 - CC3999 2
DataMemory | DMO00000 - DM65534 b
Extension Data Memory | - EMO00000 - EM65534 b

CurrentBank | - FMO00000 - FM32767 5
File
Register gssfe'n:'”mber ------ ZF000000 - ZF131071 =157
Temporary Data Memory | - TMO000 - TM511 w m*3
Control Memory | - CMO00000 - CM05999 m*3
Link Register [ W0000 - W3FFF A
Work Memory | e VMO00000 - VM59999 15"
Index Register | e Z01-2712 2 %4
Digital Trimmer | TRMO - TRM7 "2
\H/;glg:;peed Counter (Current | CTHO - CTHI )
gfr:;as:r::c?r ?Sotl;trt]itri; Value) | T CTCO-CTC3 *

*1 Write disable
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*2  32-bit device

*3  The access method when specifying bits is different depending on the setting of "Other bits in this word" in
"Individual Device Settings".

[Clear] ..ovrvennn. e 9] [EF]

[Do not clear] ..... When bits are written, the Display reads the corresponding word address from the External
Device, sets particular bits of that word address to ON, and then returns the resulting address
to the External Device. Note that the data may not be written correctly if you write to the
word address using the ladder program while the Display is reading data from, and writing
data to, the External Device.

*4 Do not write to the addresses Z11 and Z12. They are used in the system of the External Device.

NOTE | * Refer to the GP-Pro EX Reference Manual for system data area.
Cf.  GP-Pro EX Reference Manual "LS Area (Direct Access Method Area)"

» Refer to the precautions on manual notation for icons in the table.

&~ "Manual Symbols and Terminology"
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6.4 KV-7000 Series
[=== : This address can be specified as system data area.
Device Bit Address Word Address 32 bits | Remarks

Input Relay
Output Relay R000000 - R199915 R0O000 - R1999
Internal Auxiliary Relay
Link Relay B0000 - B7FFF B000 - B7FF rLIH)
Internal Auxiliary Relay MRO000000 - MR399915 MRO0000 - MR3999
Latch Relay LRO00000 - LR99915 LRO0O00 - LR999
Control Relay CRO0000 - CR7915 CROO - CR79
Work Relay VB0000 - VBFOFF VBO000 - VBFI9F
Timer (Contact) T0000 - T3999 | -
Counter (Contact) C0000-C3999 | - )
Timer (Setting Value) | = TS0000 - TS3999 *
Counter (Setting Value) | - CS0000 - CS3999 *
Timer (Current Value) | - TC0000 - TC3999 *
Counter (Current Value) | - CC0000 - CC3999 l
Data Memory | DM00000 - DM65534 ol i
Extension Data Memory | = - EMO00000 - EM65534 ol i

CurrentBank |  —— FM00000 - FM32767 15
File. . [LIH)
Register gsgtilryumber ______ ZF000000 - ZF524287 5]
Temporary Data Memory | - TMO000 - TM511 i
Control Memory | - CMO0000 - CM5999 m*z
Link Register | W0000 - W7FFF B’
Work Memory | s VMO00000 - VM50999 el
Index Register | - Z01-2712 13
Digital Trimmer | TRMO - TRM7 "

*1  32-bit device

*2  The access method when specifying bits is different depending on the setting of "Other bits in this word" in

"Individual Device Settings".

[Clear] ...oconrrenne 9], [EiaF)

[Do not clear] ..... When bits are written, the Display reads the corresponding word address from the External
Device, sets particular bits of that word address to ON, and then returns the resulting address
to the External Device. Note that the data may not be written correctly if you write to the word
address using the ladder program while the Display is reading data from, and writing data to,
the External Device.

GP-Pro EX Device/PLC Connection Manual

111



KV-700 - 8000 SIO Driver

*3 Do not write to the addresses Z11 and Z12. They are used in the system of the External Device.

NOTE | * Refer to the GP-Pro EX Reference Manual for system data area.
Cf.  GP-Pro EX Reference Manual "LS Area (Direct Access Method Area)"

« Refer to the precautions on manual notation for icons in the table.

&~ "Manual Symbols and Terminology"
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6.5 KV-Nano Series
[=== : This address can be specified as system data area.
Device Bit Address Word Address 32 bits | Remarks
Input Relay
Output Relay R0O0000 - R59915 R0OO0O - R599
Internal Auxiliary Relay
Link Relay B0000 - BIFFF B000 - BIFF rLIH|
Internal Auxiliary Relay MRO00000 - MR59915 MRO000 - MR599
Latch Relay LR00000 - LR19915 LRO0O - LR199
Control Relay CRO0000 - CR8915 CROO - CR89
Work Relay VB0000 - VBIFFF VB000 - VB1FF
Timer (Contact) TOOO - T511 |  —eee-
Counter (Contact) Cc000-C255 | e i
et ot creo-cter | :
Timer (Setting Value) | TS000 - TS511 2
Counter (Setting Value) | = - CS000 - CS255 2
Timer (Current Value) | - TC000 - TC511 *2
Counter (Current Value) |  —— CC000 - CC255 2
Data Memory | o DMO00000 - DM32767 | b
Temporary Data Memory | = - TMO000 - TM511 el
Control Memory | e CMO0000 - CM8999 LIH | 15
Link Register | o W0000 - W3FFF e
Work Memory | e VMO0000 - VM9499 A5
Index Register | e Z01-Z12 24
\I-/I;gl;:;peed Counter (Current | CTHO - CTH3 #9%5
gfr:-ps;(::r C(Jggtr;t:é Value) | T CTC0 - €17 e

*1  Write disable
*)  32-bit device
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*3  The access method when specifying bits is different depending on the setting of "Other bits in this word" in
"Individual Device Settings".

[Clear] ................ 5 ‘15|, @

[Do not clear] ..... When bits are written, the Display reads the corresponding word address from the External
Device, sets particular bits of that word address to ON, and then returns the resulting address
to the External Device. Note that the data may not be written correctly if you write to the
word address using the ladder program while the Display is reading data from, and writing
data to, the External Device.

*4 Do not write to the addresses Z11 and Z12. They are used in the system of the External Device.

*5  In the case of KV-NC32T, the maximum value of the address is CTH2. Reading of CTH3 is not a read error,
but the value will be 0. If the written, it will write error.

*6  In the case of KV-NC32T, the maximum value of the address is CTCS. Reading of CTC6 and CTC7 is not a
read error, but the value will be 0. If the written, it will write error.

NOTE | *° Refer to the GP-Pro EX Reference Manual for system data area.
Cf.  GP-Pro EX Reference Manual "LS Area (Direct Access Method Area)"

+ Refer to the precautions on manual notation for icons in the table.

&~ "Manual Symbols and Terminology"
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6.6 KV-8000 Series
[=== : This address can be specified as system data area.
Device Bit Address Word Address 32 bits | Remarks

Input Relay
Output Relay R000000 - R199915 R0O000 - R1999
Internal Auxiliary Relay
Link Relay B0000 - B7FFF B000 - B7FF rLIH)
Internal Auxiliary Relay MRO000000 - MR399915 MRO0000 - MR3999
Latch Relay LRO00000 - LR99915 LRO0O00 - LR999
Control Relay CRO0000 - CR7915 CROO - CR79
Work Relay VB0000 - VBFOFF VBO000 - VBFI9F
Timer (Contact) T0000 - T3999 | -
Counter (Contact) C0000-C3999 | - )
Timer (Setting Value) | = TS0000 - TS3999 *
Counter (Setting Value) | - CS0000 - CS3999 *
Timer (Current Value) | - TC0000 - TC3999 *
Counter (Current Value) | - CC0000 - CC3999 l
Data Memory | DM00000 - DM65534 ol i
Extension Data Memory | = - EMO00000 - EM65534 ol i

CurrentBank |  —— FM00000 - FM32767 15
File. . [LIH)
Register gsgtilryumber ______ ZF000000 - ZF524287 5]
Temporary Data Memory | - TMO000 - TM511 i
Control Memory | - CMO0000 - CM7599 m*z
Link Register | W0000 - W7FFF B’
Work Memory | s VMO000000 - VM589823 el
Index Register | - Z01-2712 13
Digital Trimmer | TRMO - TRM7 "

*1  32-bit device

*2  The access method when specifying bits is different depending on the setting of "Other bits in this word" in

"Individual Device Settings".

[Clear] ...oconrrenne 9], [EiaF)

[Do not clear] ..... When bits are written, the Display reads the corresponding word address from the External
Device, sets particular bits of that word address to ON, and then returns the resulting address
to the External Device. Note that the data may not be written correctly if you write to the word
address using the ladder program while the Display is reading data from, and writing data to,
the External Device.
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*3 Do not write to the addresses Z11 and Z12. They are used in the system of the External Device.

NOTE | * Refer to the GP-Pro EX Reference Manual for system data area.
Cf.  GP-Pro EX Reference Manual "LS Area (Direct Access Method Area)"

« Refer to the precautions on manual notation for icons in the table.

&~ "Manual Symbols and Terminology"
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7 Device Code and Address Code

Use device code and address code if you select "Device Type & Address" for the address type in Data displays.

71 KV-700 Series
Device Device Name Device Code Address Code
(HEX)

Input Relay
OutputRelay | e 0080 Word Address
Internal Auxiliary Relay
Control Relay CR 008A Word Address
Timer (Setting Value) TS 0062 Double Word Address
Counter (Setting Value) CS 0063 Double Word Address
Timer (Current Value) TC 0060 Double Word Address
Counter (Current Value) cC 0061 Double Word Address
Data Memory DM 0000 Word Address
Temporary Data Memory ™ 0001 Word Address
Control Memory CM 0002 Word Address
Digital Trimmer TRM 0064 Double Word Address
High-speed Counter (Current Value) CTH 0065 Double Word Address
z-lsigéngige\zilu%())unter Comparator CTC 0066 Double Word Address
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7.2 KV-1000 Series
Device Device Name Device Code Address Code
(HEX)

Input Relay
OutputRelay | - 0080 Word Address
Internal Auxiliary Relay
Internal Auxiliary Relay MR 0082 Word Address
Latch Relay LR 0084 Word Address
Control Relay CR 008A Word Address
Timer (Setting Value) TS 0062 Double Word Address
Counter (Setting Value) CS 0063 Double Word Address
Timer (Current Value) TC 0060 Double Word Address
Counter (Current Value) CcC 0061 Double Word Address
Data Memory DM 0000 Word Address
Extension Data Memory EM 0010 Word Address
Extension Data Memory FM 0011 Word Address
Temporary Data Memory ™ 0001 Word Address
Control Memory CM 0002 Word Address
Index Register Z 0003 Word Address
Digital Trimmer TRM 0064 Double Word Address
High-speed Counter (Current Value) CTH 0065 Double Word Address
High-speed Counter Comparator CTC 0066 Double Word Address

(Setting Value)
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7.3 KV-3000/5000/5500 Series
Device Device Name Device Code Address Code
(HEX)

Input Relay

Output Relay R 0080 Word Address

Internal Auxiliary Relay

Link Relay B 008B Word Address

Internal Auxiliary Relay MR 0082 Word Address

Latch Relay LR 0084 Word Address

Control Relay CR 008A Word Address

Work Relay VB 008C Word Address

Timer (Setting Value) TS 0062 Double Word Address

Counter (Setting Value) Cs 0063 Double Word Address

Timer (Current Value) TC 0060 Double Word Address

Counter (Current Value) cC 0061 Double Word Address

Data Memory DM 0000 Word Address

Extension Data Memory EM 0010 Word Address
Current Bank FM 0011 Word Address

File Register gssta;rsumber ZF 0012 Word Address

Temporary Data Memory ™ 0001 Word Address

Control Memory CM 0002 Word Address

Link Register W 0013 Word Address

Work Memory VM 0014 Word Address

Index Register 4 0067 Double Word Address

Digital Trimmer TRM 0064 Double Word Address

High-speed Counter (Current Value) CTH 0065 Double Word Address

High-speed Counter Comparator CTC 0066 Double Word Address

(Setting Value)
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7.4 KV-7000 Series
Device Device Name De\zi:lz)(:)o de Address Code
Input Relay
Output Relay R 0080 Word Address
Internal Auxiliary Relay
Link Relay B 008B Word Address
Internal Auxiliary Relay MR 0082 Word Address
Latch Relay LR 0084 Word Address
Control Relay CR 008A Word Address
Work Relay VB 008C Word Address
Timer (Setting Value) TS 0062 Double Word Address
Counter (Setting Value) Cs 0063 Double Word Address
Timer (Current Value) TC 0060 Double Word Address
Counter (Current Value) cC 0061 Double Word Address
Data Memory DM 0000 Word Address
Temporary Data Memory EM 0010 Word Address
Current Bank FM 0011 Word Address
File Register gssta;rsumber ZF 0012 Word Address
Temporary Data Memory ™ 0001 Word Address
Control Memory CM 0002 Word Address
Link Register W 0013 Word Address
Work Memory VM 0014 Word Address
Index Register 4 0067 Double Word Address
Digital Trimmer TRM 0064 Double Word Address

GP-Pro EX Device/PLC Connection Manual

120




KV-700 - 8000 SIO Driver

7.5 KV-Nano Series
Device Device Name Device Code Address Code
(HEX)

Input Relay
Output Relay R 0080 Word Address
Internal Auxiliary Relay
Link Relay B 008B Word Address
Internal Auxiliary Relay MR 0082 Word Address
Latch Relay LR 0084 Word Address
Control Relay CR 008A Word Address
Work Relay VB 008C Word Address
Timer (Setting Value) TS 0062 Double Word Address
Counter (Setting Value) Cs 0063 Double Word Address
Timer (Current Value) TC 0060 Double Word Address
Counter (Current Value) cC 0061 Double Word Address
Data Memory DM 0000 Word Address
Temporary Data Memory ™ 0001 Word Address
Control Memory CM 0002 Word Address
Link Register W 0013 Word Address
Work Memory VM 0014 Word Address
Index Register V4 0067 Double Word Address
High-speed Counter (Current Value) CTH 0065 Double Word Address
'("Sig?t;igeve;ui‘)’“mer Comparator CTC 0066 Double Word Address
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7.6 KV-8000 Series
Device Device Name Device Code Address Code
(HEX)
Input Relay
Output Relay R 0080 Word Address
Internal Auxiliary Relay
Link Relay B 008B Word Address
Internal Auxiliary Relay MR 0082 Word Address
Latch Relay LR 0084 Word Address
Control Relay CR 008A Word Address
Work Relay VB 008C Word Address
Timer (Setting Value) TS 0062 Double Word Address
Counter (Setting Value) Cs 0063 Double Word Address
Timer (Current Value) TC 0060 Double Word Address
Counter (Current Value) cC 0061 Double Word Address
Data Memory DM 0000 Word Address
Temporary Data Memory EM 0010 Word Address
Current Bank FM 0011 Word Address
File Register gssta;rsumber ZF 0012 Word Address
Temporary Data Memory ™ 0001 Word Address
Control Memory CM 0002 Word Address
Link Register W 0013 Word Address
Work Memory VM 0014 Word Address
Index Register 4 0067 Double Word Address
Digital Trimmer TRM 0064 Double Word Address
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8 Error Messages

Error messages are displayed on the Display screen as follows: "No.: Device Name: Error Message (Error

Occurrence Area)". Each description is shown below.

ltem

Description

No.

Error No.

Device Name

Name of the External Device where an error has occurred. Device name is a title of the
External Device set with GP-Pro EX. (Initial value [PLC1])

Error Message

Displays messages related to an error that has occurred.

Error Occurrence Area

Displays the IP address or device address of the External Device where an error has
occurred, or error codes received from the External Device.

 IP address is displayed as "IP address (Decimal): MAC address (Hex)".
» Device address is displayed as "Address: Device address".
» Received error codes are displayed as "Decimal [Hex]".

Display Examples of Error Messages
"RHAAOQ35: PLC1: Error has been responded for device write command (Error Code: 1 [01H])"

NOTE * Refer to your External Device manual for details on received error codes.

» Refer to "Display-related errors" in "Maintenance/Troubleshooting Manual" for details on the

error messages common to the driver.

@ Error Codes Specific to the External Device

Error Code e
Error Description
(HEX)
Executed illegal access.
02 2 Wrote in the write disable device.
2 Accessed the nonexistent device or address.
04 Tried to communicate in the communication baud rate not supported by the External
Device.
31 Accessed the device not defined as device in the External Device."!
0B Performed monitor read with the monitor unregistered.

*1  Setup in the ladder program is required before accessing the Timer (Contact/Current Value/
Setting Value), Counter (Contact/Current Value/Setting Value), High-speed Counter (Current
Value) and High-speed Counter Comparator (Setting Value).
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