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Introduction

This manual describes how to connect the Display and the External Device (target PLC).

In this manual, the connection procedure will be described in the sections identified below:

1 System Configuration

This section lists the types of External 

Devices and SIO that you can connect.

"1 System Configuration" (page 3)

2 External Device Selection

Select a model (series) of the External 

Device and its connection method.

"2 External Device Selection" (page 6)

3 Communication Settings

This section shows setting examples for 

communicating between the Display and 

"3 Communication Settings" (page 7)

4 Setup Items

This section describes communication 

setup items on the Display. Set the 

Display’s communication settings in GP 

Pro-EX or in offline mode.

"4 Setup Items" (page 15)

Operation
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1 System Configuration

The system configuration in the case when the External Device of Panasonic Industrial Devices SUNX and 

the Display are connected is shown.

 Connection Configuration

• 1:1 Connection

Series CPU Link I/F SIO Type Setting Example

FP7

AFP7CPS41E
AFP7CPS31E
AFP7CPS41ES
AFP7CPS31ES

Built-In ET-LAN

Ethernet (UDP)
"3.1 Setting Example 1" (page 
7)

Ethernet (TCP)
"3.2 Setting Example 2" (page 
9)

AFP7CCET1

Ethernet (UDP)
"3.3 Setting Example 3" (page 
11)

Ethernet (TCP)
"3.4 Setting Example 4" (page 
13)

AFP7CPS31
AFP7CPS21
AFP7CPS31S

AFP7CCET1

Ethernet (UDP)
"3.3 Setting Example 3" (page 
11)

Ethernet (TCP)
"3.4 Setting Example 4" (page 
13)

Display External Device
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• 1:n Connection

• n:1 Connection

• The maximum number of connected External Device for one Display is 32 over UDP, or 16 over 

TCP.

• The maximum number of connected Displays via the built-in ET-LAN for one External Device is 

16, which includes the CPU unit's serial and USB connections. The maximum number of 

connected Displays via AFP7CCET1 for one External Device is 4.

Display

External Device External Device External Device

HUB

External Device

Display Display Display

HUB
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• n:m Connection

• The maximum number of connected Displays via the built-in ET-LAN for one External Device is 

16, which includes the CPU unit's serial and USB connections. The maximum number of 

connected Displays via AFP7CCET1 for one External Device is 4.

• The maximum number of connected External Devices for one Display is 32 over UDP, or 16 over 

TCP.

Display Display Display

HUB

External Device External Device External Device
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2 External Device Selection

Select the External Device to be connected to the Display.

Setup Items Setup Description

Number of Devices/
PLCs

Enter an integer from 1 to 4 to define the number of Devices/PLCs to connect to the 
display.

Manufacturer
Select the manufacturer of the External Device to connect. Select "Panasonic Industrial 
Devices SUNX".

Series

Select the External Device model (series) and the connection method. Select 
"MEWTOCOL7-COM Ethernet".
In System configuration, make sure the External Device you are connecting is supported by  
"MEWTOCOL7-COM Ethernet".

"1 System Configuration" (page 3)

Port Select the Display port to be connected to the External Device.

Use System Area

Check this option to synchronize the system data area of the Display and the device 
(memory) of the External Device. When synchronized, you can use the External Device's 
ladder program to switch the display or display the window on the Display.

Cf. GP-Pro EX Reference Manual "LS Area (Direct Access Method Area)"

This feature can also be set in GP-Pro EX or in the Display's offline mode.

Cf. GP-Pro EX Reference Manual "System Settings [Display Unit] - [System 
Area] Settings Guide"

Cf. Maintenance/Troubleshooting Guide "Main Unit - System Area Settings"
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3 Communication Settings

This section provides examples of communication settings recommended by Pro-face for the Display and the 

External Device.

3.1 Setting Example 1

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click 

[Add Device] to add another External Device.

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

• Set IP address on the External Device address in the [Individual Device Settings] dialog box.

• You need to set IP address on the Display in the offline mode of the Display.
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 External Device Settings

Use the programming software (FPWIN GR7S) to set up communication settings on the External Device.

For details on communication settings, please refer to the manual of the External Device.

1 Select the [Create a New Project] option and click [OK].

2 From [Select PLC Type], select the [FP7] option and click [OK].

3 In the project tree, double-click [FP7 configuration].

4 From the [Selection of function] window, select the [Built-in ET-LAN] option and click [OK].

5 From the [Built-in ET-LAN] window, click [Basic communications information].

6 Set the [Home IP address (IPv4)] property to "192.168.1.5".

7 From the [Built-in ET-LAN] window, click [User connection information settings].

8 Define the External Device setup items with the following values.

9 Click [OK].

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

Setup Item Setting description

Connection to use specification Use

Connection type UDP/IP

Open type (server/client) Server connection(any destination)

Open type(automatic/manual) Open automatically.

Operating mode setting MEWTOCOL-7

Home port number 60001

Unused connection disconnect time 0

Destination setting method Specify by IP address (IPv4).

Destination IP address/name 192.168.1.1

Destination port number 1024
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3.2 Setting Example 2

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click 

[Add Device] to add another External Device.

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

• Set IP address on the External Device address in the [Individual Device Settings] dialog box.

• You need to set IP address on the Display in the offline mode of the Display.
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 External Device Settings

Use the programming software (FPWIN GR7S) to set up communication settings on the External Device.

For details on communication settings, please refer to the manual of the External Device.

1 Select the [Create a New Project] option and click [OK].

2 From [Select PLC Type], select the [FP7] option and click [OK].

3 In the project tree, double-click [FP7 configuration].

4 From the [Selection of function] window, select the [Built-in ET-LAN] option and click [OK].

5 From the [Built-in ET-LAN] window, click [Basic communications information].

6 Set the [Home IP address (IPv4)] property to "192.168.1.5".

7 From the [Built-in ET-LAN] window, click [User connection information settings].

8 Define the External Device setup items with the following values.

9 Click [OK].

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

Setup Item Setting description

Connection to use specification Use

Connection type TCP/IP

Open type (server/client) Server connection(any destination)

Open type(automatic/manual) Open automatically.

Operating mode setting MEWTOCOL-7

Home port number 60001

Unused connection disconnect time 0
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3.3 Setting Example 3

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click 

[Add Device] to add another External Device.

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

• Set IP address on the External Device address in the [Individual Device Settings] dialog box.

• You need to set IP address on the Display in the offline mode of the Display.
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 External Device Settings

Use the configuration software (ConfiguratorWD) to set up communication settings on the External Device.

For details on communication settings, please refer to the manual of the External Device.

1 Start up the configuration software.

2 From the [Option] menu, select [Select the IP of PC] to display the [Setting IP Address] window.

3 Select the [Specify the IP address of PC] option, and click [OK].

4 From the [Search] menu, select the [Search BroadCast] option.

The connected External Device will appear.

5 Click the External Device to set up its IP address, and from the [Edit] menu select the [Setting IP Address] 

command.

6 Select the [Use this IP Address] option.

7 Set the IP Address to "192.168.1.5", and click [OK].

8 From the [Edit] menu, select [Communication Setting] to display the [Communication Setting] window.

9 Set the items to the following values, and click [OK].

10 Click [OK].

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

Setup Item Setting description

Protocol Mode UDP

Action Mode Server Mode

Communication Mode MEWTOCOL

Source Port No. 60001

Timeout 15
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3.4 Setting Example 4

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click 

[Add Device] to add another External Device.

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

• Set IP address on the External Device address in the [Individual Device Settings] dialog box.

• You need to set IP address on the Display in the offline mode of the Display.
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 External Device Settings

Use the configuration software (ConfiguratorWD) to set up communication settings on the External Device.

For details on communication settings, please refer to the manual of the External Device.

1 Start up the configuration software.

2 From the [Option] menu, select [Select the IP of PC] to display the [Setting IP Address] window.

3 Select the [Specify the IP address of PC] option, and click [OK].

4 From the [Search] menu, select the [Search BroadCast] option.

The connected External Device will appear.

5 Click the External Device to set up its IP address, and from the [Edit] menu select the [Setting IP Address] 

command.

6 Select the [Use this IP Address] option.

7 Set the IP Address to "192.168.1.5", and click [OK].

8 From the [Edit] menu, select [Communication Setting] to display the [Communication Setting] window.

9 Set the items to the following values, and click [OK].

10 Click [OK].

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

Setup Item Setting description

Protocol Mode TCP

Action Mode Server Mode

Communication Mode MEWTOCOL

Source Port No. 60001

Timeout 15
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4 Setup Items

Set up the Display's communication settings in GP-Pro EX or in the Display's offline mode.

The setting of each parameter must match that of the External Device.

"3 Communication Settings" (page 7)

4.1 Setup Items in GP-Pro EX

 Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

•  Set the Display's IP address in offline mode.

Cf. Maintenance/Troubleshooting Guide "Ethernet Settings"

Setup Items Setup Description

Port No.

Enter a port number of the External Device, using 0 to 65535.
Check into [Auto], and a port number is set automatically.

• [Auto] option is available to set only when you select "Ethernet (TCP)" in [Connecting 
Method].

Timeout
Use an integer from 1 to 127 to enter the time (s) for which Display waits for the response 
from External Device.

Retry
In case of no response from the External Device, use an integer from 0 to 255 to enter how 
many times the Display retransmits the command.

Wait To Send
Use an integer from 0 to 255 to enter standby time (ms) for the Display from receiving 
packets to transmitting next commands.
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• Refer to the GP-Pro EX Reference Manual for Indirect Device.

Cf. GP-Pro EX Reference Manual "Changing the Device/PLC at Runtime (Indirect 
Device)"

• If communication is interrupted during TCP communication, reconnecting communication will 

take some time. 

The following tables show the amount of time required from interruption to reconnection. A 

communication error (RHxx065) displays until connection is re-established. The communication 

error does not appear if the time it takes for the Display to return to RUN mode exceeds the time it 

takes to re-establish communication.

As the amount of time required to reconnect depends on the Display port settings, we recommend 

using [Auto] with WinGP, and “Set value” with a display other than WinGP.

Using WinGP

Using a display other than WinGP

Operation
Display's port is 

[Set value]
Display's port is [Auto]

Enter offline mode 2 minutes*1

*1 Differs depending on the Windows [Time_Wait] setting. (Default: 120 seconds)

Immediate recovery

Reset 2 minutes*1 Immediate recovery

Restart WinGP 2 minutes*1 Immediate recovery

Operation
Display's port is 

[Set value]
Display's port is [Auto]

Enter offline mode Immediate recovery Immediate recovery

Reset Immediate recovery 1 minute*1

*1 Differs depending on the External Device [Unused connection disconnect time] set-          
ting. (Default: 60 seconds)

Restart power Immediate recovery 1 minute*1
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Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the external device and click [Settings] .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click 

[Add Device] to add another External Device.

Setup Items Setup Description

IP Address

Set IP address of the External Device.

• Check with a network administrator about IP address. Do not set the duplicate IP 
address.

Port No. Use an integer from 0 to 65535 to enter the port No. (Decimal) of the External Device.

Enable Monitor 
Register

Displays the Monitor Register setting. This property is unavailable with this driver.
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4.2 Setup Items in Offline Mode

Communication Settings

To display the setting screen, touch [Device/PLC Settings] from [Peripheral Settings] in offline mode. Touch 

the External Device you want to set from the list that appears.

• Refer to the Maintenance/Troubleshooting guide for information on how to enter offline mode or 

about the operation.

Cf. Maintenance/Troubleshooting Guide "Offline Mode"

• In offline mode, the number of settings you can view on one screen varies depending on the 

Display in use. Please refer to the Reference Manual for more details.

Setup Items Setup Description

Port No.
Enter a port number of the Display.
Select either "Fixed" or "Auto". Enter a port number of the Display with "0-65535", when 
select "Fixed". Assign automatically without affecting the input value, when select "Auto".

Timeout
Use an integer from 1 to 127 to enter the time (s) for which Display waits for the response 
from External Device.

Retry
In case of no response from the External Device, use an integer from 0 to 255 to enter how 
many times the display retransmits the command.

Wait To Send
Use an integer from 0 to 255 to enter standby time (ms) for the Display from receiving 
packets to transmitting next commands.
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• If communication is interrupted during TCP communication, reconnecting communication will 

take some time. 

The following tables show the amount of time required from interruption to reconnection. A 

communication error (RHxx065) displays until connection is re-established. The communication 

error does not appear if the time it takes for the Display to return to RUN mode exceeds the time it 

takes to re-establish communication.

As the amount of time required to reconnect depends on the Display port settings, we recommend 

using [Auto] with WinGP, and [Fixed] with a display other than WinGP.

Using WinGP

Using a display other than WinGP

Operation Display's port is [Fixed] Display's port is [Auto]

Enter offline mode 2 minutes*1

*1 Differs depending on the Windows [Time_Wait] setting. (Default: 120 seconds)

Immediate recovery

Reset 2 minutes*1 Immediate recovery

Restart WinGP 2 minutes*1 Immediate recovery

Operation Display's port is [Fixed] Display's port is [Auto]

Enter offline mode Immediate recovery Immediate recovery

Reset Immediate recovery 1 minute*1

Restart power Immediate recovery 1 minute*1

*1 Differs depending on the External Device [Unused connection disconnect time] set-          
ting. (Default: 60 seconds)
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Device Setting

To display the setting screen, touch [Device/PLC Settings] from [Peripheral Settings]. Touch the External 

Device you want to set from the displayed list, and touch [Device].

Setup Items Setup Description

Device/PLC Name
Select the External Device to set. Device/PLC name is the title of the External Device set 
with GP-Pro EX. (Initial value [PLC1])

IP Address

Set IP address of the External Device.

• Check with a network administrator about IP address. Do not set the duplicate IP 
address.

Port No. Use an integer from 0 to 65535 to enter the port No. (Decimal) of the External Device.

Enable Monitor 
Register

Displays the Monitor Register setting. This property is unavailable with this driver.
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5 Supported Devices

The following table shows the range of supported device addresses. Please note that the actual supported range of 

the devices varies depending on the External Device to be used. Please check the actual range in the manual of 

your External Device.

: This address can be specified as system data area.         

Device Bit Address Word Address
32
bits

Remarks

External input relay X00000 - X0511F WX0000 - WX0511 *1

*1 You can use these devices as a global device and local device. If used as a local device, configure a program                    
block number. Please enter the program block number of the program with the local device.
Example:
        X000 (Global external input device, address 000)
        023_X000 (Local external input device, Program block 23, address 000)

External output relay Y00000 - Y0511F WY0000 - WY0511 *1

Internal relay R00000 - R02047F WR0000 - WR2047 *1

Link relay L00000 - L1023F WL0000 - WL1023 *1

System relay SR00000 - SR0223F WS0000 - WS0223 *2

*2 Write disabled

Timer(Contact) T00000 - T04095 - *1 *2

Counter(Contact) C00000 - C01023 - *1 *2

Pulse relay P00000 - P0255F - *1 *2

Error alarm relay E00000 - E04095 - *1 *2

Direct input IN00000 - IN0062F WI0000 - WI0062 *2 *3

*3 You need to set the slot number for these devices. You can use these devices without the program block number.
Example:
        S16:IN000 (Direct input device, Slot number 16, address 000)

Direct output OT00000 - OT0062F WO0000 - WO0062 *3

Data register DT000000.0 - DT999423.F DT000000 - DT999423 *1

Link register LD00000.0 - LD16383.F LD00000 - LD16383 *1

Unit Memory UM00000.0 - UM7FFFF.F UM00000 - UM7FFFF *3 *5

System data - SD00000 - SD00255 *2

Timer set value register - TS00000 - TS04095 *1 *4

*4 32-bit device

Timer elapsed value regis-
ter

- TE00000 - TE04095 *1 *4

Counter set value register - CS00000 - CS01023 *1 *4

Counter elapsed value reg-
ister

- CE00000 - CE01023 *1 *4

Index register - I0000 - I000E *4 *5

*5 Hexadecimal address
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• You can only set the Read Area Size for the system area available to use in the External 

Device. Please refer to the GP Pro-EX Reference Manual for Read Area Size.

Cf. GP Pro-EX Reference Manual "LS Area (Direct Access Method Area)"
• Refer to the precautions on manual notation for icons in the table.

"Manual Symbols and Terminology"
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6 Device Code and Address Code

Use device code and address code when you select "Device Type & Address" for the address type in data 

displays.

 Global Devices

 Unit / Local Devices

Device Device Name
Device Code 

(HEX)
Address Code

External input relay X / WX 0080 Word Address

External output relay Y / WY 0081 Word Address

Internal relay R / WR 0082 Word Address

Link relay L / WL 0084 Word Address

System relay SR / WS 0089 Word Address

Data register DT 0000 Word Address

Link register LD 0002 Word Address

System data SD 0004 Word Address

Timer set value register TS 0064 Word Address

Timer elapsed value 
register

TE 0065 Word Address

Counter set value register CS 0062 Word Address

Counter elapsed value 
register

CE 0063 Word Address

Index register I 0005 Word Address

Device Device Name
Device Code 

(HEX)
Address Code

External input relay _X / _WX 0090
(Program No. × 0x10000) + 
Word Address

External output relay _Y / _WY 0091
(Program No. × 0x10000) + 
Word Address

Internal relay _R / _WR 0092
(Program No. × 0x10000) + 
Word Address

Link relay _L / _WL 0094
(Program No. × 0x10000) + 
Word Address

Direct input IN / WI 0097
(Unit No. × 0x10000) + 
Word Address

Direct output OT / WO 0098
(Unit No. × 0x10000) + 
Word Address

Data register _DT 0014
(Program No. × 0x10000) + 
Word Address

Link register _LD 0012
(Program No. × 0x10000) + 
Word Address
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Unit Memory UM 0013
(Unit No. × 0x10000) + 
Word Address

Timer set value register _TS 0074
(Program No. × 0x10000) + 
Word Address

Timer elapsed value 
register

_TE 0075
(Program No. × 0x10000) + 
Word Address

Counter set value register _CS 0072
(Program No. × 0x10000) + 
Word Address

Counter elapsed value 
register

_CE 0073
(Program No. × 0x10000) + 
Word Address

Device Device Name
Device Code 

(HEX)
Address Code
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7 Error Messages

Error messages are displayed on the Display screen as follows: "No.: Device Name: Error Message (Error 

Occurrence Area)". Each description is shown below.

Display Examples of Error Messages

"RHAA035: PLC1: Error has been responded for device write command (Error Code: 2 [02H])"

 Error Code Unique to External Device

Item Description

No. Error No.

Device Name
Name of the External Device where error occurs. Device name is a title of the External 
Device set with GP-Pro EX. (Initial value [PLC1])

Error Message Displays messages related to the error which occurs.

Error Occurrence Area

Displays IP address or device address of the External Device where error occurs, or error 
codes received from the External Device.

• IP address is displayed such as "IP address(Decimal): MAC address( Hex)".
• Device address is diplayed such as "Address: Device address".
• Received error codes are displayed such as "Decimal[Hex]".

• Refer to your External Device manual for details on received error codes.

• Refer to "Display-related errors" in "Maintenance/Troubleshooting Guide" for details on the error 

messages common to the driver.

Error Code 
(HEX)

Description

41
Format error
Received command in the wrong format.

42
NOT support error
Received an unsupported command.

60
Parameter error
Specified parameter contents do not exist, or cannot be used.

61
Data error
There is an error in the contact, data area, data number, size, range, or format.

62
Registration over error
Exceeded the registration limit, or operation run without any registrations.

63
PC mode error
Invalid command executed in RUN mode.

71
Exclusive control error
Executed a command that cannot be processed simultaneously with the command already in 
process.



MEWTOCOL7-COM Ethernet Driver

GP-Pro EX Connection Manual 26

80
Guarantee data abnormality error
CRC code indicates an error.

91
Expansion slave unit missing error
Specified a slot number without an expansion slave unit installed.

Error Code 
(HEX)

Description
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