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KV-700/1000/3000/5000 CPU Direct

Introduction
This manual describes how to connect the Display and the External Device (target PLC).

In this manual, the connection procedure is described in the sections indentified below.

1 System Configuration
This section lists the types of External
Devices and SIO that you can connect.

&y System Configuration” (page 3)

<=

2 || External Device Selection .
Select the model (series) of the External "2 External Device Selection" (page 11)

Device and its connection method.

<=

3 || Communication Settings
This section describes setting examples
for communicating between the Display
and the External Device.

&~ "3 Communication Settings" (page 12)

<=

4 || Setup ltems

This section describes communication
setup items on the Display.

Set the Display’s communication settings
in GP-Pro EX or in offline mode.

Fny Setup Items" (page 71)

5 || Cable Diagrams

This section describes cables and
adapters used to connect the Display and
the External Device.

&~ "5 Cable Diagrams" (page 76)

Operation
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KV-700/1000/3000/5000 CPU Direct

1 System Configuration

The following table lists system configurations for connecting KEYENCE Corporation External Devices and the

Display.
. ) Setting Cable
Series CPU Link I/F SIO Type .
Example Diagram
Setting Cable
CPU Direct”™! RS-232C Example 1 Diagram 1
(page 12) (page 76)
Setting Cable
RS-232C . Example 2 Diagram 2
(Port 1 connection) (page 14) (page 78)
Setting Cable
KV-L20 RS-232C . Example 4 Diagram 3
(Port 2 connection) (page 18) (page 80)
. Settin Cable
RS-422/485 (4wire) Examﬁle 6 | Disgram 4
(Port 2 connection) (page 22) (page 82)
Setting Cable
?Ps-r2t312C nnection) Example 3 Diagram 2
KV-700 ot T connecto (page 16) (page 78)
Series V=700
Setting Cable
KV-L20R RS-232C . Example 5 Diagram 3
(Port 2 connection) (page 20) (page 80)
. Settin Cable
RS-422/485 (4wire) Examﬁle 7 | Dingram 4
(Port 2 connection) (page 24) (page 82)
Setting Cable
RS-232C . Example 8 Diagram 2
(Port 1 connection) (page 26) (page 78)
Setting Cable
KV-L20V "2 RS-232C . Example 9 Diagram 3
(Port 2 connection) (page 28) (page 80)
RS-422/485 (4wire) | Scting Cable
. Example 10 | Diagram 4
(Port 2 connection) (page 30) (page 82)
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. ) Setting Cable
Series CPU Link I/F SIO Type )
Example Diagram
Setting Cable
CPU Direct! RS-232C Example 1 Diagram 1
(page 12) (page 76)
RS-232C Setting Cable

Example 3 Diagram 2

(Port 1 connection) (page 16) (page 78)

Setting Cable
KV-L20R ?PSo-rzt’J)chconnec fion) Example 5 Diagram 3
(page 20) (page 80)
. Setting Cable
KV-1000 -
Seri KV-1000 gi::zzzéﬁigx;? Example 7 Diagram 4
eries (page 24) (page 82)
RS-232C Setting Cable

Example 8 Diagram 2

(Port 1 connection) (page 26) (page 78)

Setting Cable

KV-L20V 2 RS-232C . Example 9 Diagram 3
(Port 2 connection) (page 28) (page 80)
. Setting Cable
RS-422/485 (4ere) Example 10 | Diagram 4
(Port 2 connection) (page 30) (page 82)
Setting Cable
CPU Direct”! | RS-232C Example 11 | Diagram 1
(page 32) (page 76)
Setting Cable
RS-232C . Example 12 | Diagram 2
KV-3000 (Port 1 connection) (page 33) (page 78)
Seri KV-3000
eries RS-232C Setting Cable
KV-L20V*? . Example 13 | Diagram 3
(Port 2 connection) (page 35) (page 80)
. Setting Cable
RS-422/485 (4ere) Example 14 | Diagram 4
(Port 2 connection) (page 37) (page 82)
Setting Cable
RS-232C . Example 12 | Diagram 2
(Port 1 connection) (page 33) (page 78)
Setting Cable
KV-5000 ) RS-232C .
Series KV-5000 KV-L20V (Port 2 connection) Example 13 | Diagram 3

(page 35) (page 80)

Setting Cable
Example 14 | Diagram 4

(page 37) (page 82)

RS-422/485 (4wire)
(Port 2 connection)
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KV-700/1000/3000/5000 CPU Direct

. ) Setting Cable
Series CPU Link I/F SIO Type )
Example Diagram
RS-232C Setting Cable

Example 15 | Diagram 2
(page 39) (page 78)

Setting Cable

(Port 1 connection)

KV_.5 500 KV-5500 KV-L20V"3 RS-232C . Example 16 | Diagram 3
Series (Port 2 connection) (page 41) (page 80)
. Setting Cable
RS-422/485 (4ere) Example 17 | Diagram 4
(Port 2 connection) (page 43) (page 82)
Setting Cable Dia-
CPU Direc *! RS232C Example 19 | gram 1 (page
(page 46) 76)
Setting Cable
RS§232€ . Example 20 | Diagram 2
(Port 1 connection) (page 47) (page 78)
Setting Cable
KV-L20V RS232C . Example 21 | Diagram 3
(Port 2 connection) (page 49) (page 80)
RS-422/485 (4wire) | Scting Cable
. Example 22 | Diagram 4
KV-7000 (Port 2 connection) (page 51) (page 82)
i KV-7300"4

Series :
RS232C Setting Ca.lble
(Port 1 connection) Example 20| Diagram 2
(page 47) (page 78)

Setting Cable
Example 21 | Diagram 3

(page 49) (page 80)
Setting Cable
Example 22 | Diagram 4
(page 51) (page 82)
Setting Cable
Example 23 | Diagram 5
(page 53) (page 88)

RS232C
(Port 2 connection)

KV-L21V

RS-422/485 (4wire)
(Port 2 connection)

RS-422/485 (2wire)
(Port 2 connection)

(@] |
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KV-700/1000/3000/5000 CPU Direct

. ) Setting Cable
Series CPU Link I/F SIO Type )
Example Diagram
RS232C Setting Ccfuble
(Port 1 connection) Example 20 | Diagram 2
(page 47) (page 78)
Setting Cable
KV-L20V ?Psozrfgcconnection) Example 21 | Diagram 3
(page 49) (page 80)
RS-422/485 (4wire) | Scting Cable
(Port 2 connection) Example 22 | Diagram 4
(page 51) (page 82)
Setting Cable
g\e/;i7e200 KV-7500" ?Psozrficconnection) Example 20 | Diagram 2
(page 47) (page 78)
RS232C Setting Ccfuble
(Port 2 connection) Example 21 | Diagram 3
(page 49) (page 80)
KV-L21V
RS-422/485 (4wire) | SoLng Cable
(Port 2 connection) Example 22| Diagram 4
(page 51) (page 82)
RS-422/485 (2wire) | ScHing Cable
(Port 2 connection) Example 23 | Diagram 5
(page 53) (page 88)
KV-N14 Setting Cable
KV-N24 CPU Direc "1™ | RS232C Example 18 | Diagram 1
KV-N40 (page 45) (page 76)
Setting Cable
CPU Direc ! RS232C Example 18 | Diagram 1
(page 45) (page 76)
Setting Cable Dia-
g\e/;gim KV-N10L RS232C Example 24 | gram 2 (page
. (page 55) 78)
KV-N60
Setting Cable Dia-
RS-422/485 (4wire) Example 25 | gram 4 (page
(page 57) 82)
KV-N11L
Setting Cable
RS-422/485 (2wire) Example 26 | Diagram 5
(page 59) (page 88)
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KV-700/1000/3000/5000 CPU Direct

. ) Setting Cable
Series CPU Link I/F SIO Type )
Example Diagram
Setting Cable
CPU Direc ! RS232C Example 18 | Diagram 1
(page 45) (page 76)
Setting Cable Dia-
KV-NCIOL RS232C Example 27 | gram 2 (page
(page 61) 78)
RS232C Setting Cable

Example 28 | Diagram 2
A . (page 63) (page 78)
gv Nano | gvNe32Ts
eres Setting Cable

?Psozrfgcconnection) Example 29 | Diagram 3
(page 65) (page 80)

Setting Cable
Example 30 | Diagram 4

(page 67) (page 82)

Setting Cable
Example 31 | Diagram 5

(page 69) (page 88)

(Port 1 connection)

KV-NC20L

RS-422/485 (4wire)
(Port 2 connection)

RS-422/485 (2wire)
(Port 2 connection)

*1  Using modular connector on CPU.

*2  For communication settings, KV STUDIO Ver. 4 or later ladder software is required.
*3  For communication settings, KV STUDIO Ver. 6 or later ladder software is required.
*4  For communication settings, KV STUDIO Ver. 8 or later ladder software is required.

*5  For communication settings, KV STUDIO Ver. 7 or later ladder software is required.

~]
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KV-700/1000/3000/5000 CPU Direct

m |PC COM Port

When connecting IPC with an External Device, the COM port used depends on the series and SIO type. Please

refer to the IPC manual for details.

Usable port
Usable Port
Series
RS-232C RS-422/485(4 wire) | RS-422/485(2 wire)

coM1*!, com2,
PS-20008 coM3™!, com4 i i
PS-3450A, PS-3451A, a1 1% %
PS3000-BA, PS3001-BD COMI, COM2 CcoM2 COM2
PS-3650A (T41 model), -
PS-3651A (T41 model) coMl ) i
PS-3650A (T42 model), *1%) *]%) k)
PS-3631A (T42 model) coM1**2, com2 coM1 COMI1
PS-3700A (Pentium®4-M) | COM1™!, cOM2™!, o o
PS-3710A COM3™2, COM4 COM3 COM3
PS-3711A coM1™!, com2™? com2™2 CoM2™2

*3

PS4000 COM1, COM2 - .

CoM1"1"2, com2™!, s14) 192
PL3000 COM3, COM4 COM1 COM1
PE-4000B Atom N270 COM1, COM2 - -

COM3™, comM4™, | com3s™, coma™,

PE-4000B Atom N2600 COM1, COM2 COMS™ CoM6™ COMS™ COM6™
PS5000™ *6 COMI, COM2™ com2™ com2™

*1  The RI/5V can be switched. Use the IPC’s switch to change if necessary.
*2  Set up the SIO type with the DIP Switch. Please set up as follows according to SIO type to be used.

*3  When making communication between an External Device and COM port on the Expansion slot,
only RS-232C is supported. However, ER (DTR/CTS) control cannot be executed because of the
specification of COM port.

For connection with External Device, use user-created cables and disable Pin Nos. 1, 4, 6 and 9.
Please refer to the IPC manual for details of pin layout.

*4  Setup the SIO type with the BIOS. Please refer to the IPC manual for details of BIOS.

*5  When setting up communication between an External Device and the RS-232C/422/485 interface
module, use the IPC (RS-232C) or PS5000 (RS-422/485) cable diagrams. However, when using
PFXZPBMPR42P2 in a RS-422/485 (4-wire) configuration with no flow control, connect 7.RTS+
and 8.CTS+, and connect 6.RTS- and 9.CTS-.

When using RS-422/485 communication with External Devices, you may need to reduce the
transmission speed and increase the TX Wait time.

GP-Pro EX Device/PLC Connection Manual 8



KV-700/1000/3000/5000 CPU Direct

*6  To use RS-422/485 communication on the RS-232C/422/485 interface module, the DIP Switch
setting is required. Please refer to "Knowledge Base" (FAQs) on the support site.

Settings FAQ ID
PFXZPBMPR42P2, RS422/485 change method FA263858
PFXZPBMPR42P2 termination resistor setting FA263974
PFXZPBMPR44P2, RS422/485 change method FA264087
PFXZPBMPR44P2 termination resistor setting FA264088

DIP Switch settings (PL3000 / PS3000 Series)

RS-232C
DIP Switch Setting Description
1 OFF"! Reserved (always OFF)
2 OFF
SIO type: RS-232C
3 OFF
4 OFF Output mode of SD (TXD) data: Always output
5 OFF Terminal resistance (220Q2) insertion to SD (TXD): None
6 OFF Terminal resistance (220€2) insertion to RD (RXD): None
7 OFF Short-circuit of SDA (TXA) and RDA (RXA): Not available
8 OFF Short-circuit of SDB (TXB) and RDB (RXB): Not available
9 OFF
RS (RTS) Auto control mode: Disabled
10 OFF

*1  When using PS-3450A, PS-3451A, PS3000-BA and PS3001-BD, turn ON the set value.

RS-422/485 (4 wire)

DIP Switch Setting Description
1 OFF Reserved (always OFF)
2 ON
SIO type: RS-422/485
3 ON
4 OFF Output mode of SD (TXD) data: Always output
5 OFF Terminal resistance (220€2) insertion to SD (TXD): None
6 OFF Terminal resistance (220€2) insertion to RD (RXD): None
7 OFF Short-circuit of SDA (TXA) and RDA (RXA): Not available
8 OFF Short-circuit of SDB (TXB) and RDB (RXB): Not available
9 OFF
RS (RTS) Auto control mode: Disabled
10 OFF

GP-Pro EX Device/PLC Connection Manual 9



RS-422/485 (2 wire)

KV-700/1000/3000/5000 CPU Direct

DIP Switch Setting Description
1 OFF Reserved (always OFF)
2 ON
SIO type: RS-422/485
3 ON
4 OFF Output mode of SD (TXD) data: Always output
5 OFF Terminal resistance (220Q2) insertion to SD (TXD): None
6 OFF Terminal resistance (220€2) insertion to RD (RXD): None
7 ON Short-circuit of SDA (TXA) and RDA (RXA): Available
8 ON Short-circuit of SDB (TXB) and RDB (RXB): Available
9 ON
RS (RTS) Auto control mode: Enabled
10 ON

GP-Pro EX Device/PLC Connection Manual
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KV-700/1000/3000/5000 CPU Direct

2 External Device Selection

Select the External Device to connect to the Display.

,;_}‘_‘: Welcome to GP-Pro EX
4 ~Device/FLC
» evice
GP-7rolz ! _

Mumber of Devices/FLCs |1 3: g
Device/FLC 1

Manufacturer | KEYEMCE Corporation |L

Series K\/-700,1000,/3000,/5000 CPU Direct E

Fan COM1 [
Befer to the manual of this Device/PLC
Becent Device/PLC

4 2

{—\ ™ Use System Area Drevice Information
.

QT

Back B] Communication Settings | Mew Screen I Cancel

Setup Items Setup Description

Number of Devices/ Enter an integer from 1 to 4 to define the number of Devices/PLCs to connect to the display.

PLCs

Manufacturer Select the manufacturer of the External Device to connect. Select "KEYENCE Corporation".
Select the External Device model (series) and the connection method. Select "K'V-700/1000/
3000/5000 CPU Direct".

Series In System configuration, make sure the External Device you are connecting is supported by
"KV-700/1000/3000/5000 CPU Direct".

& System Configuration" (page 3)
Port Select the Display port to connect to the External Device.

Check this option to synchronize the system data area of the Display and the device (memory)
of the External Device. When synchronized, you can use the External Device’s ladder program
to switch the display or display the window on the Display.

Cf. GP-Pro EX Reference Manual "LS Area (Direct Access Method Area)"
This feature can also be set in GP-Pro EX or in the Display's offline mode.

Cf. GP-Pro EX Reference Manual "System Settings [Display Unit] - [System Area]

Settings Guide"
Cf. Maintenance/Troubleshooting Guide "Main Unit - System Area Settings"

Use System Area

GP-Pro EX Device/PLC Connection Manual 11



KV-700/1000/3000/5000 CPU Direct
|

3 Communication Settings

This section provides examples of communication settings recommended by Pro-face for the Display and the

External Device.

3.1 Setting Example 1
B GP-Pro EX Settings

4 Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

(O

NOTE * You can set the speed to 9600-57600bps for KV-700 Series, and 9600-115200 bps for KV-
1000 Series.

GP-Pro EX Device/PLC Connection Manual 12



KV-700/1000/3000/5000 CPU Direct

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] -

,f": Individual Device Settings

Series Ky-700/1000 =l

Fleaze reconfirm all of address zettings that
way are using if pou have changed the senes.

Diefault |
oK@ | Cancel |

B External Device Settings

There are no settings on the External Device. The speed automatically switches according to the Display settings.

GP-Pro EX Device/PLC Connection Manual 13
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|

3.2 Setting Example 2
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

O

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] i .

#* Individual Device Settings E

K-700,/1000 -

GP-Pro EX Device/PLC Connection Manual 14
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B External Device Settings
Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 4 or later) to configure communication

settings for the External Device.

Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].
(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L20" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit placement

area.
(6) Double-click "KV-L20" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

Setup Items Setup Description
Operation Mode KV BUILDER mode
Interface RS-232C
Baud Rate Auto
Data Bit Length 8 bits
Port 1 Start Bit 1 bit
Stop Bit 1 bit
Parity Even
Check Sum None
RS/CS Flow Control Disabled

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.
(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.

GP-Pro EX Device/PLC Connection Manual 15
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|

3.3 Setting Example 3
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

]k

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] ﬁ .

#* Individual Device Settings E3

KA-700,/1000 |
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B External Device Settings
Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 4 or later) to configure communication

settings for the External Device.

Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].
(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L20R" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit

placement area.
(6) Double-click "KV-L20R" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-232C
Baud Rate Auto
Data Bit Length 8 bits
Port 1 Start Bit 1 bit
Stop Bit 1 bit
Parity Even
Check Sum None
RS/CS Flow Control Disabled
Station No. | Station No. 0
g::s:gs Transfer Timeout (sec.) |3

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.
(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.

GP-Pro EX Device/PLC Connection Manual 17
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|

3.4 Setting Example 4
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

O

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] ﬁ .

#* Individual Device Settings E3

Ky-700/ 000 |

GP-Pro EX Device/PLC Connection Manual 18
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B External Device Settings
Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 4 or later) to configure communication

settings for the External Device.

Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].
(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L20" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit placement

area.
(6) Double-click "KV-L20" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

Setup Items Setup Description
Operation Mode KV BUILDER mode
Interface RS-232C
Station No. 0
Baud Rate Auto
Port 2 Data Bit Length 8 bits
Start Bit 1 bit
Stop Bit 1 bit
Parity Even
Check Sum None

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.
(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.

GP-Pro EX Device/PLC Connection Manual 19
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|

3.5 Setting Example 5
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

£ 00D

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] i .

#* Individual Device Settings E

K-700,/1000 -

GP-Pro EX Device/PLC Connection Manual 20
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B External Device Settings
Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 4 or later) to configure communication
settings for the External Device.

Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].
(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L20R" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit

placement area.
(6) Double-click "KV-L20R" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-232C
Baud Rate Auto
Data Bit Length 8 bits
Port 2
Start Bit 1 bit
Stop Bit 1 bit
Parity Even
Check Sum None
Station No. Station No. 0
g::::gs Transfer Timeout (sec.) | 3

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.
(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.

GP-Pro EX Device/PLC Connection Manual 21
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|

3.6 Setting Example 6
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

£ 0D

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] ﬁ .

#* Individual Device Settings E3

K-700,41000 |
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B External Device Settings
Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 4 or later) to configure communication

settings for the External Device.

Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].
(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L20" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit placement

area.
(6) Double-click "KV-L20" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

Setup Items Setup Description
Operation Mode KV BUILDER mode
Interface RS-422A
Station No. 0
Baud Rate Auto
Port 2 Data Bit Length 8 bits
Start Bit 1 bit
Stop Bit 1 bit
Parity Even
Check Sum None

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.
(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.
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|

3.7 Setting Example 7
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

£ 0D

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] ﬁ .

#* Individual Device Settings E3

KA-700,/1000 |
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B External Device Settings
Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 4 or later) to configure communication
settings for the External Device.

Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].
(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L20R" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit

placement area.
(6) Double-click "KV-L20R" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-422A/485 (4wire)
Baud Rate Auto
Data Bit Length 8 bits
Port 2
Start Bit 1 bit
Stop Bit 1 bit
Parity Even
Check Sum None
Station No. Station No. 0
g::::gs Transfer Timeout (sec.) | 3

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.
(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.
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3.8 Setting Example 8
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

S[n0]

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] i

#* Individual Device Settings E

K-700/1 000 |
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B External Device Settings
Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 4 or later) to configure communication

settings for the External Device.

Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].
(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L20V" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit

placement area.
(6) Double-click "KV-L20V" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-232C
Baud Rate Auto
Data Bit Length 8 bits
Port 1 Start Bit 1 bit
Stop Bit 1 bit
Parity Even
Check Sum None
RS/CS Flow Control Disabled
Station No. | Station No. 0
g::s:gs Transfer Timeout (sec.) |3

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.
(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.
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3.9 Setting Example 9
B SGP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

. Onm

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] ﬁ .

#* Individual Device Settings E3

K-700,41000 |
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B External Device Settings
Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 4 or later) to configure communication
settings for the External Device.

Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].
(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L20V" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit

placement area.
(6) Double-click "KV-L20V" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-232C
Baud Rate Auto
Data Bit Length 8 bits
Port 2
Start Bit 1 bit
Stop Bit 1 bit
Parity Even
Check Sum None
Station No. Station No. 0
g::::gs Transfer Timeout (sec.) | 3

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.
(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.
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3.10 Setting Example 10
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

£ 0D

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] ﬁ .

#* Individual Device Settings E3

K-700,41000 |
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B External Device Settings
Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 4 or later) to configure communication
settings for the External Device.

Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].
(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L20V" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit

placement area.
(6) Double-click "KV-L20V" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-422A/485 (4wire)
Baud Rate Auto
Data Bit Length 8 bits
Port 2
Start Bit 1 bit
Stop Bit 1 bit
Parity Even
Check Sum None
Station No. Station No. 0
g::::gs Transfer Timeout (sec.) | 3

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.
(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.
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3.1 Setting Example 11
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

(oD

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] ﬁ .

#* Individual Device Settings E3

K-3000,/5000 |

B External Device Settings

There are no settings on the External Device. The speed automatically switches according to the Display setting.
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3.12 Setting Example 12
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

(O

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] i .

#* Individual Device Settings E

K-3000,/5000 -
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B External Device Settings
Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 4 or later) to configure communication

settings for the External Device.

Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].
(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L20V" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit

placement area.
(6) Double-click "KV-L20V" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-232C
Baud Rate Auto
Data Bit Length 8 bits
Port 1 Start Bit 1 bit
Stop Bit 1 bit
Parity Even
Check Sum None
RS/CS Flow Control Disabled
Station No. | Station No. 0
g::s:gs Transfer Timeout (sec.) |3

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.
(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.
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3.13 Setting Example 13
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

£ Moo

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] i .

#* Individual Device Settings E

K-3000,/5000 -
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B External Device Settings
Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 4 or later) to configure communication
settings for the External Device.

Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].
(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L20V" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit

placement area.
(6) Double-click "KV-L20V" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-232C
Baud Rate Auto
Data Bit Length 8 bits
Port 2
Start Bit 1 bit
Stop Bit 1 bit
Parity Even
Check Sum None
Station No. Station No. 0
g::::gs Transfer Timeout (sec.) | 3

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.
(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.
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3.14 Setting Example 14
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

- Opp

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] i .

#* Individual Device Settings E

K-3000,/5000 -
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B External Device Settings
Use the KEYENCE Corporation ladder software (KV STUDIO Ver. 4 or later) to configure communication
settings for the External Device.

Refer to your External Device manual for details.

(1) Start up the ladder software.

(2) From the [File] menu, select [New Project] and display the [New Project] dialog box.

(3) Type a project name in [Project Name], select the External Device to use under [PLC model], and click [OK].
(4) Click [Yes] in the [Confirm unit setting information] dialog box and display the [Unit Editor] window.

(5) Select "KV-L20V" from the displayed unit list on the [Select unit] tab, and drag & drop it to the unit

placement area.
(6) Double-click "KV-L20V" in the unit placement area.

(7) Configure the following communication settings on the [Setup unit] tab.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-422A/485 (4wire)
Baud Rate Auto
Data Bit Length 8 bits
Port 2
Start Bit 1 bit
Stop Bit 1 bit
Parity Even
Check Sum None
Station No. Station No. 0
g::::gs Transfer Timeout (sec.) | 3

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.
(12)Check [Unit setting info] and [Program], and then click [Execute]. The setting information is transferred.

This completes the setting of the External Device.
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3.15 Setting Example 15
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

£ Moo

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] i

#* Individual Device Settings E

K-3000/5000 |

@ Note
» Ifyou are using a KV-5500 series device, select [KV-3000/5000] from the [Series] list.
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B External Device Settings

Use ladder software KV STUDIO Ver. 6 or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.
(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and
click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.

(5) On the [Select unit (1)] tab, from the displayed list of units select "KV-L20V", then drag & drop to the unit

placement area.
(6) In the unit placement area click "KV-L20V" and then select the [Setup unit (2)] tab.

(7) Configure the setup items as follows.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-232C (Fixed)
Baud Rate Auto (Fixed)
Data Bit Length 8 bits (Fixed)
Port 1 Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
RS/CS Flow Control Disabled
Base Node No. 0
g::a:lgs ;I'Sr:g:)fer timeout time 3 (Fixed)

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(12)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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3.16 Setting Example 16
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

SR[0]

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] i .

#* Individual Device Settings E

k30005000 |

@ Note
« Ifyou are using a KV-5500 series device, select [KV-3000/5000] from the [Series] list.
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B External Device Settings

Use ladder software KV STUDIO Ver. 6 or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.
(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and
click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.

(5) On the [Select unit (1)] tab, from the displayed list of units select "KV-L20V", then drag & drop to the unit

placement area.
(6) In the unit placement area click "KV-L20V" and then select the [Setup unit (2)] tab.

(7) Configure the setup items as follows.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-232C
Baud Rate Auto (Fixed)
Port 2 Data Bit Length 8 bits (Fixed)
Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
Base Node No. 0
g::::gs ;I'Sr:Z:)fer timeout time 3 (Fixed)

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(12)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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3.17 Setting Example 17
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

S]0]

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] i .

#* Individual Device Settings E

K-3000/5000 |

@ Note
» Ifyou are using a KV-5500 series device, select [KV-3000/5000] from the [Series] list.
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B External Device Settings

Use ladder software KV STUDIO Ver. 6 or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.
(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and
click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.

(5) On the [Select unit (1)] tab, from the displayed list of units select "KV-L20V", then drag & drop to the unit

placement area.
(6) In the unit placement area click "KV-L20V" and then select the [Setup unit (2)] tab.

(7) Configure the setup items as follows.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-422A/485 (4wire)
Baud Rate Auto (Fixed)
Port 2 Data Bit Length 8 bits (Fixed)
Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
Base Node No. 0
g::::gs ;I'Sr:Z:)fer timeout time 3 (Fixed)

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(12)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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3.18 Setting Example 18
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Summary Change DevicelPLC
Manufacturer |KEYENCECorpocEﬁon Series  |KV-700/1000/3000/5000 CPU Direct ~ Port |COM1
Text Data Mode [2° chence
Communication Settings
S0 Type & RS232C RS422485(2wire)  ( RS422/4B5(4wire)
Speed 13200 2
Datz Length o Lol
Parity £ NONE = EVEN Laie]o]s)
Stop Bit [ 2
Flow Control @ NONE £ ER(DTRICTS) = XONKOFF
Timeout |3 3: (sec)
Retry |2 3:
Wait To Send ID 3: (ms)
RI/VCC R " WCC
In the case of RS232C. you can select the Sth pin to Rl (Input)
or VCC (5Y Power Supply). If you use the Digital's RS232C
Isolation Unit, please select it to VCC. Default
Device-Specific Settings
Allowable Mumber Add Device
of Devices/PLCs 1
. . Add Indirect
No. Device Name Settings Device
[&] 1 [Pt ] [Series=Kv-Nano
@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | TR

# Individual Device Setting ]
PLCT
Series KV-Mano j

Please reconfirm zll of address settings that
you are using if you have changed the senes

Default |
oK) | cancel |

B External Device Settings

There are no settings on the External Device. The speed automatically switches according to the Display setting.
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3.19 Setting Example 19
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Summary Change DevicelPLC
Manufacturer |KEYENCECorp0Eﬁon Series  |KV-700/1000/3000/5000 CPU Direct ~ Port |COM1
Text Data Mode [z chence
Communication Settings
S0 Type & RS232C RS422485(2wire)  ( RS422/4B5(4wire)
Speed 13200 A
Datz Length o Lol
Parity £ NONE = EVEN Laie]o]s)
Stop Bit [ 2
Flow Control @ NONE £ ER(DTRICTS) = XONKOFF
Timeout |3 3: (sec)
Retry |2 3:
Wait To Send Iﬂ 3: (ms)
RI/VCC R " WCC
In the case of RS232C. you can select the Sth pin to Rl (Input)
or VCC (5Y Power Supply). If you use the Digital's RS232C
Isolation Unit, please select it to VCC. Default
Device-Specific Settings
Allowable Mumber Add Device
of Devices/PLCs 1
. . Add Indirect
Mo. Device Name Settings Device
[&] 1 [Pt it [S=ries=Kv-7000
@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | TR

# Individual Device Setting ]
PLCT
Series KV-7000 =]

Please reconfirm zll of address settings that
you are using if you have changed the senes

Default |
oK) | cancel |

B External Device Settings

There are no settings on the External Device. The speed automatically switches according to the Display setting.
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3.20 Setting Example 20
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Summary Change DevicelPLC
Manufacturer |KEYENCECorporEﬁon Series  |KV-700/1000/3000/5000 CPU Direct ~ Port |COM1
Text Data Mode [z chence
Communication Settings
S0 Type & RS232C RS422485(2wire)  ( RS422/4B5(4wire)
Speed 13200 2
Dats Length o =3
Parity £ NONE = EVEN Laie]o]s)
Stop Bit = 1 2
Flow Control @ NONE £ ER(DTRICTS) = XONKOFF
Timeout |3 3: (sec)
Retry |2 3:
Wait To Send ID 3: (ms)
RI/VCC R " WCC
In the case of RS232C. you can select the Sth pin to Rl (Input)
or VCC (5Y Power Supply). If you use the Digital's RS232C
Isolation Unit, please select it to VCC. Default
Device-Specific Settings
Allowable Mumber Add Device
of Devices/PLCs 1
; : Add Indirect
Mo. Device Name Settings Device
[&] 1 [Pt it [S=ries=Kv-7000
@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | TR

g* Individual Device Settings X|
PLC1
Series KV-7000 =]

Please reconfirm zll of address settings that
you are using if you have changed the senes

Default |
oK) | cancel |
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B External Device Settings

Use ladder software KV STUDIO Ver. § or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.
(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and
click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.

(5) On the [Select unit (1)] tab, from the displayed list of units select "KV-L20V", then drag & drop to the unit

placement area.
(6) In the unit placement area click "KV-L20V" and then select the [Setup unit (2)] tab.

(7) Configure the setup items as follows.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-232C (Fixed)
Baud Rate Auto (Fixed)
Data Bit Length 8 bits (Fixed)
Port 1 Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
RS/CS Flow Control Disabled
Base Node No. 0
g::a:lgs ;I'Sr:g:)fer timeout time 3 (Fixed)

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(12)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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3.21 Setting Example 21
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Summary Change DevicelPLC
Manufacturer |KEYENCECorporEﬁon Series  |KV-700/1000/3000/5000 CPU Direct ~ Port |COM1
Text Data Mode [z chence
Communication Settings
S0 Type & RS232C RS422485(2wire)  ( RS422/4B5(4wire)
Speed 13200 2
Dats Length o =3
Parity £ NONE = EVEN Laie]o]s)
Stop Bit = 1 2
Flow Control @ NONE £ ER(DTRICTS) = XONKOFF
Timeout |3 3: (sec)
Retry |2 3:
Wait To Send ID 3: (ms)
RI/VCC R " WCC
In the case of RS232C. you can select the Sth pin to Rl (Input)
or VCC (5Y Power Supply). If you use the Digital's RS232C
Isolation Unit, please select it to VCC. Default
Device-Specific Settings
Allowable Mumber Add Device
of Devices/PLCs 1
; : Add Indirect
Mo. Device Name Settings Device
[&] 1 [Pt it [S=ries=Kv-7000
@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | TR

g* Individual Device Settings X|
PLC1
Series KV-7000 =]

Please reconfirm zll of address settings that
you are using if you have changed the senes

Default |
oK) | cancel |
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B External Device Settings

Use ladder software KV STUDIO Ver. § or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.
(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and
click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.

(5) On the [Select unit (1)] tab, from the displayed list of units select "KV-L20V", then drag & drop to the unit

placement area.
(6) In the unit placement area click "KV-L20V" and then select the [Setup unit (2)] tab.

(7) Configure the setup items as follows.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-232C
Baud Rate Auto (Fixed)
Port 2 Data Bit Length 8 bits (Fixed)
Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
Base Node No. 0
g::::gs ;I'Sr:Z:)fer timeout time 3 (Fixed)

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(12)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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3.22 Setting Example 22
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Summary Change DevicelPLC
Manufacturer |KEYENCE Comporation Series  |KV-700/1000/3000/5000 CPU Direct  Port [COM1
Text Data Mode [2° chence
Communication Settings
SI0 Type  RS232C " RS422/485(2wire) ' RS422/485(4wire)
Speed 15200 2
Data Length % =3
Parity  NGNE & EVEN " 0DD
Stop Bit =1 2
Flow Control & NONE € ER(DTRICTS) T XONKOFF
Timeout |3 3: (zec)
Retry |2 33
Wait To Send In 3: (ms)
RI/VCC &R CIVEC
In the case of RS232C. you can select the Sth pin to Rl (Input)
or VCC (5Y Power Supply). If you use the Digital's RS232C
Isolation Unit, please select it to VCC. Default
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
. ) Add Indirect
No. Device Name Settings Device

[&] 1 [rc it [Series=Kv-7000

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | TR

Series KV-7000 =]
Please reconfirm zll of address settings that
you are using if you have changed the senes

Default |
oK) | cancel |
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B External Device Settings

Use ladder software KV STUDIO Ver. § or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.
(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and
click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.

(5) On the [Select unit (1)] tab, from the displayed list of units select "KV-L20V", then drag & drop to the unit

placement area.
(6) In the unit placement area click "KV-L20V" and then select the [Setup unit (2)] tab.

(7) Configure the setup items as follows.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-422A/485 (4wire)
Baud Rate Auto (Fixed)
Port 2 Data Bit Length 8 bits (Fixed)
Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
Base Node No. 0
g::::gs ;I'Sr:Z:)fer timeout time 3 (Fixed)

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(12)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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3.23 Setting Example 23
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Summary Change DevicelPLC
Manufacturer |KEYENCE Comporation Series  |KV-700/1000/3000/5000 CPU Direct  Port [COM1
Text Data Mode [2° chence
Communication Settings
SI0 Type  RS232C & RS422/485(2wire) " RS422/485(4wire)
Speed 15200 2
Data Length % =3
Parity  NGNE & EVEN " 0DD
Stop Bit =1 2
Flow Control & NONE € ER(DTRICTS) T XONKOFF
Timeout |3 3: (zec)
Retry |2 33
Wait To Send In 3: (ms)
RI/VCC &R CIVEC
In the case of RS232C. you can select the Sth pin to Rl (Input)
or VCC (5Y Power Supply). If you use the Digital's RS232C
Isolation Unit, please select it to VCC. Default
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
. ) Add Indirect
No. Device Name Settings Device

[&] 1 [rc it [Series=Kv-7000

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | TR

Series KV-7000 =]
Please reconfirm zll of address settings that
you are using if you have changed the senes

Default |
oK) | cancel |
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B External Device Settings

Use ladder software KV STUDIO Ver. § or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.
(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and
click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.

(5) On the [Select unit (1)] tab, from the displayed list of units select "KV-L20V", then drag & drop to the unit

placement area.
(6) In the unit placement area click "KV-L20V" and then select the [Setup unit (2)] tab.

(7) Configure the setup items as follows.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-422A/485 (2wire)
Baud Rate Auto (Fixed)
Port 2 Data Bit Length 8 bits (Fixed)
Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
Base Node No. 0
g::::gs ;I'Sr:Z:)fer timeout time 3 (Fixed)

(8) From the [Convert] menu, select [Auto-assign relay/DM].

(9) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(10)Click [Yes].

(11)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(12)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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3.24 Setting Example 24
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Summary Change DevicelPLC
Manufacturer |KEYENCECorporEﬁon Series  |KV-700/1000/3000/5000 CPU Direct ~ Port |COM1
Text Data Mode [2° chence
Communication Settings
S0 Type & RS232C RS422485(2wire)  ( RS422/4B5(4wire)
Speed 13200 A
Data Length o =3
Parity £ NONE = EVEN Laie]o]s)
Stop Bit = 1 2
Flow Control @ NONE £ ER(DTRICTS) = XONKOFF
Timeout |3 3: (sec)
Retry |2 3:
Wait To Send ID 3: (ms)
RI/VCC R " WCC
In the case of RS232C. you can select the Sth pin to Rl (Input)
or VCC (5Y Power Supply). If you use the Digital's RS232C
Isolation Unit, please select it to VCC. Default
Device-Specific Settings
Allowable Mumber Add Device
of Devices/PLCs 1
. . Add Indirect
No. Device Name Settings Device
[&] 1 [Pt ] [Series=Kv-Nano
@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | TR

g#* Individual Device Settings X|
PLC1
Series KV-MNano j

Please reconfirm zll of address settings that
you are using if you have changed the senes

Default |
oK) | cancel |
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B External Device Settings

Use ladder software KV STUDIO Ver. § or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.
(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and
click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.
(5) On the [Select unit (1)] tab, from the [Extension Cassette left (Portl)] area select "KV-N10L".

(6) Configure the setup items as follows.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-232C (Fixed)
Baud Rate Auto (Fixed)
Data Bit Length 8 bits (Fixed)
Port 1 Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
RS/CS Flow Control Disabled
Base Node No. 0
g::a:lgs ;I'Sr:g:)fer timeout time 3 (Fixed)

(7) From the [Convert] menu, select [Auto-assign relay/DM].

(8) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(9) Click [Yes].

(10)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(11)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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3.25 Setting Example 25
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Summary Change DevicelPLC
Manufacturer |KEYENCE Comporation Series  |KV-700/1000/3000/5000 CPU Direct ~ Port [COM1
Text Data Mode [2 chence
Communication Settings
SI0 Type  RS232C " RS422/485(2wire) ' RS422/485(4wire)
Speed 15200 2
Data Length % =3
Parity  NGNE & EVEN = 0DD
Stop Bit (ol 2
Flow Control & NONE 1 ER(DTRICTS) ) XONKOFF
Timeout |3 3: (sec)
Retry |2 33
Wait To Send In 3: (ms)
RI/VCC &R CIVEC
In the case of RS232C. you can select the Sth pin to Rl (Input)
or VCC (5Y Power Supply). If you use the Digital's RS232C
Isolation Unit, please select it to VCC. Default
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
. ) Add Indirect
No. Device Name Settings Device

[&] 1 [rc fizy] [S=res=KvNano (]

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | TR

Senies KWV-Mano j
Please reconfirm zll of address settings that
you are using if you have changed the senes

Default |
oK) | cancel |
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B External Device Settings

Use ladder software KV STUDIO Ver. § or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.
(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and
click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.
(5) On the [Select unit (1)] tab, from the [Extension Cassette left (Portl)] area select "KV-N11L".

(6) Configure the setup items as follows.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-422A/485 (4wire)
Baud Rate Auto (Fixed)
Data Bit Length 8 bits (Fixed)
Port 1 Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
RS/CS Flow Control Disabled
Base Node No. 0
g::a:lgs ;I'Sr:g:)fer timeout time 3 (Fixed)

(7) From the [Convert] menu, select [Auto-assign relay/DM].

(8) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(9) Click [Yes].

(10)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(11)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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3.26 Setting Example 26
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Summary Change DevicelPLC
Manufacturer |KEYENCE Comporation Series  |KV-700/1000/3000/5000 CPU Direct ~ Port [COM1
Text Data Mode [2 chence
Communication Settings
SI0 Type  RS232C & RS422/485(2wire) " RS422/485(4wire)
Speed 15200 2
Data Length % =3
Parity  NGNE & EVEN = 0DD
Stop Bit (ol 2
Flow Control & NONE 1 ER(DTRICTS) ) XONKOFF
Timeout |3 3: (sec)
Retry |2 33
Wait To Send In 3: (ms)
RI/VCC &R CIVEC
In the case of RS232C. you can select the Sth pin to Rl (Input)
or VCC (5Y Power Supply). If you use the Digital's RS232C
Isolation Unit, please select it to VCC. Default
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
. ) Add Indirect
No. Device Name Settings Device

[&] 1 [rc fizy] [S=res=KvNano (]

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | TR

Senies KWV-Mano j
Please reconfirm zll of address settings that
you are using if you have changed the senes

Default |
oK) | cancel |
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B External Device Settings

Use ladder software KV STUDIO Ver. § or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.
(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and
click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.
(5) On the [Select unit (1)] tab, from the [Extension Cassette left (Portl)] area select "KV-N11L".

(6) Configure the setup items as follows.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-422A/485 (2wire)
Baud Rate Auto (Fixed)
Data Bit Length 8 bits (Fixed)
Port 1 Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
RS/CS Flow Control Disabled
Base Node No. 0
g::a:lgs ;I'Sr:g:)fer timeout time 3 (Fixed)

(7) From the [Convert] menu, select [Auto-assign relay/DM].

(8) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(9) Click [Yes].

(10)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(11)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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3.27 Setting Example 27
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Summary Change DevicelPLC
Manufacturer |KEYENCECorporEﬁon Series  |KV-700/1000/3000/5000 CPU Direct ~ Port |COM1
Text Data Mode [2° chence
Communication Settings
S0 Type & RS232C RS422485(2wire)  ( RS422/4B5(4wire)
Speed 13200 A
Data Length o =3
Parity £ NONE = EVEN Laie]o]s)
Stop Bit = 1 2
Flow Control @ NONE £ ER(DTRICTS) = XONKOFF
Timeout |3 3: (sec)
Retry |2 3:
Wait To Send ID 3: (ms)
RI/VCC R " WCC
In the case of RS232C. you can select the Sth pin to Rl (Input)
or VCC (5Y Power Supply). If you use the Digital's RS232C
Isolation Unit, please select it to VCC. Default
Device-Specific Settings
Allowable Mumber Add Device
of Devices/PLCs 1
. . Add Indirect
No. Device Name Settings Device
[&] 1 [Pt ] [Series=Kv-Nano
@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | TR

g#* Individual Device Settings X|
PLC1
Series KV-MNano j

Please reconfirm zll of address settings that
you are using if you have changed the senes

Default |
oK) | cancel |
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B External Device Settings

Use ladder software KV STUDIO Ver. § or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.
(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and
click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.
(5) On the [Select unit (1)] tab, from the [Extension Adapter Selection] area select "KV-NC10L".

(6) Configure the [Extension Adapter (Port1)] as follows.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-232C (Fixed)
Baud Rate Auto (Fixed)
Data Bit Length 8 bits (Fixed)
Port 1 Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
RS/CS Flow Control Disabled
Base Node No. 0
g::a:lgs ;I'Sr:g:)fer timeout time 3 (Fixed)

(7) From the [Convert] menu, select [Auto-assign relay/DM].

(8) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(9) Click [Yes].

(10)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(11)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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3.28 Setting Example 28
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Summary Change DevicelPLC
Manufacturer |KEYENCECorporEﬁon Series  |KV-700/1000/3000/5000 CPU Direct ~ Port |COM1
Text Data Mode [2° chence
Communication Settings
S0 Type & RS232C RS422485(2wire)  ( RS422/4B5(4wire)
Speed 13200 A
Datz Length o =3
Parity £ NONE = EVEN Laie]o]s)
Stop Bit = 1 2
Flow Control @ NONE £ ER(DTRICTS) = XONKOFF
Timeout |3 3: (sec)
Retry |2 3:
Wait To Send ID 3: (ms)
RI/VCC R " WCC
In the case of RS232C. you can select the Sth pin to Rl (Input)
or VCC (5Y Power Supply). If you use the Digital's RS232C
Isolation Unit, please select it to VCC. Default
Device-Specific Settings
Allowable Mumber Add Device
of Devices/PLCs 1
. . Add Indirect
No. Device Name Settings Device
[&] 1 [Pt ] [Series=Kv-Nano
@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | TR

g#* Individual Device Settings X|
PLC1
Series KV-MNano j

Please reconfirm zll of address settings that
you are using if you have changed the senes

Default |
oK) | cancel |
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B External Device Settings

Use ladder software KV STUDIO Ver. § or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.
(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and
click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.
(5) On the [Select unit (1)] tab, from the [Extension Adapter Selection] area select "KV-NC20L".

(6) Configure the [Extension Adapter (Port1)] as follows.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-232C (Fixed)
Baud Rate Auto (Fixed)
Data Bit Length 8 bits (Fixed)
Port 1 Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
RS/CS Flow Control Disabled
Base Node No. 0
g::a:lgs ;I'Sr:g:)fer timeout time 3 (Fixed)

(7) From the [Convert] menu, select [Auto-assign relay/DM].

(8) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(9) Click [Yes].

(10)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(11)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.

GP-Pro EX Device/PLC Connection Manual

64




KV-700/1000/3000/5000 CPU Direct
|

3.29 Setting Example 29
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Summary Change DevicelPLC
Manufacturer |KEYENCECorporEﬁon Series  |KV-700/1000/3000/5000 CPU Direct ~ Port |COM1
Text Data Mode [2° chence
Communication Settings
S0 Type & RS232C RS422485(2wire)  ( RS422/4B5(4wire)
Speed 13200 A
Datz Length o =3
Parity £ NONE = EVEN Laie]o]s)
Stop Bit = 1 2
Flow Control @ NONE £ ER(DTRICTS) = XONKOFF
Timeout |3 3: (sec)
Retry |2 3:
Wait To Send ID 3: (ms)
RI/VCC R " WCC
In the case of RS232C. you can select the Sth pin to Rl (Input)
or VCC (5Y Power Supply). If you use the Digital's RS232C
Isolation Unit, please select it to VCC. Default
Device-Specific Settings
Allowable Mumber Add Device
of Devices/PLCs 1
. . Add Indirect
No. Device Name Settings Device
[&] 1 [Pt ] [Series=Kv-Nano
@ Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | TR

g#* Individual Device Settings X|
PLC1
Series KV-MNano j

Please reconfirm zll of address settings that
you are using if you have changed the senes

Default |
oK) | cancel |
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B External Device Settings

Use ladder software KV STUDIO Ver. § or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.
(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and
click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.
(5) On the [Select unit (1)] tab, from the [Extension Adapter Selection] area select "KV-NC20L".

(6) Configure the [Extension Adapter (Port2)] as follows.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-232C (Fixed)
Baud Rate Auto (Fixed)
Data Bit Length 8 bits (Fixed)
Port 2 Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
RS/CS Flow Control Disabled
Base Node No. 0
g::a:lgs ;I'Sr:g:)fer timeout time 3 (Fixed)

(7) From the [Convert] menu, select [Auto-assign relay/DM].

(8) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(9) Click [Yes].

(10)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(11)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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3.30 Setting Example 30
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Summary Change DevicelPLC
Manufacturer |KEYENCE Comporation Series  |KV-700/1000/3000/5000 CPU Direct ~ Port [COM1
Text Data Mode [2 chence
Communication Settings
SI0 Type  RS232C " RS422/485(2wire) ' RS422/485(4wire)
Speed 15200 2
Data Length % =3
Parity  NGNE & EVEN = 0DD
Stop Bit (ol 2
Flow Control & NONE 1 ER(DTRICTS) ) XONKOFF
Timeout |3 3: (sec)
Retry |2 33
Wait To Send In 3: (ms)
RI/VCC &R CIVEC
In the case of RS232C. you can select the Sth pin to Rl (Input)
or VCC (5Y Power Supply). If you use the Digital's RS232C
Isolation Unit, please select it to VCC. Default
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
. ) Add Indirect
No. Device Name Settings Device

[&] 1 [rc fizy] [S=res=KvNano (]

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | TR

Senies KWV-Mano j
Please reconfirm zll of address settings that
you are using if you have changed the senes

Default |
oK) | cancel |
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B External Device Settings

Use ladder software KV STUDIO Ver. § or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.
(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and
click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.
(5) On the [Select unit (1)] tab, from the [Extension Adapter Selection] area select "KV-NC20L".

(6) Configure the [Extension Adapter (Port2)] as follows.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-422A/485 (4wire)
Baud Rate Auto (Fixed)
Data Bit Length 8 bits (Fixed)
Port 2 Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
RS/CS Flow Control Disabled
Base Node No. 0
g::a:lgs ;I'Sr:g:)fer timeout time 3 (Fixed)

(7) From the [Convert] menu, select [Auto-assign relay/DM].

(8) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(9) Click [Yes].

(10)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(11)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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3.31 Setting Example 31
B GP-Pro EX Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC 1 |
Summary Change DevicelPLC
Manufacturer |KEYENCE Comporation Series  |KV-700/1000/3000/5000 CPU Direct ~ Port [COM1
Text Data Mode [2 chence
Communication Settings
SI0 Type  RS232C & RS422/485(2wire) " RS422/485(4wire)
Speed 15200 2
Data Length % =3
Parity  NGNE & EVEN = 0DD
Stop Bit (ol 2
Flow Control & NONE 1 ER(DTRICTS) ) XONKOFF
Timeout |3 3: (sec)
Retry |2 33
Wait To Send In 3: (ms)
RI/VCC &R CIVEC
In the case of RS232C. you can select the Sth pin to Rl (Input)
or VCC (5Y Power Supply). If you use the Digital's RS232C
Isolation Unit, please select it to VCC. Default
Device-Specific Settings
Allowable Number Add Device
of Devices/PLCs 1
. ) Add Indirect
No. Device Name Settings Device

[&] 1 [rc fizy] [S=res=KvNano (]

@ Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] | TR

Senies KWV-Mano j
Please reconfirm zll of address settings that
you are using if you have changed the senes

Default |
oK) | cancel |

GP-Pro EX Device/PLC Connection Manual 69



KV-700/1000/3000/5000 CPU Direct

B External Device Settings

Use ladder software KV STUDIO Ver. § or later to define the External Device communication settings. Refer to

your External Device manual for details.

(1) Start up the ladder software.
(2) From the [File] menu, select [New project] to display the [New project] dialog box.

(3) In the [Project name] field enter the project name, in the [PLC model] property select the External Device, and
click [OK].

(4) In the [Confirm unit setting information] dialog box click [Yes], and the [Unit Editor] window will display.
(5) On the [Select unit (1)] tab, from the [Extension Adapter Selection] area select "KV-NC20L".

(6) Configure the [Extension Adapter (Port2)] as follows.

Setup Items Setup Description
Operation Mode KV BUILDER/KV STUDIO mode
Interface RS-422A/485 (2wire)
Baud Rate Auto (Fixed)
Data Bit Length 8 bits (Fixed)
Port 2 Start Bit 1 bits (Fixed)
Stop Bit 1 bits (Fixed)
Parity Even (Fixed)
Check Sum none (Fixed)
RS/CS Flow Control Disabled
Base Node No. 0
g::a:lgs ;I'Sr:g:)fer timeout time 3 (Fixed)

(7) From the [Convert] menu, select [Auto-assign relay/DM].

(8) From the [File] menu, select [Close] and display the [Unit Editor] dialog box.

(9) Click [Yes].

(10)From the [Monitor/Simulator] menu, select [Transfer to PLC] to display the [Transfer Program] dialog box.

(11)Select the [Unit setting info] and [Program] check boxes, and then click [Execute]. The settings are

transferred.

This completes the setting of the External Device.
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4 Setup Items

Set up the Display’s communication settings in GP-Pro EX or in the Display’s offline mode.
The setting of each parameter must match that of the External Device.

&~ "3 Communication Settings" (page 12)

4.1 Setup ltems in GP-Pro EX

B Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device/PLC T |
Summary Change Device/PLC
I anufacturer IKEYENCE Corporation Series [M-700/1000,/3000/5000 CPU Direct  Port  [COM1
Text Data Made IT LChange

Communication Settings

510 Type (v RS232C € RSLZZ/E5(Zwie]  RS422/485(4wie)
Speed m

Data Length ) 7 =g

Farity = HONE = EVEN £ 0Dp

Stop Bit =1 z

Flovs Cantral ¥ HOKE I ERDTR/CTS] ) HONV=OFF

Timeaut m [zec)

Fietry m

Wwialt Ta Send [ =Hims

Rl /%CC &~ Rl  YCC

In the case of RS232C, vou can select the Sth pin ta Rl [Input]
or WCC [ Power Supply]. If you uge the Digital's RS232C
Isalation Unit, please select it to VCC. Default

Device-Specific Settings

Allowable Mumber Add Device
of Devices/PLCs 1

MNo. Device Mame Settings én:eliiLr;direct
[&] 1 [FLci ] [Eeries=rv-700/1000
Setup ltems Setup Description
SIO Type Select the SIO type for communicating with the External Device.
Speed Select the communication speed between the External Device and the Display.
Data Length Select a data length.
Parity Select how to check parity.
Stop Bit Select a stop bit length.
Select the communication control method to prevent overflow of transmission and reception
Flow Control
data.
) Enter the time (s) for which the Display waits for the response from the External Device, from
Timeout N "
1to 127"
In case of no response from the External Device, enter how many times the Display retransmits
Retry n n
the command, from "0 to 255".
Wait To Send Enter the standby time (ms) from when the Display receives packets until it transmits the next

command, from "0 to 255".
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Setup Items Setup Description

You can switch between RI/VCC for the 9th pin when you select RS-232C for SIO type.
RI/VCC To connect to the IPC, switch between RI/5V using the IPC selector switch. Refer to your IPC
manual for details.

NOTE * Refer to the GP-Pro EX Reference Manual for Indirect Device.
Cf.  GP-Pro EX Reference Manual "Changing the Device/PLC at Runtime (Indirect
Device)"

B Device Setting
To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC]

window, select the external device and click [Settings] B

,f‘;: Individual Device Settings

PLC1

Series Ky/-700/1000 =l

Fleaze reconfirm all of address zettings that
wou are uzing if pou have changed the senes.

Diefault |
oK@ | cancel |

Setup Items Setup Description

Series Select the series of the External Device.
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4.2 Setup Items in Offline Mode
NOTE * Refer to the Maintenance/Troubleshooting guide for information on how to enter offline mode

or about the operation.
Cf.  Maintenance/Troubleshooting Guide "Offline Mode"

* The number of the setup items to be displayed for 1 page in the offline mode depends on the

Display in use. Please refer to the Reference manual for details.

B Communication Settings
To display the setting screen, touch [Device/PLC Settings] from [Peripheral Settings] in offline mode. Touch the

External Device you want to set from the displayed list.

Comm, Device Option
FN-TB0/ 1088,/ 3000/5088 CPU Direct [Com1] Fage 1/1
510 Type |RS2320 -
Speed | 19280 el
Data Length g
Parity EVEN
Stop Bit 1
Flow Gontrol NOME
Timeout{s) | 3w | Al
Retry | P w | A
Wait to Sendims) | P w | a
: 2BB8/01/08
i S 19:19:14
Setup Items Setup Description

Select the SIO type for communicating with the External Device.

In the communication settings, set [SIO Type] correctly according to the serial interface

SIO Type specifications of the Display.
If you select an SIO type that the serial interface does not support, proper operation cannot
be guaranteed.
Refer to your Display manual for details on the serial interface specifications.

Speed Select the communication speed between the External Device and the Display.

Data Length Data length is displayed.

GP-Pro EX Device/PLC Connection Manual 73



KV-700/1000/3000/5000 CPU Direct

Setup Items Setup Description
Parity The parity check method is displayed.
Stop Bit Stop bit length is displayed.
The communication control method to prevent overflow of transmission and reception
Flow Control
data.
) Enter the time (s) for which the Display waits for the response from the External Device,
Timeout "
from "1 to 127".
In case of no response from the External Device, enter how many times the Display
Retry . " "
retransmits the command, from "0 to 255".
Wait To Send Enter the standby time (ms) from when the Display receives packets until it transmits the

next command, from "0 to 255".

W Device Setting
To display the setting screen, touch [Device/PLC Settings] from [Peripheral Settings]. Touch the External Device

you want to set from the list that appears, and touch [Device].

Comm, Device Option
K\-TB0/1000/3080,/5088 CPU Direct [Gom1] Page 1/1
Device/PLG Name [PLGL > |
Series K\-70, 1088
Setup Items Setup Description

Select the External Device to set. Device/PLC Name is the title of the External Device set

Device/PLC Name with GP-Pro EX. (Initial value [PLC1])

Series Displays the series of the External Device.
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W Option
To display the setting screen, touch [Device/PLC Settings] from [Peripheral Settings]. Touch the External Device

you want to set from the list that appears, and touch [Option].

Setup Items Setup Description

You can switch between RI/VCC for the 9th pin when you select RS-232C for SIO type.
RI/VCC To connect to the IPC, you need to switch between RI/5V using the IPC selector switch.
Refer to your IPC manual for details.

NOTE * GP-4100 series, GP-4*01TM, GP-Rear Module, LT-4*01TM and LT-Rear Module do not have
the [Option] setting in the offline mode.
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5 Cable Diagrams

The cable diagrams shown below may be different from the cable diagrams recommended by KEYENCE

Corporation. Please be assured there is no operational problem in applying the cable diagrams shown in this

manual.

* The FG pin on the External Device must be D-class grounded. Refer to your External Device manual for
details.

* The SG and FG are connected inside the Display. If you connect the External Device to the SG, do not form
any short-circuit loop in the system design.

* Ifthe communication is not stable because of noise or other factors, connect an isolation unit.

Cable Diagram 1

Display
. Cable Remarks
(Connection Port)
GP3000 (COM1)
GP4000"! (COM1) D-sub 9Pin by KEYENCE Corporation
SP5000 (COM1/2) OP-26486
ST (COM1) 1A +
LT3000 (COM1) Modular cable by KEYENCE Corporation
IPC™? OP-26487 (2.5m)
PC/AT
User-created cable
+
D-sub 9Pin by KEYENCE Corporation
GP-4105 (COM1) 1B OP-26486
+
Modular cable by KEYENCE Corporation
OP-26487 (2.5m)

*1  All GP4000 models except GP-4100 Series and GP-4203T

*2  Available only with COM ports that support RS-232C.
‘5" m |PC COM Port (page 8)

1A)

Display

External Device

OP-26486

@ - OP-26487 O

NS

Modular connector 6 pin (plug)

D-sub 9 pin (socket)
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1B)
Display side External Device side
Terminal block Shield D-sub 9 pin (plug)
Signal i kY ; Signal
Display name i Y Pin name
RD(RXD) H — 2 |RD(RXD) OP-26486 External Device
SD(TXD) : 3 SD(TXD) @ O OP-26487 O
ER(DTR) 4 |ER(DTR)
SG 5 SG /
RS(RTS) - — 7 RS(RTS) D-sub’® oi ot Modular connector 6 pin (plug)
CS(CTS) - 8 [Cs(CTe)| ouP9pin fsocked

1

User-created cable
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Displa
p, U Cable Remarks

(Connection Port)
GP3000 (COM1)
GP4000"! (COM1)
SP5000 (COM1/2)
ST (COM1) 2A User-created cable Zrhleez:ble length must be 15m
LT3000 (COM1) ‘
IPC™2
PC/AT
GP-4105 (COM1) 2B User-created cable The cable length must be 15m

or less.

4%
II; iegi%c(lclcf:)Ml) RJ45 RS-232C Cable (Sm) by Pro-face The cable length t be 5

) u 2C PFXZLMCBRJR21 £ must be om ot
(COM1) less.

*1  All GP4000 models except GP-4100 Series and GP-4203T
*2  Available only with COM ports that support RS-232C.

‘F” m |PC COM Port (page 8)

2A)

Display

Display side External Device side
Dsub 9 pin (socket) Shield Dsub 9 pin (socket)
Pin Signal name :,’; ',"r‘“,‘ Pin Signal name
2 RD(RXD) f¢—1 , 2 RD(RXD)
3 SD(TXD) :><: 3 SD(TXD)
4 ER(DTR) 5 SG
5 SG 7 | RS(RTS)
8 |cscTs) e} ', i 8 | cscTs)
shel | FG |—% Vi
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2B)
Display side ) External Device side
Terminal block Shield Dsub 9 pin (socket)
Signal name ‘," ," “, Pin Signal name
i [
Display RD(RXD) <—v—:,' f'—'—>, : 2 RD(RXD)
SD(TXD) 3 SD(TXD)
ER(DTR) —| 5 SG
SG Y bt 7 RS(RTS)
: ] ]
CS(CTS) <J ' |—_> 8 CS(CTS)
\ v
2C)
External Device side
Dsub 9 pin (socket)
Pin Signal name
Displa D
pey X 2 | RoRxD)
RXD 3 | sp(xp)
1) GND 5 SG
I: 7 RS(RTS)
8 CS(CTS)
Legend Name Note

(1

RJ45 RS-232C Cable (5m) by Pro-face
PFXZLMCBRJR21
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Displa
p, v Cable Remarks
(Connection Port)
GP3000 (COM1)
GP4000"! (COM1)
SP5000 (COM1/2)
ST (COM1) 3A User-created cable Zrhleezsble length must be 15m
LT3000 (COM1) ’
IPC™?
PC/AT
GP-4105 (COM1) 3B User-created cable Zrhfez:ble length must be 15m
LT-4*01TM (COM1
LT-Rear Moc(iule : RJ45 RS-232C Cable (Sm) by Pro-face The cable length must be Sm or
3C PFXZLMCBRIJR21
(COM1) less.
*1  All GP4000 models except GP-4100 Series and GP-4203T

*2

‘F” m |PC COM Port (page 8)

Available only with COM ports that support RS-232C.

» Set the PORT2 toggle switch on the External Device to "232C".

3A)

Display

Display side
Dsub 9 pin (socket)

Shield

External Device side
Terminal block

Signal name

RD(RXD)

ER(DTR)

2
3 SD(TXD)
4

5

SG

8 CS(CTS)

-~

1
]
1
]
]
]
i
[]

Pin Signal name
1 SG
3 SD(TXD)
5 RD(RXD)

FG
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3B)
Display side External Device side
Terminal block Shield Terminal block
s ™
Signal name H ,:' ! Pin Signal name
! i
RD(RXD) T 1 SG
Display SD(TXD) 3 |[sD(xp)
ER(DTR) —l 5 RD(RXD)
SG ! [
ni N
CS(CTS) ll I
! (]
| iTi
3C)
External Device side
Terminal block
Pin Signal name
Display GND
1 SG
RXD
3 SD(TXD)
1 TXD
(1) 5 RD(RXD)
Legend Name Note
RJ45 RS-232C Cable (5m) by Pro-face
(1) PFXZLMCBRIJR21
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Display
. Cable Remarks
(Connection Port)
GP3000%! (COM1) COM port conversion adapter by Pro-face
AGP-3302B (COM2) CA3-ADPCOM-01
GP-4*01TM (COM1) _ o
4A Connector terminal block conversion adapter by Pro-face The cable length
GP-Rear Module
CA3-ADPTRM-01 must be 500m or
(COM1) less
ST'2 (COM2) * :
LT3000 (COM1) User-created cable
*3
IpC 4B User-created cable
Online adapter by Pro-face
CA4-ADPONL-01
+
AC Connector terminal block conversion adapter by Pro-face
CA3-ADPTRM-01
+ The cable length
GP3000"(COM2) User-created cable must be 500m or
less.
Online adapter by Pro-face
4D CA4-ADPONL-01
+
User-created cable
The cable length
GP-4106 (COM1) 4E User-created cable must be 500m or
less.
RS-422 Terminal Block Conversion Adapter by Pro-face
* *5
GP4000™ (COM2) AF PFXZCBADTMI The cable length
GP-4201T (COM1) * must be 500m or
SP5000 (COM1/2) User-created cable less.
4B User-created cable
* The cable length
PE-4000B "
PS5000™ 4G User-created cable must be 500m or

less.

*1  All GP3000 models except AGP-3302B
*2  All ST models except AST-3211A and AST-3302B
*3  Available only with COM ports that support RS-422/485 (4wire). (Except PE-4000B, PS5000)

m |[PC COM Port (page 8)

*4  All GP4000 models except GP-4100 Series, GP-4*01TM, GP-Rear Module, GP-4201T and GP-4*03T

*S  When using a Terminal Block Conversion Adapter (CA3-ADPTRM-01) instead of the RS-422 Terminal Block
Conversion Adapter, refer to Cable Diagram 4A.

*6  Available only with COM ports that support RS-422/485 (4wire).

®m |PC COM Port (page 8)
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[ MPORTANT + Terminal number to be used for communication varies depending on the External
Device. Terminal numbers corresponding to each series are shown below.
Pin KV-L20V KV-N11L
KV-L21V KV-NC20L
SDB(+) 5 2
SDA(-) 3 1
RDB(+) 4 3
RDA(-) 2 4
SG 1 5
+ Set the PORT2 toggle switch on the External Device to "422A 485(4)". Also, turn ON the

switch of the terminator.
» Pay attention that pole A and pole B are reversely named for the Display and the External

Device.
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4A)

Termination Display side External Device side
resistance 1erminal block I____S_rliglq___’ Terminal block
220Q Q\/ Signal name '." ','“‘.‘ Pin Signal name
Display ~ CA3-ADPCOM-01 { RDA |« . /\\ .' I. 5 SDB()
] 1 )
| = RDB <_._/ 3 SDA(-)
, =3 ! /\
{ SDA : / \ > 4 RDB(+)
CA3-ADPTRM-01 SDB ; - RDAQ)
Termination SG ] vl 1 SG
resistance FG o .
220Q 1/4W :| :| ;
TERMRX g ¥
D User-created cable "
4B)

o Display side External Device side
TorminationD-Sub 9 pin (socket) Shield Terminal block
220Q 1/4W Pin Signal name ‘.'l ,'”‘. Pin Signal name

' '
{ 1 RDA  |fe—i /\\ - 5 SDB(+)
Displ i b
spay 2 RDB |« - 3 SDA(-)
] )
{ 3 SDA /\\ —» 4 RDB(+)
]
7 SDB 2 RDA(-)

/ 5 SG 1 SG
Termination
resistance 4 ERA :I
220Q 1/4W

8 CSA
9 ERB :I .
Vo
6 CSB .
\ V!
Shell FG |— Vi
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4C)

Terminati Display side External Device side
2?4?552’2 Terminal block Shield Terminal block
[ A}
2200 QW Signal name / i Pin  [Signal name
! [BR]
Display ~ CA4-ADPONL-01 { RDA |e :" /\\ Ll 5 SDB(+)
1 ]
H [
[lj] [ = RDB <—.—/ A 3 SDA(-)
/ ]
{ SDA : / \ > 4 RDB(+)
CA3-ADPTRM-01 SDB ; > 5 RDA()
)
[
Termination SG ': [ ! SG
resistance FG Y ] .:
220Q 1/4W f L
TERMRX | |
< L
User-created cable
4D)

Termination Display side External Device side
resistance D-Sub 9 pin (plug) Shield Terminal block
z200 AW Pin Signal name '." '.'“'ll Pin Signal name

) [ |

i 2 RDA |« AN
Display  as-ADPONL-01 { / \ i 5 SDB(+)
7 RDB |« 3 SDA(-)
{ 3 SDA /\\ H 4 RDB(+)
b 8 SDB ; 2 RDA(-)

Termination 5 SG ‘.| ‘.‘ : 1 SG
resistance \ v
2200 174w | Shell FG - Y

User-created cable
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4E)

Display side External Device side
Termination Terminal block Shield Terminal block

resistance*1 [ g 1 ame ! i Pin Signal name
] IR}

\4 RDA fe—i—A\ 5 SDB(+)
Displ { f/ N\

il RDB ,' - 3 SDA(-)
1 ]

{ SDA /\ > 4 RDB(+)
P

SDB \——'—> 2 RDA(-)

S se - 1 G

Termination E H
resistance*1 ERA :I ! E
CSA b
' )
ERB : b
\ (I
csB :It b
) ]
=. ¥

1|

*1 The resistance in the Display is used as the termination resistance. Set the value of the DIP Switch on the
rear of the Display as shown in the table below.

DIP Switch No. Set Value
1 OFF
2 ON
3 OFF
4 ON
4F)
Termination Display side External Device side
resistance 1erminal block ,---.S.*l‘?l(!--_, Terminal block
2200 W Signal name 'r" '," ".I Pin Signal name
! [
= RDB 4——/ \—-—-— 3 SDA(-)
, =3 ! /\
/ { SDA ' / \ » 4 RDB(+)
PFXZCBADTM1 / SDB ; | > 2 RDA(-)
H |
' ]
Termination SG ] i 1 SG
resistance FG _'.' -= .:
220Q 1/4W \ L
TERMRX |L ___________ VY

User-created cable
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4G)
o Display side External Device side
Termination 1 g, 9 pin (socket) Shield Terminal block
resistance , N
220Q 1/4W Pin Signal name / i Pin Signal name
| /\ [
3 Rx+  |[&— — 5 SDB(+)
Display { 4 Rx- <_:'J R 3 SDA(-)
{ 2 Tx+ //\\ > 4 RDB(+)
1 Tx- i > 2 RDA(-)
5 GND 1 SG
Termination
resistance 7 NC
220Q 1/4W
8 NC
9 NC ; b
0 ]
6 NC ' b
\ Vi
Shell G |—% v

\
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Display
i Cable Notes
(Connection Port)
COM port conversion adapter by Pro-face
AGP-3302B (COM2) . +
GP-4*01TM (COM1) 5A Terminal block conversion adapter by Pro-face Cable length:
GP-Rear Module (COM1) CA3-ADPTRM-01 1000m or less
ST'2 (COM2) +
LT3000 (COM1) User-created cable
5B User-created cable
Online adapter by Pro-face
CA4-ADPONL-01
+
5C Terminal block conversion adapter by Pro-face
CA3-ADPTRM-01
GP3000*3 (COM2) +
User-created cable
Online adapter by Pro-face
5D CA4-ADPONL-01
+ Cable length:
User-created cable 1000m or less
COM port conversion adapter by Pro-face
CA3-ADPCOM-01
+
w4 SE Terminal block conversion adapter by Pro-face
IPC CA3-ADPTRM-01
+
User-created cable
SF User-created cable
GP-4106 (COM1) 5G User-created cable Cable length:
1000m or less
GP-4107 (COM1) )
GP-4*03T"S (COM2) 5H User-created cable fgg(l)‘;nl?ﬁ?s's
GP-4203T (COM1)
RS-422 Terminal Block Conversion Adapter by Pro-face
* *7
GP-4201T (COM1) * L000m rgl ’
SP5000 (COM1/2) User-created cable or less
5B User-created cable
LT-4*01TM (COM1) RJ45 RS-485 Cable (5m) by Pro-face Cable lenath:
LT-Rear Module (COM1) 5] PFXZLMCBRJRS1 -
200m or less
PE-4000B™8 Cable length:
PS5000*% 5K User-created cable 1000m or less

*1  All GP3000 models except AGP-3302B
*2  All ST models except AST-3211A and AST-3302B
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*3
*4

*5
*6
*7

*8

All GP3000 models except GP-3200 series and AGP-3302B
Ogthe COM port which can communicate by RS-422/485 (2 wire) can be used. (Except PE-4000B, PS5000)

H |PC COM Port (page 8)

Except GP-4203T

KV-700/1000/3000/5000 CPU Direct

All GP4000 models except GP-4100 Series, GP-4*01TM, GP-Rear Module, GP-4201T and GP-4*03T

When using a Terminal Block Conversion Adapter (CA3-ADPTRM-01) instead of the RS-422 Terminal Block
Conversion Adapter, refer to Cable Diagram SA.

Ogthe COM port which can communicate by RS-422/485 (2 wire) can be used.

H |PC COM Port (page 8)

mrnAsd © Terminal number to be used for communication varies depending on the External Device.
Terminal numbers corresponding to each series are shown below.

oir KV-L20V KV-N11L
KV-L21V KV-NC20L
SG 1 5
S/R(-) 3 1
S/R(+) 5 2
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KV-700/1000/3000/5000 CPU Direct

5A)
Display side
Terminal block
Termination Signal Shield
reS|st2a2n0cS name /~~""====>m, External Device side
Display CA3-ADPCOM-01 RDA |« ’,' / \‘ Terminal block
] o Signal
RDB_|+— name
1 SDA i At +—{ S/IR(+)
= C 1/ =
SDB 4 v S/R(-) -
\ \ H Termination
CA3-ADPTRM-01 SG \ - SG |resistance
— \ i 2200
User-created cable
5B)
Display side
Display D-sub 9 pin (socket)
Pin Signal Shield
name P >, External Device side
% 1 RDA [ /% Terminal block
« ! / \ Signal
Termination 2 RDB |« H :" "n name
resistzaznoc(e2 3 SDA ; /A\: ': > S/R(+) %
7 SDB " +——> S/R(-) o
\ \ ' Termination
5 SG ‘ - < ," SG |resistance
2 I, o’ 2200
ERA
8 CSA 4—,
9 ERB
6 CSB [«
Shell FG
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KV-700/1000/3000/5000 CPU Direct

5C)
Display side
Terminal block
Termination Signal Shield
reS'StzaZ"OCS name it ~, External Device side
Display ~ CA4-ADPONL-01 % RDA |« ",’ / \“ Termslpal ?Iock
! Igna
RDB < :" "" ": nagme
. SDA L A —{ S/R(+)
= YA =
SDB t 1 1 S/R(-) o
\ \ H Termination
CA3-ADPTRM-01 SG \ L il SG |resistance
FG \ \ 2200
User-created cable
5D)
Display side
D-sub 9 pin (plug)
Termination -
) ; Signal .
Raliioe Pin_| name ..Shield____ External Device side
Disol 2 RDA [¢— / N\ Terminal block
isplay % / / \ -
7 | RDB |e— {0 | e
] ! ]
3 SDA [— /A\; —> S/R(+)%
) [} ]
8 SDB " " " > S/R(_) Termination
\ \ 1
CA4-ADPONL-01 5 SG ‘\ “\\ ,," SG ;ezsggance
shell | FG —— ;
User-created cable
5E)
Display side External Device side
Terminal block Shield Terminal block
Termination - ymmmm—————— pic) -
resistance %E’rﬂzl ’/ ,/ \\\ ﬁ'ﬁ’,ﬂ%'
]
. CA3-ADPCOM-01 220 RDA - A—t- i, S/R(+)
Display % 2OB i / \ ',' ‘: %
i — SIR(-) -
1 H 1 Termination
[ - SDA i ' : SG |resistance
|- i ' ! 2200
SDB '-I '.‘ '.'
CA3-ADPTRM-01 sSG \ Vo
FG

F 3

v

User-created cable
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KV-700/1000/3000/5000 CPU Direct

5F)
Display side External Device side
Display D-sub 9 pin (socket) __Shield Terminal block
Pin | oo |/ AN
1 DATA+ [« " A ,.' ‘. » S/R(+) %
Termination 2 DATA- ! \ H S/R(-) Termination
resistance 5 SG(GND) L H , SG |[resistance
2200 \ \ ! 2200
3 NC
A T ‘o’
7 NC
4 ERA
8 CSA 4—,
9 ERB
6 CSB [«
Shell FG
5G)
Display side External Device side
Display Terminal block Shield Terminal block
Signal JTTTTTTTTT, N Signal
name K PR name
% RDA [« /’\ ———>{ SIR(+) %
Termination RDB |« .5 :' E S/R() Termination
resistance SDA ! ! SG resistance
2200 t 2200
SDB Y
SG
ERA
CSA
ERB
CSB |«

*1 The resistance in the Display is used as the termination resistance. Set the value of the DIP Switch on the
rear of the Display as shown in the table below.

DIP Switch No. Set Value
1 OFF
2 OFF
3 OFF
4 ON
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5H)

KV-700/1000/3000/5000 CPU Direct

Display side External Device side
Display D-sub 9 pin (plug) Shield Terminal block
Pn_ [ Sema] A
% 3 | LINE+ [« A SIR(+) %
Termination 8 LINE- <_€_/\-i_§_> S/R(_) Termination
resistzaznt;:g 5 SG(GND) I'\ "\ "' SG ;ezs(;?;ance
1 NC N ‘\\ ',"
> | NC ) ’
4 RS(RTS)
6 5V
7 NC
9 NC
Shell FG

¢ In COM on the GP-4107, the SG and FG terminals are isolated.

51)
Display side
Terminal block
Termi_nation Signal Shield
res's;aznocg name ST 7, External Device side
i RDA |¢— /\  Terminal block
Display DB et / ". ﬁiggg'
«— i ]
[ —] SDA :' AL i »| SIR(+)
1 ! ' ' %
7 so8 |/ \{Tsro) =
PFXZCBADTM1 v \ I ermination
SG % “,' SG |resistance
\ \ 2200
TMRMRX | Vi
FG —]

A

\ 4

User-created cable
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KV-700/1000/3000/5000 CPU Direct

5J)
External Device side
Terminal block
Signal
name
Displ D1(+
isplay (+) SIR(+) %
20 SRO
ermination
(1) GND SG |[resistance
2200
Number Name Notes
RJ45 RS-485 Cable (5m) by Pro-face
1) PFXZLMCBRIJRS81
5K)
Display side External Device side
Display D-sub 9 pin (socket) Shield Terminal block
. i ST Signal
Pin_[ Sema] AN
2 |DATA+ |+ /A\ 4 b S/R(+)%
Termination 1 DATA- |« ! ! i S/R(_) Termination
resistance ' ! H i
2 I L O B 56 I
7 NC \ \
5 GND S |
4 NC
8 NC
9 NC
6 NC
Shell FG
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KV-700/1000/3000/5000 CPU Direct

6 Supported Device

The range of supported device addresses is shown in the table below. Please note that the actual supported range
for devices varies depending on the external device that is used. Please check the actual range in the external

device manual.

6.1 KV-700 Series
[ : This address can be specified as system data area.
Device Bit Address Word Address 32 bits Remarks
Input Relay
Output Relay 00000 - 59915 000 - 599 rLIH)
Internal Auxiliary Relay
Control Relay CRO0000 - CR3915 CROO - CR39
Timer (Contact) TOOO - T511 | -
Counter (Contact) cooo-Ccs11 | e i
High-speed Counter *]
Comparator (Contact) creo-cres o e
Timer (Setting Value) | = - TS000 - TS511 2
Counter (Setting Value) | - CS000 - CS511 2
Timer (Current Value) | - TC000 - TC511 2
Counter (Current Value) | - CC000 - CC511 2
Data Memory | e DMO00000 - DM39999 e 19)
Temporary Data Memory | - TMO000 - TM511 [(L/H) [w19)
Control Memory | e CM0000 - CM3999 el
Digital Trimmer | - TRMO - TRM7 2
High-speed Counter )
(CurrentValue) | T CTHO - CTHI
High-speed Counter )
Comparator (Setting Value) | CTCO-CTC3

*1  Write disable
*2  32-bit device

* When connecting KV-700 Series, use settings within the device address ranges above.

» Ifyou try to access device addresses supported only by the KV-1000 Series devices, the following
error messages display: "Error has been responded for device read command (Error
Code(02)[(0x02)]" or "Error has been responded for device write command (Error
Code(02)[(0x02)]".

GP-Pro EX Device/PLC Connection Manual 95



KV-700/1000/3000/5000 CPU Direct

NOTE | *© Refer to the GP-Pro EX Reference Manual for system data area.
Cf.  GP-Pro EXReference Manual "LS Area (Direct Access Method Area)"

» Refer to the precautions on manual notation for icons in the table.

&~ "Manual Symbols and Terminology"
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KV-700/1000/3000/5000 CPU Direct

6.2 KV-1000 Series
[ : This address can be specified as system data area.
Device Bit Address Word Address 32 bits Remarks

Input Relay *l
Output Relay 00000 - 59915 000 - 599 1
Internal Auxiliary Relay rLIH)
Internal Auxiliary Relay MRO00000 - MR99915 MRO000 - MR999
Latch Relay LR00000 - LR99915 LROO0O - LR999
Control Relay CR0000 - CR3915 CROO - CR39
Timer (Contact) T0O000-T3999 | -
Counter (Contact) C0000-C3999 | = - )
High-speed Counter )
Comparator (Contact) creo-cres e
Timer (Setting Value) | - TS0000 - TS3999 "3
Counter (Setting Value) | - CS0000 - CS3999 3
Timer (Current Value) | - TC0000 - TC3999 3
Counter (Current Value) | - CC0000 - CC3999 3
Data Memory | o DMO00000 - DM65534 .19
Extension Data Memory EM | - EMO00000 - EM65534 .19
Extension Data Memory FM | - FMO00000 - FM32766 .

ry L | =Y
Temporary Data Memory | - TMO000 - TM511 i L)
Control Memory | e CMO00000 - CM11998 19
Index Register | e 701-2712 e o I
Digital Trimmer | -t TRMO - TRM7 3
High-speed Counter 3
(CurrentValue) | 77 CTHO - CTHI
High-speed Counter | CTCO - CTC3 3

Comparator (Setting Value)

*1  RO00 to R599 (R00000 to R59915) are shown in KV-1000, but 000 to 599 (00000 to 59915) in GP-Pro EX.

*2  Write disable
*3  32-bit device

*4 Do not write to the addresses Z11 and Z12. They are used in the system of the External Device.
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KV-700/1000/3000/5000 CPU Direct

NOTE | * Refer to the GP-Pro EX Reference Manual for system data area.
Cf.  GP-Pro EX Reference Manual "LS Area (Direct Access Method Area)"

» Refer to the precautions on manual notation for icons in the table.

&~ "Manual Symbols and Terminology"
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KV-700/1000/3000/5000 CPU Direct

6.3 KV-3000/5000/5500 Series
[ : This address can be specified as system data area.
Device Bit Address Word Address 32 bits | Remarks
Input Relay
Output Relay R00000 - R99915 R000 - R999

Internal Auxiliary Relay

Link Relay B0000 - B3FFF B000 - B3FF rLIH)
Internal Auxiliary Relay MRO00000 - MR99915 MRO00 - MR999

Latch Relay LRO00000 - LR99915 LRO0O00 - LR999

Control Relay CRO0O000 - CR3915 CROO - CR39

Work Relay VB0000 - VB3FFF VBO000 - VB3FF

Timer (Contact) TO000 - T3999 | -

Counter (Contact) Cc0000-C3999 | e

High-speed Counter

*
—_

Comparator (Contact) creo-cres o
Timer (Setting Value) | TS0000 - TS3999 2
Counter (Setting Value) | - CS0000 - CS3999 2
Timer (Current Value) | - TC0000 - TC3999 *2
Counter (Current Value) | - CC0000 - CC3999 *2
Data Memory | - DMO00000 - DM65534 m
Extension Data Memory | = - EMO00000 - EM65534 e L
- CurrentBank | FMO00000 - FM32767 e K
ile
Register | Serial Number | ZF000000 - ZF131071 15
System
[LIH
Temporary Data Memory | = TMO000 - TM511 19]
Control Memory | o CMO00000 - CM05999 e K
Link Register | e W0000 - W3FFF E-F]
Work Memory | e VMO00000 - VM59999 e B
Index Register | e Z01-2712 213
Digital Trimmer | TRMO - TRM7 *2
\I—/I;gl;:;peed Counter (Current | CTHO - CTHI )
High-speed Counter | CTCO - CTC3 )

Comparator (Setting Value)

*1  Write disable
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KV-700/1000/3000/5000 CPU Direct

*2  32-bit device

*3 Do not write to the addresses Z11 and Z12. They are used in the system of the External Device.

NOTE | © Refer to the GP-Pro EX Reference Manual for system data area.
Cf.  GP-Pro EX Reference Manual "LS Area (Direct Access Method Area)"

» Refer to the precautions on manual notation for icons in the table.

&~ "Manual Symbols and Terminology"
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KV-700/1000/3000/5000 CPU Direct

6.4 KV-7000 Series
[ : This address can be specified as system data area.
Device Bit Address Word Address 32 bits | Remarks
Input Relay
Output Relay R00000 - R99915 RO00 - R999
Internal Auxiliary Relay
Link Relay B0000 - B7FFF B000 - B7FF rLIH
Internal Auxiliary Relay MRO000000 - MR399915 MRO0000 - MR3999
Latch Relay LRO00000 - LR99915 LRO000 - LR999
Control Relay CRO0O000 - CR7915 CRO0 - CR79
Work Relay VB0000 - VBF9FF VBO000 - VBF9F
Timer (Contact) T0O000 -T3999 | -
Counter (Contact) C0000-C3999 | e -
Timer (Setting Value) | = TS0000 - TS3999 *
Counter (Setting Value) | - CS0000 - CS3999 *
Timer (Current Value) | - TC0000 - TC3999 *
Counter (Current Value) | - CC0000 - CC3999 *
Data Memory | - DMO00000 - DM65534 m
Extension Data Memory | = - EMO00000 - EM65534 ot 1)
- CurrentBank | - FMO00000 - FM32767 LiH =15
ile
Register | Serial Number | ZF000000 - ZF524287 - =15
System
Temporary Data Memory | - TMO000 - TM511 |r_JE}
Control Memory | - CMO0000 - CM5999 e 19)
Link Register | e WO0000 - W7FFF E-F]
Work Memory | e VMO00000 - VM50999 15
Index Register | e Z01-712 12
Digital Trimmer | - TRMO - TRM7 "

*1  32-bit device

*2 Do not write to the addresses Z11 and Z12. They are used in the system of the External Device.

NOTE | °© Refer to the GP-Pro EX Reference Manual for system data area.
Cf.  GP-Pro EX Reference Manual "LS Area (Direct Access Method Area)"

» Refer to the precautions on manual notation for icons in the table.

&~ "Manual Symbols and Terminology"
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KV-700/1000/3000/5000 CPU Direct

6.5 KV-Nano Series
[ : This address can be specified as system data area.
Device Bit Address Word Address 32 bits | Remarks
Input Relay
Output Relay R0O0000 - R59915 RO00 - R599
Internal Auxiliary Relay
Link Relay B0000 - BIFFF B000 - BIFF rLIH)
Internal Auxiliary Relay MRO00000 - MR59915 MRO00 - MR599
Latch Relay LR00000 - LR19915 LRO0O00 - LR199
Control Relay CRO0000 - CR8915 CROO - CR89
Work Relay VB0000 - VBIFFF VB000 - VB1FF
Timer (Contact) TO0O - T511 | -
Counter (Contact) c000-C255 | e i
i apeed Conter e | :
Timer (Setting Value) | TS000 - TS511 2
Counter (Setting Value) | - CS000 - CS255 2
Timer (Current Value) | - TC000 - TC511 *2
Counter (Current Value) | - CC000 - CC255 *2
Data Memory | e DMO00000 - DM32767 m
Temporary Data Memory | = - TMO000 - TM511 19
Control Memory | e CM0000 - CM8999 LH | g
Link Register | W0000 - W3FFF L. .F]
Work Memory | e VMO0000 - VM9499 e 19)
Index Register | Z01-2712 23
\Ij;glglrj\;peed Counter (Current | CTHO - CTH3 *9%4
High-speed Counter | CTCO - CTC7 *2%5

Comparator (Setting Value)

*1  Write disable
*)  32-bit device

*3 Do not write to the addresses Z11 and Z12. They are used in the system of the External Device.

*4  In the case of KV-NC32T, the maximum value of the address is CTH2. Reading of CTH3 is not a read error,
but the value will be 0. If the written, it will write error.

*5  In the case of KV-NC32T, the maximum value of the address is CTCS5. Reading of CTC6 and CTC7 is not a
read error, but the value will be 0. If the written, it will write error.
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KV-700/1000/3000/5000 CPU Direct

NOTE | *© Refer to the GP-Pro EX Reference Manual for system data area.
Cf.  GP-Pro EX Reference Manual "LS Area (Direct Access Method Area)"

» Refer to the precautions on manual notation for icons in the table.

&~ "Manual Symbols and Terminology"
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KV-700/1000/3000/5000 CPU Direct

7 Device Code and Address Code

Use device code and address code if you select "Device Type & Address" for the address type in Data displays.

71 KV-700 Series
Device Device Name Device Code Address Code
(HEX)

Input Relay
OutputRelay | e 0080 Word Address
Internal Auxiliary Relay
Control Relay CR 008A Word Address
Timer (Setting Value) TS 0062 Double Word Address
Counter (Setting Value) CS 0063 Double Word Address
Timer (Current Value) TC 0060 Double Word Address
Counter (Current Value) CccC 0061 Double Word Address
Data Memory DM 0000 Word Address
Temporary Data Memory ™ 0001 Word Address
Control Memory CM 0002 Word Address
Digital Trimmer TRM 0064 Double Word Address
High-speed Counter (Current Value) CTH 0065 Double Word Address
ggi’t};ge\‘/ﬁui‘)’””ter Comparator CTC 0066 Double Word Address
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KV-700/1000/3000/5000 CPU Direct

7.2 KV-1000 Series
Device Device Name Device Code Address Code
(HEX)
Input Relay
OutputRelay | e 0080 Word Address
Internal Auxiliary Relay
Internal Auxiliary Relay MR 0082 Word Address
Latch Relay LR 0084 Word Address
Control Relay CR 008A Word Address
Timer (Setting Value) TS 0062 Double Word Address
Counter (Setting Value) CS 0063 Double Word Address
Timer (Current Value) TC 0060 Double Word Address
Counter (Current Value) cc 0061 Double Word Address
Data Memory DM 0000 Word Address
Extension Data Memory EM 0010 Word Address
Extension Data Memory FM 0011 Word Address
Temporary Data Memory ™ 0001 Word Address
Control Memory CM 0002 Word Address
Index Register Z 0003 Word Address
Digital Trimmer TRM 0064 Double Word Address
High-speed Counter (Current Value) CTH 0065 Double Word Address
:-ggert;;ge\?;ui?umer Comparator CTC 0066 Double Word Address
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KV-700/1000/3000/5000 CPU Direct

7.3 KV-3000/5000/5500 Series
Device Device Name Device Code Address Code
(HEX)

Input Relay

Output Relay R 0080 Word Address

Internal Auxiliary Relay

Link Relay B 008B Word Address

Internal Auxiliary Relay MR 0082 Word Address

Latch Relay LR 0084 Word Address

Control Relay CR 008A Word Address

Work Relay VB 008C Word Address

Timer (Setting Value) TS 0062 Double Word Address

Counter (Setting Value) Cs 0063 Double Word Address

Timer (Current Value) TC 0060 Double Word Address

Counter (Current Value) CcC 0061 Double Word Address

Data Memory DM 0000 Word Address

Extension Data Memory EM 0010 Word Address
Current Bank FM 0011 Word Address

File Register gsgitaelnl:lumber ZF 0012 Word Address

Temporary Data Memory ™ 0001 Word Address

Control Memory CM 0002 Word Address

Link Register w 0013 Word Address

Work Memory VM 0014 Word Address

Index Register V4 0067 Double Word Address

Digital Trimmer TRM 0064 Double Word Address

High-speed Counter (Current Value) CTH 0065 Double Word Address

ggn;zge\fsui?””ter Comparator CTC 0066 Double Word Address
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KV-700/1000/3000/5000 CPU Direct

7.4 KV-Nano Series
Device Device Name Device Code Address Code
(HEX)

Input Relay
Output Relay R 0080 Word Address
Internal Auxiliary Relay
Link Relay B 008B Word Address
Internal Auxiliary Relay MR 0082 Word Address
Latch Relay LR 0084 Word Address
Control Relay CR 008A Word Address
Work Relay VB 008C Word Address
Timer (Setting Value) TS 0062 Double Word Address
Counter (Setting Value) Cs 0063 Double Word Address
Timer (Current Value) TC 0060 Double Word Address
Counter (Current Value) CcC 0061 Double Word Address
Data Memory DM 0000 Word Address
Temporary Data Memory ™ 0001 Word Address
Control Memory CM 0002 Word Address
Link Register W 0013 Word Address
Work Memory VM 0014 Word Address
Index Register 4 0067 Double Word Address
High-speed Counter (Current Value) CTH 0065 Double Word Address
z'lsig:;rs]ge\(/a:m(;())unter Comparator CTC 0066 Double Word Address
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KV-700/1000/3000/5000 CPU Direct
8 Error Messages

Error messages are displayed on the Display screen as follows: "No.: Device Name: Error Message (Error

Occurrence Area)". Each description is shown below.

ltem Description

No. Error No.

Name of the External Device where an error has occurred. Device name is a title of the

Device Name External Device set with GP-Pro EX. (Initial value [PLC1])

Error Message Displays messages related to an error that has occurred.

Displays the IP address or device address of the External Device where an error has
occurred, or error codes received from the External Device.

Error Occurrence Area NOTE

* IP address is displayed as "IP address (Decimal): MAC address (Hex)".
* Device address is displayed as "Address: Device address".
» Received error codes are displayed as "Decimal [Hex]".

Display Examples of Error Messages
"RHAA035: PLC1: Error has been responded for device write command (Error Code: 1 [01H])"

NOTE » Refer to your External Device manual for details on received error codes.
» Refer to "Display-related errors" in "Maintenance/Troubleshooting Manual" for details on the

error messages common to the driver.

@ Error Codes Specific to the External Device

Error Code

Error Description
(HEX)

Executed illegal access.
02 2 Wrote in the write disable device.
2 Accessed the nonexistent device or address.

04 Tried to communicate in the communication baud rate not supported by the External
Device.

31 Accessed the device not defined as device in the External Device."!

0B Performed monitor read with the monitor unregistered.

*1  When you write to Timer (Contact/Current Value/Setting Value), Counter (Contact/Current
Value/Setting Value), High-speed Counter, and High-speed Counter Comparator (Setting
Value), the changed settings must be made in the in the ladder program in advance.
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