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Introduction

This manual describes how to connect the Display and the External Device (target PLC).

In this manual, the connection procedure will be described by following the below sections:

1 System Configuration

This section shows the types of External 

Device which can be connected and SIO 

type.

"1 System Configuration" (page 3)

2 Selection of External Device

Select a model (series) of the External 

Device to be connected and connection 

method.

"2 Selection of External Device" (page 10)

3 Example of Communication Settings

This section shows setting examples for 

communicating between the Display and 

the External Device.

"3 Example of Communication Setting" 
(page 11)

4 Setup Items

This section describes communication 

setup items on the Display.

Set communication settings of the Display 

with GP-Pro Ex or in offline mode.

"4 Setup Items" (page 59)

Operation
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1 System Configuration

The system configuration in the case when the External Device and the Display are connected is shown.

Series CPU Link I/F
Port 

No.

Communication 

Method

Data Code 

Settings
Setting Example

FA-M3

F3SP25-2N
F3SP28-3N
F3SP35-5N
F3SP38-6N
F3SP53-4H
F3SP58-6H

F3LE01-5T *1 12289

Ethernet
(UDP)

Binary*2 Setting Example 1 
(page 11)

ASCII*3 Setting Example 2 
(page 13)

Ethernet
(TCP)

Binary*2 Setting Example 5 
(page 19)

ASCII*3 Setting Example 6 
(page 21)

F3LE11-0T *1

12289

Ethernet
(UDP)

Binary*2 Setting Example 1 
(page 11)

ASCII*3 Setting Example 2 
(page 13)

Ethernet
(TCP)

Binary*2 Setting Example 5 
(page 19)

ASCII*3 Setting Example 6 
(page 21)

12291

Ethernet
(UDP)

Binary*3 Setting Example 3 
(page 15)

ASCII*2 Setting Example 4 
(page 17)

Ethernet
(TCP)

Binary*3 Setting Example 7 
(page 23)

ASCII*2 Setting Example 8 
(page 25)
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FA-M3

F3SP21-0N
F3SP28-3S
F3SP38-6S
F3SP53-4S
F3SP58-6S
F3SP59-7S

F3LE01-5T *1

F3LE01-0T *1 12289

Ethernet
(UDP)

Binary*2 Setting Example 1 
(page 11)

ASCII*3 Setting Example 2 
(page 13)

Ethernet
(TCP)

Binary*2 Setting Example 5 
(page 19)

ASCII*3 Setting Example 6 
(page 21)

F3LE11-0T *1

F3LE12-0T *1

12289

Ethernet
(UDP)

Binary*2 Setting Example 1 
(page 11)

ASCII*3 Setting Example 2 
(page 13)

Ethernet
(TCP)

Binary*2 Setting Example 5 
(page 19)

ASCII*3 Setting Example 6 
(page 21)

12291

Ethernet
(UDP)

Binary*3 Setting Example 3 
(page 15)

ASCII*2 Setting Example 4 
(page 17)

Ethernet
(TCP)

Binary*3 Setting Example 7 
(page 23)

ASCII*2 Setting Example 8 
(page 25)

F3SP22-0S F3LE01-0T *1 12289

Ethernet
(UDP)

Binary*2 Setting Example 1 
(page 11)

ASCII*3 Setting Example 2 
(page 13)

Ethernet
(TCP)

Binary*2 Setting Example 5 
(page 19)

ASCII*3 Setting Example 6 
(page 21)

Series CPU Link I/F
Port 

No.

Communication 

Method

Data Code 

Settings
Setting Example
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FA-M3

F3SP22-0S
F3LE11-0T *1

F3LE12-0T *1

12289

Ethernet
(UDP)

Binary*2 Setting Example 1 
(page 11)

ASCII*3 Setting Example 2 
(page 13)

Ethernet
(TCP)

Binary*2 Setting Example 5 
(page 19)

ASCII*3 Setting Example 6 
(page 21)

12291

Ethernet
(UDP)

Binary*3 Setting Example 3 
(page 15)

ASCII*2 Setting Example 4 
(page 17)

Ethernet
(TCP)

Binary*3 Setting Example 7 
(page 23)

ASCII*2 Setting Example 8 
(page 25)

F3SP66-4S
F3SP67-6S

Ethernet I/F on 
CPU Unit

12289

Ethernet
(UDP)

Binary
Setting Example 9 
(page 27)

ASCII
Setting Example 
10 (page 29)

Ethernet
(TCP)

Binary
Setting Example 
11 (page 31)

ASCII
Setting Example 
12 (page 33)

12291

Ethernet
(UDP)

Binary
Setting Example 
13 (page 35)

ASCII
Setting Example 
14 (page 37)

Ethernet
(TCP)

Binary
Setting Example 
15 (page 39)

ASCII
Setting Example 
16 (page 41)

F3LE01-0T *1 12289

Ethernet
(UDP)

Binary*2 Setting Example 1 
(page 11)

ASCII*3 Setting Example 2 
(page 13)

Ethernet
(TCP)

Binary*2 Setting Example 5 
(page 19)

ASCII*3 Setting Example 6 
(page 21)

Series CPU Link I/F
Port 

No.

Communication 

Method

Data Code 

Settings
Setting Example
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FA-M3

F3SP66-4S
F3SP67-6S

F3LE11-0T *1

F3LE12-0T *1

12289

Ethernet
(UDP)

Binary*2 Setting Example 1 
(page 11)

ASCII*3 Setting Example 2 
(page 13)

Ethernet
(TCP)

Binary*2 Setting Example 5 
(page 19)

ASCII*3 Setting Example 6 
(page 21)

12291

Ethernet
(UDP)

Binary*3 Setting Example 3 
(page 15)

ASCII*2 Setting Example 4 
(page 17)

Ethernet
(TCP)

Binary*3 Setting Example 7 
(page 23)

ASCII*2 Setting Example 8 
(page 25)

F3SP71-4N
F3SP76-7N
F3SP71-4S
F3SP76-7S

Ethernet I/F on 
CPU Unit

12289

Ethernet
(UDP)

Binary
Setting Example 
17 (page 43)

ASCII
Setting Example 
18 (page 45)

Ethernet
(TCP)

Binary
Setting Example 
19 (page 47)

ASCII
Setting Example 
20 (page 49)

12291

Ethernet
(UDP)

Binary
Setting Example 
21 (page 51)

ASCII
Setting Example 
22 (page 53)

Ethernet
(TCP)

Binary
Setting Example 
23 (page 55)

ASCII
Setting Example 
24 (page 57)

F3LE01-0T *1 12289

Ethernet
(UDP)

Binary*2 Setting Example 1 
(page 11)

ASCII*3 Setting Example 2 
(page 13)

Ethernet
(TCP)

Binary*2 Setting Example 5 
(page 19)

ASCII*3 Setting Example 6 
(page 21)

Series CPU Link I/F
Port 

No.

Communication 

Method

Data Code 

Settings
Setting Example
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FA-M3

F3SP71-4N
F3SP76-7N
F3SP71-4S
F3SP76-7S

F3LE11-0T *1

F3LE12-0T *1

12289

Ethernet
(UDP)

Binary*2 Setting Example 1 
(page 11)

ASCII*3 Setting Example 2 
(page 13)

Ethernet
(TCP)

Binary*2 Setting Example 5 
(page 19)

ASCII*3 Setting Example 6 
(page 21)

12291

Ethernet
(UDP)

Binary*3 Setting Example 3 
(page 15)

ASCII*2 Setting Example 4 
(page 17)

Ethernet
(TCP)

Binary*3 Setting Example 7 
(page 23)

ASCII*2 Setting Example 8 
(page 25)

*1 In TCP connection, you can connect max 8 units of the External Device to 1 display unit.

*2 Set the data code setting to ON.

*3 Set the data code setting to OFF.

Series CPU Link I/F
Port 

No.

Communication 

Method

Data Code 

Settings
Setting Example
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 Connection Configuration

1:1 Connection

1:n Connection

n:1 Connection

TCP connection: maximum 16 units
UDP connection: maximum 32 units

TCP connection: maximum 8 units
UDP connection: no limitation



Personal Computer Link Ethernet Driver    

GP-Pro EX Device/PLC Connection Manual 9

n:m Connection

TCP connection: maximum 8 units
UDP connection: no limitation

TCP connection: maximum 16 units
UDP connection: maximum 32 units
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2 Selection of External Device

Select the External Device to be connected to the Display.

Setup Items Setup Description

Number of Devices/
PLCs

Use an integer from 1 to 4 to enter the number of Devices/PLCs to connect to the display.

Manufacturer
Select the manufacturer of the External Device to be connected. Select "YOKOGAWA 
Electric Corporation".

Series

Select a model (series) of the External Device to be connected and connection method. 
Select "Personal Computer Link Ethernet".
Check the External Device which can be connected in "Personal Computer Link Ethernet" 
in system configuration.

"1 System Configuration" (page 3)

Port Select the Display port to be connected to the External Device.

Use System Area

Check this option to synchronize the system data area of the Display and the device 
(memory) of the External Device. When synchronized, you can use the External Device’s 
ladder program to switch the display or display the window on the Display.

Cf. GP-Pro EX Reference Manual "LS Area (Direct Access Method Area)"
This feature can also be set in GP-Pro EX or in the Display's offline mode.

Cf. GP-Pro EX Reference Manual "System Settings [Display Unit] - [System 
Area] Settings Guide"

Cf. Maintenance/Troubleshooting Guide "Main Unit - System Area Settings"
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3 Example of Communication Setting

Examples of communication settings of the Display and the External Device, recommended by Pro-face, are 

shown.

3.1 Setting Example 1

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the External Device and click [Settings]  .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

• Set IP address on the External Device for IP address in Device-specific settings.

• You need to set IP address on the Display in the offline mode of the Display.
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 Setting of External Device

Use the switches on the side of Ethernet module for setting the External Device.

 IP Address Setting Switch

Use 8 Hex rotary switches for setting.

Port No.

Condition Setting Switch

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

Setup Items Setup Description

IP Address Setting Rotary Switch Option

Setup Items Setup Description

Port No. 12289

DIP Switch Settings Setup Description

SW1 ON Binary

SW2 OFF Not protect

SW3 --- (Reserved)

SW4 --- (Reserved)

SW5 --- (Reserved)

SW6 --- (Reserved)

SW7*1

*1 SW7 is available to set in F3LE01-5T only.

OFF Close

SW8 OFF Normal
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3.2 Setting Example 2

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the External Device and click [Settings]  .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

• Set IP address on the External Device for IP address in Device-specific settings.

• You need to set IP address on the Display in the offline mode of the Display.
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 Setting of External Device

Use the switches on the side of Ethernet module for setting the External Device.

 IP Address Setting Switch

Use 8 Hex rotary switches for setting.

Port No.

Condition Setting Switch

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

Setup Items Setup Description

IP Address Setting Rotary Switch Option

Setup Items Setup Description

Port No. 12289

DIP Switch Settings Setup Description

SW1 OFF ASCII

SW2 OFF Not protect

SW3 --- (Reserved)

SW4 --- (Reserved)

SW5 --- (Reserved)

SW6 --- (Reserved)

SW7*1

*1 SW7 is available to set in F3LE01-5T only.

OFF Close

SW8 OFF Normal
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3.3 Setting Example 3

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the External Device and click [Settings]  .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

• Set IP address on the External Device for IP address in Device-specific settings.

• You need to set IP address on the Display in the offline mode of the Display.
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 Setting of External Device

Use the switches on the side of Ethernet module for setting the External Device.

 IP Address Setting Switch

Use 8 Hex rotary switches for setting.

Port No.

Condition Setting Switch

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

Setup Items Setup Description

IP Address Setting Rotary Switch Option

Setup Items Setup Description

Port No. 12291

DIP Switch Settings Setup Description

SW1 OFF Binary

SW2 OFF Not protect

SW3 --- (Reserved)

SW4 --- (Reserved)

SW5 --- (Reserved)

SW6 --- (Reserved)

SW7 OFF Close

SW8 OFF Normal
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3.4 Setting Example 4

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the External Device and click [Settings]  .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

• Set IP address on the External Device for IP address in Device-specific settings.

• You need to set IP address on the Display in the offline mode of the Display.
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 Setting of External Device

Use the switches on the side of Ethernet module for setting the External Device.

 IP Address Setting Switch

Use 8 Hex rotary switches for setting.

Port No.

Condition Setting Switch

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

Setup Items Setup Description

IP Address Setting Rotary Switch Option

Setup Items Setup Description

Port No. 12291

DIP Switch Settings Setup Description

SW1 ON ASCII

SW2 OFF Not protect

SW3 --- (Reserved)

SW4 --- (Reserved)

SW5 --- (Reserved)

SW6 --- (Reserved)

SW7 OFF Close

SW8 OFF Normal
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3.5 Setting Example 5

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the External Device and click [Settings]  .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

• Set IP address on the External Device for IP address in Device-specific settings.

• You need to set IP address on the Display in the offline mode of the Display.
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 Setting of External Device

Use the switches on the side of Ethernet module for setting the External Device.

 IP Address Setting Switch

Use 8 Hex rotary switches for setting.

Port No.

Condition Setting Switch

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

Setup Items Setup Description

IP Address Setting Rotary Switch Option

Setup Items Setup Description

Port No. 12289

DIP Switch Settings Setup Description

SW1 ON Binary

SW2 OFF Not protect

SW3 --- (Reserved)

SW4 --- (Reserved)

SW5 --- (Reserved)

SW6 --- (Reserved)

SW7*1

*1 SW7 is available to set in F3LE01-5T only.

OFF Close

SW8 OFF Normal
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3.6 Setting Example 6

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the External Device and click [Settings]  .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

• Set IP address on the External Device for IP address in Device-specific settings.

• You need to set IP address on the Display in the offline mode of the Display.
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 Setting of External Device

Use the switches on the side of Ethernet module for setting the External Device.

 IP Address Setting Switch

Use 8 Hex rotary switches for setting.

Port No.

Condition Setting Switch

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

Setup Items Setup Description

IP Address Setting Rotary Switch Option

Setup Items Setup Description

Port No. 12289

DIP Switch Settings Setup Description

SW1 OFF ASCII

SW2 OFF Not protect

SW3 --- (Reserved)

SW4 --- (Reserved)

SW5 --- (Reserved)

SW6 --- (Reserved)

SW7*1

*1 SW7 is available to set in F3LE01-5T only.

OFF Close

SW8 OFF Normal
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3.7 Setting Example 7

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the External Device and click [Settings]  .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

• Set IP address on the External Device for IP address in Device-specific settings.

• You need to set IP address on the Display in the offline mode of the Display.
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 Setting of External Device

Use the switches on the side of Ethernet module for setting the External Device.

 IP Address Setting Switch

Use 8 Hex rotary switches for setting.

Port No.

Condition Setting Switch

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

Setup Items Setup Description

IP Address Setting Rotary Switch Option

Setup Items Setup Description

Port No. 12291

DIP Switch Settings Setup Description

SW1 OFF Binary

SW2 OFF Not protect

SW3 --- (Reserved)

SW4 --- (Reserved)

SW5 --- (Reserved)

SW6 --- (Reserved)

SW7 OFF Close

SW8 OFF Normal
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3.8 Setting Example 8

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the External Device and click [Settings]  .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

• Set IP address on the External Device for IP address in Device-specific settings.

• You need to set IP address on the Display in the offline mode of the Display.
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 Setting of External Device

Use the switches on the side of Ethernet module for setting the External Device.

 IP Address Setting Switch

Use 8 Hex rotary switches for setting.

Port No.

Condition Setting Switch

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

Setup Items Setup Description

IP Address Setting Rotary Switch Option

Setup Items Setup Description

Port No. 12291

DIP Switch Settings Setup Description

SW1 ON ASCII

SW2 OFF Not protect

SW3 --- (Reserved)

SW4 --- (Reserved)

SW5 --- (Reserved)

SW6 --- (Reserved)

SW7 OFF Close

SW8 OFF Normal
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3.9 Setting Example 9

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the External Device and click [Settings]  .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

• Set IP address on the External Device for IP address in Device-specific settings.

• You need to set IP address on the Display in the offline mode of the Display.
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 Setting of External Device

Make communication settings of the External Device with the ladder soft (Wide Field2).

Please refer to the manual of the External Device for more details.

Procedure

1 Start the ladder soft.

2 Create a new project. Select the External Device to be used when creating the project.

3 Select [Open]-[CPU Properties] from the [File] menu and open the CPU property file for settings.

4 In the [LOAD] settings, select the settings to be loaded. Set 0 (not loaded) for the others except the following 

settings.

• [LOAD] Settings 

5 Make communication settings with the [Setting] tree’s [NETWORK][ETHERNET][HIGHER-LEVEL LINK 

SERVICE].

• [NETWORK] Settings 

• [ETHERNET] Settings 

• [HIGHER-LEVEL LINK SERVICE] Settings 

6 Select [Save as] from the [File] menu and save the CPU property file.

7 Select [Download]-[CPU Properties] from the [ONLINE] menu and download the set CPU property file to the 

External Device.

Setup Items Setup Description

NETWORK 1

ETHERNET 1

HIGHER-LEVEL LINK SERVICE 1

Setup Items Setup Description

NETWORK_SELECT 1

Setup Items Setup Description

ETHER_MY_IPADDRESS
IP Address of the External Device
Ex: 192.168.0.3

ETHER_SUBNET_MASK
Subnet Mask of the External Device
Ex: 255.255.255.0

Setup Items Setup Description

HILINK_PROTOCOL_A 1

HILINK_DATA_FORMAT_A 1
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3.10 Setting Example 10

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the External Device and click [Settings]  .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

• Set IP address on the External Device for IP address in Device-specific settings.

• You need to set IP address on the Display in the offline mode of the Display.
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 Setting of External Device

Make communication settings of the External Device with the ladder soft (Wide Field2).

Please refer to the manual of the External Device for more details.

Procedure

1 Start the ladder soft.

2 Create a new project. Select the External Device to be used when creating the project.

3 Select [Open]-[CPU Properties] from the [File] menu and open the CPU property file for settings.

4 In the [LOAD] settings, select the settings to be loaded. Set 0 (not loaded) for the others except the following 

settings.

• [LOAD] Settings 

5 Make communication settings with the [Setting] tree’s [NETWORK][ETHERNET][HIGHER-LEVEL LINK 

SERVICE].

• [NETWORK] Settings 

• [ETHERNET] Settings 

• [HIGHER-LEVEL LINK SERVICE] Settings 

6 Select [Save as] from the [File] menu and save the CPU property file.

7 Select [Download]-[CPU Properties] from the [ONLINE] menu and download the set CPU property file to the 

External Device.

Setup Items Setup Description

NETWORK 1

ETHERNET 1

HIGHER-LEVEL LINK SERVICE 1

Setup Items Setup Description

NETWORK_SELECT 1

Setup Items Setup Description

ETHER_MY_IPADDRESS
IP Address of the External Device
Ex: 192.168.0.3

ETHER_SUBNET_MASK
Subnet Mask of the External Device
Ex: 255.255.255.0

Setup Items Setup Description

HILINK_PROTOCOL_A 1

HILINK_DATA_FORMAT_A 0
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3.11 Setting Example 11

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the External Device and click [Settings]  .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

• Set IP address on the External Device for IP address in Device-specific settings.

• You need to set IP address on the Display in the offline mode of the Display.
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 Setting of External Device

Make communication settings of the External Device with the ladder soft (Wide Field2).

Please refer to the manual of the External Device for more details.

Procedure

1 Start the ladder soft.

2 Create a new project. Select the External Device to be used when creating the project.

3 Select [Open]-[CPU Properties] from the [File] menu and open the CPU property file for settings.

4 In the [LOAD] settings, select the settings to be loaded. Set 0 (not loaded) for the others except the following 

settings.

• [LOAD] Settings 

5 Make communication settings with the [Setting] tree’s [NETWORK][ETHERNET][HIGHER-LEVEL LINK 

SERVICE].

• [NETWORK] Settings 

• [ETHERNET] Settings 

• [HIGHER-LEVEL LINK SERVICE] Settings 

6 Select [Save as] from the [File] menu and save the CPU property file.

7 Select [Download]-[CPU Properties] from the [ONLINE] menu and download the set CPU property file to the 

External Device.

Setup Items Setup Description

NETWORK 1

ETHERNET 1

HIGHER-LEVEL LINK SERVICE 1

Setup Items Setup Description

NETWORK_SELECT 1

Setup Items Setup Description

ETHER_MY_IPADDRESS
IP Address of the External Device
Ex: 192.168.0.3

ETHER_SUBNET_MASK
Subnet Mask of the External Device
Ex: 255.255.255.0

Setup Items Setup Description

HILINK_PROTOCOL_A 0

HILINK_DATA_FORMAT_A 1
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3.12 Setting Example 12

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the External Device and click [Settings]  .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

• Set IP address on the External Device for IP address in Device-specific settings.

• You need to set IP address on the Display in the offline mode of the Display.
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 Setting of External Device

Make communication settings of the External Device with the ladder soft (Wide Field2).

Please refer to the manual of the External Device for more details.

Procedure

1 Start the ladder soft.

2 Create a new project. Select the External Device to be used when creating the project.

3 Select [Open]-[CPU Properties] from the [File] menu and open the CPU property file for settings.

4 In the [LOAD] settings, select the settings to be loaded. Set 0 (not loaded) for the others except the following 

settings.

• [LOAD] Settings 

5 Make communication settings with the [Setting] tree’s [NETWORK][ETHERNET][HIGHER-LEVEL LINK 

SERVICE].

• [NETWORK] Settings 

• [ETHERNET] Settings 

• [HIGHER-LEVEL LINK SERVICE] Settings 

6 Select [Save as] from the [File] menu and save the CPU property file.

7 Select [Download]-[CPU Properties] from the [ONLINE] menu and download the set CPU property file to the 

External Device.

Setup Items Setup Description

NETWORK 1

ETHERNET 1

HIGHER-LEVEL LINK SERVICE 1

Setup Items Setup Description

NETWORK_SELECT 1

Setup Items Setup Description

ETHER_MY_IPADDRESS
IP Address of the External Device
Ex: 192.168.0.3

ETHER_SUBNET_MASK
Subnet Mask of the External Device
Ex: 255.255.255.0

Setup Items Setup Description

HILINK_PROTOCOL_A 0

HILINK_DATA_FORMAT_A 0
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3.13 Setting Example 13

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the External Device and click [Settings]  .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

• Set IP address on the External Device for IP address in Device-specific settings.

• You need to set IP address on the Display in the offline mode of the Display.
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 Setting of External Device

Make communication settings of the External Device with the ladder soft (Wide Field2).

Please refer to the manual of the External Device for more details.

Procedure

1 Start the ladder soft.

2 Create a new project. Select the External Device to be used when creating the project.

3 Select [Open]-[CPU Properties] from the [File] menu and open the CPU property file for settings.

4 In the [LOAD] settings, select the settings to be loaded. Set 0 (not loaded) for the others except the following 

settings.

• [LOAD] Settings 

5 Make communication settings with the [Setting] tree’s [NETWORK][ETHERNET][HIGHER-LEVEL LINK 

SERVICE].

• [NETWORK] Settings 

• [ETHERNET] Settings 

• [HIGHER-LEVEL LINK SERVICE] Settings 

6 Select [Save as] from the [File] menu and save the CPU property file.

7 Select [Download]-[CPU Properties] from the [ONLINE] menu and download the set CPU property file to the 

External Device.

Setup Items Setup Description

NETWORK 1

ETHERNET 1

HIGHER-LEVEL LINK SERVICE 1

Setup Items Setup Description

NETWORK_SELECT 1

Setup Items Setup Description

ETHER_MY_IPADDRESS
IP Address of the External Device
Ex: 192.168.0.3

ETHER_SUBNET_MASK
Subnet Mask of the External Device
Ex: 255.255.255.0

Setup Items Setup Description

HILINK_PROTOCOL_B 1

HILINK_DATA_FORMAT_B 1
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3.14 Setting Example 14

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the External Device and click [Settings]  .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

• Set IP address on the External Device for IP address in Device-specific settings.

• You need to set IP address on the Display in the offline mode of the Display.
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 Setting of External Device

Make communication settings of the External Device with the ladder soft (Wide Field2).

Please refer to the manual of the External Device for more details.

Procedure

1 Start the ladder soft.

2 Create a new project. Select the External Device to be used when creating the project.

3 Select [Open]-[CPU Properties] from the [File] menu and open the CPU property file for settings.

4 In the [LOAD] settings, select the settings to be loaded. Set 0 (not loaded) for the others except the following 

settings.

• [LOAD] Settings 

5 Make communication settings with the [Setting] tree’s [NETWORK][ETHERNET][HIGHER-LEVEL LINK 

SERVICE].

• [NETWORK] Settings 

• [ETHERNET] Settings 

• [HIGHER-LEVEL LINK SERVICE] Settings 

6 Select [Save as] from the [File] menu and save the CPU property file.

7 Select [Download]-[CPU Properties] from the [ONLINE] menu and download the set CPU property file to the 

External Device.

Setup Items Setup Description

NETWORK 1

ETHERNET 1

HIGHER-LEVEL LINK SERVICE 1

Setup Items Setup Description

NETWORK_SELECT 1

Setup Items Setup Description

ETHER_MY_IPADDRESS
IP Address of the External Device
Ex: 192.168.0.3

ETHER_SUBNET_MASK
Subnet Mask of the External Device
Ex: 255.255.255.0

Setup Items Setup Description

HILINK_PROTOCOL_B 1

HILINK_DATA_FORMAT_B 0



Personal Computer Link Ethernet Driver    

GP-Pro EX Device/PLC Connection Manual 39

3.15 Setting Example 15

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the External Device and click [Settings]  .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

• Set IP address on the External Device for IP address in Device-specific settings.

• You need to set IP address on the Display in the offline mode of the Display.
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 Setting of External Device

Make communication settings of the External Device with the ladder soft (Wide Field2).

Please refer to the manual of the External Device for more details.

Procedure

1 Start the ladder soft.

2 Create a new project. Select the External Device to be used when creating the project.

3 Select [Open]-[CPU Properties] from the [File] menu and open the CPU property file for settings.

4 In the [LOAD] settings, select the settings to be loaded. Set 0 (not loaded) for the others except the following 

settings.

• [LOAD] Settings 

5 Make communication settings with the [Setting] tree’s [NETWORK][ETHERNET][HIGHER-LEVEL LINK 

SERVICE].

• [NETWORK] Settings 

• [ETHERNET] Settings 

• [HIGHER-LEVEL LINK SERVICE] Settings 

6 Select [Save as] from the [File] menu and save the CPU property file.

7 Select [Download]-[CPU Properties] from the [ONLINE] menu and download the set CPU property file to the 

External Device.

Setup Items Setup Description

NETWORK 1

ETHERNET 1

HIGHER-LEVEL LINK SERVICE 1

Setup Items Setup Description

NETWORK_SELECT 1

Setup Items Setup Description

ETHER_MY_IPADDRESS
IP Address of the External Device
Ex: 192.168.0.3

ETHER_SUBNET_MASK
Subnet Mask of the External Device
Ex: 255.255.255.0

Setup Items Setup Description

HILINK_PROTOCOL_B 0

HILINK_DATA_FORMAT_B 1
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3.16 Setting Example 16

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the External Device and click [Settings]  .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

• Set IP address on the External Device for IP address in Device-specific settings.

• You need to set IP address on the Display in the offline mode of the Display.
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 Setting of External Device

Make communication settings of the External Device with the ladder soft (Wide Field2).

Please refer to the manual of the External Device for more details.

Procedure

1 Start the ladder soft.

2 Create a new project. Select the External Device to be used when creating the project.

3 Select [Open]-[CPU Properties] from the [File] menu and open the CPU property file for settings.

4 In the [LOAD] settings, select the settings to be loaded. Set 0 (not loaded) for the others except the following 

settings.

• [LOAD] Settings 

5 Make communication settings with the [Setting] tree’s [NETWORK][ETHERNET][HIGHER-LEVEL LINK 

SERVICE].

• [NETWORK] Settings 

• [ETHERNET] Settings 

• [HIGHER-LEVEL LINK SERVICE] Settings 

6 Select [Save as] from the [File] menu and save the CPU property file.

7 Select [Download]-[CPU Properties] from the [ONLINE] menu and download the set CPU property file to the 

External Device.

Setup Items Setup Description

NETWORK 1

ETHERNET 1

HIGHER-LEVEL LINK SERVICE 1

Setup Items Setup Description

NETWORK_SELECT 1

Setup Items Setup Description

ETHER_MY_IPADDRESS
IP Address of the External Device
Ex: 192.168.0.3

ETHER_SUBNET_MASK
Subnet Mask of the External Device
Ex: 255.255.255.0

Setup Items Setup Description

HILINK_PROTOCOL_B 0

HILINK_DATA_FORMAT_B 0
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3.17 Setting Example 17

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the External Device and click [Settings]  .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

• Set IP address on the External Device for IP address in Device-specific settings.

• You need to set IP address on the Display in the offline mode of the Display.
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 Setting of External Device

The ladder software (WideField3) configures the External Device’s communication settings. 

Refer to your External Device manual for communication setting details.

Procedure

1 Start up the ladder software.

2 Create a new project. Select the External Device to be used when creating the project.

3 Select [Open]-[CPU Properties] from the [File] menu and open the CPU property file for settings.

4 Select [CPU properties] from [Project Settings].

5 Make communication settings with the [SETUP] tree’s [ETHERNET], [HIGHER-LEVEL LINK SERVICE].

• [ETHERNET] Settings 

• [HIGHER-LEVEL LINK SERVICE] Settings 

6 Download the setting CPU property file and the project file to the External Device.

7 Reboot the External Device.

Setup Items Setup Description

ETHER_MY_IPADDRESS 192.168.0.1

ETHER_SUBNET_MASK 255.255.255.0

Setup Items Setup Description

HILINK_PROTOCOL_A 1

HILINK_DATA_FORMAT_A 1

HLINK_PROTECT 0
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3.18 Setting Example 18

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the External Device and click [Settings]  .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

• Set IP address on the External Device for IP address in Device-specific settings.

• You need to set IP address on the Display in the offline mode of the Display.
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 Setting of External Device

The ladder software (WideField3) configures the External Device’s communication settings. 

Refer to your External Device manual for communication setting details.

Procedure

1 Start up the ladder software.

2 Create a new project. Select the External Device to be used when creating the project.

3 Select [Open]-[CPU Properties] from the [File] menu and open the CPU property file for settings.

4 Select [CPU properties] from [Project Settings].

5 Make communication settings with the [SETUP] tree’s [ETHERNET], [HIGHER-LEVEL LINK SERVICE].

• [ETHERNET] Settings 

• [HIGHER-LEVEL LINK SERVICE] Settings 

6 Download the setting CPU property file and the project file to the External Device.

7 Reboot the External Device.

Setup Items Setup Description

ETHER_MY_IPADDRESS 192.168.0.1

ETHER_SUBNET_MASK 255.255.255.0

Setup Items Setup Description

HILINK_PROTOCOL_A 1

HILINK_DATA_FORMAT_A 0

HLINK_PROTECT 0
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3.19 Setting Example 19

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the External Device and click [Settings]  .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

• Set IP address on the External Device for IP address in Device-specific settings.

• You need to set IP address on the Display in the offline mode of the Display.
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 Setting of External Device

The ladder software (WideField3) configures the External Device’s communication settings. 

Refer to your External Device manual for communication setting details.

Procedure

1 Start up the ladder software.

2 Create a new project. Select the External Device to be used when creating the project.

3 Select [Open]-[CPU Properties] from the [File] menu and open the CPU property file for settings.

4 Select [CPU properties] from [Project Settings].

5 Make communication settings with the [SETUP] tree’s [ETHERNET], [HIGHER-LEVEL LINK SERVICE].

• [ETHERNET] Settings 

• [HIGHER-LEVEL LINK SERVICE] Settings 

6 Download the setting CPU property file and the project file to the External Device.

7 Reboot the External Device.

Setup Items Setup Description

ETHER_MY_IPADDRESS 192.168.0.1

ETHER_SUBNET_MASK 255.255.255.0

Setup Items Setup Description

HILINK_PROTOCOL_A 0

HILINK_DATA_FORMAT_A 1

HLINK_PROTECT 0
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3.20 Setting Example 20

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the External Device and click [Settings]  .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

• Set IP address on the External Device for IP address in Device-specific settings.

• You need to set IP address on the Display in the offline mode of the Display.
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 Setting of External Device

The ladder software (WideField3) configures the External Device’s communication settings. 

Refer to your External Device manual for communication setting details.

Procedure

1 Start up the ladder software.

2 Create a new project. Select the External Device to be used when creating the project.

3 Select [Open]-[CPU Properties] from the [File] menu and open the CPU property file for settings.

4 Select [CPU properties] from [Project Settings].

5 Make communication settings with the [SETUP] tree’s [ETHERNET], [HIGHER-LEVEL LINK SERVICE].

• [ETHERNET] Settings 

• [HIGHER-LEVEL LINK SERVICE] Settings 

6 Download the setting CPU property file and the project file to the External Device.

7 Reboot the External Device.

Setup Items Setup Description

ETHER_MY_IPADDRESS 192.168.0.1

ETHER_SUBNET_MASK 255.255.255.0

Setup Items Setup Description

HILINK_PROTOCOL_A 0

HILINK_DATA_FORMAT_A 0

HLINK_PROTECT 0
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3.21 Setting Example 21

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the External Device and click [Settings]  .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

• Set IP address on the External Device for IP address in Device-specific settings.

• You need to set IP address on the Display in the offline mode of the Display.
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 Setting of External Device

The ladder software (WideField3) configures the External Device’s communication settings. 

Refer to your External Device manual for communication setting details.

Procedure

1 Start up the ladder software.

2 Create a new project. Select the External Device to be used when creating the project.

3 Select [Open]-[CPU Properties] from the [File] menu and open the CPU property file for settings.

4 Select [CPU properties] from [Project Settings].

5 Make communication settings with the [SETUP] tree’s [ETHERNET], [HIGHER-LEVEL LINK SERVICE].

• [ETHERNET] Settings 

• [HIGHER-LEVEL LINK SERVICE] Settings 

6 Download the setting CPU property file and the project file to the External Device.

7 Reboot the External Device.

Setup Items Setup Description

ETHER_MY_IPADDRESS 192.168.0.1

ETHER_SUBNET_MASK 255.255.255.0

Setup Items Setup Description

HILINK_PROTOCOL_B 1

HILINK_DATA_FORMAT_B 1

HLINK_PROTECT 0
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3.22 Setting Example 22

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the External Device and click [Settings]  .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

• Set IP address on the External Device for IP address in Device-specific settings.

• You need to set IP address on the Display in the offline mode of the Display.
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 Setting of External Device

The ladder software (WideField3) configures the External Device’s communication settings. 

Refer to your External Device manual for communication setting details.

Procedure

1 Start up the ladder software.

2 Create a new project. Select the External Device to be used when creating the project.

3 Select [Open]-[CPU Properties] from the [File] menu and open the CPU property file for settings.

4 Select [CPU properties] from [Project Settings].

5 Make communication settings with the [SETUP] tree’s [ETHERNET], [HIGHER-LEVEL LINK SERVICE].

• [ETHERNET] Settings 

• [HIGHER-LEVEL LINK SERVICE] Settings 

6 Download the setting CPU property file and the project file to the External Device.

7 Reboot the External Device.

Setup Items Setup Description

ETHER_MY_IPADDRESS 192.168.0.1

ETHER_SUBNET_MASK 255.255.255.0

Setup Items Setup Description

HILINK_PROTOCOL_B 1

HILINK_DATA_FORMAT_B 0

HLINK_PROTECT 0
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3.23 Setting Example 23

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the External Device and click [Settings]  .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

• Set IP address on the External Device for IP address in Device-specific settings.

• You need to set IP address on the Display in the offline mode of the Display.
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 Setting of External Device

The ladder software (WideField3) configures the External Device’s communication settings. 

Refer to your External Device manual for communication setting details.

Procedure

1 Start up the ladder software.

2 Create a new project. Select the External Device to be used when creating the project.

3 Select [Open]-[CPU Properties] from the [File] menu and open the CPU property file for settings.

4 Select [CPU properties] from [Project Settings].

5 Make communication settings with the [SETUP] tree’s [ETHERNET], [HIGHER-LEVEL LINK SERVICE].

• [ETHERNET] Settings 

• [HIGHER-LEVEL LINK SERVICE] Settings 

6 Download the setting CPU property file and the project file to the External Device.

7 Reboot the External Device.

Setup Items Setup Description

ETHER_MY_IPADDRESS 192.168.0.1

ETHER_SUBNET_MASK 255.255.255.0

Setup Items Setup Description

HILINK_PROTOCOL_B 0

HILINK_DATA_FORMAT_B 1

HLINK_PROTECT 0
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3.24 Setting Example 24

 Settings of GP-Pro EX

Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC].

Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the External Device and click [Settings]  .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

Notes

• Check with a network administrator about IP address. Do not set the duplicate IP address.

• Set IP address on the External Device for IP address in Device-specific settings.

• You need to set IP address on the Display in the offline mode of the Display.
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 Setting of External Device

The ladder software (WideField3) configures the External Device’s communication settings. 

Refer to your External Device manual for communication setting details.

Procedure

1 Start up the ladder software.

2 Create a new project. Select the External Device to be used when creating the project.

3 Select [Open]-[CPU Properties] from the [File] menu and open the CPU property file for settings.

4 Select [CPU properties] from [Project Settings].

5 Make communication settings with the [SETUP] tree’s [ETHERNET], [HIGHER-LEVEL LINK SERVICE].

• [ETHERNET] Settings 

• [HIGHER-LEVEL LINK SERVICE] Settings 

6 Download the setting CPU property file and the project file to the External Device.

7 Reboot the External Device.

Setup Items Setup Description

ETHER_MY_IPADDRESS 192.168.0.1

ETHER_SUBNET_MASK 255.255.255.0

Setup Items Setup Description

HILINK_PROTOCOL_B 0

HILINK_DATA_FORMAT_B 0

HLINK_PROTECT 0
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4 Setup Items

Set communication settings of the Display with GP-Pro EX or in offline mode of the Display.

The setting of each parameter must be identical to that of External Device.

"3 Example of Communication Setting" (page 11)

4.1 Setup Items in GP-Pro EX

 Communication Settings

To display the setup screen, from the [Project] menu, point to [System Settings] and select [Device/PLC]..

• Set the Display’s IP address in offline mode.

Cf. Maintenance/Troubleshooting Guide "Ethernet Settings"

Setup Items Setup Description

Port No.

Use an integer from 1024 to 65535 to enter the port No. of the Display. When you check 
the option of [Auto Assign], the port No. will be automatically set.

• [Auto Assign] option is available to set only when you select "Ethernet (TCP)" in 

[Connecting Method].

Timeout
Use an integer from 1 to 127 to enter the time (s) for which the Display waits for the 
response from the External Device.

Retry
In case of no response from the External Device, use an integer from 0 to 255 to enter how 
many times the Display retransmits the command.

Wait To Send
Use an integer from 0 to 255 to enter standby time (ms) for the Display from receiving 
packets to transmitting next commands.

• Refer to the GP-Pro EX Reference Manual for Indirect Device.

Cf. GP-Pro EX Reference Manual "Changing the Device/PLC at Runtime (Indirect 
Device)"



Personal Computer Link Ethernet Driver    

GP-Pro EX Device/PLC Connection Manual 60

 Device Setting

To display the [Individual Device Settings] dialog box, from [Device-Specific Settings] in the [Device/PLC] 

window, select the External Device and click [Settings]  .

To connect multiple External Devices, from [Device-Specific Settings] in the [Device/PLC] window, click [Add 

Device] to add another External Device.

Setup Items Setup Description

IP Address

Set IP address of the External Device.

• Check with a network administrator about IP address. Do not set the duplicate IP 

address.

Port No. Use an integer 12289 or 12291 to enter the port No. of the External Device.

Data Code Select the data format to communicate with the External Device from "Binary" or "ASCII".
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4.2 Setup Items in Offline Mode

 Communication Settings

To display the setting screen, touch [Device/PLC Settings] from [Peripheral Settings] in offline mode. Touch the 

External Device you want to set from the displayed list. 

• Refer to the Maintenance/Troubleshooting guide for information on how to enter offline mode or 

about the operation.

Cf. Maintenance/Troubleshooting Guide "Offline Mode"

Setup Items Setup Description

Port No.

Set the Port No. of the Display. In UDP connection, entered port No. will be assigned 
regardless of whether you select [Fixed] or [Auto].  In TCP connection, select either of 
[Fixed] or [Auto]. When you select [Fixed], use an integer from 1024 to 65535 to enter the 
port No. of the Display. When you select [Auto], the port No. will be automatically 
assigned regardless of the entered value.

Timeout
Use an integer from 1 to 127 to enter the time (s) for which the Display waits for the 
response from the External Device.

Retry
In case of no response from the External Device, use an integer from 0 to 255 to enter how 
many times the Display retransmits the command.

Wait To Send
Use an integer from 0 to 255 to enter standby time (ms) for the Display from receiving 
packets to transmitting next commands.
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 Device Setting

To display the setting screen, touch [Device/PLC Settings] from [Peripheral Settings]. Touch the External Device 

you want to set from the displayed list, and touch [Device].

Setup Items Setup Description

Device/PLC Name
Select the External Device for device setting. Device name is a title of External Device set 
with GP-Pro EX.(Initial value [PLC1])

IP Address

Set IP address of the External Device.

• Check with a network administrator about IP address. Do not set the duplicate IP 

address.

Port No. Use an integer 12289 or 12291 to enter the port No. of the External Device.

Data Code Select the data format to communicate with the External Device from "Binary" or "ASCII".
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5 Supported Device

Range of supported device address is shown in the table below. Please note that the actually supported range of 

the devices varies depending on the External Device to be used. Please check the actual range in the manual of 

your External Device.

Enter the External Device address in the dialog below.

• Address notation

1. Device Select the Device.

2. Address Enter the address.

3. CPU number Enter the CPU number of the External Device with which to 
communicate, using the number from 1 to 4.

21

3

1   D 00001
Address
Device
CPU number
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This address can be specified as system data area.

Device Bit Address Word Address
32

bits
Notes

Input Relay X00201 to X71664 X00201 to X71649  *1*2

Output Relay Y00201 to Y71664 Y00201 to Y71649  *1

Internal Relay I00001 to I65535 I0001 to I65521  

Common Relay E0001 to E4096 E0001 to E4081  

Special Relay M0001 to M9984 M0001 to M9969  

Link Relay L00001 to L78192 L00001 to L78177  *3

Time-up Relay TU0001  to  TU3072 ---

Count-up Relay CU000  to  CU3072 ---

Timer present value --- TP0001 to TP3072

Timer present value 
(count-up)

--- TI0001 to TI3072

Timer preset value --- TS0001 to TS3072 *2

Counter present value --- CP0001 to CP3072

Counter present value 
(count-up)

--- CI0001 to CI3072

Counter preset value --- CS001 to CS3072 *2

Data Register --- D00001 to D65535

Common Register --- B000001 to B262144

Cache Register --- F000001 to F524288  *4

General Register --- R0001 to R4096

Special Register --- Z0001 to Z1024

Link Register --- W00001 to W78192  *3

Special Module --- SW0010000 to SW7169999 *2*5

Information

--- INF100 to INF101 *2*6

--- INF200 to INF214 *2*6

--- INF30010 to INF37163 *2*6

INF4100.00 to 
INF4215.15

INF4100 to INF4215 *2*6

--- INF500 *6

Program Information --- PRI00000 to PRI99913 *2*7

User Log Read --- ULR000000 to ULR 064128 *2*8

Error History Read --- ERH000000 to ERH 128022 *2*9
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*1 Address for input relay and output relay can be specified when data position number (bit) 01 to 49 for lower                   
2 digits is the value of (multiples of 16) + 1 only.

Example: X00201

*2 Write disable

*3 In link relay (L) and link register (W), the upper 1st digit on address input area shows the link number, and                    
lower 4th digit shows the address. Specify the word address for link relay (L) and link register (W) with the                   
value of (multiples of 16) + 1.

Example: When specifying L71024 of link relay

*4 Only the F3SP71-4N, F3SP76-7N, F3SP71-4S and F3SP76-7S can be used.

*5 Information of Special Module Read/Write

SW0 01 0003 

Data Position No. (0000 to 9999)

Module Slot No. (01 to 16)

Module Unit No. (0 to 7)
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*6 Information Read
1. Read the status of CPU module and program

2. Read the information of system ID, CPU type and area size

3. Read the mounting module name

4. Read the ERR LED of CPU module or the ALM LED lighting factor

5. Delete the current alarm information of CPU module (write only)

INF  1  00

0: CPU status (1 word)

1:Program status (1 word)

Parameter No. (1)

INF  2  00

ASCII mode:

   13,14: Program area size (2 words)

   12: CPU type (1 word)

   08 to 11: Revisiov (4 words)

   00 to 07: System ID (8 words)

Binary mode:

   13: Program area size (1 word)

   12: CPU type (1 word)

   08 to 11: Revisiov (4 words)

   00 to 07: System ID (8 words)

Parameter No. (2)

INF 3  0  01  0

    3: Input/Output relay point (1 word)

    2: Input/Output (1 word)

    0,1: Module name (2 words)

Slot No. (1 to 16)

Unit No. (0 to 7)

Parameter No. (3)

INF 4  1  01

0 to 15: Factor (16 words)

Factor designated  flag (1:ERR factor, 2:ALM factor)

Parameter No. (4)

INF 5  00

Parameter No. (5)
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*7 Program Information Read

*8 User Log Read

*9 Error History Read

PRI   000  00

ASCII mode:

    Creation date: 7 to 13 (7 words)

    Size step No.: 4 to 6 (3 words)

    Program name: 0 to 3 (4 words)

Read information (000: Program name, Creation date)

PRI   000  00

Read information (001 to 999: Reading such as the block names of No.n)

Binary mode:

    Creation date: 6 to 10 (5 words)

    Size step No.: 4 to 5 (2 words)

    Program name: 0 to 3 (4 words)

ASCII mode:

    Size step No.: 4 to 6 (3 words)

    Program name: 0 to 3 (4 words)

Binary mode:

    Size step No.: 4 to 5 (2 words)

    Program name: 0 to 3 (4 words)

When 000 is written in Read information

When one of the numbers from 001 to 999 is written in Read information

ULR   000  000

User log: 0 to 128 (word)

User log reading point
    000: Latest user log
    001 to 064: No.n user log from new data

ERH   000  000

ASCII mode:
    0: Error information
        (00: System error, 01: BASIC error, 02: Sequence error, 03: I/O error)
    1, 2: Error code (Charactor string)
   3 to 6: Date (YY/MM/DD) charactor string

    7 to 10: Time (HH:MM:SS) charactor string
    11 to 22: Added information (Charactor string)

Binary mode:
    0: Error information
        (0000: System error, 0001: BASIC error, 0002: Sequence error, 0003: I/O error)
    1: Error code
  2 to 4: Date (YYYY/MMMM/DDDD)

   5 to 7: Time (HHHH:MMMM:SSSS)
    8 to 18: Added information

Error history reading point
    000: Latest error data
    001 to 128: No.n error data from new data 
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• Please refer to the GP-Pro EX Reference Manual for system data area.

Cf. GP-Pro EX Reference Manual "LS Area (Direct Access Method Area)"
• Please refer to the precautions on manual notation for icons in the table.

"Manual Symbols and Terminology"
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6 Device Code and Address Code

Use device code and address code when you select "Device Type & Address" for the address type in data displays.

Device Device Name
Device Code

(HEX)
Address Code

Input Relay

1X 0080

(Module unit No. x 0x40) + ((Module 
slot No. - 1) x 0x4) + ((Terminal No. - 
1) divided by 16)*1

2X 0180

3X 0280

4X 0380

Output Relay

1Y 0081

(Module unit No. x 0x40) + ((Module 
slot No. - 1) x 0x4) + ((Terminal No. - 
1) divided by 16)*1

2Y 0181

3Y 0281

4Y 0381

Internal Relay

1I 0082

Value of (word address - 1) divided by 
16 

2I 0182

3I 0282

4I 0382

Common Relay

1E 0084

Value of (word address - 1) divided by 
16 

2E 0184

3E 0284

4E 0384

Special Relay

1M 0083

Value of (word address - 1) divided by 
16 

2M 0183

3M 0283

4M 0383

Link Relay

1L 0088

(Link No. x 0x10000) + ((word address 
- 1) divided by 16)*2

2L 0188

3L 0288

4L 0388

Timer present value

1TP 0060

Value of word address from which 1 is 
deducted

2TP 0160

3TP 0260

4TP 0360
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Timer present value 
(count-up)

1TI 006D

Value of word address from which 1 is 
deducted

2TI 016D

3TI 026D

4TI 036D

Timer preset value

1TS 0063

Value of word address from which 1 is 
deducted

2TS 0163

3TS 0263

4TS 0363

Counter present value

1CP 0061

Value of word address from which 1 is 
deducted

2CP 0161

3CP 0261

4CP 0361

Counter present value 
(count-up)

1CI 006E

Value of word address from which 1 is 
deducted

2CI 016E

3CI 026E

4CI 036E

Counter preset value

1CS 0064

Value of word address from which 1 is 
deducted

2CS 0164

3CS 0264

4CS 0364

Data Register

1D 0000

Value of word address from which 1 is 
deducted

2D 0100

3D 0200

4D 0300

Common Register

1B 0004

Value of word address from which 1 is 
deducted

2B 0104

3B 0204

4B 0304

Cache Register*3

1F 0006

Value of word address from which 1 is 
deducted

2F 0106

3F 0206

4F 0306

Device Device Name
Device Code

(HEX)
Address Code
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General Register

1R 0003

Value of word address from which 1 is 
deducted

2R 0103

3R 0203

4R 0303

Special Register

1Z 0001

Value of word address from which 1 is 
deducted

2Z 0101

3Z 0201

4Z 0301

Link Register

1W 0002

(Link No. x 0x10000) + ((word address 
- 1) divided by 16)*2

2W 0102

3W 0202

4W 0302

Special Module

1SW 0065

Word address
2SW 0165

3SW 0265

4SW 0365

Device Device Name
Device Code

(HEX)
Address Code
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Information

1INF1 0066

Word address
(Read only)

2INF1 0166

3INF1 0266

4INF1 0366

1INF2 006a

Word address
(Read only)

2INF2 016a

3INF2 026a

4INF2 036a

1INF3 006b

Word address
(Read only)

2INF3 016b

3INF3 026b

4INF3 036b

1INF4 0005

Word address
(Read only)

2INF4 0105

3INF4 0205

4INF4 0305

1INF5 006c

Word address
(Write only)

2INF5 016c

3INF5 026c

4INF5 036c

Program Information

1PRI 0067

Word address
(Read only)

2PRI 0167

3PRI 0267

4PRI 0367

User Log Read

1ULR 0068

Word address
(Read only)

2ULR 0168

3ULR 0268

4ULR 0368

Error History Read

1ERH 0069

Word address
(Read only)

2ERH 0169

3ERH 0269

4ERH 0369

Device Device Name
Device Code

(HEX)
Address Code
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*1 Please refer to "5 Supported Device *1" for each name.

*2 Please refer to "5 Supported Device *3" for each name.

*3 Only the F3SP71-4N, F3SP76-7N, F3SP71-4S and F3SP76-7S can be used.
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7 Error Messages

Error messages are displayed on the screen of Display as follows: "No. : Device Name: Error Message (Error 

Occurrence Area)". Each description is shown below.

Display Examples of Error Messages

"RHAA035: PLC1: Error has been responded for device write command (Error Code: 2 [02H])"

Item Description

No. Error No.

Device Name
Name of External Device where error occurs. Device name is a title of External Device set 
with GP-Pro EX.(Initial value [PLC1])

Error Message Displays messages related to the error which occurs.

Error Occurrence Area

Displays IP address or device address of External Device where error occurs, or error codes 
received from External Device.

• IP address is displayed such as "IP address (Decimal): MAC address (Hex)".
• Device address is displayed such as "Address: Device address".
• Received error codes are displayed such as "Decimal [Hex]".

• Refer to your External Device manual for details on received error codes.

• Refer to "Display-related errors" in "Maintenance/Troubleshooting Guide" for details on the error 

messages common to the driver.
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